Полезная информация

Server for Information Technologies
Сервер поддерживается
Центром Информационных Технологий
(095) 932-9212, 932-9213, 939-0783
E-mail: info@citforum.ru
Сервер Информационных Технологий содержит море(!) аналитической информации

Команда FBX


Overwrite Floppies
Data Compression
Changed Files Backup Type
Backup History Files
Existing Files
Confirmation

Архивизация - это единственный способ надежно защитить данные жесткого диска. Архивизацией называется создание резервных копий файлов и приложений, хранящихся не жестком диске. Эти копии создаются на внешнем носителе (например, на дискетах), которые можно сохранить в надежном месте. Если жесткий диск будет запорчен, или будут утрачены данные, их можно восстановить с помощью копий. Программа Fastback Express (FBX) позволяет создавать надежные резервные копии, а также легко и быстро восстанавливать данные.

     FBX [/? /H] [/A] [/B] [/F] [/M] [/3]

Параметры команды

Параметр Описание
/A Принудительно использует графический курсор "мыши".
/B Запрещает использование графического курсора "мыши".
/F Запрещает "трехмерный" вывод на экран.
/M Вывод на монохромный дисплей.
/3 Использует "трехмерный" вид представления на экране.

FBX позволяет создавать следующие виды архивизации:

FBX позволяет также восстановить с архивного носителя отдельные файлы или все файлы.

Интерфейс FBX состоит из основного меню, в котором вы можете использовать спускающиеся меню и диалоговые окна. В нижней части основного меню перечислены элементы, которые можно использовать для перемещения по экрану. Для выбора командной кнопки или пункта меню с подсвеченной буквой, нажмите клавишу Alt одновременно с этой буквой. Для перемещения в меню используйте клавиши управления курсором. Для перемещения в диалоговом окне используйте клавишу Tab. Чтобы изменить выбор, нажмите пробел.

В любом месте интерфейса FBX с помощью клавиши F1 можно получить оперативную помощь, доступную с помощью спускающегося меню Help или выбора конкретной темы.

В зависимости от типа архивизации или восстановления вам потребуется выбрать тот или иной источник и приемник. Источником может быть диск, содержащий архивизируемые или восстанавливаемые файлы. При архивизации источником обычно является жесткий диск, а при восстановлении - дискета.

Когда выведется меню FBX, выберите From. Выводится диалоговое окно Backup From, с перечнем доступных дисководов. По умолчанию все выбранные дисководы отмечаются точкой. Выберите Exclude All и блок Volume List, перейдите к нужному дисководу и нажмите на нем пробел. Чтобы отменить выбор диска и выбрать другой, снова нажмите пробел. Выбрав OK, закройте диалоговое окно.

Приемник - это диск, куда вы хотите скопировать архивизированные данные. Когда появится меню FBX, выберите To. Если в Primary Drive указан не тот диск, который вы хотите использовать, выберите блок списка Primary Drive. По умолчанию в Primary Drive показан диск с максимальной емкостью, который может поддерживать ваша система. Вы можете также задать вспомогательный диск (по умолчанию он не используется). Эту возможность можно использовать в системах с двумя дисководами: второй диск в этом случае будет задействован, когда заполнится первый. Основной и вспомогательный диски должны иметь идентичный размер и емкость.

Чтобы выбрать дисковод, подсветите его и нажмите Enter. По умолчанию FBX выбирает носитель с максимальной емкостью, который поддерживает заданный диск. Задайте маршрут архивизации. Это позволит записывать архивизируемые файлы в каталог. Это полезно применять, когда работающие в сети пользователи указывают для архивизации один и тот же жесткий диск сервера. Затем выберите OK.

Чтобы создать резервные копии всех файлов на диске, сделайте следующее. Выберите Start..., после чего в столбце Estimate будут показаны оценка времени архивизации и необходимый объем в килобайтах. Вставьте архивные дискеты, как того требует FBX. Не забудьте пометить дискеты также, как это делает FBX. Когда начнется процесс архивизации, чтобы временно остановить его, вы можете выбрать Pause (для возобновления - Continue). С помощью Stop можно прервать архивизацию.

Если ваши архивные диски уже содержат данные, вы увидите следующее сообщение:

     This Volume Has Files On It!

Вы должны указать FBX, что нужно делать с этими файлами:

Параметр Пояснение
Use Available Space Записывает архивные файлы в доступное на диске (дискете) пространство. Существующие файлы стираться не будут, но FBX может не выполнить полностью операции копирования.
Erase Volume Перед записью на него файлов стира- ет информацию на архивном диске (существующие на нем файлы будут удалены).
Erase All Volumes Стирает все архивные тома перед записью информации на них.
Dismount Выводит вам подсказку, чтобы вы сменили дискету в дисководе. После этого операция архивизации будет продолжена.
Delete Marked Files Стирает файлы, выбранные в диалоговом окне Files.
Abort Backup Прекращает операцию архривизации после копирования текущего файла.

Когда архивизация завершится, выберите Close. После завершения вы можете просмотреть результаты, выбрав Report. Чтобы напечатать копию отчета, выберите Print.

Чтобы сравнить оригиналы файлов с их копиями и убедиться в правильности копирования, вы можете сделать следующее. Выберите в блоке Operation элемент Compare. Затем задайте источник и приемник и выберите <Start...>. Когда выведется соответствующий запрос, вставьте в дисковод первых архивный диск. После завершения сравнения вы можете просмотреть отчет.

Вы можете создать копии только тех файлов жесткого диска, которые изменились с момента последнего копирования. Можно также скопировать все файлы, кроме файлов приложений (то есть файлов с расширениями .EXE, .COM и .DLL). Этот вид копирования выполняется также, как архивизация всех файлов, но в блоке Selections перед выбором Start... нужно выбрать All Changed Files или All Files Except Applications соответственно.

Чтобы создать резервные копии выбранных файлов, выберите в блоке Selections пункт Files I Choose и нажмите Enter.

FBX предусматривает несколько различных методов выбора отдельных файлов или групп файлов, участвующих в операции копирования. После выбора таких файлов создание резервных копий выполняется обычным образом. Чтобы пометить файлы для архивизации, перейдите в корневой каталог и выберите Exclude, чтобы отменить выбор всех каталогов и файлов. Чтобы выбрать каталог, подсветите его и нажмите пробел или дважды щелкните "мышью" на имени каталога. При сокращенном выводе все подкаталоги не выводятся и не выбираются. Вы можете выбрать развернутый вывод или щелкните на пиктограмме группы "мышью". После этого подкаталоги будут выводиться и выбираться.

Чтобы выбрать файл, перейдите в окно файлов и дважды щелкните "мышью" на имени файла. Командная кнопка View позволяет вам просмотреть выбранный файл. Повторив этот шаг, вы можете выбрать все нужные каталоги и файлы. Затем выберите Close.

Выбрать группу файлов можно также с помощью спецификации файлов. Для этого перейдите в строку командных кнопок окна Files To Back Up. Для отмены существующего выбора выберите Exclude. Перейдите в нижнюю часть окна Files To Back Up. Отметьте файлы, которые нужно включить в операцию архивизации или исключить из нее. Для переключения выбора нажмите пробел.

Перейдите в поле PATH и наберите каталог, из которого вы хотите выбрать файлы. Перейдите в поле SPEC и наберите спецификацию файлов. Перейдите в поле SUBDIRS. Это позволяет определить, будут ли выбираться файлы в подкаталогах текущего каталога. Для переключения нажмите при необходимости пробел. Повторите эти шаги, задав все нужные спецификации файлов. Затем выберите OK.

Вы можете также определить группу, задав несколько спецификаций файлов. FBX предусматривает ряд предопределенных групп. Кроме того, вы можете задать собственные группы.

Чтобы определить группу, перейдите в каталог, к которому нужно применить группу (в этом каталоге FBX будет выполнять поиск соответствующих файлов). Выберите меню File, а затем Groups... и задайте в поле Apply To Path маршрут группы (каталог, в котором FBX будет отмечать соответствующие файлы). Выберите группу из списка Groups. Подсветите группу или выберите ее с помощью "мыши". В поле Spec в нижней части диалога выводится группа спецификаций файлов. Подсветив группу, выберите Include. С помощью Exclude вы можете отменить выбор группы файлов. Перейдите в поле Apply Subdirs и для его выбора или отмены нажмите пробел. Чтобы использовать дополнительные спецификации файлов, повторите эти шаги. Затем выберите Close.

Определить собственную группу вы можете следующим образом. В диалоге Groups выберите Add. В поле Group Name наберите имя группы. Перейдите в поле Group Spec и наберите спецификации файлов, которые нужно включить в группу. Затем выберите OK.

Чтобы выбрать группу файлов по размеру, диапазону даты или атрибуту DOS, вы можете использовать фильтры. Фильтры FBX классифицируются следующим образом:

Фильтр Описание
Фильтр даты Фильтр диапазона даты Date Range позволяет выбирать исключаемые из операции файлы по их дате. FBX будет копировать только файлы с датами в указанных диапазонах.
Фильтр размера Фильтр диапазона размера Size Range позволяет вам исключать из операции файлы с определенным размером. Он обычно используется с другими типами фильтров или методами выбора.
Фильтр атрибута Фильтр атрибута файла Attribute позволяет выбирать файлы по их атрибуту.

Чтобы задать фильтры, откройте окно Choose Files и выберите Filters.... Если вы хотите задать диапазон дат, выберите Exclude Files Dated и задайте диапазон, используя поля Before (До) After (После). Чтобы задать диапазон размера, перейдите в поле Exclude Files With Sizes и задайте размер с помощью полей Smaller than (Меньше чем) и Larger than (Больше чем). Чтобы исключить из операции архивизации файлы с определенными атрибутами, перейдите в поле Exclude Files With Attributes и выберите его, затем задайте атрибуты файла. После этого выберите OK.

Командная кнопка Backup Options... позволяет вам выбрать любой из следующих параметров архивизации:

Overwrite Floppies

Перед созданием резервных копий файлов на дискетах FBX запрашивает подтверждения. Этот параметр можно установить следующим образом:

Значение Описание
Ask First FBX будет запрашивать подтверждение перед затиранием файла. Если файл найден на архивном диске, FBX запрашивает, хотите ли вы стереть выбранные файлы или использовать на каждом диске (дискете) доступное пространство.
Always FBX без подтверждения затирает все файлы, которые находит на архивных дисках. Текущие архивизируемые файлы затираться не будут.
Never FBX использует доступное на диске пространство, не затирая никаких файлов.

Data Compression

Определяет используемый метод упаковки данных. Упаковку данных FBX использует для уменьшения числа архивных дисков. При этом применяются следующие методы упаковки и компрессии:

Метод Описание
Save Time FBX упаковывает файлы таким образом, чтобы уменьшить общее время архивизации (по умолчанию).
Save Space FBX упаковывает файлы так, чтобы уменьшить примерно вдвое число необходимых для архивизации дисков.
Off Запрещает упаковку файлов.

Changed Files Backup Type

Определяет тип архивизации:

Тип Описание
Incremental Создаются резервные копии только тех файлов, которые изменились с момента последней архивизации всех или только измененных файлов. После архивизации FBX устанавливает бит архивизации файлов, указывающий на то, что они скопированы. Такой тип архивизации доступен только после выбора в блоке Selections пункта All Changed Files.
Differential Создаются резервные копии только тех файлов, которые изменились с момента последней архивизации всех или только измененных файлов. После архивизации FBX не устанавливает бит архивизации файлов. Такой тип архивизации доступен только после выбора в блоке Selections пункта All Changed Files.
Write Verify Определяет, нужно ли FBX проверять точность копирования путем чтения каждого записанного байта данных и сравнения его с байтом оригинала. Отметка означает выбор Write Verify. Хотя этот вид копирования рекомендуется использовать, он почти удваивает время копирования.
Virus Scan During Backup Определяет, должна ли FBX просматривать копируемые файлы на наличие вируса. Значение On разрешает Virus Scan, а Off запрещает его. По умолчанию устанавливается On.

Backup History Files

В процессе архивизации FBX создает специальный файл, который называется файлом протокола. Этот файл содержит имена скопированных файлов, их размеры, даты и атрибуты, а также том и дорожку, на которых эти файлы сохранены. Последний файл протокола используется при операции восстановления для определения расположения выбранных для восстановления файлов.

FBX сохраняет две копии файла протокола. Одна из них записывается в каталог NWDOS, а другая - на последнюю архивную дискету. При каждом выполнении архивизации файл протокола записывается в каталог NWDOS, а существующий файл протокола затирается. Таким образом, если нужно скопировать файлы, сохраненные не в последней операции копирования, а раньше, нужно скопировать в системный каталог с дискеты старый файл протокола.

Имя файла протокола комбинируется из буквы диска, на который копируются файлы, даты архивизации, позиции архивного копирования в последовательности операций архивизации и типа архивизации. Сохласно этим соглашениям FBX присваивает метку каждому архивному тому и нумерует их в последовательном порядке.

По умолчанию FBX использует для восстановления файлов файл протокола из каталога NWDOS. Это означает, что будут восстанавливаться файлы, сохраненные в последней операции архивизации. Чтобы восстановить все файлы, перейдите в блок Operation и подсветите Restore. Задайте источник и приемник, перейдите в блок Selections и подсветите All Files. Затем выберите Start.... Выведется окно Restore Files, в котором FBX сообщает, сколько томов потребуется для восстановления, число восстанавливаемых файлов, их объем в килобайтах и примерное время восстановления (Estimate).

Вставляйте архивные дискеты согласно запросам FBX. При восстановлении вы можете выбрать Pause, чтобы временно приостановить операцию, и Continue для ее возобновления. С помощью Stop вы можете прервать процесс восстановления.

После завершения восстановления с помощью Report вы можете просмотреть результаты. Чтобы вывести копию этого отчета на печать, выберите Print.

Для обеспечения правильности восстановления можно также сравнить восстановленные данные с файлами архивных дисков. Это делается также, как при сравнении в процессе архивизации.

Чтобы считать более старый файл протокола, сделайте следующее. Определите, в какой операции архивизации участвовали файлы, которые вы хотите восстановить, и отложите все эти архивные дискеты. Перейдите в блок Operation и подсветите Retrieve History. Для выбора соответствующего файла протокола выберите меню File и View History File.... Перейдите в блок Files и подсветите нужный файл протокола. Для смены каталогов выберите блок Directories. Для просмотра файла в текущем каталоге можно использовать Show All Files. Откройте блок From и убедитесь, что Primary Drive указывает тот диск и носитель, который содержит ваши архивные файлы. Выберите Start... и вставьте последнюю архивную дискету. FBX скопирует файл протокола в каталог NWDOS. Выберите Close.

Чтобы восстановить только отмеченные вами файлы, выберите в блоке Selections пункт Files I Choose. FBX предусматривает несколько различных методов выбора отдельных файлов или групп файлов, участвующих в операции восстановления. Это те же методы, что и применяемые при создании резервных копий. После выбора нужных файлов вы можете восстановить их обычным образом (как при восстановлении всего диска).

Командная кнопка Restore Options... позволяет вам выбрать некоторые параметры восстановления.

Existing Files

Определяет, будет ли FBX при восстановлении затирать существующие на диске целевые файлы. Этот параметр можно установить следующим образом:

Значение Описание
Overwrite Always Затирает существующий файл архивным файлом.
Overwrite Always Не затирает существующего файла файлом архивной копии.
Overwrite Older Only Затирает существующие файлы, если они более старые, чем архивные файлы (по умолчанию).

Confirmation

Определяет, должна ли FBX выводить при операции восстановления запрос. Вы можете задать следующие варианты:

Значение Описание
Off Запрещает вывод запроса на подтверждение (по умолчанию).
Directories Перед восстановлением или перезаписью каталога выводит запрос.
Files and Directories Выводит запрос перед затиранием файлов и каталогов.
Only On Overwrite Выводит запрос на подтверждение перед затиранием файла.
Virus Scan During Restore В процессе восстановления архивные дискеты просматриваются на наличие вирусов.


Comments: info@citmgu.ru
Copyright © CIT