Полезная информация

Server for Information Technologies Сервер поддерживается
Центром Информационных Технологий
(095) 932-9212, 932-9213, 939-0783
E-mail: info@citforum.ru
Сервер содержит море(!) аналитической информации CIT Forum CD-ROM

Использование меню "Опции" утилиты NetSync

Меню "Options" утилиты NETSYNC3 и меню "Опции" NETSYNC4 позволяют сконфигурировать среду NetSync.

Большинство задач вы можете выполнять как на сервере NetWare 4, так и на серверах 3.1x. Исключения указываются под заголовками задач, рассматриваемыми в этой главе.

Меню "Опции" утилиты NETSYNC4

После авторизации хотя бы одного сервера NetWare 3.1x (смотрите раздел "Авторизация серверов NetWare 3.1x") у вас появляется возможность попасть в меню "Опции", нажав на клавишу <Esc>. Впоследствии меню "Опции" появляется сразу же после загрузки NETSYNC4.

Основное меню "Опции" на сервере NetWare 4 содержит следующие пункты:

Меню "Options" утилиты NETSYNC3

Меню "Options" утилиты NETSYNC3 появляется сразу же после установления первого соединения с хостом NetWare 4. Впоследствии меню "Options" появляется сразу же после загрузки NETSYNC3.

Основное меню "Options" на сервере NetWare 3.1x содержит следующие пункты:

Более подробную информацию о перемещении сервиса печати смотрите в главе "Поддержка печати в NetSync".

Управление файлом журнала регистрации NetSync

Файл журнала регистрации как на сервере NetWare 4, так и на серверах NetWare 3.1x, называется NETSYNC.LOG и располагается в каталоге SYS:SYSTEM\NETSYNC. В файле журнала регистрации NetSync отражают все события, связанные с синхронизацией. Такие события включают:

На следующей иллюстрации приводится часть файла журнала регистрации.

Figure 3-1. Экран с примером файла журнала регистрации NetSync

Просмотр файла журнала регистрации

На сервере NetWare 3.1x файл журнала регистрации можно просмотреть только при помощи текстового редактора рабочей станции.

Чтобы просмотреть файл журнала регистрации на сервере NetWare 4, можно использовать как текстовый редактор рабочей станции, так и следующую процедуру:

Процедура

  1. Из меню "Опции" выберите "Опции файла журнала регистрации".
  2. Выберите "Просмотр истории файла журнала регистрации".

    Эта опция позволяет просматривать файл журнала регистрации. Вы можете просмотреть в нем все зарегистрированные события.

    Если на сервере нет большого блока непрерывной памяти, эта опция может не работать, даже если у вас есть большой объем "свободной" памяти. Если эта опция не будет работать, то для просмотра файла журнала регистрации нужно использовать редактор рабочей станции.

  3. Для перемещения по файлу используйте клавиши со стрелками и клавиши листания страниц.
  4. Для выхода нажмите <Esc>.

Просмотр активного экрана журнала регистрации

  1. Из меню "Опции" выберите "Просмотр активного журнала регистрации".

    Эта опция лишь отображает файл журнала регистрации, не позволяя прокрутку или редактирование. Экран журнала прокручивается в реальном масштабе времени, отображая происходящие события.

  2. Для выхода из этого экрана нажмите <Esc>.

Изменение размера файла журнала регистрации

По умолчанию размер файла журнала регистрации составляет 0,5 MB (размер может изменяться от 10 KB (10240 байт) до 10 MB (10485760 байт).

Для экономии дискового пространства можно уменьшить размер файла журнала регистрации. И наоборот, для увеличения количества хранимых событий, нужно увеличить его размер. Если файл слишком велик, просмотр будет обременительным.

Процедура

  1. В меню "Опции" выберите "Опции файла журнала регистрации".
  2. Выберите "Максимальный размер файла регистрации".
  3. Введите новый размер в байтах и нажмите <Enter>.
  4. Для выхода из меню нажмите <Esc>.

Показ всех событий на экране регистрации

Опция "Показ всех событий на экране регистрации" влияет на то, какие события будут отображаться на активном регистрационном экране: все события или только основные события и неудачно выполненные операции.

Тем не менее, независимо от того, какие события отображаются на экране, в файле журнала регистрации, если он существует, записываются все события с целью протоколирования.

По умолчанию указывается "Нет" (не отражать все события).

NOTE: Когда опция установлена на "Нет", то "ожидаемые" неудачи, такие, например, как добавление объекту свойства, которое у него уже существует, не отображаются на текущем регистрационном экране.

Процедура

  1. Из меню "Опции" выберите "Опции файла журнала регистрации".
  2. Выберите "Показ всех событий на экране регистрации".
  3. Для отображения всех событий выберите "Да". В противном случае выберите "Нет".

    В случае изменения этой опции на "Да", на текущем регистрационном экране будут отображаться все события, а не только основные и выполненные неудачно операции.

  4. Для сохранения изменений нажмите <Enter>.
  5. Для выхода из меню нажмите <Esc>.

Удаление файла журнала регистрации

Вы можете удалить файл журнала регистрации в том случае, если вы

Если вы удаляете файл журнала регистрации, новый файл создается автоматически для протоколирования новых данных NetSync.

Процедура

  1. Из меню "Опции" выберите "Опции файла журнала регистрации".
  2. Выберите "Удаление текущего файла журнала регистрации".
  3. Удалите файл журнала, набрав "Д" и нажав <Enter>.
  4. Для выхода из меню "Опции файла журнала регистрации" нажмите <Esc>.
  5. Для подтверждения вашего выбора выделите "Да" или "Нет" и нажмите <Enter>.

Запрещение создания файла журнала регистрации

Эта опция предотвращает создание файла журнала регистрации. Вы можете запретить создавать файл журнала регистрации, если:

По умолчанию используется опция "Да", означающая, что файл журнала регистрации нужен и будет по умолчанию создаваться.

Процедура

  1. Из меню "Опции" выберите "Опции файла журнала регистрации".
  2. Выберите "Включение файла журнала регистрации".
  3. Запретите создание файла журнала регистрации, набрав "Н" и нажав <Enter>.
  4. Для выхода из меню "Опции файла журнала регистрации", нажмите <Esc>.

Блокировка синхронизации процедур регистрации NetWare 3.1x и NetWare 4

Вы можете выполнить эту задачу только при помощи утилиты NETSYNC4.

Синхронизация процедур регистрации NetWare 3.1x и NetWare 4 разрешает пользователям, входящим в систему при помощи сервиса Bindery, иметь также процедуру регистрации на сервере NetWare 4. По умолчанию эта опция разрешена.

Вы можете отказаться от этой синхронизации. Более подробную информацию можно найти в разделе "Процедура регистрации пользователя".

Процедура

  1. Из меню "Опции" выберите "Опции конфигурации".
  2. Выберите "Синхронизация изменений процедур регистрации в Mail:".
  3. Запретите синхронизацию процедур регистрации в каталоге mail на сервере NetWare 4, набрав "Н" и нажав <Enter>.

    Процедуры регистрации всегда синхронизируются в каталоге mail серверов NetWare 3.1x.

  4. Для сохранения изменений нажмите <Enter>.

Изменение интервала сторожевой системы

В NETSYNC4 (на хосте NetWare 4) интервал задержки сторожевого пакета определяет, как часто проверяется правильность работы серверов NetWare 3.1x, входящих в кластер NetSync.

В NETSYNC3 (на серверах NetWare 3.1x, входящих в кластер) интервал задержки сторожевого пакета определяет, как часто проверяется правильность работы хоста NetWare 4.

Интервал по умолчанию - пять минут, его можно изменять в пределах от 30 секунд до 64800 секунд (18 часов).

Процедура

  1. Из меню "Опции" выберите "Опции конфигурации".
  2. Выберите "Интервал задержки сторожевой системы".
  3. Введите интервал в секундах.
  4. Нажмите <Enter>.

Управление списком авторизованных серверов NetWare 3.1x

Авторизованными серверами NetWare являются те серверы NetWare 3.1x, которые имеют право устанавливать соединение с хостом NetWare 4, и, следовательно, являются частью кластера NetSync.

Добавление авторизованных серверов к списку

Вы можете выполнить эту задачу только при помощи утилиты NETSYNC4.

Для того, чтобы заменить один сервер в списке другим, сначала необходимо удалить сервер, который вы хотите заменить. Затем добавьте в список новый сервер. Авторизация большинства серверов происходит во время процесса инсталляции NetSync (смотрите раздел "Авторизация серверов NetWare 3.1x").

Добавить сервер к кластеру NetSync можно, выполнив следующее:

Процедура

  1. Загрузите NETSYNC4 с консоли сервера NetWare 4.
  2. Из меню "Опции" выберите "Редактирование списка серверов".
  3. Установите курсор на пустой строке и введите имя сервера или же нажмите <Ins> или <Enter>.

    IMPORTANT: Не изменяйте имя сервера в этом списке до тех пор, пока не изменено имя самого сервера.

  4. Выполните пункты с 3 по 9 из раздела "Авторизация серверов NetWare 3.1x".
  5. Для подтверждения ваших изменений нажмите <Enter>.

Удаление авторизованных серверов из списка

Вы можете выполнить эту задачу только при помощи утилиты NETSYNC4.

Удаление сервера из списка авторизованных серверов удаляет сервер из кластера NetSync.

NOTE: Серверы из списка можно удалять только поочередно.

Процедура

  1. Из меню "Опции" выберите "Редактирование списка серверов".
  2. Выделите сервер NetWare 3.1x, который вы хотите удалить и нажмите <Delete>.

Копирование Bindery сервера NetWare 3.1x на сервер NetWare 4

Вы можете выполнить это задачу только при помощи утилиты NETSYNC4.

Вы можете вручную скопировать (загрузить) Bindery сервера NetWare 3.1x в Bindery контекст сервера NetWare 4, если сервер NetWare 3.1x не синхронизирован. Это может случиться при следующих обстоятельствах:

Процедура

  1. Из меню "Опции" выберите "Редактирование списка серверов".
  2. Выделите сервер NetWare 3.1x, Bindery которого вы хотите загрузить, и нажмите <Enter>.
  3. Выделите опцию "Копирование Bindery 3.1x в 4.1" и нажмите клавишу <Y> , чтобы подтвердить свой выбор.

    Если вы по какой-либо причине выгрузите, а затем снова загрузите NETSYNC4, эта опция будет очищена для всех серверов. Для тех серверов NetWare 3.1x, которые еще не скопировали свои Bindery на сервер NetWare 4, нужно изменить эту опцию на "Да".

  4. Для сохранения изменений нажмите <Enter>.
  5. Для выхода из меню "Редактирование списка серверов", нажмите <Esc>.
  6. Для подтверждения вашего выбора выделите "Да" и нажмите <Enter>.

    Копируется вся информация Bindery, но к Bindery контексту сервера NetWare 4 добавляется только новая информация. Информация, которая уже была скопирована, отбрасывается.

Удаление конфигурационных данных NetSync

Конфигурационные данные включают следующую информацию:

На хосте NetWare 4 На сервере NetWare 3.1x
Имена авторизованных серверов NetWare 3.1x и их паролиИмя хоста NetWare 4
пароль NetSyncпароль NetSync

Вы можете удалить конфигурацию NetSync на сервере NetWare 3.1x, если:

По умолчанию значение данной опции блокирует уничтожение конфигурационной информации ("Нет").

Процедура

  1. Из меню "Опции" выберите "Опции конфигурации".
  2. Выберите "Удаление данных конфигурации NetSync".
  3. Удалите конфигурационные данные, набрав "Д".
  4. Чтобы сохраненить изменения нажмите <Enter>.
  5. Для выхода из меню "Опции конфигурации", нажмите <Esc>.
  6. Для подтверждения изменений выделите "Да" и нажмите <Enter>.

Назад | Содержание | Вперед

Comments: info@citmgu.ru
Designed by Andrey Novikov
Copyright © CIT