Полезная информация

cc/td/doc/product/software/ios120/relnote
hometocprevnextglossaryfeedbacksearchhelp
PDF

Table of Contents

Release Notes for Cisco
800  Series Routers  for
Cisco  IOS  Release  12.0(1)XB

Release Notes for Cisco
800  Series Routers  for
Cisco  IOS  Release  12.0(1)XB

January 11, 1999

These release notes describe the new features and significant software components for Cisco  IOS Releases 12.0(1)XB and 12.0(1)XB1 for Cisco 800 series routers.


Note The Cisco 800 series routers support a subset of the Cisco IOS features described in these release notes. The Cisco IOS features that are available for the Cisco 800 series routers are listed in the section "Cisco IOS Feature Sets for Cisco 800 Series Routers".

Contents

These release notes discuss the following topics:

System Requirements

This section describes the system requirements and includes the following sections:

Memory Requirements

This section describes the memory requirements for the Cisco IOS feature sets supported by Cisco  IOS Releases 12.0(1)XB and 12.0(1)XB1 on Cisco 800 series routers.


Table 1: Release 12.0 Memory Requirements for Cisco 800 Routers
Platform/Feature Set Image Name Minimum Required Code Memory Required Main Memory Release 12.0 Runs from

IP

c800-g3-mw

8 MB Flash

4 MB DRAM

RAM

IP Plus

c800-g3s-mw

8 MB Flash

4 MB DRAM

RAM

IP/IPX Plus

c800-g3n-mw

8 MB Flash

4 MB DRAM

RAM

IP/X.25

c800-g3x-mw

8 MB Flash

4 MB DRAM

RAM

Cisco 800 Series Routers

The Cisco 800 series routers connect small professional offices over Integrated Services Digital Network (ISDN) Basic Rate Interface (BRI) lines to corporate networks and to the Internet. Table 2 summarizes the Cisco 800 series routers and the ports that each model offers.


Table 2: Cisco 800 Series Router Ports
Router Ethernet Ports ISDN Ports Telephone Ports Console Ports

Cisco 801

One 10BaseT (RJ-45)

ISDN BRI S/T (RJ-45)

-

RJ-45

Cisco 802

One 10BaseT (RJ-45)

ISDN BRI U, integrated Network Termination 1 (NT1) (RJ-45)

-

RJ-45

Cisco 803

Four-port 10BaseT (RJ-45) hub

ISDN BRI S/T (RJ-45)

Two (RJ-11)

RJ-45

Cisco 804

Four-port 10BaseT (RJ-45) hub

ISDN BRI U, integrated NT1 (RJ-45)

Two (RJ-11)

RJ-45

The Cisco 800 series routers provide the following key features:

Cisco IOS Feature Sets for Cisco  800 Series Routers

The following list shows which feature sets are supported on the Cisco 800 series routers. These feature sets only apply to Cisco  IOS Releases  12.0(1)XB and 12.0(1)XB1:

Feature Set Tables

To determine what features are available with each feature set (software image), see Table 3. The table summarizes the features you can use when running a specific feature set on the Cisco 800 series routers. The feature set table uses the following symbol conventions to identify features:


Note This feature set table contains only a selected list of features. This table is not a cumulative or complete list of all the features in each image.


Table 3: Cisco IOS Software Feature Sets for the Cisco 800 Routers
Feature Set
 Features IP IP Plus IP/IPX Plus IP/X.25
IP Routing

Easy IP Phase 2-DHCP Server

Yes

Yes

Yes

Yes

Cisco IOS STP Enhancements

Yes

Yes

Yes

Yes

IP Type of Service and Precedence for GRE Tunnels

No

Yes

Yes

Yes

ISDN MIB RFC 2127

Yes

Yes

Yes

Yes

OSPF Packet Pacing

No

No

No

No

OS IFSS Featurette

No

No

No

No

Protocol-Independent Multicast (PIM) Version 2

No

No

No

No

IBM Support

Bridging Code Rework

No

No

No

No

RIF Passthru in DLSw+

No

No

No

No

Security

AAA Support for MS-CHAP

Yes

Yes

Yes

Yes

Additional Vendor-Proprietary RADIUS Attributes

No

No

No

No

Authenticating ACL

No

No

No

No

Automated Double Authentication

No

No

No

No

Context-Based Access Control (CBAC)

No

No

No

No

Certificate Authority Interoperability

No

No

No

No

Internet Key Exchange Security Protocol

No

No

No

No

IPSec Network Security

No

No

No

No

Named Method Lists for AAA Authentication & Accounting

No

No

No

No

Management

VPDN MIB Feature

No

No

No

No

WAN Services

Always On/Dynamic ISDN

No

No

Yes

Yes

Dialer Watch

Yes

Yes

Yes

Yes

Interface Name Modularity

No

No

No

No

MPPC- MS PPP Compression

Yes

Yes

Yes

Yes

MS Callback

Yes

Yes

Yes

Yes

Mobile IP

No

No

No

No

Level 2 Tunnel Protocol (L2TP)

No

No

No

No

PPP Over Frame Relay

No

No

No

No

RIP Enhancements

Yes

Yes

Yes

Yes

Time-Based Access Lists

Yes

Yes

Yes

Yes

Switching

Multiple ISDN Switch Types

Yes

Yes

Yes

Yes

National ISDN Switch Type

Yes

Yes

Yes

Yes

Scalability

Airline Product Set (ALPS)

No

No

No

No

Cisco IOS File System

No

No

No

No

Conditionally Triggered Debugging

No

No

No

No

Entity MIB

No

No

No

No

Expression MIB

No

No

No

No

OSPF Point to Multipoint

No

No

No

No

The Cisco 800 series routers also support the features listed in Table 4.


Table 4: Additional Features supported by Cisco 800 Routers
Feature IP IP Plus IP/IPX Plus IP/X.25

Routed Protocol

IP

IP

IP/IPX

IP

Routing Protocol

RIP

Snapshot

RIP/EIGRP

Snapshot

RIP/EIGRP/IPXWAN

Snapshot

RIP/EIGRP

Snapshot

Tunneling

GRE

GRE

GRE

X.25

X.25

X.25

SNTP (time)

SNTP

SNTP

SNTP

Multicast

IP Multicast Forwarding

IP Multicast Forwarding

IP Multicast Forwarding

Management

SNMP

SNMP/SYSLOG

SNMP/SYSLOG

SNMP/SYSLOG

New and Changed Information

The following sections list the new features supported by the Cisco 800 series routers in Cisco IOS  Releases 12.0(1)XB and 12.0(1)XB1.

New Software Features

The following new features in Cisco IOS Releases 12.0(1)XB and 12.0(1)XB1 are available for the Cisco 800 series routers. These Cisco IOS releases also support the features in Cisco IOS Release  12.0(1)T, which are described in the Release Notes for Cisco IOS Release 12.0T. To access this document, see the "Related Documentation" section later in this document.

Voice Features Over ISDN

The Cisco 800 series routers support the connection of analog telephones, fax machines, and modems. These devices are connected to basic telephone services through the ISDN line. The routers support the following supplementary services, which can be ordered from the telephone service provider:

The ISDN voice priority feature controls the priority of data and voice calls for the devices connected to the router telephone ports. If an ISDN circuit endpoint is busy with a data call or calls, and either a voice call comes in or you attempt to place a voice call, the data call is handled per the voice priority setting.

Automatic Detection of ISDN Switch and SPIDs

This feature applies to North America only. The Cisco 800 series routers can detect the ISDN switch that supports the ISDN line and the service profile identifiers (SPIDs) assigned by the telephone service provider. SPIDs identify the ISDN B channels. The SPID format is generally an ISDN telephone number with numbers added to it, for example, 40855522220101. Depending on the switch that supports the ISDN line, the ISDN line could be assigned zero, one, or two SPIDs.

Important Notes

This section describes warnings and cautions about using the Cisco  IOS Release 12.0(1)XB software.

B Channel Activation

When a call comes in, a B channel is activated. If the amount of traffic on the B channel exceeds a threshold, the other B channel is activated. If the amount of traffic falls below the threshold, one of the B channels is deactivated. The B channel that is initially activated when the call comes in is not necessarily B1 nor is the B channel that is deactivated when the traffic level lessens necessarily B2.

Dial Peer Limitation

The isdn answer1 and isdn answer2 commands determine which called telephone numbers, for example, 555-1111 and 555-2222, a Cisco 800 series router can answer. Using these commands limits a router to using the two dial peers that contain the telephone numbers 555-1111 and 555-2222. (When not using these commands, a router can use up to six dial peers.)

A sample scenario in which the isdn answer1 and isdn answer2 commands are used is when a Cisco  801 or Cisco 803 router is connected with other ISDN devices to an ISDN S-bus.

Excessive ISDN Line Activation

The following protocols send updates that can cause an ISDN line to be activated excessively thereby increasing your monthly ISDN line cost:

For information on preventing this situation, refer to the Cisco 800 Series Routers Software Configuration Guide. This guide contains information on setting up extended access lists to prevent IP, UDP, IPX, and SNTP updates from activating the ISDN line. For CDP, make certain that you enter the no cdp enable command to disable CDP.

Phone Mate Answering Machine Model 9200

Phone Mate answering machine model 9200 failed to recognize the ringing signal sent by AMD R79 ringing SLIC. This was confirmed by testing against Phone Mate model 3750 and newer model  9300.

Open Caveats

This section describes possibly unexpected behavior by Cisco IOS Releases 12.0(1)XB and 12.0(1)XB1. This section describes only severity 1 and 2 caveats.

In addition, some caveats in Cisco IOS Releases  12.0(1) T apply to Cisco IOS Releases 12.0(1)XB and 12.0(1)XB1. For descriptions of Cisco IOS Release 12.0 T caveats, see the Cisco IOS Software Release 12.0 T Caveats. To access this document, see the section, "Related Documentation."

For example, the following sequence of events causes a failure:
    no shut
    isdn spid1 0 4081234567
    isdn spid2 0 4081234568
    isdn autodetect
     
    
The proper sequence of events is as follows:
    isdn spid1 0 4081234567
    isdn spid2 0 4081234568
    isdn autodetect
     
    [CSCdk44854]
     
    
You can work around this vulnerability by preventing any affected Cisco IOS device from receiving or processing UDP datagrams addressed to its port 514. This can be done either using packet filtering on surrounding devices, or by using input access list filtering on the affected IOS device itself.
If you use an input access list, that list should be applied to all interfaces to which attackers may be able to send datagrams. This includes not only physical LAN and WAN interfaces, but virtual subinterfaces of those physical interfaces, as well as virtual interfaces and/or interface templates corresponding to GRE, L2TP, L2F, and other tunnelling protocols.
The input access list must block traffic destined for any of the Cisco IOS device's own IP addresses, as well as for any broadcast or multicast addresses on which the Cisco IOS device may be listening. It's important to remember to block old-style "all-zeroes" broadcasts as well as new-style "all-ones" broadcasts.
There is no single input access list that will work in all configurations. It is very important that you understand the effect of your access list in your specific configuration before you activate
the list.
The following example shows a possible access list for a three-interface router, along with the configuration commands needed to apply that access list. The example assumes no need for input filtering other than as a workaround for this vulnerability.
      ! Deny all multicasts, and all unspecified-net broadcasts, to port 514
      access-list 101 deny udp any 224.0.0.0 31.255.255.255 eq 514
      ! Deny old-style unspecified-net broadcasts
      access-list 101 deny udp any host 0.0.0.0 eq 514
      ! Deny network-specific broadcasts. This example assumes that all of
      ! the local interfaces are on the class B network 172.16.0.0, subnetted
      ! everywhere with mask 255.255.255.0. This will differ from network
      ! to network. Note that we block both new-style and old-style broadcasts.
      access-list 101 deny udp any 172.16.0.255 0.0.255.0 eq 514
      access-list 101 deny udp any 172.16.0.0   0.0.255.0 eq 514
      ! Deny packets sent to the addresses of our own network interfaces.
      access-list 101 deny udp any host 172.16.1.1 eq 514
      access-list 101 deny udp any host 172.16.2.1 eq 514
      access-list 101 deny udp any host 172.16.3.3 eq 514
      ! Permit all other traffic (default would be to deny)
      access-list 101 permit ip any any
 
      ! Apply the access list to the input side of each interface
      interface ethernet 0
      ip address 172.16.1.1 255.255.255.0
      ip access-group 101 in
 
      interface ethernet 2
      ip address 172.16.2.1 255.255.255.0
      ip access-group 101 in
 
      interface ethernet 3
      ip address 172.16.3.3 255.255.255.0
      ip access-group 101 in
 
It can be complicated to list all possible addresses, and especially all possible broadcast addresses, to which attack packets might be sent. If you do not expect to receive any legitimate syslog traffic on an interface, you may wish to simply block all syslog traffic arriving on that interface. Remember that this will affect traffic routed through the Cisco IOS device as well as traffic destined to the device.
Input access lists have an impact on system performance, and should be installed with a degree of caution, especially on systems that are running very near their capacity limits. [CSCdk77426]

Related Documentation

The following sections describe the documentation available for the Cisco 800 series routers. Typically these documents consist of hardware installation guides, software installation guide guides, Cisco IOS configuration and command references, system error messages, and feature modules, which are updates to the Cisco IOS documentation. Documentation is available as printed manuals or electronic documents, except for feature modules, which are available online only.

The most up-to-date documentation can be found on the Web via Cisco Connection Online (CCO) and on the latest Documentation CD-ROM. These electronic documents might contain updates and modifications made after the paper documents were printed. For information on CCO, refer to the "Cisco Connection Online" section later in this document. For more information on to the CD-ROM, refer to the "Documentation CD-ROM" section later in this document.

The following sections describe the documentation related to these release notes:

Cisco IOS Software Documentation

The release notes for Cisco IOS Releases 12.0(1)XB and 12.0(1)XB1 should be used in conjunction with the Release Notes for Cisco IOS Release 12.0 T. This document describes the release from which the current special release is derived.

Additional documentation for Cisco IOS Release 12.0 T is listed below.

To access release-specific documentation on the documentation CD-ROM, follow this path:

Cisco Product Documentation: Cisco Product Documentation/Cisco IOS Software Configuration/Cisco IOS Release 12.0

The following documents apply to Cisco IOS Releases 12.0(1)XB and 12.0(1)XB1:


Note Due to a production problem, many source-route bridging commands were omitted from the printed version of the Cisco IOS Software Command Summary (78-4746-01). For complete documentation of all source-route bridging commands, refer to the Bridging and IBM Networking Command Reference (78-4743-01). You can also obtain the most current documentation on the Documentation CD-ROM or Cisco Connection Online (CCO).

Platform-Specific Documents

Hardware documentation for the Cisco 800 series routers is listed below. These documents ship with the Cisco 800 series routers.

To access hardware documents on CCO, follow this path:

Products and Ordering: Cisco Documentation: Cisco Product Documentation/Access Servers and Access Routers/Fixed Access Routers/Cisco 800

To access hardware documentation on the documentation CD-ROM, follow this path:

Cisco Product Documentation: Cisco Product Documentation/Access Servers and Access Routers/Fixed Access Routers/Cisco 800

The following documents are specific to the Cisco 800 series routers:

Software Documents

Cisco IOS software documentation is listed in Table 5. Software documentation consists of the Cisco  IOS configuration guides and command references and also includes several supporting documents. These documents are shipped with the Cisco 800 series routers in electronic form on the Documentation CD-ROM, unless you specifically ordered the printed version of the documents.

To access software documents on CCO, follow this path:

Products and Ordering: Cisco Documentation: Cisco IOS Software Configuration: Cisco IOS Release 12.0

To access software documentation on the documentation CD-ROM, follow this path:

Cisco Product Documentation: Cisco IOS Software Configuration: Cisco IOS Release 12.0


Table 5: Software Documents for Cisco 800 Series Routers
Books Chapter Topics

· Configuration Fundamentals Configuration Guide

· Configuration Fundamentals Command Reference

Configuration Fundamentals Overview
Cisco IOS User Interfaces
File Management
Interface Configuration
System Management

· Network Protocols Configuration Guide, Part 1

· Network Protocols Command Reference, Part 1

IP Addressing
IP Services
IP Routing Protocols

· Network Protocols Configuration Guide, Part 2

· Network Protocols Command Reference, Part 2

AppleTalk
Novell IPX

· Network Protocols Configuration Guide, Part 3

· Network Protocols Command Reference, Part 3

Apollo Domain
Banyan VINES
DECnet
ISO CLNS
XNS

· Wide-Area Networking Configuration Guide

· Wide-Area Networking Command Reference

ATM
Frame Relay
SMDS
X.25 and LAPB

· Security Configuration Guide

· Security Command Reference

AAA Security Services
Security Server Protocols
Traffic Filtering
Network Data Encryption
Passwords and Privileges
Neighbor Router Authentication
IP Security Options

· Dial Solutions Configuration Guide

· Dial Solutions Command Reference

Dial Business Solutions and Examples
Dial-In Port Setup
DDR and Dial Backup
Remote Node and Terminal Service
Cost-Control and Large-Scale Dial Solutions
VPDN

· Cisco IOS Switching Services Configuration Guide

· Cisco IOS Switching Services Command Reference

Switching Paths for IP Networks
Virtual LAN (VLAN) Switching and Routing

· Bridging and IBM Networking Configuration Guide

· Bridging and IBM Networking Command Reference

Transparent Bridging
Source-Route Bridging
Remote Source-Route Bridging
DLSw+
STUN and BSTUN
LLC2 and SDLC
IBM Network Media Translation
DSPU and SNA Service Point
SNA Frame Relay Access Support
APPN
NCIA Client/Server Topologies
IBM Channel Attach

· Cisco IOS Software Command Summary

· Dial Solutions Quick Configuration Guide

· System Error Messages

· Debug Command Reference


Note The Cisco Management Information Base (MIB) User Quick Reference publication is no longer being published. For the latest list of MIBs supported by Cisco, see the Cisco Network Management Toolkit on Cisco Connection Online. On CCO, go to Software and Support, select Software Center, and click Network Management Products. Next, select Cisco Network Management Toolkit, and click Cisco MIBs.

Service and Support

For service and support for a product purchased from a reseller, contact the reseller. Resellers offer a wide variety of Cisco service and support programs, which are described in the section "Service and Support" in the information packet that shipped with your product.


Note If you purchased your product from a reseller, you can access CCO as a guest. CCO is Cisco Systems' primary real-time support channel. Your reseller offers programs that include direct access to CCO services.

For service and support for a product purchased directly from Cisco, use CCO.

Software Configuration Tips on the Cisco TAC Home Page

The following URL contains links to access helpful tips on configuring your Cisco products:

http://www.cisco.com/kobayashi/serv_tips.shtml

This URL is subject to change without notice. If it changes, point your web browser to http://www.cisco.com/, and follow this path: Software & Support, Technical Tips (button on left margin).

"Hot Tips" are popular tips and hints gathered from the Cisco Technical Assistance Center (TAC). Most of these documents are available from the TAC fax-on-demand service. To access fax-on-demand and receive documents at your fax machine from the USA, call 888-50-CISCO (888-502-4726). From other areas, call 415-596-4408.

The following sections are provided from the Technical Tips page:

Cisco Connection Online

Cisco Connection Online (CCO) is Cisco Systems' primary, real-time support channel. Maintenance customers and partners can self-register on CCO to obtain additional information and services.

Available 24 hours a day, 7 days a week, CCO provides a wealth of standard and value-added services to Cisco's customers and business partners. CCO services include product information, product documentation, software updates, release notes, technical tips, the Bug Navigator, configuration notes, brochures, descriptions of service offerings, and download access to public and authorized files.

CCO serves a wide variety of users through two interfaces that are updated and enhanced simultaneously: a character-based version and a multimedia version that resides on the World Wide Web (WWW). The character-based CCO supports Zmodem, Kermit, Xmodem, FTP, and Internet e-mail, and it is excellent for quick access to information over lower bandwidths. The WWW version of CCO provides richly formatted documents with photographs, figures, graphics, and video, as well as hyperlinks to related information.

You can access CCO in the following ways:

For a copy of CCO's Frequently Asked Questions (FAQ), contact cco-help@cisco.com. For additional information, contact cco-team@cisco.com.


Note If you are a network administrator and need personal technical assistance with a Cisco product that is under warranty or covered by a maintenance contract, contact Cisco's Technical Assistance Center (TAC) at 800  553-2447, 408  526-7209, or tac@cisco.com. To obtain general information about Cisco Systems, Cisco products, or upgrades, contact 800  553-6387, 408  526-7208, or cs-rep@cisco.com.

Documentation CD-ROM

Cisco documentation and additional literature are available in a CD-ROM package, which ships with your product. The Documentation CD-ROM, a member of the Cisco Connection Family, is updated monthly. Therefore, it might be more current than printed documentation. To order additional copies of the Documentation CD-ROM, contact your local sales representative or call customer service. The CD-ROM package is available as a single package or as an annual subscription. You can also access Cisco documentation on the World Wide Web at http://www.cisco.com, http://www-china.cisco.com, or http://www-europe.cisco.com.

If you are reading Cisco product documentation on the World Wide Web, you can submit comments electronically. Click Feedback in the toolbar, select Documentation, and click Enter the feedback form. After you complete the form, click Submit to send it to Cisco. We appreciate your comments.


hometocprevnextglossaryfeedbacksearchhelp

Copyright 1989-1999©Cisco Systems Inc.