Полезная информация

cc/td/doc/product/software/ios120/12cgcr/voice_c
hometocprevnextglossaryfeedbacksearchhelp
PDF

Table of Contents

Configuring Voice over HDLC for the Cisco MC3810

Configuring Voice over HDLC for the Cisco MC3810

This chapter describes how to configure voice traffic over High-Level Data Link Control (HDLC), a protocol that provides Cisco serial encapsulation. For a description of the commands used to configure Voice over HDLC, refer to the "Voice-Related Commands" chapter in the Voice, Video, and Home Applications Command Reference.

Voice over HDLC enables a Cisco MC3810 concentrator to carry live voice traffic (for example, telephone calls and faxes) back-to-back to a second Cisco MC3810. Voice over HDLC on the Cisco  MC3810 is supported on serial ports 0 or 1, or on 0:x (the T1/E1 trunk, where x represents the channel group number).

Configuring Voice over HDLC is simpler than configuring Voice over Frame Relay or ATM. Because the target voice-network peer is another Cisco  MC3810 configured back-to-back with the first Cisco MC3810, you do not have to configure the network backbone to support Voice  over HDLC.

Before you can configure your Cisco MC3810 to use Voice over HDLC, you must first configure the clock source for the Cisco MC3810 interfaces. For more information, refer to the "Configuring Synchronous Clocking on the Cisco MC3810" appendix.

Voice over HDLC Configuration Task List

To configure Voice over HDLC, perform the following tasks:

Configure HDLC Voice Encapsulation

Before you can configure HDLC dial peers, you need to configure the HDLC voice encapsulation.

To configure HDLC voice encapsulation, use the following commands beginning in global configuration mode:
Step Command Purpose
1

controller {t1 | e1} 0

If configuring Voice over HDLC over the T1/E1 trunk (T1/E1 0), enter controller configuration mode.

If configuring Voice over HDLC over serial port 0 or 1, proceed to Step 5.

If the digital voice module (DVM) is installed, the controller number can be either 0 or 1. If the multiflex trunk (MFT) is installed, the controller number must be  0.

2

channel-group channel-no timeslots timeslot-list speed {56 | 64}

Configure the channel group number and the timeslot list for the controller. The channel group is a number from 0   to 23. The timeslot-list is a number from 1 to 24.

The channel group number must be unique, and cannot be the same as a configured CAS group or voice group.

3

exit

Exit controller configuration mode.

4

interface serial 0:x
{multipoint | point-to-point}

If configuring Voice over HDLC over the T1/E1 trunk, enter interface configuration mode by specifying serial 0:x, where x is the channel group number you configured in the previous step.

Note Beginning with Release 12.0, serial 2 is not a valid designation on the Cisco MC3810. You must enter the channel group number.

If the Voice over HDLC connection will be over a point-to-point network, specify the point-to-point option. The default option, multipoint, assumes you have a fully meshed network. Proceed to step 6.

5

interface serial number
{multipoint | point-to-point}

If configuring Voice over HDLC over serial port 0 or  1, enter interface configuration mode and configure the serial interface.

If the Voice over HDLC connection will be over a point-to-point network, specify the point-to-point option. The default option, multipoint, assumes you have a fully meshed network.

You can specify serial port 0 or 1 for traffic over the Universal I/O (UIO) serial ports.

6

voice-encap size

Configure the voice segmentation size. The valid range for the size value is from 80 to 1600. There is no default.

7

exit

Exit interface configuration mode.

Configure Dial Peers

Dial peers describe the entities to and/or from which a call is established. Dial-peer configuration tasks define the address or set of addresses serviced by that dial peer and the call parameters required to establish a call to and/or from that dial peer.

There are two different kinds of dial peers:


Note The configuration for HDLC dial peers is very similar to the dial-peer configuration for Frame Relay or ATM. The term HDLC dial peer is used here because in most cases, the peer is back-to-back and normally on the same network.

POTS dial peers associate a telephone number with a particular voice port so that incoming calls for that telephone number can be received and outgoing calls can be placed. HDLC peers point to specific voice-network devices so that incoming calls can be received and outgoing calls can be placed. Both POTS and HDLC dial peers are needed to establish Voice over HDLC connections if you want to both send and receive calls. Establishing two-way communication using Voice over HDLC requires establishing a specific voice connection between two defined endpoints.

The following sections describe how to configure POTS and HDLC dial peers.

Configure POTS Dial Peers

To configure a POTS dial peer, you need to uniquely identify the peer (by assigning it a unique tag number), define its telephone number, and associate it with a voice port through which calls will be established. Under most circumstances, the default values for the remaining dial-peer configuration commands will be sufficient to establish connections.

To configure POTS dial peers, use the following commands beginning in global configuration mode:
Step Command Purpose
1

dial-peer voice tag pots

Define a POTS dial peer and enter dial-peer configuration mode. All subsequent commands that you enter in dial-peer voice mode before you exit will apply to this dial peer.

The tag value identifies the dial peer and must be unique on the Cisco MC3810. Do not duplicate a specific tag number.

2

destination-pattern string

Configure the dial peer's destination pattern.

The string is a series of digits that specify the E.164 or private dialing plan telephone number. Valid entries are the digits 0 through 9 and the letters A through D. The following special characters can be entered in the string:

  • The star character (*) and the pound sign (#) that appear on standard touch-tone dial pads can be used in any dial string. However, these characters cannot be used as leading characters in a string (for example, *650).

  • The period (.) can be entered any time, and is used as a wildcard character.

  • The comma (,) can be used only in prefixes, and is used to insert a one-second pause or a delay.

3

port slot/port

Associate this POTS dial peer with a specific logical dial interface. Enter the slot/port number of the voice port connected to the POTS dial peer.

4

forward-digits {num-digit | all}

(Optional) If using the digit-forwarding feature, configure the digit-forwarding method that will be used on the dial peer.

5

prefix string

(Optional) If the forward-digits feature was not configured in the last step, assign the dialed digits prefix for the dial peer.

To configure additional POTS dial peers, exit dial-peer configuration mode by entering exit, and repeat the previous steps.

Configure HDLC Dial Peers

To configure an HDLC dial peer, you need to uniquely identify the peer (by assigning it a unique tag number), define the outgoing serial port number and the virtual circuit number.

To configure HDLC dial peers, use the following commands beginning in global configuration mode:
Step Command Purpose
1

dial-peer voice tag vohdlc

Define a dial peer for Voice over HDLC and enter dial-peer configuration mode. All subsequent commands that you enter in dial-peer voice mode before you exit will apply to this dial peer.

The tag value identifies the dial peer and must be unique on the Cisco MC3810. Do not duplicate a specific tag number.

2

destination-pattern string

Configure the dial peer's destination pattern. The same restrictions for the string listed in the POTS dial-peer configuration also apply to the Voice over HDLC destination-pattern.

3

session target interface serial-port-number

Configure the HDLC session target for the dial peer. For the serial-port-number value, enter either 0 and 1.

4

preference value

(Optional) Configure a preference for the Voice over HDLC dial peer. The value is a number from 0 to 10 where the lower the number, the higher the preference.

5

alt-dial string

(Optional) Configure the alternate dial-out string when configuring on-net-to-off-net alternative dialing.

To configure additional HDLC dial peers, exit dial-peer configuration mode by entering exit, and repeat the previous steps.

Validation Tips

If you have relatively few dial peers configured, you can use the show dial-peer voice command to verify the validity of your dial-peer configuration.

Troubleshooting Tips

If you are having trouble connecting a call, you can try to resolve the problem by performing the following tasks:

Voice over HDLC Configuration Example

Figure 32 shows an example of a simple back-to-back Voice over HDLC configuration.


Figure 32: Voice over HDLC Configuration Example


The following is the configuration for both Cisco MC3810 concentrators to configure back-to-back Voice over HDLC:

Configuration for Cisco MC3810 No. 1

interface Serial1 point-to-point
 ip address 5.5.5.1 255.0.0.0
 no keepalive
 ipx network 2222
 ipx accounting
 voice-encap 512
 clockrate 64000
ip classless
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 login
voice-port 1/1
 dial-peer voice 1 pots
 destination-pattern 3388801
 port 1/1
dial-peer voice 2 pots
 destination-pattern 3388802
 port 1/2
dial-peer voice 44 vohdlc
 destination-pattern 348....
 session target Serial1
end

Configuration for Cisco MC3810 No. 2

interface Serial1 point-to-point
 ip address 5.5.5.2 255.0.0.0
 no keepalive
 ipx network 2222
 ipx accounting
 voice-encap 512
 clockrate 64000
ip classless
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 login
voice-port 1/1
 dial-peer voice 1 pots
 destination-pattern 3488803
 port 1/1
dial-peer voice 2 pots
 destination-pattern 3488804
 port 1/2
dial-peer voice 40 vohdlc
 destination-pattern 338....
 session target Serial1
end

hometocprevnextglossaryfeedbacksearchhelp
Copyright 1989-1998 © Cisco Systems Inc.