Полезная информация

cc/td/doc/product/software/ios120/12cgcr/voice_c
hometocprevnextglossaryfeedbacksearchhelp
PDF

Table of Contents

Configuring Voice over Frame Relay for the Cisco MC3810

Configuring Voice over Frame Relay for the Cisco MC3810

This chapter shows you how to configure Voice over Frame Relay on the Cisco MC3810 concentrator. For a description of the commands used to configure Voice over Frame Relay, refer to the "Voice-Related Commands" chapter in the Voice, Video, and Home Applications Command Reference.

Voice over Frame Relay enables a Cisco MC3810 concentrator to carry voice traffic (for example, telephone calls and faxes) over a Frame Relay network. Voice over Frame Relay on the Cisco  MC3810 is supported on serial ports 0 and 1, as well as on the T1/E1 trunk.


Note The Cisco MC3810 does not support Frame Relay switched virtual circuits (SVCs).

This chapter describes the commands to specifically configure Voice over Frame Relay on the Cisco  MC3810. It is assumed you have already configured your Frame Relay backbone network. As part of your Frame Relay configuration, you need to configure the map class, and the Local Management Interface (LMI) among other Frame Relay functionality. For more information about Frame Relay configuration, see the Wide-Area Networking Configuration Guide.

List of Terms

Call leg---A logical connection between the router and either a telephony endpoint over a bearer channel, or another endpoint using a session protocol.

CIR---Committed information Rate. The average rate of information transfer a subscriber (for example, the network administrator) has stipulated for a Frame Relay PVC.

CODEC---coder-decoder. Device that typically uses pulse code modulation to transform analog signals into a digital bit stream and digital signals back into analog signals. In Voice over IP, it specifies the voice coder rate of speech for a dial peer.

DCE---Data communications equipment.

DLCI---Data-link connection identifier.

Dial peer---An addressable call endpoint. In Voice over IP, there are two kinds of dial peers: POTS and VoIP.

DS0---A 64-K B-channel on an E1 or T1 WAN interface.

DTE---Data terminal equipment.

DTMF---Dual tone multifrequency. Use of two simultaneous voice-band tones for dial (such as touch tone).

E&M---E&M stands for recEive and transMit (or Ear and Mouth). E&M is a trunking arrangement generally used for two-way switch-to-switch or switch-to-network connections. Cisco's E&M interface is an RJ-48 connector that allows connections to PBX trunk lines (tie lines).

FXO---Foreign Exchange Office. An FXO interface connects to the PSTN's central office and is the interface offered on a standard telephone. Cisco's FXO interface is an RJ-11 connector that allows an analog connection to be directed at the PSTN's central office. This interface is of value for off-premise extension applications.

FXS---Foreign Exchange Station. An FXS interface connects directly to a standard telephone and supplies ring, voltage, and dial tone. Cisco's FXS interface is an RJ-11 connector that allows connections to basic telephone service equipment, keysets, and PBXs.

PBX---Private Branch Exchange. Privately owned central switching office.

PLAR---Private Line Auto Ringdown. This type of service results in a call attempt to some particular remote endpoint when the local extension is taken off-key.

POTS---Plain Old Telephone Service. Basic telephone service supplying standard single line telephones, telephone lines, and access to the public switched telephone network.

POTS dial peer---Dial peer connected via a traditional telephony network. POTS peers point to a particular voice port on a voice network device.

PSTN---Public Switched Telephone Network. PSTN refers to the local telephone company.

PVC---Permanent virtual circuit.

Trunk---Service that allows quasi-transparent connections between two PBXs, a PBX and a local extension, or some other combination of telephony interfaces to be permanently conferenced together by the session application and signaling passed transparently through the IP network.

UIO---Universal I/O serial port (Cisco MC3810)

VoFR dial peer---Dial peer connected via a Frame Relay network. VoFR peers point to specific VoFR devices.

Prerequisites Tasks

Before you can configure your Cisco MC3810 concentrator to use Voice over Frame Relay, you must first:

After you have analyzed your dial plan and decided how to integrate it into your existing Frame Relay network, you are ready to configure your network devices to support Voice over Frame Relay.

Voice over Frame Relay Configuration Task List

To configure Voice over Frame Relay, you need to perform the following tasks:

    1. Configure Frame Relay Network to Support Real-Time Voice Traffic

    2. Prepare to Configure Voice Dial Peers

    3. Configure Dial Peers

    4. Configure Voice Ports

Configure Frame Relay Network to Support Real-Time Voice Traffic

This section describes the preliminary Frame Relay configuration tasks necessary to support Voice over Frame Relay. This section is divided into three procedures:

You can perform any of the procedures, depending on your application.

Configure a Frame Relay Map Class for a Group of DLCIs

Before configuring a Frame Relay data-link connection identifier (DLCI) for voice traffic, you can configure a Frame Relay map class to assign traffic shaping properties to a group of DLCIs. If you have a large number of permanent virtual circuits (PVCs) to configure, you can assign the PVCs the same traffic shaping properties without statically defining the values for each PVC.

Configuring a Frame Relay map class is optional. You can create multiple map classes, with different variables for each map class. If you want to skip this task, proceed to the next section.


Note When configuring the burst size, the committed burst size, and the committed information rate (CIR) values, obtain the appropriate values from your carrier. The values configured on the Cisco MC3810 must match those of the carrier. Traffic shaping is necessary to prevent your carrier from discarding excess frames on ingress.

To configure a Frame Relay map class for a group of DLCIs, use the following commands beginning in configuration mode:
Step Command Purpose

1 . 

map-class frame-relay map-class-name

Create a map-class name you will assign to a group of PVCs. The map-class-name must be unique.

2 . 

frame-relay be in bits

Configure the incoming excess burst size for this group of PVCs.

3 . 

frame-relay be out bits

Configure the outgoing excess burst size for this group of PVCs.

4 . 

frame-relay  adaptive-shaping   becn

Configure the adaptive traffic rate adjustment to support Backward Explicit Congestion Notification (BECN) on this group of PVCs.

5 . 

exit

Exit map-class configuration mode.

Configure a Frame Relay DLCI for Voice Traffic

When configuring a Frame Relay PVC to support voice traffic, you must ensure that the carrier can accommodate the traffic rate or profile transmitted on the PVC. If too much traffic is sent at once, the carrier may discard frames, which causes disruptions to real-time voice traffic. Or, the carrier may deal with traffic bursts by queuing up the bursts and delivering them at a metered rate. Excessive queuing also causes disruption to real-time voice traffic.

To compensate for this, it is recommended that you configure Frame Relay traffic shaping, and that you configure the traffic profile parameters specified with the map class. For more information on configuring the map class, see the previous section.

To configure a Frame Relay DLCI to support voice traffic, use the following commands beginning in configuration mode:
Step Command Purpose

1 . 

controller {t1 | e1} number

If configuring Voice over Frame Relay over the T1/E1 trunk (T1/E1 0), enter the controller configuration mode.

If configuring Voice over Frame Relay over serial port  0  or  1, proceed to Step 5.

If the Digital Voice Module (DVM) is installed, the controller number can be either 0 or 1. If the Multiflex-Trunk (MFT) is installed, the number must be 0.

2 . 

channel-group channel-no timeslots timeslot-list speed {56 | 64}

Configure the channel group number and the timeslot list for the controller. The channel group is a number from 0 to 23. The timeslot-list is a number from 1 to 24.

The channel group number must be unique, and cannot be the same as a configured CAS group or voice group.

3 . 

exit

Exit controller configuration mode.

4 . 

interface serial 0: x

If configuring Voice over Frame Relay over the T1/E1 trunk, enter interface configuration mode by specifying serial 0:x, where x is the channel group number you configured in the previous step.

In the previous Cisco IOS Release 11.3(1) MA, serial port 2 was a valid port number. Beginning with Release 12.0, serial 2 is not a valid designation on the Cisco MC3810. You must enter the channel group number. Proceed to Step  6.

5 . 

interface serial number

If configuring Voice over Frame Relay over serial port 0 or  1, enter interface configuration mode and configure the serial interface.

You can specify serial port 0 or 1 for traffic over the Universal I/O (UIO) serial ports.

6 . 

encapsulation frame-relay [ietf]

Set the encapsulation type to Frame Relay on the serial port. Specify the ietf option only if RFC 1490 is supported.

7 . 

clock rate network clock rate

If configuring back-to-back Frame Relay, set the network clock rate in kbps for the data communications equipment (DCE) side on serial ports 0 and 1 only. The valid range is from 56 to 2048 kbps, and the value must be a multiple of the value set using the network-clock base-rate command.

8 . 

dce terminal-timing enable

If configuring back-to-back Frame Relay, configure the DCE port to use its own clock signal to prevent phase shifting of the data with respect to the clock.

9 . 

frame-relay traffic-shaping

If a Frame Relay map class was not configured and assigned to this DLCI, enable Frame Relay traffic shaping on the interface.

Make sure to use Frame Relay traffic shaping only; do not use generic traffic shaping.

Note Frame Relay traffic shaping should be enabled on the interface if sending voice and data traffic over a single Frame Relay PVC over a public Frame Relay network. If sending voice and data traffic over a back-to-back Frame Relay configuration, or on a private Frame Relay network, traffic shaping is not required.

10 . 

frame-relay interface-dlci dlci voice-encap size

Configure the Frame Relay DLCI to support data segmentation for voice encapsulation. The size denotes the data segmentation size. The valid range is from 80 to 1600 bytes.

You must configure the voice encapsulation option to support voice traffic. Set the data segmentation size to match the line rate, or the port access rate. Configure the same data segmentation size value on both Cisco MC3810 concentrators on the voice connection. For more information about recommended data segmentation sizes, see Table 7.

When the voice-encap option is configured, all priority queuing, custom queuing, and weighted fair queuing is disabled on the interface.

Note The voice-encapsulation option applies only to the transmit DLCI side. This option sends the Frame Relay stream through a segmentation engine that is similar to FRF.12.

11 . 

class name

Associate the DLCI with a map class that you configured in the previous section. The traffic shaping properties associated with the map class will be assigned to the DLCI.

12 . 

exit

Exit DLCI configuration mode.

If the serial interface was configured for multipoint operation, repeat Steps 10 through 12 for each subinterface.


Table 7: Recommended Data Segmentation Sizes
Access Rate Recommended Data Segmentation Size1

64 kbps

80 bytes

128 kbps

160 bytes

256 kbps

320 bytes

512 kbps

640 bytes

1536 kbps (full T1)

1600 bytes

2048 kbps (full E1)

1600 bytes

1The data segmentation size is based on back-to-back Frame Relay. If sending traffic through an IGX with standard Frame Relay, subtract 6 bytes from the recommended data segmentation size.


Note When configuring the voice encapsulation data segmentation size, use the slower access rate of either the local or remote device to calculate which data segmentation size to use. If you configure a data segmentation size too high for either the local or remote device, the access rate will become throttled because the slower device cannot handle the larger data segmentation size. For example, if the access rate at the local device is 512  kbps and the access rate of the remote device is 256 kbps, configure the data segmentation size based on the slower 256 kbps access rate.

When configuring Voice over Frame Relay in back-to-back hard-wired configurations, make sure one side of the voice connection is configured as DCE and the other side is configured as DTE. The Voice over Frame Relay configuration must be performed on the Cisco MC3810 concentrators on both sides of the voice connection.

Configure Switched Frame Relay for Voice Traffic

To configure switched Frame Relay to support voice traffic, use the following command in configuration mode:
Command Purpose

frame-relay switching

Enable PVC switching on the Cisco MC3810.


Note The voice-encapsulation option applies only to the transmit DLCI side.

Prepare to Configure Voice Dial Peers

After you have analyzed your dial plan and decided how to integrate it into your existing network, you are ready to configure your network devices to support Voice over Frame Relay. The actual configuration procedure depends entirely upon the topology of your voice network, but, in general, you need to complete the following steps:

TimeSaver If possible, you might want to configure the Frame Relay dial peers in a back-to-back configuration before separating them across the Frame Relay network. Using a back-to-back configuration, you can test your Voice over Frame Relay and dial-peer configuration to see if you can successfully make a voice connection. Then, when you place both peers on the network, if you cannot make a voice connection, you can isolate the cause as a network problem. For an example of a back-to-back Voice over Frame Relay configuration, see the "Voice over Frame Relay Configuration Examples" section.

Organize Voice Network Information

After you have configured your Frame Relay network, you should collect all of the data directly related to each dial peer by creating a peer configuration table to prepare for configuring Voice over Frame Relay.

Create a Peer Configuration Table

There is specific information relative to each dial peer that needs to be identified before you can configure Voice over Frame Relay. One way to do this is to create a peer configuration table.

Figure 15 shows a diagram of a small voice network in which Router 1 connects a small sales branch office to the main office through Router 2. There are only two devices in the sales branch office that need to be established as dial peers: a basic telephone and a fax machine. Router 2 is the primary gateway to the main office; as such, it needs to be connected to the company's private branch exchange (PBX). There are two basic telephones and one fax machine connected to the PBX that need to be established as dial peers in the main office.

Table 8 shows the peer configuration table for the example illustrated in Figure 15.


Figure 15: Sample Voice over Frame Relay Network



Table 8:
Dial Peer Ext Prefix Destination-Pattern Type Voice Port Session Target
Router 1

1

61111

13101161111

POTS

1/1

2

62222

13101162222

POTS

1/2

10

1310117....

VOFR

S0 150

Router 2

11

1310116....

VOFR

S0 150

3

73333

7

1310117....

POTS

1/1

4

74444

7

1310117....

POTS

1/1

5

75555

7

1310117....

POTS

1/1

Peer Configuration Table for Sample Voice over Frame Relay Network

The dial plan shown in Table 8 lists a simple dial-peer configuration table, with no special configuration for how you forward or playout excess digits. For more information on other options for designing your dial plan and configuring your dial peers to connect with PBXs, see the "Advanced Dial Peer Configuration" section.

Configure Dial Peers

Dial peers describe the entities to and/or from which a call is established. Dial-peer configuration tasks define the address or set of addresses serviced by that dial peer and the call parameters required to establish a call to and/or from that dial peer.

There are two different kinds of dial peers:

POTS peers associate a telephone number with a particular voice port so that incoming calls for that port can be received. Voice over Frame Relay peers point to specific voice-network devices (by associating destination telephone numbers with a specific Frame Relay DLCI) so that outgoing calls can be placed. Both POTS and Voice over Frame Relay dial peers are needed to establish Voice over Frame Relay connections if you want to both send and receive calls.

For tandem voice nodes, POTS dial peers are not required.

Establishing two-way communication using Voice over Frame Relay requires establishing a specific voice connection between two defined endpoints. As shown in Figure 16, for outgoing calls (from the perspective of the voice-telephony dial peer 1), the voice-telephony dial peer establishes the source (the originating telephone number and voice port) of the call. The voice-network dial peer establishes the destination by associating the destination phone number with a specific Frame Relay DLCI.


Figure 16: Outgoing Calls from the Perspective of Cisco MC3810 No. 1


In the example, the destination pattern 14085554000 string maps to a U.S. phone number 555-4000, with the digit 1 plus the area code (408) preceding the number. When configuring the destination pattern, set the dial string to match the local dial conventions.

To complete the two-way communications loop, you need to configure VoFR dial peer 4 as shown in Figure 17.


Figure 17: Outgoing Calls from the Perspective of Cisco MC3810 No. 2


The only exception to this is when both POTS dial peers are connected to the same concentrator, as shown in Figure 18. In this circumstance, you would not need to configure a Voice over Frame Relay dial peer.


Figure 18: Communication between Dial Peers Sharing the Same Concentrator


When configuring dial peers, you need to understand the relationship between the destination pattern and the session target. The destination pattern is the telephone number of the voice device attached to the voice port. The session target represents the route to a serial port on the peer Cisco MC3810 at the other end of the Frame Relay connection. Figure 19 and Figure 20 show the relationship between the destination pattern and the session target, as seen from the perspective of both Cisco  MC3810 concentrators in a Voice over Frame Relay configuration.


Figure 19: Relationship between Destination Pattern and Session Target From the Perspective of Cisco MC3810 No. 1



Figure 20:
Relationship between Destination Pattern and Session Target From the Perspective of Cisco MC3810 No. 2


Configure POTS Dial Peers

To configure a POTS dial peer, you need to uniquely identify the peer (by assigning it a unique tag number), define its telephone number, and associate it with a voice port through which calls will be established. Under most circumstances, the default values for the remaining dial-peer configuration commands are sufficient to establish connections.

To configure POTS dial peers, use the following commands beginning in configuration mode:
Step Command Purpose

1 . 

dial-peer voice tag pots

Define a POTS peer and enter dial-peer configuration mode. All subsequent commands that you enter in dial-peer voice mode before you exit will apply to this dial peer.

The tag value identifies the dial peer and must be unique on the Cisco MC3810. Do not duplicate a specific tag number.

2 . 

destination-pattern string

Configure the dial peer's destination pattern.

The string is a series of digits that specify the E.164 or private dialing plan telephone number. Valid entries are the digits 0 through 9 and the letters A through D. The following special characters can be entered in the string:

3 . 

port slot/port

Associate this voice-telephony dial peer with a specific logical dial interface. Enter the slot/port number of the voice port connected to the POTS dial peer.

4 . 

forward-digits {num-digit | all}

(Optional) If using the forward-digits feature, configure the digit-forwarding method that will be used on the dial peer.

5 . 

prefix string

(Optional) If the forward-digits feature was not configured in the last step, assign the dialed digits prefix for the dial peer.

6 . 

preference value

(Optional) Configure a preference for the POTS dial peer. The value is a number from 0 to 10 where the lower the number, the higher the preference. If POTS and voice network (VoFR) peers are mixed in the same hunt group, POTS dial peers will be searched first, even if a voice-network peer has a higher preference number.

For more information about hunt groups and preferences, see the "Hunt Groups and Preference Configuration" section.

To configure additional POTS dial peers, exit dial-peer configuration mode by entering exit, and repeat the previous steps.

Configure Voice over Frame Relay Dial Peers

To configure a Voice over Frame Relay dial peer, you need to uniquely identify the peer (by assigning it a unique tag number), define the outgoing serial port number and the virtual circuit number.

To configure Voice over Frame Relay dial peers, use the following commands beginning in configuration mode:
Step Command Purpose

1 . 

dial-peer voice tag vofr

Define a Voice over Frame Relay dial peer and enter dial-peer configuration mode. All subsequent commands that you enter in dial-peer voice mode before you exit will apply to this dial peer.

The tag value identifies the dial peer and must be unique on the Cisco MC3810. Do not duplicate a specific tag number.

2 . 

destination-pattern string

Configure the dial peer's destination pattern. The same restrictions for the string listed in the POTS dial-peer configuration also apply to the VoFR destination-pattern.

3 . 

session target interface Serial interface dlci

Configure the Frame Relay session target for the dial peer.

4 . 

preference value

(Optional) Configure a preference for the Voice over Frame Relay dial peer. The value is a number from 0 to 10 where the lower the number, the higher the preference.

For more information about hunt groups and preferences, see the "Hunt Groups and Preference Configuration" section.

5 . 

alt-dial string

(Optional) Configure the alternate dial-out string when configuring on-net-to-off-net alternative dialing.

To configure additional Voice over Frame Relay dial peers, exit dial-peer configuration mode by entering exit, and repeat the previous steps.


Note When configuring Voice over Frame Relay, the dial-peer configuration must be performed on the Cisco MC3810 concentrators on both sides of the voice connection.

Depending on your configuration, you may need to consider how to configure voice networks with excess digit playout, forward digits and default voice routes, or use hunt groups with dial-peer preferences. For more information on these topics, see the "Advanced Dial Peer Configuration" section.

Validation Tips

Verify that the voice connection is working by doing the following:

You can check the validity of your dial peer and voice-port configuration by performing the following steps:

Troubleshooting Tips

If you are having trouble connecting a call, you can try to resolve the problem by performing the following tasks:

Advanced Dial Peer Configuration

Depending on the configuration, you may need to consider different strategies for how you configure the dial plan, and how you configure the dial peers. This section describes the following topics regarding dial peer configuration that you may need to consider:


Note These concepts also apply to Voice over ATM.

Excess Digits Playout

Excess digits are defined as received digits that are beyond the length of the destination pattern on a terminating router. A terminating router will forward excess digits to the telephony interface. For example, if the digits "123456789" are matched on a terminating router with a destination pattern of "1.....," the "6789" are excess digits and will be forwarded.

A router that is originating a call will only collect digits up to the length of a defined destination pattern. When a number is dialed that is longer than the destination pattern, after the last digit in the destination pattern is dialed, the call is immediately placed, and the additional digits are not collected by the Cisco MC3810.

For example, if the digits "123456789" are dialed on an originating Cisco MC3810 with a destination pattern of 1...., then "6789" are not collected. The call is placed immediately after the digit "5" is dialed. The additional digits "6789" are not collected, but are passed through the audio path.

In configurations where a phone on an FXS port on the Cisco MC3810 is connected to the PSTN through an FXO port on the same Cisco MC3810, additional steps are necessary to enable a call to go through. Because the uncollected excess digits are passed through the audio path, the excess digits might not go through if the audio path isn't ready when the excess digit is dialed. When dialing a destination pattern in this situation, pause and wait for a second dial tone before dialing the excess digits. This will give the audio path time to accept the excess digits.

Forward Digits and Voice Default Routes

Voice default routing for fixed-length dial plans can be used with larger PBX configurations to forward digits to Cisco MC3810 telephony interfaces.

Figure 21 shows an example of routing voice calls through a PBX using forward digits. In the configuration, the Cisco MC3810-t and Cisco MC3810-T are tandem nodes, and are required to support forwarding digits so that calls from Cisco MC3810s 0, 5, or 9 can make a call to extension "8208."


Figure 21: Routing Voice Calls Among Cisco MC3810s Through a PBX


On the two tandem nodes, the forward-digits command is required. This command specifies to forward all digits matched with the destination "8..." to the appropriate port. For a call from Cisco MC3810-0 to reach extension 8208, the call must first terminate at Cisco MC3810-T, which plays out the digits "8208" to the voice port connected to the PBX. The PBX then routes the voice call to Cisco MC3810-t. On the tandem nodes, although the forward-digits all command is used, the forward-digits 4 command can also be used in this example.

The following are the dial-peer configurations on each Cisco MC3810 required for this configuration:

For Cisco MC3810-t:
dial-peer voice 8 pots
destination-pattern 8208
session-target s0 1 dial-peer voice 1000 pots
destination-pattern 8...
forward-digits all
port 1/1 dial-peer voice 9999 pots
destination-pattern ....
forward-digits all
port 1/1
For Cisco MC3810-T:
dial-peer voice 1 vofr
destination-pattern 8200
session-target s0 1 dial-peer voice 6 vofr
destination-pattern 8209
session-target s0 6 dial-peer voice 10 vofr
destination-pattern 8209
session-target s0 10 dial-peer voice 1 pots
destination-pattern 8...
forward-digits all
port 1/1
For Cisco MC3810-0:
dial-peer voice 1 pots
destination-pattern 8200
port 1/1 dial-peer voice 1000 vofr
destination-pattern8...
session-target s0 1 For Cisco MC3810-5: dial-peer voice 5 pots
destination-pattern 8205
port 1/1 dial-peer voice 1000 vofr
destination-pattern 8...
session-target s0-1
For Cisco MC3810-9:
dial-peer voice 9 pots
destination-pattern 8209
port 1/1 dial-peer voice 1000 vofr
destination-pattern 8...
session-target s0 1

The concept of voice default routes is also shown in Figure 21 and in the configuration. In the example, the configurations for the destination dial plans "8..." in both the tandem nodes are voice default routes because all voice calls dialed that start with 8 followed by three digits will either match on 8208 or end up with 8...., which is the last resort voice route used by Cisco MC3810-t if no other route is discovered.

Hunt Groups and Preference Configuration

When configuring the destination pattern for voice-telephony dial peers (such as to a PBX), if you configure each dial peer with a different destination pattern, then you may have limitations on the availability of calls getting through. This is because when you configure each dial peer with a different destination pattern, the destination is a single DS0 timeslot on the voice connection to the PBX. If that timeslot gets busy, then a call attempt to the dial peer mapped to that specific DS0 timeslot will fail.

For example, in the following dial-peer configuration, there are four POTS dial peers configured, all with a different destination pattern on the same PBX:

dial-peer voice 1 pots
 destination-pattern 3001
 port 1/1 dial-peer voice 2 pots
 destination-pattern 3002
 port 1/2 dial-peer voice 3 pots
 destination-pattern 3003
 port 1/3 dial-peer voice 4 pots
 destination-pattern 3004
 port 1/4

Because each dial peer has a different destination pattern configured, there is no backup available if the DS0 timeslot mapped to the dial peer is busy with another call.

However, the Cisco MC3810 supports the concept of hunt groups, in which you configure a group of dial peers on the same PBX with the same destination pattern. With a hunt group, if a call attempt is made to a dial peer on a specific DS0 timeslot, if that timeslot is busy, the Cisco MC3810 hunts for another timeslot on that channel until an available timeslot is found. In this case, each dial peer is configured using the same destination pattern of 3000, forming a dial pool to that destination pattern.

To provide specific dial peers in the pool with a preference over other dial peers, you can configure the preference order for each dial peer using the preference command. The following is an example of the dial-peer configuration with all dial peers having the same destination pattern, but different preference orders:

dial-peer voice 1 pots
 destination pattern 3000
 port 1/1
 preference 0 dial-peer voice 2 pots
 destination pattern 3000
 port 1/2
 preference 1 dial-peer voice 3 pots
 destination pattern 3000
 port 1/3
 preference 2 dial-peer voice 4 pots
 destination pattern 3000
 port 1/4
 preference 3

Note that when setting the preference order, the lower the preference number, the higher the priority. The highest priority is given to the dial peer with preference order 0.

You can also set the preference order on the network side, for voice network dial peers. However, you cannot mix the preference orders for POTS dial peers (local telephone devices) and voice-network peers (devices across the WAN backbone). You can set a separate preference order for each dial-peer type, but the preference order will not work on both at the same time. For example, you can configure preference order 0, 1, and 2 for voice telephony dial peers, and you can configure a separate preference order 0, 1, and 2 for the voice network dial peers, but the two preference orders are separate. The system only resolves the preference among dial peers of the same type; it does not resolve preferences between the two separate preference order lists.

The hunt group feature hunts for dial peers in the following order:

    1. Dial peers are first hunted based on the priority set using the preference dial-peer command.

    2. Dial peers are then hunted using the criteria of the longest number match. For example, if you have one dial peer set for 345.... and a second dial peer set for 3456789, the hunt group would first select the dial peer 3456789 because it has the longest match of the two dial peers.

    3. Local POTS dial peers are hunted first before voice network peers.

    4. Dial peers are then hunted in the order they were defined on the Cisco MC3810.


Note If POTS and voice network peers are mixed in the same hunt group, the POTS dial peers must have priority over the voice-network peers.

Variable Length Dial Plans

In most voice configurations, fixed-length dialing plans, in which all the dial-peer destination patterns have the same length, are sufficient because the telephone number strings are all the same length. However, in some voice network configuration, variable length dial plans are required, especially if the network crosses country boundaries and the telephone number strings are of different lengths.

By entering the "T" timer character in the destination pattern, the Cisco MC3810 can be configured to accept a fixed-length dial string, and then wait for additional dialed digits. For example, the following dial-peer configuration shows how the T character can be set to allow variable length dial strings.

dial peer voice 1 pots
destination-pattern 2222T
port 1/1

In this example, the Cisco MC3810 accepts the digits 2222, and then waits for an unspecified number of dialed digits. If digits continue to be entered before the inter-digit timeout expires, then the Cisco  MC3810 will gather up to 31 additional digits. Once the inter-digit timeout expires, the Cisco  MC3810 places the call. The inter-digit timeout is set by the timeouts inter-digit voice-port command.

The inter-digit timeout timer can be immediately terminated by entering the "#" digit. If the # character is entered while the Cisco MC3810 is waiting for the additional digits, the # character is treated as an end-dial accelerator. The # character is not treated as an actual digit in the destination pattern and is not sent as part of the dialed string across the network.

However, if the # character is entered before the Cisco MC3810 is waiting for the additional digits (meaning before the "T" character is entered in the destination pattern)< then the # character is treated as a dialed digit. For example, if a destination pattern is configured with the string 222...T, then the digits 2222####1234567 can be gathered, but the digits 2222###1234#67 cannot be gathered because the final # character is treated as a terminator.

The default value for the interdigit timeout is 1- seconds. If the duration is not changed, using the "T" timer adds 10 seconds to each call setup time because the call is not attempted until the timer expires (unless the # character is used as a terminator). Because of this dependency, if using variable length dial plans, the voice-port interdigit timeout should be reduced to reduce the call setup time.

Voice over Frame Relay Configuration Examples

This section provides the following Voice over Frame Relay configuration examples:

Back-to-Back Voice over Frame Relay Configuration

Figure 22 shows a configuration example for two Cisco MC3810 concentrators configured back-to-back, with Voice over Frame Relay configured for both concentrators. This setup is useful to test your Voice over Frame Relay configuration locally to make sure voice connections can be made locally before configuring Voice over Frame Relay across a larger network. Following the figure are the commands required to configure the Cisco MC3810 concentrators in this example.


Note There are special considerations required when configuring two Cisco MC3810 concentrators for back-to-back Frame Relay. For example, you must make sure one side is DCE and the other is configured to DTE. On the DCE side, you must configure the clock rate network-clock and dce  terminal timing enable commands. On both sides, make sure to configure the serial ports for point-to-point operation.

Figure 22: Back-to-Back Voice over Frame Relay Configuration


Configuration for Cisco MC3810 No. 1

no service pad
no service udp-small-servers
no service tcp-small-servers
hostname Frame-top
frame-relay switching
interface Ethernet0
  ip address 10.1.10.1 255.0.0.0
interface Serial0 point-to-point
  ip address 12.0.0.3 255.0.0.0
  encapsulation frame-relay
  no fair-queue
  clock rate network-clock 2000000
  dce terminal-timing enable
  frame-relay class fr1
  frame-relay map ip 12.0.0.1 231 broadcast 
  frame-relay interface-dlci 231 voice-encap 1600
  frame-relay intf-type dce
map-class frame-relay fr1
  frame-relay adaptive-shaping becn
  frame-relay cir 64000
  frame-relay bc 1000

router rip
  redistribute connected
  network 12.0.0.0
voice-port 1/1
dial-peer voice 1 pots 
  destination-pattern 10
  port 1/1
 
dial-peer voice 101 vofr 
  destination-pattern 2.
  session target Serial0 231
end

Configuration for Cisco MC3810 No. 2

interface Ethernet0
  ip address 10.1.20.1 255.0.0.0
router rip
  redistribute connected
  network 12.0.0.0
interface Serial0 point-to-point
  ip address 12.0.0.1 255.0.0.0
  encapsulation frame-relay
  bandwidth 2000000	
  frame-relay class fr1		
  frame-relay map ip 12.0.0.3 231 broadcast
  frame-relay interface-dlci 231 voice-encap 1600
map-class frame-relay fr1
  frame-relay adaptive-shaping becn
  frame-relay cir 64000
  frame-relay bc 1000
voice-port 1/1
dial-peer voice 1 pots  	 
  destination-pattern 20	
  port 1/1			
dial-peer voice 101 vofr	
  destination-pattern 1.
  session target Serial0 231	
end

Voice over Frame Relay Network Configuration

The following is a configuration example for a Voice over Frame Relay network, including configuration for voice ports and dial peers. Figure 23 shows the configuration for one Cisco  MC3810 at a central site connected to two Cisco  MC3810 concentrators at different remote sites across a Frame Relay network. Following the figure are the commands required to configure the Cisco MC3810 concentrators in this example.


Figure 23: Voice over Frame Relay Network Configuration


Configuration for Central Site Cisco MC3810

The following is the configuration for the central site Cisco MC3810 concentrator:

hostname central		
controller T1 0		
 framing esf		
 linecode b8zs		
 channel-group 1 timeslots 1-24 speed 64		
		
interface Ethernet0		
 ip address 172.22.124.66 255.255.255.0		
		
interface Serial 0:1 multipoint
 ip address 223.223.224.229 255.255.255.0		
 encapsulation frame-relay		
 no fair-queue		
 frame-relay traffic-shaping		
 frame-relay interface-dlci 100 voice-encap 80 		
 class fr1		
 frame-relay interface-dlci 200 voice-encap 160 
 class fr2
router igrp 1
 network 172.22.0.0
 network 223.223.224.0
no ip classless
map-class frame-relay fr1
 frame-relay adaptive-shaping becn
 frame-relay cir 64000
 frame-relay bc 1000
map-class frame-relay fr2
 frame-relay adaptive-shaping becn
 frame-relay cir 128000
 frame-relay bc 1000
line con 0
 exec-timeout 0 0
line aux 0
line vty 0
voice-port 1/1
voice-port 1/2
voice-port 1/3
voice-port 1/4
voice-port 1/5
voice-port 1/6
dial-peer voice 1 pots
 destination-pattern 3488801
 port 1/1
dial-peer voice 2 pots
 destination-pattern 3488802
 port 1/2
dial-peer voice 3 pots
 destination-pattern 3488803
 port 1/3
dial-peer voice 4 pots
 destination-pattern 3488804
 port 1/4
dial-peer voice 5 pots
 destination-pattern 3488805
 port 1/5
dial-peer voice 6 pots
 destination-pattern 3488806
 port 1/6
dial-peer voice 338 vofr
 destination-pattern 338....
 session target Serial0:1 100
dial-peer voice 358 vofr
 destination-pattern 358....
 session target Serial0:1 200
end

Configuration for Remote Site 1 Cisco MC3810

The following is the configuration for the Cisco MC3810 concentrator at Remote Site 1:

hostname remote1
controller T1 0
 framing esf
 linecode b8zs
 channel-group 2 timeslots 1 speed 64
interface Ethernet0
 ip address 172.22.125.66 255.255.255.0
interface Serial 0:2 multipoint
 ip address 223.223.224.227 255.255.255.0
 encapsulation frame-relay
no fair-queue
 frame-relay traffic-shaping
 frame-relay interface-dlci 100 voice-encap 80 
  class fr1
router igrp 1
 network 172.22.0.0
 network 223.223.224.0
no ip classless
map-class frame-relay fr1
 frame-relay cir 64000
 frame-relay bc 1000 
 frame-relay adaptive-shaping becn
line con 0
 exec-timeout 0 0
line aux 0
line vty 0
voice-port 1/1
voice-port 1/2
voice-port 1/3
voice-port 1/4
voice-port 1/5
voice-port 1/6
dial-peer voice 1 pots
 destination-pattern 3388801
 port 1/1
dial-peer voice 2 pots
 destination-pattern 3388802
 port 1/2
dial-peer voice 3 pots
 destination-pattern 3388803
 port 1/3
dial-peer voice 4 pots
 destination-pattern 3388804
 port 1/4
dial-peer voice 5 pots
 destination-pattern 3388805
 port 1/5
dial-peer voice 6 pots
 destination-pattern 3388806
 port 1/6
dial-peer voice 2000 vofr
 destination-pattern 358....
 session target Serial0:2 100
dial-peer voice 2001 vofr
 destination-pattern 348....
 session target Serial0:2 100

Configuration for Remote Site 2 Cisco MC3810

The following is the configuration for the Cisco MC3810 concentrator at Remote Site 2:

hostname remote2
interface Ethernet0
 ip address 172.22.126.66 255.255.255.0
interface Serial1 multipoint
 ip address 223.223.224.226 255.255.255.0
 encapsulation frame-relay
 no fair-queue
 frame-relay traffic-shaping
 frame-relay interface-dlci 200 voice-encap 160 
  class fr1
 clock rate 128000
router igrp 1
 network 172.22.0.0
 network 223.223.224.0
no ip classless
map-class frame-relay fr1
 frame-relay cir 128000
 frame-relay bc 1000
 frame-relay adaptive-shaping becn
line con 0
 exec-timeout 0 0
line aux 0
line vty 0
voice-port 1/1
voice-port 1/2
voice-port 1/3
voice-port 1/4
voice-port 1/5
voice-port 1/6
dial-peer voice 1 pots
 destination-pattern 3588801
 port 1/1
dial-peer voice 2 pots
 destination-pattern 3588802
 port 1/2
dial-peer voice 3 pots
 destination-pattern 3588803
 port 1/3
dial-peer voice 4 pots
 destination-pattern 3588804
 port 1/4
dial-peer voice 5 pots
 destination-pattern 3588805
 port 1/5
dial-peer voice 6 pots
 destination-pattern 3588806
 port 1/6
dial-peer voice 2000 vofr
 destination-pattern 348....
 session target Serial1 200
dial-peer voice 2001 vofr
 destination-pattern 338....
 session target Serial1 200
end

hometocprevnextglossaryfeedbacksearchhelp
Copyright 1989-1998 © Cisco Systems Inc.