Полезная информация

cc/td/doc/product/software/ios120/12cgcr/voice_c
hometocprevnextglossaryfeedbacksearchhelp
PDF

Table of Contents

Configuring Voice over ATM for the Cisco MC3810

Configuring Voice over ATM for the Cisco MC3810

This chapter shows you how to configure Voice over ATM on the Cisco MC3810 concentrator. For a description of the commands used to configure Voice over ATM, refer to the "Voice-Related Commands" chapter in the Voice, Video, and Home Applications Command Reference.

Voice over ATM enables a Cisco MC3810 to carry voice traffic (for example, telephone calls and faxes) over an ATM network. The Cisco MC3810 supports compressed Voice over ATM on ATM  port 0 only.


Note The Cisco MC3810 does not support ATM switched virtual circuits (SVCs).

Note When using ATM on the Cisco MC3810, the channel group, time division multiplexing (TDM) group, and channel associated signaling (CAS) functionality are not available on the multiflex trunk (MFT) because ATM uses all T1/E1 timeslots.

List of Terms

AAL---ATM Adaptation Layer.

Call leg---A logical connection between the router and either a telephony endpoint over a bearer channel or another endpoint using a session protocol.

CAS---Channel associated signaling

CODEC---Coder-decoder. Device that typically uses pulse code modulation to transform analog signals into a digital bit stream and digital signals back into analog signals. In Voice over ATM, it specifies the voice coder rate of speech for a dial peer.

Dial peer---An addressable call endpoint. In Voice over ATM, there are two kinds of dial peers: POTS and VoATM.

DS0---A 64-K B-channel on an E1 or T1 WAN interface.

DTMF---Dual tone multifrequency. Use of two simultaneous voice-band tones for dial (such as touch tone).

DVM---Digital voice module (Cisco MC3810).

E&M---E&M stands for recEive and transMit (or Ear and Mouth). E&M is a trunking arrangement generally used for two-way switch-to-switch or switch-to-network connections. Cisco's E&M interface is an RJ-48 connector that allows connections to PBX trunk lines (tie lines).

FXO---Foreign Exchange Office. An FXO interface connects to the PSTN's central office and is the interface offered on a standard telephone. Cisco's FXO interface is an RJ-11 connector that allows an analog connection to be directed at the PSTN's central office. This interface is of value for off-premise extension applications.

FXS---Foreign Exchange Station. An FXS interface connects directly to a standard telephone and supplies ring, voltage, and dial tone. Cisco's FXS interface is an RJ-11 connector that allows connections to basic telephone service equipment, keysets, and PBXs.

MFT---Multiflex trunk (Cisco MC3810).

PBX---Private Branch Exchange. Privately owned central switching office.

PLAR---Private Line Auto Ringdown. This type of service results in a call attempt to some particular remote endpoint when the local extension is taken off-key.

POTS---Plain Old Telephone Service. Basic telephone service supplying standard single line telephones, telephone lines, and access to the public switched telephone network.

POTS dial peer---Dial peer connected via a traditional telephony network. POTS peers point to a particular voice port on a voice network device.

PSTN---Public Switched Telephone Network. PSTN refers to the local telephone company.

PVC---Permanent virtual circuit.

TDM---Time division multiplexing.

Trunk---Service that allows quasi-transparent connections between two PBXs, a PBX and a local extension, or some other combination of telephony interfaces to be permanently conferenced together by the session application and signaling passed transparently through the IP network.

UIO---Universal I/O serial port (Cisco MC3810).

VBR---Variable Bit Rate.

VoATM dial peer---Dial peer connected via an ATM network. VoATM peers point to specific VoATM devices.

Prerequisite Tasks

Before you can configure your Cisco MC3810 concentrator to use Voice over Frame Relay, you must first:

After you have analyzed your dial plan and decided how to integrate it into your existing ATM network, you are ready to configure your network devices to support Voice over ATM.

Voice over ATM Configuration Task List

To configure Voice over ATM, you need to perform the following tasks:

    1. Configure your ATM network to support real-time voice traffic. The steps include the following:

    2. Configure dial peers. Each dial peer defines the characteristics associated with a call leg. A call leg is a discrete segment of a call connection that lies between two points in the connection. An end-to-end call is comprised of four call legs, two from the perspective of the source access server, and two from the perspective of the destination access server. Dial peers are used to apply attributes to call legs and to identify call origin and destination. There are two different kinds of dial peers:

    3. Configure your Cisco MC3810 concentrator to support voice ports. In general, voice-port commands define the characteristics associated with a particular voice-port signaling type. Voice ports on the Cisco MC3810 support three basic voice signaling types:

This chapter assumes you have already configured your ATM backbone network. For more information about ATM configuration using standard Cisco IOS software, refer to the Cisco IOS Wide Area Networking Configuration Guide. This chapter describes the commands to specifically configure Voice over ATM on the Cisco MC3810.


Note ATM defaults to Interim Local Management Interface (ILMI). If your carrier is using Local Management Interface (LMI), make sure to configure LMI support on the Cisco MC3810.

Preliminary ATM Configuration for Voice

This section describes the preliminary ATM configuration tasks necessary to support Voice over ATM. The commands and procedures in this section are specific to the Cisco MC3810.


Note If any CAS groups, channel groups, or clear channels are configured on T1/E1 controller 0, you must remove them before configuring Voice over ATM. Because ATM requires all DS0s, if any DS0s on controller 0 are used by other applications, the ATM configuration cannot take place.

To configure the Cisco MC3810 to support Voice over ATM on the T1/E1 trunk, use the following commands beginning in global configuration mode:
Step Command Purpose
1

controller {t1 | e1} 0

Select T1/E1 controller 0. ATM is supported only on controller 0.

2

mode atm

Specify that the controller will support ATM encapsulation, and to create virtual ATM interface 0, which you will use to create the ATM PVCs.

When the controller is set to ATM mode, the following takes place:

  • The controller framing is automatically set to Extended SuperFrame (ESF) on T1 and to CRC4 on E1. The linecode is automatically set to B8ZS on T1 and to HDB3 on E1.

  • Channel groups, CAS groups, common channel signaling (CCS) groups or clear channels are not allowed on the trunk because ATM traffic occupies all the DS0's.

If the Cisco MC3810 has an E1 controller, a screen display similar to the following appears:


TDMB channel # 99 Timeslots ( X 48K, . 56K,* 64K, - skipped)
0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
- * * * * * * * * * * * * * * * - - - - - - - - - - - - - - - -
TDMB channel # 99 Timeslots ( X 48K, . 56K,* 64K, -skipped)
0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
- * * * * * * * * * * * * * * * - * * * * * * * * * * * * * * *

The display shows which DS0 timeslots are allocated. For example, in the display, timeslots marked with the * symbol indicate that the timeslot is a 64 kbps channel. Timeslots marked with the hyphen (-) symbol are skipped.

If the Cisco MC3810 has a T1 controller, the screen display will be different, showing the DS0 timeslots specific to the T1 channels.

3

no shutdown

Make sure the controller is activated.

4

exit

Exit controller configuration mode.

5

interface atm0
{multipoint | point-to-point}

Enter interface configuration mode to configure ATM interface 0.

Note Beginning with Release 12.0, serial 2 is not a valid designation on the Cisco MC3810. Voice over ATM is supported only on ATM 0.

If the Voice over ATM connection will be over a point-to-point network, specify the point-to-point option. The default option, multipoint, assumes you have a fully meshed network.

6

ip address ip-address mask

Assign the IP address and subnet mask to the interface.

7

pvc [name] vpi/vci

Create an ATM PVC for voice traffic and enter virtual circuit configuration mode.

8

encapsulation aal5mux voice

Set the encapsulation of the PVC to support voice traffic.

Note To configure a PVC to support data traffic, use aal5snap encapsulation.
9

vbr-rt peak-rate average-rate [burst]

Configure the peak rate, average rate, and the burst cell size to perform traffic shaping between voice and data PVCs. The vbr-rt command configures the variable bit-rate for real-time networks such as for voice networks.

Traffic shaping is necessary so that the carrier does not discard the incoming calls from the MC3810. To configure voice and data traffic shaping, you must configure the peak, average, and burst options for voice traffic. Configure the burst value if the PVC will be carrying bursty traffic. The peak, average, and burst values are needed so the PVC can effectively handle the bandwidth for the number of voice calls. To calculate the minimum peak, average, and burst values for the number of voice calls, use the following calculations:

  • Peak value: (2 x the maximum number of calls) x 16 kb

The peak value equals the Peak Information Rate (PIR).

  • Average value: (1 x the maximum number of calls) x 16   kb

The average value equals the Average Information Rate (AIR). This correlates to the carrier's sustained cell rate.

  • Burst value: (4 x the maximum number of calls)

The burst value is the burst size in cells.
Note When you configure data PVCs that will be traffic shaped with voice PVCs, use the aal5snap encapsulation and calculate the overhead as 1.13 times the voice rate.
10

exit

Exit ATM virtual circuit configuration mode.

The only commands in ATM virtual circuit configuration mode used for ATM voice PVCs are encapsulation aal5mux voice, vbr-rt, and ilmi.

Repeat Steps 7 through 10 for each ATM voice PVC you want to configure. When you have completed configuring all the ATM voice PVCs, continue with Steps 11 through 16.

11

pvc [name] vpi/vci

Create an ATM PVC for data traffic and enter virtual circuit configuration mode.

12

encapsulation aal5snap

Set the encapsulation of the PVC to support ATM data traffic. In ATM PVC configuration mode, configure either the ubr, ubr+, or the vbr-nrt traffic shaping commands for the data PVC as appropriate.

13

exit

Exit ATM virtual circuit configuration mode. Repeat Steps 12 through 15 for each data PVC configured.

14

exit

Exit interface configuration mode.

15

exit

Exit configuration mode.

16

show atm vc

Verify the ATM PVC configuration.

The Voice over ATM configuration must be performed on the Cisco MC3810 concentrators on both sides of the voice connection.


Note When verifying your ATM PVC connectivity, note that you cannot issue the ping command over a voice PVC because the command applies to data only. If you have data and voice PVCs set to the same destination, you can issue the ping command over the data PVC.

Prepare to Configure Voice Dial Peers

After you have analyzed your dial plan and decided how to integrate it into your existing network, you are ready to configure your network devices to support Voice over ATM. The actual configuration procedure depends on the topology of your voice network, but in general you need to complete the following tasks:

TimeSaver If possible, you might want to configure the ATM dial peers in a back-to-back configuration before separating them across the ATM network. Using a back-to-back configuration, you can test your Voice over ATM and dial-peer configuration to see if you can successfully make a voice connection. Then, when you place both peers on the network, if you cannot make a voice connection, you can isolate the cause as a network problem. For an example of a back-to-back voice over ATM configuration, refer to the "Voice over ATM Configuration Examples" section.

Organize Voice Network Information

After you have merged your telephony and WAN networks together, there are tasks you can do to simplify configuring Voice over ATM. One is to collect all of the information directly related to each dial peer by creating a peer configuration table.

Create a Peer Configuration Table

There is specific information relative to each dial peer that needs to be identified before you can configure Voice over ATM. One way to do this is to create a peer configuration table.

Figure 24 shows a diagram of a small voice network in which Router 1, with ATM virtual circuit 20, connects a small sales branch office to the main office through Router 2. There are only two devices in the sales branch office that need to be established as dial peers: a basic telephone and a fax machine. Router 2, with an ATM virtual circuit of 40, is the primary gateway to the main office; as such, it needs to be connected to the company's PBX. There are three devices that need to be established as dial peers in the main office, all of which are basic telephones connected to the PBX.

Table 9 shows the peer configuration table for the example illustrated in Figure 24.


Figure 24: Sample Voice over ATM Network



Table 9:
Dial Peer Extension Prefix Dest-Pattern Type Voice Port Session Target
Router 1

1

61111

+13101161111

POTS

1/1

2

62222

+13101162222

POTS

1/2

10

+1310117....

VoATM

S2 20

Router 2

11

+1310116....

VoATM

S2 40

3

73333

7

+1310117....

POTS

1/1

4

74444

7

+1310117....

POTS

1/1

5

75555

7

+1310117....

POTS

1/1

Peer Configuration Table for Sample Voice over ATM Network

The dial plan shown in Table 9 lists a simple dial-peer configuration table, with no special configuration for how you forward or playout excess digits. For more information on other options for designing your dial plan and configuring your dial peers to connect with PBXs, see the "Advanced Dial-Peer Configuration" section in the "Configuring Voice over Frame Relay" chapter. The concepts described in that chapter also apply to Voice over ATM.

Configure Dial Peers

Dial peers describe the entities to and/or from which a call is established. Dial-peer configuration tasks define the address or set of addresses serviced by that dial peer and the call parameters required to establish a call to and/or from that dial peer.

There are two different kinds of dial peers:

POTS dial peers associate a telephone number with a particular voice port so that incoming calls for that telephone number can be received. Voice over ATM dial peers point to specific voice-network devices (by associating destination telephone numbers with a specific ATM virtual circuit) so that outgoing calls can be placed. Both POTS and Voice over ATM dial peers are required if you want to both send and receive calls using Voice over ATM.

Establishing two-way communication using Voice over ATM requires establishing a specific voice connection between two defined endpoints. As shown in Figure 25, for outgoing calls (from the perspective of the POTS dial peer 1), the POTS dial peer establishes the source (the originating telephone number and voice port) of the call. The Voice over ATM dial peer establishes the destination by associating the destination phone number with a specific ATM virtual circuit.


Figure 25: Outgoing Calls from the Perspective of Cisco MC3810 No. 1


In the example, the destination pattern 14085554000 string maps to a U.S. phone number 555-4000, with the digit 1 plus the area code (408) preceding the number. When configuring the destination pattern, set the dial string to match the local dial conventions.

To complete the two-way communications loop, you need to configure Voice over ATM dial peer 2 as shown in Figure 26.


Figure 26: Outgoing Calls from the Perspective of Cisco MC3810 No. 2


The only exception is when both POTS dial peers are connected to the same concentrator, as shown in Figure 27. In this circumstance, because both dial peers share the same destination IP address, you do not need to configure a Voice over ATM dial peer.


Figure 27: Communication between Dial Peers Sharing the Same Concentrator


When configuring dial peers, you need to understand the relationship between the destination pattern and the session target. The destination pattern represents the pattern for the device at the voice connection endpoint, such as a telephone or a PBX. The session target represents the serial port on the peer Cisco MC3810 at the other end of the ATM connection. Figure 28 and Figure 29 show the relationship between the destination pattern and the session target, as seen from the perspective of both Cisco MC3810 concentrators in a Voice over ATM configuration.


Figure 28: Relationship between the Destination Pattern and Session Target from the Perspective of Cisco MC3810 No.1



Figure 29:
Relationship between the Destination Pattern and Session Target from the Perspective of Cisco MC3810 No.2


Configure POTS Dial Peers

To configure a POTS dial peer, you need to uniquely identify the peer (by assigning it a unique tag number), define its telephone number, and associate it with a voice port through which calls will be established. Under most circumstances, the default values for the remaining dial-peer configuration commands will be sufficient to establish connections.

To configure POTS peers, use the following commands beginning in global configuration mode:
Step Command Purpose
1

dial-peer voice tag pots

Define a POTS dial peer and enter dial-peer configuration mode. All subsequent commands that you enter in dial-peer voice mode before you exit will apply to this dial peer.

The tag value identifies the dial peer and must be unique on the Cisco MC3810. Do not duplicate a specific tag number.

2

destination-pattern string

Configure the dial peer's destination pattern.

The string is a series of digits that specify the E.164 or private dialing plan telephone number. Valid entries are the digits 0 through 9 and the letters A through D. The following special characters can be entered in the string:

  • The star character (*) and the pound sign (#) that appear on standard touch-tone dial pads can be used in any dial string. However, these characters cannot be used as leading characters in a string (for example, *650).

  • The period (.) can be entered any time, and is used as a wildcard character.

  • The comma (,) can be used only in prefixes, and is used to insert a one-second pause or a delay.

  • The timer (T) character can be used to configure variable-length dial plans. For more information, see the "Advanced Dial-Peer Configuration" section in "Configuring Voice over Frame Relay."

3

port slot/port

Associate this POTS dial peer with a specific logical dial interface. Enter the slot/port number of the voice port connected to the POTS dial peer.

4

preference value

(Optional) Configure a preference for the POTS dial peer. The value is a number from 0 to 10 where the lower the number, the higher the preference. If POTS and voice-network (VoATM) peers are mixed in the same hunt group, POTS dial peers will be searched first, even if a voice-network peer has a higher preference number.

For more information about hunt groups and preferences, see the "Advanced Dial-Peer Configuration" section in "Configuring Voice over Frame Relay."

5

forward-digits {num-digit | all}

(Optional) If using the digit-forwarding feature, configure the digit-forwarding method that will be used on the dial peer.

6

prefix string

(Optional) If the forward digits feature was not configured in the last step, assign the dialed digits prefix for the dial peer.

To configure additional POTS dial peers, exit dial-peer configuration mode by entering exit, and repeat the previous steps.

Configuring Voice over ATM Dial Peers

To configure a Voice over ATM dial peer, you need to uniquely identify the peer (by assigning it a unique tag number), define the outgoing serial port number and the virtual circuit number.

To configure Voice over ATM dial peers, use the following commands beginning in global configuration mode:
Step Command Purpose
1

dial-peer voice tag voatm

Define a Voice over ATM dial peer for Voice over ATM and enter dial-peer configuration mode.

The tag value identifies the dial peer and must be unique on the Cisco MC3810. Do not duplicate a specific tag number.

2

destination-pattern string

Configure the dial peer's destination pattern. The same restrictions for the string listed in the POTS dial-peer configuration also apply to the VoATM destination pattern.

3

session target ATM0 pvc [name] | [vpi/]vci]]

Configure the ATM session target for the dial peer. Make sure to specify ATM 0 as the interface for the PVC.

4

preference value

(Optional) Configure a preference for the Voice over ATM dial peer. The value is a number from 0 to 10 where the lower the number, the higher the preference.

For more information about hunt groups and preferences, see the "Advanced Dial-Peer Configuration" section in "Configuring Voice over Frame Relay."

5

alt-dial string

(Optional) Configure the alternate dial-out string when configuring on-net-to-off-net alternative dialing.


Note The Cisco MC3810 supports ATM traffic over T1/E1 controller 0 only.

To configure additional Voice over ATM dial peers, exit dial-peer configuration mode by entering exit, and repeat the previous steps.

Depending on your configuration, you may need to consider how to configure your voice networks with excess digit playout, forward digits and default voice routes, or use hunt groups with dial-peer preferences. For more information on these topics, see the "Advanced Dial-Peer Configuration" section in the "Configuring Voice over Frame Relay" chapter. Although the descriptions for these topics use Voice over Frame Relay examples, these topics also apply to Voice over ATM.

Validation Tips

Verify that the voice connection is working by doing the following:

You can check the validity of your dial-peer and voice-port configuration by performing the following tasks:

Troubleshooting Tips

If you are having trouble connecting a call and you suspect the problem is associated with the dial-peer configuration, you can try to resolve the problem by performing the following tasks:

Voice over ATM Configuration Examples

This section shows the following configuration examples for Voice over ATM:

Back-to-Back Voice over ATM Example

Figure 30 shows a configuration example for two Cisco MC3810 concentrators configured back-to-back, with Voice over ATM configured for both concentrators. This setup is useful to test your Voice over ATM configuration locally to make sure voice connections can be made locally before configuring Voice over ATM across a larger network. Following the figure are the commands required to configure the Cisco MC3810 concentrators in this example.


Note There may be special considerations for configuring back-to-back ATM compared to configuring for an ATM network.

Figure 30: Back-to-Back Voice over ATM Configuration


Configuration for Cisco MC3810 No. 1

hostname location1
no ip domain-lookup
interface Ethernet0
 ip address 10.1.10.1 255.255.255.0
 no ip mroute-cache
 no ip route-cache
controller T1 0
 clock source internal
 mode atm
interface atm0 point-to-point
ip address 10.1.1.1 255.255.255.0
 no ip mroute-cache
pvc 1 1 100
 encapsulation aal5mux voice
 vbr-rt 384 192 48
pvc 2 1 200
 encapsulation aal5snap
 map-group atm1
router rip
 redistribute connected
 network 10.0.0.0
no ip classless
map-list atm1
 ip 10.1.1.2 atm pvc 2 broadcast
line con 0
line aux 0
line vty 0 4
 password cisco
 login
dial-peer voice 1 pots
 destination-pattern 10
 port 1/1
dial-peer voice 202 voatm
 destination-pattern 2.
 session target ATM0 1

Configuration for Cisco MC3810 No. 2

hostname location2
no ip domain-lookup
interface Ethernet0
 ip address 10.1.20.1 255.255.255.0
 no ip mroute-cache
 no ip route-cache
controller T1 0
  clock source line
  mode atm
interface atm0 point-to-point
ip address 10.1.1.2 255.255.255.0
 no ip mroute-cache
pvc 1 1 100
 encapsulation aal5mux voice
 vbr-rt 384 192 48
pvc 2 1 200
 encapsulation aal5snap
 map-group atm1
router rip
redistribute connected
network 10.0.0.0
no ip classless
map-list atm1
 ip 10.1.1.1 atm pvc 2 broadcast
dial-peer voice 1 pots
 destination-pattern 20
 port 1/1
dial-peer voice 202 voatm
 destination-pattern 1.
 session target ATM0 1
end

Voice and Data Traffic over ATM Example

Figure 31 shows an example for both voice and data traffic over ATM between two Cisco  MC3810 concentrators, including configuration for voice ports and dial peers. Following the figure are the commands required to configure the Cisco MC3810 concentrators in this example.


Figure 31: Voice over ATM Configuration Example


Configuration for the Cisco MC3810 No. 1

version 11.3
interface Ethernet0
 ip address 172.22.124.239 255.255.0.0
controller T1 0
 mode ATM
interface atm0 point-to-point
 ip address 223.223.224.229 255.255.255.0
 no ip mroute-cache
 no ip route-cache
 map-group atm1
pvc 26 26 200
 encapsulation aal5snap
pvc 27 27 270
 encapsulation aal5mux voice
 vbr-rt 384 192 48
no ip classless
map-list atm1
 ip 223.223.224.228 atm pvc 26 broadcast
voice-port 1/1
voice-port 1/2
voice-port 1/3
voice-port 1/4
dial-peer voice 1 pots
 destination-pattern 3488801
 port 1/1
dial-peer voice 2 pots
 destination-pattern 3488802
 port 1/2
dial-peer voice 1001 voatm
 destination-pattern 338....
 session target ATM0 27
end

Configuration for Cisco MC3810 No. 2

version 11.3
interface Ethernet0
 ip address 172.22.124.247 255.255.0.0
controller T1 0
 mode ATM
interface atm0 point-to-point
 ip address 223.223.224.228 255.255.255.0
 no ip mroute-cache
 no ip route-cache
 map-group atm1
pvc 26 26 200
 encapsulation aal5snap
pvc 27 27 270
 encapsulation aal5mux voice
 vbr-rt 384 192 48
no ip classless
map-list atm1
 ip 223.223.224.229 atm pvc 26 broadcast
login
line vty 1 4
 login
voice-port 1/1
voice-port 1/2
voice-port 1/3
voice-port 1/4
dial-peer voice 1 pots
 destination-pattern 3388801
 port 1/1
dial-peer voice 2 pots
 destination-pattern 3388802
 port 1/2
dial-peer voice 1001 voatm
 destination-pattern 348....
 session target ATM0 27 
end

hometocprevnextglossaryfeedbacksearchhelp
Copyright 1989-1998 © Cisco Systems Inc.