Полезная информация

cc/td/doc/product/software/ios120/12cgcr/voice_c
hometocprevnextglossaryfeedbacksearchhelp
PDF

Table of Contents

Configuring Frame Relay-ATM Interworking for the Cisco MC3810

Configuring Frame Relay-ATM Interworking for the Cisco MC3810

The Cisco MC3810 supports the FRF.5 Frame Relay-ATM Interworking function, which enables Frame Relay voice or data traffic to be encapsulated in ATM cells. For a description of the commands used to configure Frame Relay-ATM interworking, refer to the "Voice-Related Commands" chapter in the Voice, Video, and Home Applications Command Reference.


Note The Cisco MC3810 provides only network interworking (FRF.5). The Cisco MC3810 can be used with service interworking (FRF.8), which is provided by the carrier's ATM network equipment.

Before you can configure your Cisco MC3810 to support Frame Relay-ATM Interworking, especially if transmitting voice traffic, you must first configure the clock source for the Cisco  MC3810 interfaces. For more information, refer to the "Configuring Synchronous Clocking on the Cisco MC3810" appendix.

Frame Relay-ATM Interworking Concepts

Using the FRF.5 Frame Relay-ATM Interworking function, you can transport Frame Relay traffic over an ATM cloud via a virtual interface within the Cisco MC3810. Using the encapsulation process, you can migrate from Frame Relay to ATM, or you can tunnel Frame Relay traffic across an ATM backbone to a second Cisco MC3810 or other Frame Relay device, and then extract the ATM traffic back to Frame Relay. The Frame Relay traffic is encapsulated in the ATM data cells.

You can transport either data or voice traffic using Frame Relay-ATM Interworking.

Figure 33 shows how the virtual interface in the Cisco MC3810 converts Frame Relay traffic to ATM traffic.


Figure 33: Frame Relay-ATM Network Interworking Virtual Interfaces


Figure 34 shows an example of encapsulating Frame Relay traffic within ATM cells on the Cisco  MC3810, tunneling it across the ATM backbone, and then extracting it back from ATM on a second Cisco  MC3810.


Figure 34: Tunneling Frame Relay Traffic over ATM Using Frame Relay to ATM Interworking


Figure 35 shows an application of Frame Relay-ATM Interworking, in which the FRF.5 interworking function (IWF) takes place between a Frame Relay carrier network and an ATM carrier network.


Figure 35: Frame Relay-ATM Interworking between Frame Relay and ATM Carrier Networks


Configuring Frame Relay-ATM Interworking

To configure Frame Relay-ATM Interworking, use the following commands beginning in global configuration mode:
Step Command Purpose
1

interface fr-atm number

Create a Frame Relay-ATM Interworking interface. The number value is a number between 0 and 20. Repeat this step for each Frame Relay-ATM Interworking interface configured. The number assigned is unique on each Cisco MC3810. The default interface created is FR-ATM20.

Do not enter a space between fr-atm and the Frame  Relay-ATM Interworking interface number.

The Frame Relay-ATM interworking interface is a virtual interface that can be added dynamically. This interface does not have a physical interface, but can perform the operations similar to that of a physical interface. You can configure up to 21 Frame Relay-ATM interworking virtual interfaces.

2

encapsulation frame-relay [ietf]

Configure the interface for Frame Relay encapsulation. Specify the ietf option only if RFC 1490 is supported.

3

frame-relay interface-dlci dlci [voice-encap size]

Configure the Frame Relay data-link connection identifier (DLCI). If the DLCI will be used for data traffic only, do not specify the voice encapsulation option. If the Frame Relay DLCI will be used for voice traffic, specify the voice-encapsulation option and specify the data segmentation size. The range for the data segmentation size is from 80 to 1600. For recommended data segmentation sizes, see Table 11.

The DLCI must match on both sides of the ATM network because the DLCI is mapped on both sides.

4

frame-relay route in-dlci out-interface out-dlci [voice-encap size]

Configure the Frame Relay route. If the Frame Relay DLCI will be used for voice traffic, specify the voice-encapsulation option and specify the data segmentation size. The range for the data segmentation size is from 8 to 1600. For recommended data segmentation sizes, see Table 11.

5

no keepalive

Turn off Frame Relay keepalive packets.

6

fr-atm   connect dlci dlci atm0 pvc [name] [vpi/vci]

Map a Frame Relay DLCI to an ATM PVC name or Virtual Path Identifier/Virtual Channel Identifier. The encapsulation type of the current interface must be Frame Relay or Frame Relay 1490 (IETF). The ATM interface on the Cisco MC3810 must be set to ATM 0.

This step can be repeated to define multiple DLCIs on the virtual interface. To connect DLCIs to different ATM PVCs, you must define separate Frame Relay-ATM interfaces.

7

exit

Exit interface configuration mode.

8

controller {t1 | e1} 0

Select T1/E1 controller 0. ATM is supported only on controller 0.

9

mode atm

Specify that the controller will support ATM encapsulation, and to create virtual ATM interface 0, which you will use to create ATM PVCs.

10

no shutdown

Make sure the controller is activated.

11

exit

Exit controller configuration mode.

12

interface atm0 point-to-point

Enter interface configuration mode to configure ATM interface 0 for a point-to-point network.

13

ip address ip-address mask

Assign the IP address and subnet mask to the interface.

14

pvc [name] vpi/vci

Create an ATM PVC and enter virtual circuit configuration mode.

15

encapsulation aal5mux frame

Set the encapsulation of the ATM PVC to support Frame Relay-ATM Interworking.

16

Configure one of the following commands to perform traffic shaping on the virtual circuit:

ubr output value [input value]

Assign the Unspecified Bit Rate (UBR) peak cell rate in kbps for this virtual circuit.

or

ubr+ output-peak-value output-minimum-rate-value [input-peak-value] [input-minimum-rate-value]

Assign the UBR+ values in kbps for this virtual circuit.

or

vbr-nrt output-pcr output-scr output mbs [input-pcr] [input scr] [input mbs]

Assign the variable bit rate (VBR)-non real-time (NBR) values for this virtual circuit.

or

vbr-rt peak-rate average-rate [burst]

Assign the variable bit rate (VBR)-real-time (RT) values for this virtual circuit if the virtual circuit will be supporting voice traffic.

Note The UBR, UBR+, VBR-NRT, and VBR-RT services are mutually exclusive. You can assign only one of these services on a virtual circuit at one time.
15

exit

Exit ATM virtual circuit configuration mode.


Table 11: Recommended Data Segmentation Sizes
Port Access Rate Recommended Data Segmentation Size1

64 kbps

80 bytes

128 kbps

160 bytes

256 kbps

320 bytes

512 kbps

640 bytes

1536 kbps (full T1)

1600 bytes

2048 kbps (full E1)

1600 bytes

1The data segmentation size is based on back-to-back Frame Relay. If sending traffic through an IGX with standard Frame Relay, subtract 6 bytes from the recommended data segmentation size.


Note When configuring the voice encapsulation data segmentation size, use the slower access rate of either the local or remote device to calculate which data segmentation size to use. If you configure a data segmentation size too high for either the local or remote device, the circuit rate will become throttled because the slower device cannot handle the larger data segmentation size. For example, if the access rate at the local device is 512 kbps and the access rate of the remote device is 256 kbps, configure the data segmentation size based on the slower 256 kbps circuit rate.

Configuring Frame Relay-ATM Interworking for Voice

If you are configuring Frame Relay-ATM Interworking for voice traffic, then you need to configure the voice-network dial peers to support Frame Relay-ATM Interworking.

Configure the POTS Dial Peers

Configure the POTS dial peers for the PBX or telephony devices attached to the local voice ports. For more information about the concept of dial peers, see the "Voice, Video, and Home Applications Overview" chapter.

To configure POTS dial peers, use the following commands beginning in configuration mode:
Step Command Purpose
1

dial-peer voice tag pots

Define a POTS peer and enter dial-peer configuration mode. The tag value of the command uniquely identifies the dial peer. All subsequent commands that you enter in dial peer voice mode before you exit will apply to this dial peer.

2

destination-pattern string

Configure the dial peer's destination pattern.

3

port slot/port

Associate this voice-telephony dial peer with a specific logical dial interface. Enter the slot/port number of the voice port connected to the POTS dial peer.

4

preference value

(Optional) Configure a preference for the POTS dial peer. The value is a number from 0 to 10 where the lower the number, the higher the preference. If POTS and voice-network (VoFR) peers are mixed in the same hunt group, POTS dial peers will be searched first, even if a voice-network peer has a higher preference number.

For more information about hunt groups and preferences, see the "Hunt Groups and Preference Configuration" section in "Configuring Voice over Frame Relay."

5

forward-digits {num-digit | all}

(Optional) If using the digit-forwarding feature, configure the digit-forwarding method that will be used on the dial peer.

6

prefix string

(Optional) If the forward-digits feature was not configured in the last step, assign the dialed digits prefix for the dial peer.

Configuring the Frame Relay-ATM Interworking Voice Network Dial Peers

To configure dial peers for voice over Frame Relay-ATM Interworking, use the following commands beginning in configuration mode:
Step Command Purpose
1

dial-peer voice tag vofr

Define a Voice over Frame Relay dial peer for Voice over Frame Relay and enter dial-peer configuration mode. The tag value uniquely identifies the dial peer.

2

destination-pattern string

Configure the dial peer's destination pattern.

3

session target FRATMnumber dlci dlci

Configure the Frame Relay-ATM Interworking session target for the dial peer.

Do not enter a space between FRATM and the Frame  Relay-ATM Interworking interface number.

4

alt-dial string

(Optional) Configure the alternate dial-out string when configuring on-net-to-off-net alternative dialing.

5

preference value

(Optional) Configure a preference for the dial peer. The value is a number from 0 to 10 where the lower the number, the higher the preference. If POTS and voice-network (VoFR) peers are mixed in the same hunt group, POTS dial peers will be searched first, even if a voice-network peer has a higher preference number.

Frame Relay-ATM Interworking Configuration Examples

This section describes the following examples of configuring Frame Relay-ATM Interworking:

Frame Relay-ATM Interworking Example (Data Traffic Only)

The following example shows a Frame Relay-ATM Interworking configuration for two Cisco  MC3810 concentrators exchanging data traffic only. Figure 36 shows the network configuration.


Figure 36: Frame Relay-ATM Interworking Example for Data Traffic Only


Configuration for Cisco MC3810 No. 1

hostname Router
no aaa per-user
controller T1 0
 mode atm
interface Ethernet0
 ip address 172.22.124.239 255.255.0.0
 no ip mroute-cache
 no ip route-cache
interface ATM0 point-to-point
 ip address 223.223.224.229 255.255.255.0
 no ip mroute-cache
 no ip route-cache
 map-group atm1
 pvc 1 1 200 
 encapsulation aal5mux frame-relay
 pvc 26 26 200 
 encapsulation aal5snap
interface FR-ATM1
 ip address 223.223.201.1 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 223.223.201.2 200 broadcast
 fr-atm connect dlci 200 ATM0 1
interface FR-ATM20
 no keepalive
no ip classless
map-list atm1
 ip 223.223.224.228 atm-vc 26 broadcast
end

Configuration for Cisco MC3810 No. 2

hostname Router
controller T1 0
 mode atm
interface Ethernet0
 ip address 172.22.124.247 255.255.0.0
 no ip mroute-cache
 no ip route-cache
 ipx network 123
interface Serial0 
 no ip address
 no ip mroute-cache
interface Serial1
interface ATM0 point-to-point
 ip address 223.223.224.228 255.255.255.0
 no ip mroute-cache
 encapsulation atm
 no ip route-cache
 map-group atm1
 pvc 1 1 200 
 encapsulation aal5mux frame-relay
 pvc 26 26 200 
 encapsulation aal5snap
interface FR-ATM2
 ip address 223.223.201.2 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 223.223.201.1 200 broadcast
fr-atm connect dlci 200 ATM0 1
interface FR-ATM20
no keepalive
map-list atm1
 ip 223.223.224.229 atm-vc 26 broadcast
end

Frame Relay-ATM Interworking Example (Data and Voice Traffic)

The following example shows a Frame Relay-ATM Interworking configuration for two Cisco  MC3810 concentrators exchanging both data and voice traffic. Figure 37 shows the network configuration.


Figure 37: Frame Relay-ATM Interworking Example for Data and Voice Traffic


Configuration for the Cisco MC3810 No. 1

hostname Router
controller T1 0
 mode atm
interface Ethernet0
 ip address 172.22.125.87 255.255.0.0
 no ip route-cache
 no ip mroute-cache
 no cdp enable
interface ATM0
 ip address 223.223.224.229 255.255.255.0
 no ip route-cache
 no ip mroute-cache
 map-group atm1
 atm enable-payload-scrambling
 pvc 1 1 200 
 encapsulation aal5mux frame-relay
 pvc 26 26 200 
 encapsulation aal5snap
interface FR-ATM 1
 ip address 223.223.201.1 255.255.255.0
 encapsulation frame-relay
 no ip mroute-cache
 frame-relay interface-dlci 200 voice-encap 512
 no keepalive
 frame-relay lmi-type ansi
 fr-atm connect dlci 200 ATM0 1
interface FR-ATM20
map-list atm1
 ip 223.223.224.228 atm-vc 26 broadcast
no cdp run
voice-port 1/1
voice-port 1/2
voice-port 1/3
voice-port 1/4
voice-port 1/5
voice-port 1/6
dial-peer voice 1 pots
 destination-pattern 3488801
 port 1/1
dial-peer voice 1001 vofr
 destination-pattern 338....
 session target FR-ATM1 200
end

Configuration for Cisco MC3810 No. 2

hostname Router
controller T1 0
 mode atm
interface Ethernet0
 ip address 172.22.125.87 255.255.0.0
interface ATM0
 ip address 223.223.224.228 255.255.255.0
 map-group atm1
 atm enable-payload-scrambling
 pvc 1 1 200 
 encapsulation aal5mux frame-relay
 pvc 26 26 200
 encapsulation aal5snap
interface FR-ATM 1
 ip address 223.223.201.1 255.255.255.0
 encapsulation frame-relay
 no ip mroute-cache
 frame-relay interface-dlci 200 voice-encap 512
 no keepalive
 fr-atm connect dlci 200 ATM0 1
interface FR-ATM20
ip classless
map-list atm1
 ip 223.223.224.229 atm-vc 26 broadcast
voice-port 1/1
voice-port 1/2
voice-port 1/3
voice-port 1/4
voice-port 1/5
voice-port 1/6
dial-peer voice 1 pots
 destination-pattern 3388801
 port 1/1
dial-peer voice 1001 vofr
 destination-pattern 348....
 session target FR-ATM1 200
end


hometocprevnextglossaryfeedbacksearchhelp
Copyright 1989-1998 © Cisco Systems Inc.