Полезная информация

cc/td/doc/product/software/ios120/12cgcr/qos_c
hometocprevnextglossaryfeedbacksearchhelp
PDF

Table of Contents

Configuring Frame Relay and Frame  Relay Traffic Shaping

Configuring Frame Relay and Frame  Relay Traffic Shaping

This chapter describes the tasks for configuring Frame Relay and Frame Relay Traffic Shaping (FRTS) on a router. For a complete description of the commands mentioned in this chapter, refer to the Quality of Service Solutions Command Reference and Wide-Area Networking Command Reference guide. To locate documentation of specific commands, use the command reference, master index, or search online.

Frame Relay Traffic Shaping Configuration Task List

To configure FRTS and verify that the information is correct, perform the tasks in the following sections:

See the section "FRTS Configuration Examples" later in this chapter for ideas of how to configure FRTS on your network.

Configure a Map Class

To configure a map class, perform the following tasks. Only the first task is required.

To configure a map class, use the following commands beginning in global configuration mode. Only the first command is required.
Step Command Purpose

1

map-class frame-relay map-class-name

Specify the Frame Relay map class name and enter map-class configuration mode.

2

frame-relay custom-queue-list list-number

(Optional) Specify a custom queue list to be used for the map class.

3

frame-relay priority-group list-number

(Optional) Assign a priority list to virtual circuits (VCs) associated with the map class.

4

frame-relay adaptive-shaping [becn | foresight]1

(Optional) Select either BECN or ForeSight as the congestion backward-notification mechanism to which traffic shaping will adapt.

5

frame-relay cir out bps2

(Optional) Specify the outbound committed information rate (CIR).

6

frame-relay mincir in bps2

(Optional) Set the minimum acceptable incoming CIR.

7

frame-relay mincir out bps2

(Optional) Set the minimum acceptable outgoing CIR.

8

frame-relay bc out bits2

(Optional) Set the outgoing Committed Burst (Bc) size.

9

frame-relay be out bits2

(Optional) Set the outgoing Excess Burst (Be) size.

10

frame-relay idle-timer duration

(Optional) Set the idle timeout interval.

1This command replaces the frame-relay becn-response-enable command, which will be removed in a future Cisco IOS release. If you use the frame-relay  becn-response-enable command in scripts, you should replace it with the frame-relay adaptive-shaping becn command.
2The in and out keywords are optional. Configuring the command without the in and out keywords will apply that value to both the incoming and outgoing traffic values for the SVC setup. For example, frame-relay cir 56000 applies 56000 to both incoming and outgoing traffic values for setting up the SVC.

For SVCs, you can define multiple map classes. A map class is associated with a static map, not with the interface or subinterface itself. Because of the flexibility this association allows, you can define different map classes for different destinations.

Configure Frame Relay Traffic Shaping

FRTS provides these capabilities:


Note FRTS is not effective for Layer 2 PVC switching using the frame-relay route command.

Virtual Circuits for Different Types of Traffic

By defining separate VCs for different types of traffic and specifying queueing and an outbound traffic rate for each VC, you can provide guaranteed bandwidth for each type of traffic. By specifying different traffic rates for different VCs over the same line, you can perform virtual time-division multiplexing. By throttling outbound traffic from high-speed lines in central offices to lower-speed lines in remote locations, you can ease congestion and data loss in the network; enhanced queueing also prevents congestion-caused data loss.

Traffic Shaping Tasks

Traffic shaping applies to both permanent virtual circuits (PVCs) and SVCs. To configure FRTS, perform the tasks in the following sections:

Enable Frame Relay Traffic Shaping on the Interface

Enabling FRTS on an interface enables both traffic shaping and per-VC queueing on all the interface's PVCs and SVCs. Traffic shaping enables the router to control the circuit's output rate and react to congestion notification information if also configured.

To enable FRTS on the specified interface, use the following command in interface configuration mode:
Command Purpose

frame-relay traffic-shaping

Enable Frame Relay traffic shaping and per-VC queueing.

Understand the Frame Relay ForeSight Feature

The router ForeSight feature is the network traffic control software used in Cisco switches. The Cisco Frame Relay switch can extend ForeSight messages over a User-to-Network Interface (UNI), passing the backward explicit congestion notification (BECN) bit for VCs.

The ForeSight feature allows Cisco Frame Relay routers to process and react to ForeSight messages and adjust VC-level traffic shaping in a timely manner.

The ForeSight feature must be configured explicitly on both the Cisco router and the Cisco switch. It is enabled on the Cisco router when FRTS is configured. However, the router's response to the ForeSight feature is not applied to any VC until the frame-relay adaptive-shaping foresight command is added to the VC's map class. When the ForeSight feature is enabled on the switch, the switch will periodically send out a ForeSight message based on the time value configured. The time interval can range from 40 to 5000 milliseconds.

When a Cisco router receives a ForeSight message indicating that certain data-link connection identifiers (DLCIs) are experiencing congestion, the Cisco router reacts by activating its traffic shaping function to slow down the output rate. The router reacts as it would if it were to detect the congestion by receiving a packet with the BECN bit set.

Congestion Notification Methods

The difference between the BECN and ForeSight congestion notification methods is that BECN requires a user packet to be sent in the direction of the congested DLCI to convey the signal. The sending of user packets is not predictable and therefore is not reliable as a notification mechanism. Rather than wait for user packets to provide the congestion notification, timed ForeSight messages guarantee that the router receives notification before congestion becomes a problem. Traffic can be slowed down in the direction of the congested DLCI.

ForeSight Prerequisites

For the ForeSight feature to work, the following conditions must exist on the Cisco router:

The following additional condition must exist on the Cisco switch: The UNI connecting to the router is Consolidated Link Layer Management (CLLM) enabled, with the proper time interval specified.

The ForeSight feature is enabled automatically when you use the frame-relay traffic-shaping command. However, you must issue the map-class frame-relay command and the frame-relay adaptive-shaping foresight command before the router will respond to the ForeSight feature and apply the traffic shaping effect on a specific interface, subinterface, or VC.

Enable Enhanced Local Management Interface

When used in conjunction with traffic shaping, the router can respond to changes in the network dynamically. This optional feature allows the router to learn QoS parameters from the Cisco switch and use them for traffic shaping, configuration, or management purposes.

Enhanced Local Management Interface (ELMI) also simplifies traffic shaping configuration on the router. Previously, users needed to configure traffic shaping rate enforcement values, possibly for every VC. Enabling ELMI reduces the chance of specifying inconsistent or incorrect values when configuring the router.

To enable ELMI, you must configure it on the main interface. Use the following optional commands in interface configuration mode:
Step Command Purpose

1

interface interface-type interface-number

Specify the physical interface.

2

encapsulation frame-relay [cisco | ietf]

Enable Frame Relay encapsulation on the interface.

3

frame-relay qos-autosense

Enable the Enhanced Local Management Interface feature.


Note ELMI enables automated exchange of Frame Relay QoS parameter information between the Cisco router and the Cisco switch. Routers can base congestion management and prioritization decisions on known QoS values, such as the CIR, Bc, and Be. The router senses QoS values from the switch and can be configured to use those values in traffic shaping. This enhancement works between Cisco routers and Cisco switches (BPX/MGX and IGX platforms).

It is not necessary to configure traffic shaping on the interface to enable ELMI. You might want to enable it to know the values being used by the switch. If you want the router to respond to the QoS information received from the switch by adjusting the output rate, you must configure traffic shaping on the interface using the frame-relay traffic-shaping command in interface configuration mode.

For an example of how to configure a Frame Relay interface with QoS autosense enabled, see the section "Enhanced Local Management Interface Example" later in this chapter.

Specify a Traffic Shaping Map Class for the Interface

When you specify a Frame Relay map class for a main interface, all the VCs on its subinterfaces inherit all the traffic shaping parameters defined for the class.

To specify a map class for a particular ELMI interface, use the following command in interface configuration mode:
Command Purpose

frame-relay class map-class-name

Specify a Frame Relay map class for the interface.

You can override the default for a specific DLCI on a specific subinterface by using the frame-relay class VC configuration command to assign the DLCI explicitly to a different class. For an example of assigning subinterface DLCIs to the default class and assigning others explicitly to a different class, see the section "FRTS Configuration Examples" later in this chapter.

Define a Map Class with Queueing and Traffic Shaping Parameters

When you define a map class for Frame Relay, you can define the average and peak rates (in bits per second) allowed on VCs associated with the map class. You can also specify either a custom queue list or a priority queue group to use on VCs associated with the map class.

To define a map class, use the following commands in global configuration mode:
Step Command Purpose

1

map-class frame-relay map-class-name

Specify a map class to define.

2

frame-relay traffic-rate average [peak]

Define the traffic rate for the map class.

3

frame-relay custom-queue-list list-number

Specify a custom queue list.

4

frame-relay priority-group list-number

Specify a priority queue list.

5

frame-relay adaptive-shaping {becn | foresight}1

Select either BECN or ForeSight as the congestion backward notification mechanism to which traffic shaping will adapt.

1This command replaces the frame-relay becn-response-enable command, which will be removed in a future Cisco IOS release. If you use the frame-relay  becn-response-enable command in scripts, you should replace it with the frame-relay adaptive-shaping becn command.

Define Access Lists

You can specify access lists and associate them with the custom queue list defined for any map class. The list number specified in the access list and the custom queue list tie them together.

See the appropriate protocol chapters for information about defining access lists for the protocols you want to transmit on the Frame Relay network.

Define Priority Queue Lists for the Map Class

You can define a priority list for a protocol and you can also define a default priority list. The number used for a specific priority list ties the list to the Frame Relay priority group defined for a specified map class.

For example, if you enter the frame relay priority-group 2 command for the map class fast_vcs and then you enter the priority-list 2 protocol decnet high command, that priority list is used for the map class fast_vcs. The average and peak traffic rates defined for the map class fast_vcs are used for DECnet traffic.

Define Custom Queue Lists for the Map Class

You can define a queue list for a protocol and a default queue list. You can also specify the maximum number of bytes to be transmitted in any cycle. The number used for a specific queue list ties the list to the Frame Relay custom queue list defined for a specified map class.

For example, if you enter the frame relay custom-queue-list 1 command for the map class slow_vcs and then you enter the queue-list 1 protocol ip list 100 command, that queue list is used for the map class slow_vcs; access-list 100 definition is also used for that map class and queue. The average and peak traffic rates defined for the map class slow_vcs are used for IP traffic that meets the access-list 100 criteria.

Create a Broadcast Queue for an Interface

Very large Frame Relay networks might have performance problems when many DLCIs terminate in a single router or access server that must replicate routing updates and service advertising updates on each DLCI. The updates can consume access-link bandwidth and cause significant latency variations in user traffic; the updates can also consume interface buffers and lead to higher packet rate loss for both user data and routing updates.

To avoid such problems, you can create a special broadcast queue for an interface. The broadcast queue is managed independently of the normal interface queue, has its own buffers, and has a configurable size and service rate.

A broadcast queue is given a maximum transmission rate (throughput) limit measured in both bytes per second and packets per second. The queue is serviced to ensure that no more than this maximum is provided. The broadcast queue has priority when transmitting at a rate below the configured maximum, and hence has a guaranteed minimum bandwidth allocation. The two transmission rate limits are intended to avoid flooding the interface with broadcasts. The actual transmission rate limit in any second is the first of the two rate limits that is reached.

To create a broadcast queue, use the following command in interface configuration mode:
Command Purpose

frame-relay broadcast-queue size byte-rate packet-rate

Create a broadcast queue for an interface.

Configure Discard Eligibility

You can specify which Frame Relay packets have low priority or low time sensitivity and will be the first to be dropped when a Frame Relay switch is congested. The mechanism that allows a Frame Relay switch to identify such packets is the discard eligible (DE) bit.

This feature requires that the Frame Relay network be able to interpret the DE bit. Some networks take no action when the DE bit is set. Other networks use the DE bit to determine which packets to discard. The most desirable interpretation is to use the DE bit to determine which packets should be dropped first and also which packets have lower time sensitivity.

You can define DE lists that identify the characteristics of packets to be eligible for discarding, and you can also specify DE groups to identify the DLCI that is affected.

To define a DE list specifying the packets that can be dropped when the Frame Relay switch is congested, use the following command in global configuration mode:
Command Purpose

frame-relay de-list list-number {protocol protocol  |
interface interface-type interface-number} characteristic

Define a DE list.

You can specify DE lists based on the protocol or the interface, and on characteristics such as fragmentation of the packet, a specific Transmission Control Protocol (TCP) or User Datagram Protocol (UDP) port, an access list number, or a packet size. See the frame-relay de-list command in the Wide-Area Networking Command Reference for arguments and other information.

To define a DE group specifying the DE list and DLCI affected, use the following command in interface configuration mode:
Command Purpose

frame-relay de-group group-number dlci

Define a DE group.

Configure DLCI Priority Levels

DLCI priority levels allow you to separate different types of traffic and can provide a traffic management tool for congestion problems caused by the following situations:

Before you configure the DLCI priority levels, complete the following tasks:

Make sure that you define each of the DLCIs to which you intend to apply levels. You can associate priority-level DLCIs with subinterfaces.

Note DLCI priority levels provide a way to define multiple parallel DLCIs for different types of traffic. DLCI priority levels do not assign priority queues within the router or access server; in fact, they are independent of the device's priority queues. However, if you enable queueing and use the same DLCIs for queueing, then high-priority DLCIs can be put into high-priority queues.

To configure DLCI priority levels, use the following command in interface configuration mode:
Command Purpose

frame-relay priority-dlci-group group-number high-dlci
medium-dlci normal-dlci low-dlci  

Enable multiple parallel DLCIs for different types of Frame Relay traffic, associate specified DLCIs with the same group, and define their levels.


Note If you do not explicitly specify a DLCI for each of the priority levels, the last DLCI specified in the command line is used as the value of the remaining arguments. At a minimum, you must configure the high-priority and the medium-priority DLCIs.

Monitor the Frame Relay Connections

To monitor Frame Relay connections, use any of the following commands in EXEC mode:
Command Purpose

clear frame-relay-inarp

Clear dynamically created Frame Relay maps, which are created by the use of Inverse ARP.

show interfaces type interface-number

Show information about Frame Relay DLCIs and the LMI.

show frame-relay lmi [interface-type interface-number]

Show LMI statistics.

show frame-relay map

Show the current Frame Relay map entries.

show frame-relay pvc [interface-type interface-number
[dlci]]

Show PVC statistics.

show frame-relay route

Show configured static routes.

show frame-relay traffic

Show Frame Relay traffic statistics.

show frame-relay lapf

Show information about the status of LAPF.

show frame-relay svc maplist

Show all the SVCs under a specified map list.

FRTS Configuration Examples

The following examples provide FRTS configuration examples for interfaces and subinterfaces:

SVC Interface Example

The following example configures a physical interface, applies a map group to the physical interface, and then defines the map group:

interface serial 0
 ip address 172.10.8.6
 encapsulation frame-relay
 map-group bermuda
 frame-relay lmi-type q933a
 frame-relay svc
!
map-list bermuda source-addr E164 123456 dest-addr E164 654321
 ip 131.108.177.100 class hawaii
 appletalk 1000.2 class rainbow
!
map-class frame-relay rainbow
 frame-relay idle-timer 60
!
map-class frame-relay hawaii
 frame-relay cir in 64000
 frame-relay cir out 64000

SVC Subinterface Example

The following example configures a point-to-point interface for SVC operation. This example assumes that the main interface (serial 0) has been configured for signalling, and that SVC operation has been enabled on the main interface.

int s 0.1 point-point
! Define the map-group; details are specified under the map-list holiday command.
map-group holiday
!
! Associate the map-group with a specific source and destination.
map-list holiday local-addr X121 <X121-addr> dest-addr E164 <E164-addr>
! Specify destination protocol addresses for a map-class.
 ip 131.108.177.100 class hawaii IETF
 appletalk 1000.2 class rainbow IETF broadcast
!
! Define a map class and its QoS settings.
map-class hawaii
 frame-relay cir in 2000000
 frame-relay cir out 56000
 frame-relay be 9000
!
! Define another map class and its QOS settings.
map-class rainbow
 frame-relay cir in 64000
 frame-relay idle-timer 2000

Traffic Shaping with Three Point-to-Point Subinterfaces Example

In this example, the VCs on subinterfaces Serial0.1 and Serial0.2 inherit class parameters from the main interface, namely those defined in slow_vcs, but the VC defined on subinterface Serial0.2 (DLCI 102) is specifically configured to use map class fast_vcs.

Map class slow_vcs uses a peak rate of 9600 and average rate of 4800 bps. Because BECN feedback is enabled by default, the output rate will be cut back as low as 4800 bps in response to received BECNs. This map class is configured to use custom queueing using queue-list 1. In this example, queue-list 1 has three queues, with the first two being controlled by access lists 100 and 115.

Map class fast_vcs uses a peak rate of 64,000 and average rate of 16,000 bps. Because BECN feedback is enabled by default, the output rate will be cut back to as low as 4800 bps in response to received BECNs. This map class is configured for priority queueing using priority-group 2.

interface Serial0
 no ip address
 encapsulation frame-relay
 frame-relay lmi-type ansi
 frame-relay traffic-shaping
 frame-relay class slow_vcs
!
interface Serial0.1 point-to-point
 ip address 10.128.30.1 255.255.255.248
 ip ospf cost 200
 bandwidth 10
 frame-relay interface-dlci 101
!
interface Serial0.2 point-to-point
 ip address 10.128.30.9 255.255.255.248
 ip ospf cost 400
 bandwidth 10
 frame-relay interface-dlci 102
   class fast_vcs
!
interface Serial0.3 point-to-point
 ip address 10.128.30.17 255.255.255.248
 ip ospf cost 200
 bandwidth 10
 frame-relay interface-dlci 103
!
map-class frame-relay slow_vcs
 frame-relay traffic-rate 4800 9600
 frame-relay custom-queue-list 1
!
map-class frame-relay fast_vcs
 frame-relay traffic-rate 16000 64000
 frame-relay priority-group 2
!
access-list 100 permit tcp any any eq 2065
access-list 115 permit tcp any any eq 256
!
priority-list 2 protocol decnet high
priority-list 2 ip normal
priority-list 2 default medium
!
queue-list 1 protocol ip 1 list 100
queue-list 1 protocol ip 2 list 115
queue-list 1 default 3
queue-list 1 queue 1 byte-count 1600 limit 200
queue-list 1 queue 2 byte-count 600 limit 200
queue-list 1 queue 3 byte-count 500 limit 200

Traffic Shaping with Router ForeSight Example

The following example illustrates a router configuration with traffic shaping enabled. DLCIs 100 and 101 on subinterfaces Serial3.2 and Serial3.3 inherit class parameters from the main interface. The traffic shaping for these two VCs will be adaptive to the ForeSight notification.

For serial interface 0, the output rate for DLCI 103 will not be affected by the ForeSight function.

interface Serial0
 no ip address
 encapsulation frame-relay
 frame-relay lmi-type ansi
 frame-relay traffic-shaping
!
interface Serial0.2 point-to-point
 ip address 10.128.30.17 255.255.255.248
 frame-relay interface-dlci 102
 class fast_vcs
!
interface Serial0.3 point-to-point
 ip address 10.128.30.5 255.255.255.248
 ip ospf cost 200
 frame-relay interface-dlci 103
 class slow_vcs
!
interface serial 3
 no ip address
 encapsulation frame-relay
 frame-relay traffic-shaping
 frame-relay class fast_vcs
!
interface Serial3.2 multipoint
 ip address 100.120.20.13 255.255.255.248
 frame-relay map ip 100.120.20.6 16 ietf broadcast
!
interface Serial3.3 point-to-point
 ip address 100.120.10.13 255.255.255.248
 frame-relay interface-dlci 101
!
map-class frame-relay slow_vcs
 frame-relay adaptive-shaping becn
 frame-relay traffic-rate 4800 9600
!
map-class frame-relay fast_vcs
 frame-relay adaptive-shaping foresight
 frame-relay traffic-rate 16000 64000
 frame-relay cir 56000
 frame-relay bc 64000

Enhanced Local Management Interface Example

Figure 11 illustrates a Cisco switch and a Cisco router, both configured with ELMI enabled. The switch sends QoS information to the router, which uses it for traffic rate enforcement.


Figure 11: Enhanced Local Management Interface---Sent between the Cisco Switch and the Cisco Router

The following configuration example shows a Frame Relay interface enabled with QoS autosense. The router receives messages from the Cisco switch, which is also configured with QoS autosense enabled. When ELMI is configured in conjunction with traffic shaping, the router receives congestion information through BECN or ForeSight congestion signaling and reduces its output rate to the value specified in the traffic shaping configuration.

interface serial0
  no ip address
  encapsulation frame-relay
  frame-relay lmi-type ansi
  frame-relay traffic-shaping
  frame-relay qos-autosense
!
interface serial0.1 point-to-point
  no ip address
  frame-relay interface-dlci 101

hometocprevnextglossaryfeedbacksearchhelp

Copyright 1989-1998©Cisco Systems Inc.