Полезная информация

cc/td/doc/product/software/ios120/12cgcr/np1_r
hometocprevnextglossaryfeedbacksearchhelp
PDF

Table of Contents

OSPF Commands

OSPF Commands

Use the commands in this chapter to configure and monitor the Open Shortest Path First (OSPF) routing protocol. For OSPF configuration information and examples, refer to the "Configuring OSPF" chapter of the Network Protocols Configuration Guide, Part 1.

area authentication

To enable authentication for an OSPF area, use the area authentication router configuration command. To remove an area's authentication specification or a specified area from the configuration, use the no form of this command.

area area-id authentication [message-digest]
no area area-id authentication
no area
area-id

Syntax Description

area-id

Identifier of the area for which authentication is to be enabled. The identifier can be specified as either a decimal value or an IP  address.

message-digest

(Optional) Enables MD5 authentication on the area specified by area-id.

Default

Type 0 authentication (no authentication)

Command Mode

Router configuration

Usage Guidelines

This command first appeared in Cisco IOS Release 10.0. The message-digest keyword first appeared in Cisco IOS Release 11.0.

Specifying authentication for an area sets the authentication to Type 1 (simple password) as specified in RFC 1247. If this command is not included in the configuration file, authentication of Type 0 (no authentication) is assumed.

The authentication type must be the same for all routers and access servers in an area. The authentication password for all OSPF routers on a network must be the same if they are to communicate with each other via OSPF. Use the ip ospf authentication-key command to specify this password.

If you enable MD5 authentication with the message-digest keyword, you must configure a password with the ip ospf message-digest-key command.

To remove the area's authentication specification, use the no form of this command with the authentication keyword.


Note To remove the specified area from the software configuration, use the command no area area-id (with no other keywords). That is, no area area-id removes all area options, such as area authentication, area default-cost, area nssa, area range, area stub, and area virtual-link.

Example

The following example mandates authentication for areas 0 and 36.0.0.0 of OSPF routing process  201. Authentication keys are also provided.

interface ethernet 0
  ip address 131.119.251.201 255.255.255.0
  ip ospf authentication-key adcdefgh
!
interface ethernet 1
  ip address 36.56.0.201 255.255.0.0
  ip ospf authentication-key ijklmnop
!
router ospf 201
  network 36.0.0.0 0.255.255.255 area 36.0.0.0
  network 131.119.0.0 0.0.255.255 area 0
  area 36.0.0.0 authentication
  area 0 authentication

Related Commands

You can use the master indexes or search online to find documentation of related commands.

area default-cost
area stub
ip ospf authentication-key
ip ospf message-digest-key

area default-cost

To specify a cost for the default summary route sent into a stub area, use the area default-cost router configuration command. To remove the assigned default route cost, use the no form of this command.

area area-id default-cost cost
no area area-id default-cost cost
no area area-id

Syntax Description

area-id

Identifier for the stub area. The identifier can be specified as either a decimal value or as an IP address.

cost

Cost for the default summary route used for a stub area. The acceptable value is a 24-bit number.

Default

Cost of 1

Command Mode

Router configuration

Usage Guidelines

This command first appeared in Cisco IOS Release 10.0.

The command is used only on an area border router attached to a stub area.

There are two stub area router configuration commands: the stub and default-cost options of the area command. In all routers and access servers attached to the stub area, the area should be configured as a stub area using the stub option of the area command. Use the default-cost option only on an area border router attached to the stub area. The default-cost option provides the metric for the summary default route generated by the area border router into the stub area.


Note To remove the specified area from the software configuration, use the command no area area-id (with no other keywords). That is, no area area-id removes all area options, such as area authentication, area default-cost, area nssa, area range, area stub, and area virtual-link.

Example

The following example assigns a default-cost of 20 to stub network 36.0.0.0:

interface ethernet 0
  ip address 36.56.0.201 255.255.0.0
!
router ospf 201
  network 36.0.0.0 0.255.255.255 area 36.0.0.0
  area 36.0.0.0 stub
  area 36.0.0.0 default-cost 20

Related Commands

You can use the master indexes or search online to find documentation of related commands.

area authentication
area stub

area nssa

To configure an area as a not so stubby area (NSSA), use the area nssa router configuration command. To remove the nssa distinction from the area, use the no form of this command.

area area-id nssa [no-redistribution] [default-information-originate]
no area area-id nssa
no area area-id

Syntax Description

area-id

Identifier of the area for which authentication is to be enabled. The identifier can be specified as either a decimal value or an IP  address.

no-redistribution

(Optional) Used when the router is a NSSA ABR and you want the redistribute command to import routes only into the normal areas, but not into the NSSA area.

default-information-
originate

(Optional) Used to generate a Type 7 default into the NSSA area. This argument only takes effect on NSSA ABR.

Default

No NSSA area is defined.

Command Mode

Router configuration

Usage Guidelines

This command first appeared in Cisco IOS Release 10.0.


Note To remove the specified area from the software configuration, use the command no area area-id (with no other keywords). That is, no area area-id removes all area options, such as area authentication, area default-cost, area nssa, area range, area stub, and area virtual-link.

Example

The following example enables NSSA authentication on area 1:

router ospf1
  redistribute rip subnets
  network 172.19.92.0.0.0.0.255 area 1
  area 1 nssa

area range

To consolidate and summarize routes at an area boundary, use the area range router configuration command. To disable this function, use the no form of this command.

area area-id range address mask
no area area-id range address mask
no area area-id

Syntax Description

area-id

Identifier of the area about which routes are to be summarized. It can be specified as either a decimal value or as an IP address.

address

IP address.

mask

IP mask.

Default

Disabled

Command Mode

Router configuration

Usage Guidelines

This command first appeared in Cisco IOS Release 10.0.

The area range command is used only with area border routers (ABRs). It is used to consolidate or summarize routes for an area. The result is that a single summary route is advertised to other areas by the ABR. Routing information is condensed at area boundaries. External to the area, a single route is advertised for each address range. This is called route summarization.

Multiple area router configuration commands specifying the range option can be configured. Thus, OSPF can summarize addresses for many different sets of address ranges.


Note To remove the specified area from the software configuration, use the command no area area-id (with no other keywords). That is, no area area-id removes all area options, such as area authentication, area default-cost, area nssa, area range, area stub, and area virtual-link.

Example

The following example specifies one summary route to be advertised by the ABR to other areas for all subnets on network 36.0.0.0 and for all hosts on network 192.42.110.0:

interface ethernet 0
  ip address 192.42.110.201 255.255.255.0
!
interface ethernet 1
  ip address 36.56.0.201 255.255.0.0
!
router ospf 201
  network 36.0.0.0 0.255.255.255 area 36.0.0.0
  network 192.42.110.0 0.0.0.255 area 0
  area 36.0.0.0 range 36.0.0.0 255.0.0.0
  area 0 range 192.42.110.0 255.255.255.0

area stub

To define an area as a stub area, use the area stub router configuration command. To disable this function, use the no form of this command.

area area-id stub [no-summary]
no area area-id stub
no area
area-id

Syntax Description

area-id

Identifier for the stub area; either a decimal value or an IP address.

no-summary

(Optional) Prevents an ABR from sending summary link advertisements into the stub area.

Default

No stub area is defined.

Command Mode

Router configuration

Usage Guidelines

This command first appeared in Cisco IOS Release 10.0.

You must configure the area stub command on all routers and access servers in the stub area. Use the area router configuration command with the default-cost option to specify the cost of a default internal router sent into a stub area by an area border router.

There are two stub area router configuration commands: the stub and default-cost options of the area router configuration command. In all routers attached to the stub area, the area should be configured as a stub area using the stub option of the area command. Use the default-cost option only on an ABR attached to the stub area. The default-cost option provides the metric for the summary default route generated by the area border router into the stub area.

To further reduce the number of link state advertisements (LSA) sent into a stub area, you can configure no-summary on the ABR to prevent it from sending summary LSAs (LSA type 3) into the stub area.


Note To remove the specified area from the software configuration, use the command no area area-id (with no other keywords). That is, no area area-id removes all area options, such as area authentication, area default-cost, area nssa, area range, area stub, and area virtual-link.

Example

The following example assigns a default cost of 20 to stub network 36.0.0.0:

interface ethernet 0
  ip address 36.56.0.201 255.255.0.0
!
router ospf 201
  network 36.0.0.0 0.255.255.255 area 36.0.0.0
  area 36.0.0.0 stub
  area 36.0.0.0 default-cost 20

Related Commands

You can use the master indexes or search online to find documentation of related commands.

area authentication
area default-cost

area virtual-link

To define an OSPF virtual link, use the area virtual-link router configuration command with the optional parameters. To remove a virtual link, use the no form of this command.

area area-id virtual-link router-id [hello-interval seconds] [retransmit-interval seconds]
[transmit-delay seconds] [dead-interval seconds] [[authentication-key key] |
[message-digest-key keyid md5 key]]
no area area-id virtual-link router-id [hello-interval seconds] [retransmit-interval seconds]
[transmit-delay seconds] [dead-interval seconds] [[authentication-key key] |
[message-digest-key keyid md5 key]]
no area area-id

Syntax Description

area-id

Area ID assigned to the transit area for the virtual link. This can be either a decimal value or a valid IP address. There is no default.

router-id

Router ID associated with the virtual link neighbor. The router ID appears in the show ip ospf display. It is internally derived by each router from the router's interface IP addresses. This value must be entered in the format of an IP address. There is no default.

hello-interval seconds

(Optional) Time in seconds between the hello packets that the Cisco IOS software sends on an interface. Unsigned integer value to be advertised in the software's hello packets. The value must be the same for all routers and access servers attached to a common network. The default is 10  seconds.

retransmit-interval seconds

(Optional) Time in seconds between link state advertisement retransmissions for adjacencies belonging to the interface. Expected round-trip delay between any two routers on the attached network. The value must be greater than the expected round-trip delay. The default is 5  seconds.

transmit-delay seconds

(Optional) Estimated time in seconds it takes to transmit a link state update packet on the interface. Integer value that must be greater than zero. Link state advertisements in the update packet have their age incremented by this amount before transmission. The default value is 1 second.

dead-interval seconds

(Optional) Time in seconds that a software's hello packets are not seen before its neighbors declare the router down. Unsigned integer value. The default is four times the hello interval, or 40  seconds. As with the hello interval, this value must be the same for all routers and access servers attached to a common network.

authentication-key key

(Optional) Password to be used by neighboring routers. Any continuous string of characters that you can enter from the keyboard up to 8 bytes long. This string acts as a key that will allow the authentication procedure to generate or verify the authentication field in the OSPF header. This key is inserted directly into the OSPF header when originating routing protocol packets. A separate password can be assigned to each network on a per-interface basis. All neighboring routers on the same network must have the same password to be able to route OSPF traffic. The password is encrypted in the configuration file if the service password-encryption command is enabled. There is no default value.

message-digest-key keyid md5 key

(Optional) Key identifier and password to be used by neighboring routers and this router for MD5 authentication. The keyid is a number in the range 1 to 255. The key is an alphanumeric string of up to 16 characters. All neighboring routers on the same network must have the same key identifier and key to be able to route OSPF traffic. There is no default value.

Defaults

area-id: No area ID is predefined.
router-id: No router ID is predefined.
hello-interval seconds: 10 seconds
retransmit-interval seconds: 5 seconds
transmit-delay seconds: 1 second
dead-interval seconds: 40 seconds
authentication-key key: No key is predefined.
message-digest-key keyid md5 key: No key is predefined.

Command Mode

Router configuration

Usage Guidelines

This command first appeared in Cisco IOS Release 10.0. The following keywords and arguments first appeared in Cisco IOS Release 11.0: message-digest-key keyid md5 key.

In OSPF, all areas must be connected to a backbone area. If the connection to the backbone is lost, it can be repaired by establishing a virtual link.

The smaller the hello interval, the faster topological changes will be detected, but more routing traffic will ensue.

The setting of the retransmit interval should be conservative, or needless retransmissions will result. The value should be larger for serial lines and virtual links.

The transmit delay value should take into account the transmission and propagation delays for the interface.

The Cisco IOS software will use the specified authentication key only when authentication is enabled for the backbone with the area area-id authentication router configuration command.

The two authentication schemes, simple text and MD5 authentication, are mutually exclusive. You can specify one or the other or neither. Any keywords and arguments you specify after authentication-key key or message-digest-key keyid md5 key are ignored. Therefore, specify any optional arguments before such a keyword-argument combination.


Note Each virtual link neighbor must include the transit area ID and the corresponding virtual link neighbor's router ID in order for a virtual link to be properly configured. Use the show ip ospf EXEC command to see the router ID.

Note To remove the specified area from the software configuration, use the command no area area-id (with no other keywords). That is, no area area-id removes all area options, such as area authentication, area default-cost, area nssa, area range, area stub, and area virtual-link.

Examples

The following example establishes a virtual link with default values for all optional parameters:

router ospf 201
  network 36.0.0.0 0.255.255.255 area 36.0.0.0
  area 36.0.0.0 virtual-link 36.3.4.5

The following example establishes a virtual link with MD5 authentication:

router ospf 201
  network 36.0.0.0 0.255.255.255 area 36.0.0.0
  area 36.0.0.0 virtual-link 36.3.4.5 message-digest-key 3 md5 sa5721bk47

Related Commands

You can use the master indexes or search online to find documentation of related commands.

area authentication
service password-encryption
show ip ospf

default-information originate (OSPF)

To generate a default route into an OSPF routing domain, use the default-information originate router configuration command. To disable this feature, use the no form of this command.

default-information originate [always] [metric metric-value] [metric-type type-value]
{level-1 | level-1-2 | level-2} [route-map map-name]
no default-information originate [always] [metric metric-value] [metric-type type-value]
{level-1 | level-1-2 | level-2} [route-map map-name]

Syntax Description

originate

Causes the Cisco IOS software to generate a default external route into an OSPF domain if the software already has a default route and you want to propagate to other routers.

always

(Optional) Always advertises the default route regardless of whether the software has a default route.

metric metric-value

(Optional) Metric used for generating the default route. If you omit a value and do not specify a value using the default-metric router configuration command, the default metric value is 10. The value used is specific to the protocol.

metric-type type-value

(Optional) External link type associated with the default route advertised into the OSPF routing domain. It can be one of the following values:

1---Type 1 external route

2---Type 2 external route

The default is Type 2 external route.

level-1

Level 1 routes are redistributed into other IP routing protocols independently. It specifies if IS-IS advertises network 0.0.0.0 into the Level 1 area.

level-1-2

Both Level 1 and Level 2 routes are redistributed into other IP routing protocols. It specifies if IS-IS advertises network 0.0.0.0 into both levels in a single command.

level-2

Level 2 routes are redistributed into other IP routing protocols independently. It specifies if IS-IS advertises network 0.0.0.0 into the Level 2 subdomain.

route-map map-name

(Optional) Routing process will generate the default route if the route map is satisfied.

Default

Disabled

Command Mode

Router configuration

Usage Guidelines

This command first appeared in Cisco IOS Release 10.0.

Whenever you use the redistribute or the default-information router configuration commands to redistribute routes into an OSPF routing domain, the Cisco IOS software automatically becomes an autonomous system boundary router (ASBR). However, an ASBR does not, by default, generate a default route into the OSPF routing domain. The software still must have a default route for itself before it generates one, except when you have specified the always keyword.

When you use this command for the OSPF process, the default network must reside in the routing table and you must satisfy the route-map map-name keyword. Use the default-information originate always route-map map-name form of the command when you do not want the dependency on the default network in the routing table.

Example

The following example specifies a metric of 100 for the default route redistributed into the OSPF routing domain and an external metric type of Type 1:

router ospf 109
  redistribute igrp 108 metric 100 subnets
  default-information originate metric 100 metric-type 1

Related Commands

You can use the master indexes or search online to find documentation of related commands.

redistribute

default-metric

To set default metric values for the OSPF routing protocol, use this form of the default-metric router configuration command. To return to the default state, use the no form of this command.

default-metric number
no default-metric number

Syntax Description

number

Default metric value appropriate for the specified routing protocol.

Default

Built-in, automatic metric translations, as appropriate for each routing protocol

Command Mode

Router configuration

Usage Guidelines

This command first appeared in Cisco IOS Release 10.0.

The default-metric command is used in conjunction with the redistribute router configuration command to cause the current routing protocol to use the same metric value for all redistributed routes. A default metric helps solve the problem of redistributing routes with incompatible metrics. Whenever metrics do not convert, using a default metric provides a reasonable substitute and enables the redistribution to proceed.

Example

The following example shows a router in autonomous system 109 using both the RIP and the OSPF routing protocols. The example advertises OSPF-derived routes using the RIP protocol and assigns the IGRP-derived routes a RIP metric of 10.

router rip
  default-metric 10
  redistribute ospf 109

Related Commands

You can use the master indexes or search online to find documentation of related commands.

redistribute

distance ospf

To define OSPF route administrative distances based on route type, use the distance ospf router configuration command. To restore the default value, use the no form of this command.

distance ospf {[intra-area dist1] [inter-area dist2] [external dist3]}
no distance ospf

Syntax Description

intra-area dist1

(Optional) Sets the distance for all routes within an area. The default value is  110.

inter-area dist2

(Optional) Sets the distance for all routes from one area to another area. The default value is 110.

external dist3

(Optional) Sets the distance for routes from other routing domains, learned by redistribution. The default value is 110.

Default

dist1: 110
dist2: 110
dist3: 110

Command Mode

Router configuration

Usage Guidelines

This command first appeared in Cisco IOS Release 11.1(14).

You must specify at least one of the keyword/argument pairs.

This command performs the same function as the distance commnad used with an access list. However, the distance ospf command allows you to set a distance for an entire group of routes, rather than a specific route that passes an access list.

A common reason to use the distance ospf command is when you have multiple OSPF processes with mutual redistribution, and you want to prefer internal routes from one over external routes from the other.

Example

The following example changes the external distance to 200, making it less trustworthy.

Router A
router ospf 1
  redistribute ospf 2 subnet
  distance ospf external 200
!
router ospf 2
  redistribute ospf 1 subnet
 distance ospf external 200
Router B
router ospf 1
 redistribute ospf 2 subnet
 distance ospf external 200
!
router ospf 2  redistribute ospf 1 subnet
 distance ospf external 200
Related Commands

You can use the master indexes or search online to find documentation of related commands.

distance

ip ospf authentication-key

To assign a password to be used by neighboring routers that are using OSPF's simple password authentication, use the ip ospf authentication-key interface configuration command. To remove a previously assigned OSPF password, use the no form of this command.

ip ospf authentication-key password
no ip ospf authentication-key

Syntax Description

password

Any continuous string of characters that can be entered from the keyboard up to 8 bytes in length.

Default

No password is specified.

Command Mode

Interface configuration

Usage Guidelines

This command first appeared in Cisco IOS Release 10.0.

The password created by this command is used as a "key" that is inserted directly into the OSPF header when the Cisco IOS software originates routing protocol packets. A separate password can be assigned to each network on a per-interface basis. All neighboring routers on the same network must have the same password to be able to exchange OSPF information.


Note The Cisco IOS software will use this key only when authentication is enabled for an area with the area authentication router configuration command.

Example

The following example enables the authentication key with the string yourpass:

ip ospf authentication-key yourpass

Related Commands

You can use the master indexes or search online to find documentation of related commands.

area authentication

ip ospf cost

To explicitly specify the cost of sending a packet on an interface, use the ip ospf cost interface configuration command. To reset the path cost to the default value, use the no form of this command.

ip ospf cost cost
no ip ospf cost

Syntax Description

cost

Unsigned integer value expressed as the link state metric. It can be a value in the range 1 to 65535.

Default

No default cost is predefined.

Command Mode

Interface configuration

Usage Guidelines

This command first appeared in Cisco IOS Release 10.0.

You can set the metric manually using this command, if you need to change the default. Using the bandwidth command changes the link cost as long as this command is not used.

The link state metric is advertised as the link cost in the router link advertisement. We do not support type of service (TOS), so you can assign only one cost per interface.

In general, the path cost is calculated using the following formula:

108 ÷ Bandwidth

Using this formula, the default path costs were calculated as noted in the following list. If these values do not suit your network, you can use your own method of calculating path costs.

Example

The following example sets the interface cost value to 65:

ip ospf cost 65

ip ospf database-filter

To filter outgoing LSAs to an OSPF interface, use the ip ospf database-filter interface configuration command. To restore the forwarding of LSAs to the interface, use the no form of this command.

ip ospf database-filter all out
no ip ospf database-filter all out

Syntax Description

This command has no arguments or keywords.

Default

Disabled; all outgoing LSAs are flooded to the interface.

Command Mode

Interface configuration

Usage Guidelines

This command first appeared in Cisco IOS Release 12.0.

This command performs the same function that the neighbor database-filter command performs on a neighbor basis.

Example

The following example prevents flooding of OSPF LSAs to broadcast, nonbroadcast, or point-to-point networks reachable through Ethernet interface 0:

interface ethernet 0
  ip ospf database-filter all out

Related Commands

You can use the master indexes or search online to find documentation of related commands.

neighbor database-filter

ip ospf dead-interval

To set how long hello packets must not have been seen before its neighbors declare the router down, use the ip ospf dead-interval interface configuration command. To return to the default time, use the no form of this command.

ip ospf dead-interval seconds
no ip ospf dead-interval

Syntax Description

seconds

Unsigned integer that specifies the interval in seconds; the value must be the same for all nodes on the network.

Default

Four times the interval set by the ip ospf hello-interval command

Command Mode

Interface configuration

Usage Guidelines

This command first appeared in Cisco IOS Release 10.0.

The interval is advertised in the router's hello packets. This value must be the same for all routers and access servers on a specific network.

Example

The following example sets the OSPF dead interval to 60 seconds:

interface ethernet 1
 ip ospf dead-interval 60

Related Commands

You can use the master indexes or search online to find documentation of related commands.

ip ospf hello-interval

ip ospf demand-circuit

To configure OSPF to treat the interface as an OSPF demand circuit, use the ip ospf demand-circuit interface configuration command. To remove the demand circuit designation from the interface, use the no form of this command.

ip ospf demand-circuit
no ip ospf demand-circuit

Syntax Description

This command has no arguments or keywords.

Default

The circuit is not a demand circuit.

Command Mode

Interface configuration

Usage Guidelines

This command first appeared in Cisco IOS Release 11.2.

On point-to-point interfaces, only one end of the demand circuit must be configured with this command. Periodic hellos are suppressed and periodic refreshes of LSAs do not flood the demand circuit. It allows the underlying datalink layer to be closed when the topology is stable. In point-to-multipoint topology, only the multipoint end must configured with this command.

Example

The following example sets the configures an ISDN on demand circuit:

router ospf1
  network 18.0.3.0.0.0.0.25 area 0
interface BRIO
  ip ospf demand-circuit

ip ospf hello-interval

To specify the interval between hello packets that the Cisco IOS software sends on the interface, use the ip ospf hello-interval interface configuration command. To return to the default time, use the no form of this command.

ip ospf hello-interval seconds
no ip ospf hello-interval

Syntax Description

seconds

Unsigned integer that specifies the interval in seconds. The value must be the same for all nodes on a specific network.

Default

10 seconds

Command Mode

Interface configuration

Usage Guidelines

This command first appeared in Cisco IOS Release 10.0.

This value is advertised in the hello packets. The smaller the hello interval, the faster topological changes will be detected, but more routing traffic will ensue. This value must be the same for all routers and access servers on a specific network.

Example

The following example sets the interval between hello packets to 15 seconds:

interface ethernet 1
  ip ospf hello-interval 15

Related Commands

You can use the master indexes or search online to find documentation of related commands.

ip ospf dead-interval

ip ospf message-digest-key

To enable OSPF MD5 authentication, use the ip ospf message-digest-key interface configuration command. To remove an old MD5 key, use the no form of this command.

ip ospf message-digest-key keyid md5 key
no ip ospf message-digest-key keyid

Syntax Description

keyid

An identifier in the range 1 to 255.

key

Alphanumeric password of up to 16 bytes.

Default

OSPF MD5 authentication is disabled.

Command Mode

Interface configuration

Usage Guidelines

This command first appeared in Cisco IOS Release 11.0.

Usually, one key per interface is used to generate authentication information when sending packets and to authenticate incoming packets. The same key identifier on the neighbor router must have the same key value.

The process of changing keys is as follows. Suppose the current configuration is as follows:

interface ethernet 1
  ip ospf message-digest-key 100 md5 OLD

You change the configuration to the following:

interface ethernet 1
  ip ospf message-digest-key 101 md5 NEW

The system assumes its neighbors do not have the new key yet, so it begins a rollover process. It sends multiple copies of the same packet, each authenticated by different keys. In this example, the system sends out two copies of the same packet---the first one authenticated by key 100 and the second one authenticated by key 101.

Rollover allows neighboring routers to continue communication while the network administrator is updating them with the new key. Rollover stops once the local system finds that all its neighbors know the new key. The system detects that a neighbor has the new key when it receives packets from the neighbor authenticated by the new key.

After all neighbors have been updated with the new key, the old key should be removed. In this example, you would enter the following:

interface ethernet 1
  no ip ospf message-digest-key 100

Then, only key 101 is used for authentication on Ethernet interface 1.

We recommend that you not keep more than one key per interface. Every time you add a new key, you should remove the old key to prevent the local system from continuing to communicate with a hostile system that knows the old key. Removing the old key also reduces overhead during rollover.

Example

The following example sets a new key 19 with the password 8ry4222:

interface ethernet 1
  ip ospf message-digest-key 10 md5 xvv560qle
  ip ospf message-digest-key 19 md5 8ry4222

Related Commands

You can use the master indexes or search online to find documentation of related commands.

area authentication

ip ospf name-lookup

To configure OSPF to look up Domain Name System (DNS) names for use in all OSPF show EXEC command displays, use the ip ospf name-lookup global configuration command. To disable this function, use the no form of this command.

ip ospf name-lookup
no ip ospf name-lookup

Syntax Description

This command has no arguments or keywords.

Default

Disabled

Command Mode

Global configuration

Usage Guidelines

This command first appeared in Cisco IOS Release 10.0.

This feature makes it easier to identify a router because it is displayed by name rather than by its router ID or neighbor ID.

Example

The following example configures OSPF to look up DNS names for use in all OSPF show EXEC command displays:

ip ospf name-lookup

ip ospf network

To configure the OSPF network type to a type other than the default for a given media, use the ip  ospf network interface configuration command. To return to the default value, use the no form of this command.

ip ospf network {broadcast | non-broadcast | {point-to-multipoint [non-broadcast]}}
no ip ospf network

Syntax Description

broadcast

Sets the network type to broadcast.

non-broadcast

Sets the network type to NBMA.

point-to-multipoint [non-broadcast]

Sets the network type to point-to-multipoint.

The optional non-broadcast keyword sets the point-to-multipoint network to be nonbroadcast. If you use the non-broadcast keyword, the neighbor command is required.

Default

Depends on the network type.

Command Mode

Interface configuration

Usage Guidelines

This command first appeared in Cisco IOS Release 10.0. The point-to-multipoint keyword first appeared in Cisco IOS Release 10.3. The non-broadcast keyword used with the point-to-multipoint keyword first appeared in Cisco IOS Release 11.3 AA.

Using this feature, you can configure broadcast networks as nonbroadcast multiaccess (NBMA) networks when, for example, you have routers in your network that do not support multicast addressing. You can also configure nonbroadcast multiaccess networks (such as X.25, Frame Relay, and SMDS) as broadcast networks. This feature saves you from having to configure neighbors.

Configuring NBMA networks as either broadcast or nonbroadcast assumes that there are virtual circuits from every router to every router or fully meshed network. This is not true for some cases, for example, because of cost constraints or when you have only a partially meshed network. In these cases, you can configure the OSPF network type as a point-to-multipoint network. Routing between two routers that are not directly connected will go through the router that has virtual circuits to both routers. You do not need to configure neighbors when using this feature.

If this command is issued on an interface that does not allow it, it will be ignored.

OSPF has two features related to point-to-multipoint networks. One feature applies to broadcast networks; the other feature applies to nonbroadcast networks.

Examples

The following example sets your OSPF network as a broadcast network:

interface serial 0
 ip address 160.89.77.17 255.255.255.0  ip ospf network broadcast  encapsulation frame-relay

The following example illustrates a point-to-multipoint network with broadcast.

interface Serial0
 ip address 10.0.1.1 255.255.255.0
 encapsulation frame-relay
  ip ospf cost 100
 ip ospf network point-to-multipoint
 frame-relay map ip 10.0.1.3 202 broadcast
 frame-relay map ip 10.0.1.4 203 broadcast
 frame-relay map ip 10.0.1.5 204 broadcast
 frame-relay local-dlci 200
!
router ospf 1
 network 10.0.1.0 0.0.0.255 area 0
 neighbor 10.0.1.5 cost 5
 neighbor 10.0.1.4 cost 10

Related Commands

You can use the master indexes or search online to find documentation of related commands.

frame-relay map
neighbor (OSPF)
x25 map

ip ospf priority

To set the router priority, which helps determine the designated router for this network, use the ip  ospf priority interface configuration command. To return to the default value, use the no form of this command.

ip ospf priority number
no ip ospf priority

Syntax Description

number

8-bit unsigned integer that specifies the priority. The range is from 0 to 255.

Default

Priority of 1

Command Mode

Interface configuration

Usage Guidelines

This command first appeared in Cisco IOS Release 10.0.

When two routers attached to a network both attempt to become the designated router, the one with the higher router priority takes precedence. If there is a tie, the router with the higher router ID takes precedence. A router with a router priority set to zero is ineligible to become the designated router or backup designated router. Router priority is only configured for interfaces to multiaccess networks (in other words, not point-to-point networks).

This priority value is used when you configure OSPF for nonbroadcast networks using the neighbor router configuration command for OSPF.

Example

The following example sets the router priority value to 4:

interface ethernet 0
 ip ospf priority 4

Related Commands

You can use the master indexes or search online to find documentation of related commands.

ip ospf network
neighbor (OSPF)

ip ospf retransmit-interval

To specify the time between link state advertisement retransmissions for adjacencies belonging to the interface, use the ip ospf retransmit-interval interface configuration command. To return to the default value, use the no form of this command.

ip ospf retransmit-interval seconds
no ip ospf retransmit-interval

Syntax Description

seconds

Time in seconds between retransmissions. It must be greater than the expected round-trip delay between any two routers on the attached network. The range is 1 to 65535 seconds. The default is 5 seconds.

Default

5 seconds

Command Mode

Interface configuration

Usage Guidelines

This command first appeared in Cisco IOS Release 10.0.

When a router sends a link state advertisement (LSA) to its neighbor, it keeps the LSA until it receives back the acknowledgment. If it receives no acknowledgment in seconds, it will retransmit the LSA.

The setting of this parameter should be conservative, or needless retransmission will result. The value should be larger for serial lines and virtual links.

Example

The following example sets the retransmit-interval value to 8 seconds:

interface ethernet 2
 ip ospf retransmit-interval 8

ip ospf transmit-delay

To set the estimated time it takes to transmit a link state update packet on the interface, use the ip  ospf transmit-delay interface configuration command. To return to the default value, use the no form of this command.

ip ospf transmit-delay seconds
no ip ospf transmit-delay

Syntax Description

seconds

Time in seconds that it takes to transmit a link state update.The range is 1  to 65535 seconds. The default is 1  second.

Default

1 second

Command Mode

Interface configuration

Usage Guidelines

This command first appeared in Cisco IOS Release 10.0.

Link state advertisements in the update packet must have their ages incremented by the amount specified in the seconds argument before transmission. The value assigned should take into account the transmission and propagation delays for the interface.

If the delay is not added before transmission over a link, the time in which the LSA propagates over the link is not considered. This setting has more significance on very low speed links.

Example

The following example sets the retransmit-delay value to 3 seconds:

interface ethernet 0
 ip ospf transmit-delay 3

neighbor (OSPF)

To configure OSPF routers interconnecting to nonbroadcast networks, use this form of the neighbor router configuration command. To remove a configuration, use the no form of this command.

neighbor ip-address [priority number] [poll-interval seconds] [cost number]
no neighbor
ip-address [priority number] [poll-interval seconds] [cost number]

Syntax Description

ip-address

Interface IP address of the neighbor.

priority number

(Optional) 8-bit number indicating the router priority value of the nonbroadcast neighbor associated with the IP address specified. The default is 0. This keyword does not apply to point-to-multipoint interfaces.

poll-interval seconds

(Optional) Unsigned integer value reflecting the poll interval. RFC 1247 recommends that this value be much larger than the hello interval. The default is 120 seconds (2 minutes). This keyword does not apply to point-to-multipoint interfaces.

cost number

(Optional) Assigns a cost to the neighbor, in the form of an integer from 1 to 65535. Neighbors with no specific cost configured will assume the cost of the interface, based on the ip  ospf cost command. On point-to-multipoint interfaces, this is the only keyword and argument that make sense. This keyword does not apply to NBMA networks.

Default

No configuration is specified.

Command Mode

Router configuration

Usage Guidelines

This command first appeared in Cisco IOS Release 10.0. The cost keyword was added in Release  11.3  AA.

X.25 and Frame Relay provide an optional broadcast capability that can be configured in the map to allow OSPF to run as a broadcast network. At the OSPF level you can configure the router as a broadcast network. See the x25 map and frame-relay map commands in the "X.25 Commands" and "Frame Relay Commands" chapters, respectively, in the Wide-Area Networking Command Reference for more detail.

One neighbor entry must be included in the Cisco IOS software configuration for each known nonbroadcast network neighbor. The neighbor address has to be on the primary address of the interface.

If a neighboring router has become inactive (hello packets have not been seen for the Router Dead Interval period), it may still be necessary to send hello packets to the dead neighbor. These hello packets will be sent at a reduced rate called Poll Interval.

When the router first starts up, it sends only hello packets to those routers with non-zero priority; that is, routers that are eligible to become designated routers (DR) and backup designated routers (BDR). After DR and BDR are selected, DR and BDR will then start sending hello packets to all neighbors in order to form adjacencies.

Prior to Release 12.0, the neighbor command applied to NBMA networks only. With Release 12.0, the neighbor command applies to NBMA networks and point-to-multipoint networks. On NBMA networks, the cost keyword is not accepted.

Examples

The following example declares a router at address 131.108.3.4 on a nonbroadcast network, with a priority of 1 and a poll interval of 180 seconds:

router ospf
 neighbor 131.108.3.4 priority 1 poll-interval 180

The following example illustrates a point-to-multipoint network with nonbroadcast:

interface Serial0
ip address 10.0.1.1 255.255.255.0
ip ospf network point-to-multipoint non-broadcast
encapsulation frame-relay
no keepalive
frame-relay local-dlci 200
frame-relay map ip 10.0.1.3 202
frame-relay map ip 10.0.1.4 203
frame-relay map ip 10.0.1.5 204
no shut
!
router ospf 1
network 10.0.1.0 0.0.0.255 area 0
neighbor 10.0.1.3 cost 5
neighbor 10.0.1.4 cost 10
neighbor 10.0.1.5 cost 15

Related Commands

You can use the master indexes or search online to find documentation of related commands.

ip ospf priority

neighbor database-filter

To filter outgoing LSAs to an OSPF neighbor, use the neighbor database-filter router configuration command. To restore the forwarding of LSAs to the neighbor, use the no form of this command.

neighbor ip-address database-filter all out
no
neighbor ip-address database-filter all out

Syntax Description

ip-address

IP address of the neighbor to which outgoing LSAs are blocked.

Default

Disabled; all outgoing LSAs are flooded to the neighbor.

Command Mode

Router configuration

Usage Guidelines

This command first appeared in Cisco IOS Release 12.0.

This command performs the same function that the ip ospf database-filter command performs on an interface basis.

Example

The following example prevents flooding of OSPF LSAs to point-to-multipoint networks to the neighbor at IP address 1.2.3.4:

router ospf 109
  neighbor 1.2.3.4 database-filter all out

Related Commands

You can use the master indexes or search online to find documentation of related commands.

ip ospf database-filter

network area

To define the interfaces on which OSPF runs and to define the area ID for those interfaces, use the network area router configuration command. To disable OSPF routing for interfaces defined with the address wildcard-mask pair, use the no form of this command.

network address wildcard-mask area area-id
no network address wildcard-mask area area-id

Syntax Description

address

IP address.

wildcard-mask

IP-address-type mask that includes "don't care" bits.

area-id

Area that is to be associated with the OSPF address range. It can be specified as either a decimal value or as an IP address. If you intend to associate areas with IP subnets, you can specify a subnet address as the area-id.

Default

Disabled

Command Mode

Router configuration

Usage Guidelines

This command first appeared in Cisco IOS Release 10.0.

The address and wildcard-mask arguments together allow you to define one or multiple interfaces to be associated with a specific OSPF area using a single command. Using the wildcard-mask allows you to define one or multiple interfaces to be associated with a specific OSPF area using a single command. If you intend to associate areas with IP subnets, you can specify a subnet address as the area-id.

For OSPF to operate on the interface, that interface's primary address must be covered by the network area command. If the network area command covers only the secondary address, it will not enable OSPF over that interface.

The Cisco IOS software sequentially evaluates the address/wildcard-mask pair for each interface as follows:

    1. The wildcard-mask is logically ORed with the interface IP address.

    2. The wildcard-mask is logically ORed with address in the network command.

    3. The software compares the two resulting values.

    4. If they match, OSPF is enabled on the associated interface and this interface is attached to the OSPF area specified.


Note Any individual interface can only be attached to a single area. If the address ranges specified for different areas overlap, the software will adopt the first area in the network command list and ignore the subsequent overlapping portions. In general, it is recommended that you devise address ranges that do not overlap in order to avoid inadvertent conflicts.

Example

The following partial example initializes OSPF routing process 109, and defines four OSPF areas: 10.9.50.0, 2, 3, and 0. Areas 10.9.50.0, 2, and 3 mask specific address ranges, while area 0 enables OSPF for all other networks.

interface ethernet 0
  ip address 131.108.20.1 255.255.255.0
router ospf 109
  network 131.108.20.0  0.0.0.255 area 10.9.50.0
  network 131.108.0.0  0.0.255.255 area 2
  network 131.109.10.0  0.0.0.255 area 3
  network 0.0.0.0  255.255.255.255 area 0

Related Commands

You can use the master indexes or search online to find documentation of related commands.

router ospf

ospf auto-cost

To control how OSPF calculates default metrics for the interface, use the ospf auto-cost router configuration command. To assign cost based only on the interface type, use the no form of this command.

ospf auto-cost reference-bandwidth ref-bw
no ospf auto-cost reference-bandwidth

Syntax Description

ref-bw

Rate in megabits per second (bandwidth). The range is 1 to 4294967; the default is 100.

Default

100 Mbits

Command Mode

Router configuration

Usage Guidelines

This command first appeared in Cisco IOS Release 11.2.

In Cisco IOS Release 10.3 and later, by default OSPF will calculate the OSPF metric for an interface according to the bandwidth of the interface. For example, a 64K link will get a metric of 1562, while a T1 link will have a metric of 64.

The OSPF metric is calculated as ref-bw divided by bandwidth, with ref-bw equal to 108 by default, and bandwidth determined by the bandwidth command. The calculation gives FDDI a metric of 1.

If you have multiple links with high bandwidth (such as FDDI or ATM), you might want to use a larger number to differentiate the cost on those links.

The value set by the ip ospf cost command overrides the cost resulting from the ospf auto-cost command.

Example

The following example changes the cost of the FDDI link to 10, while the gigabit Ethernet link remains at a cost of 1. Thus, the link costs are differentiated.

router ospf 1
  ospf auto-cost reference-bandwidth 1000

Related Commands

You can use the master indexes or search online to find documentation of related commands.

ip ospf cost

ospf ignore lsa mospf

To suppress the sending of syslog messages when the router receives LSA Type 6 (MOSPF) packets, which are unsupported, use the ospf ignore lsa mospf router configuration command. To restore the sending of syslog messages, use the no form of this command.

ospf ignore lsa mospf
no ospf ignore lsa mospf

Syntax Description

This command has no arguments or keywords.

Default

Disabled; each MOSPF packet causes the router to send a syslog message.

Command Mode

Router configuration

Usage Guidelines

This command first appeared in Cisco IOS Release 11.1.

Cisco routers do not support LSA Type 6 (MOSPF), and they generate syslog messages if they receive such packets. If the router is receiving many MOSPF packets, you might want to configure the router to ignore the packets and thus prevent a large number of syslog messages.

Example

The following example configures the router to suppress the sending of syslog messages when it receives MOSPF packets:

router ospf 109
  ospf ignore lsa mospf

ospf log-adj-changes

To configure the router to send a syslog message when the state of an OSPF neighbor changes, use the ospf  log-adj-changes router configuration command. To turn off this function, use the no form of this command.

ospf log-adj-changes
no ospf log-adj-changes

Syntax Description

This command has no arguments or keywords.

Default

No such syslog message is sent.

Command Mode

Router configuration

Usage Guidelines

This command first appeared in Cisco IOS Release 11.2.

Configure this command if you want to know about OSPF neighbor changes without turning on the debugging command debug ip ospf adjacency. The ospf log-adj-changes command provides a higher level view of changes to the state of the peer relationship with less output.

Example

The following example configures the router to send a syslog message for any neighbor state changes:

ospf log-adj-changes

router ospf

To configure an OSPF routing process, use the router ospf global configuration command. To terminate an OSPF routing process, use the no form of this command.

router ospf process-id
no router ospf process-id

Syntax Description

process-id

Internally used identification parameter for an OSPF routing process. It is locally assigned and can be any positive integer. A unique value is assigned for each OSPF routing process.

Default

No OSPF routing process is defined.

Command Mode

Global configuration

Usage Guidelines

This command first appeared in Cisco IOS Release 10.0.

You can specify multiple OSPF routing processes in each router.

Example

The following example configures an OSPF routing process and assign a process number of 109:

router ospf 109

Related Commands

You can use the master indexes or search online to find documentation of related commands.

network area

show ip ospf

To display general information about OSPF routing processes, use the show ip ospf EXEC command.

show ip ospf [process-id]

Syntax Description

process-id

(Optional) Process ID. If this argument is included, only information for the specified routing process is included.

Command Mode

EXEC

Usage Guidelines

This command first appeared in Cisco IOS Release 10.0.

Sample Display

The following is sample output from the show ip ospf command when entered without a specific OSPF process ID:

Router# show ip ospf
Routing Process "ospf 201" with ID 192.42.110.200
Supports only single TOS(TOS0) route
It is an area border and autonomous system boundary router
Redistributing External Routes from,
      	igrp 200 with metric mapped to 2, includes subnets in redistribution
      	rip with metric mapped to 2
      	igrp 2 with metric mapped to 100
      	igrp 32 with metric mapped to 1
Number of areas in this router is 3
Area 192.42.110.0
      	Number of interfaces in this area is 1
      	Area has simple password authentication
      	SPF algorithm executed 6 times

Table 23 describes significant fields shown in the display.


Table 23: Show IP OSPF Field Descriptions
Field Description

Routing process "ospf 201" with ID 192.42.110.200

Process ID and OSPF router ID.

Supports ...

Number of Types of service supported (Type 0 only).

It is ...

Possible types are internal, area border, or autonomous system boundary.

Summary Link update interval

Specify summary update interval in hours:minutes:seconds, and time to next update.

External Link update interval

Specify external update interval in hours:minutes:seconds, and time to next update.

Redistributing External Routes from

Lists of redistributed routes, by protocol.

Number of areas

Number of areas in router, area addresses, and so on.

Link State Update Interval

Specify router and network link state update interval in hours:minutes:seconds, and time to next update.

Link State Age Interval

Specify max-aged update deletion interval and time until next database cleanup in hours:minutes:seconds.

show ip ospf border-routers

To display the internal OSPF routing table entries to an area border router (ABR) and autonomous system boundary router (ASBR), use the show ip ospf border-routers privileged EXEC command.

show ip ospf border-routers

Syntax Description

This command has no arguments or keywords.

Command Mode

Privileged EXEC

Usage Guidelines

This command first appeared in Cisco IOS Release 10.0.

Sample Display

The following is sample output from the show ip ospf border-routers command:

Router# show ip ospf border-routers
OSPF Process 109 internal Routing Table
Destination      Next Hop        Cost   Type     Rte Type Area           SPF No
160.89.97.53     144.144.1.53    10     ABR      INTRA    0.0.0.3        3
160.89.103.51    160.89.96.51    10     ABR      INTRA    0.0.0.3        3
160.89.103.52    160.89.96.51    20     ASBR     INTER    0.0.0.3        3
160.89.103.52    144.144.1.53    22     ASBR     INTER    0.0.0.3        3

Table 24 describes the fields shown in the display.


Table 24: Show IP OSPF Border-Routers Field Descriptions
Field Description

Destination

Destination's router ID.

Next Hop

Next hop toward the destination.

Cost

Cost of using this route.

Type

The router type of the destination; it is either an area border router (ABR) or autonomous system boundary router (ASBR) or both.

Rte Type

The type of this route, it is either an intra-area or interarea route.

Area

The area ID of the area that this route is learned from.

SPF No

The internal number of SPF calculation that installs this route.

show ip ospf database

Use the show ip ospf database EXEC command to display lists of information related to the OSPF database for a specific router. The various forms of this command deliver information about different OSPF link state advertisements.

show ip ospf [process-id area-id] database
show ip ospf [process-id area-id] database [adv-router [ip-address]]
show ip ospf [process-id area-id] database [asbr-summary] [link-state-id]
show ip ospf
[process-id area-id] database [asbr-summary] [link-state-id] [adv-router
[
ip-address]]
show ip ospf [process-id area-id] database [asbr-summary] [link-state-id] [self-originate]
[link-state-id]
show ip ospf [process-id area-id] database [database-summary]
show ip ospf [process-id] database [external] [link-state-id]
show ip ospf [process-id] database [external] [link-state-id] [adv-router [ip-address]]
show ip ospf [process-id area-id] database [external] [link-state-id] [self-originate]
[link-state-id]
show ip ospf [process-id area-id] database [network][link-state-id]
show ip ospf [process-id area-id] database [network] [link-state-id] [adv-router [ip-address]]
show ip ospf [process-id area-id] database [network] [link-state-id] [self-originate]
[link-state-id]
show ip ospf [process-id area-id] database [nssa-external] [link-state-id]
show ip ospf [process-id area-id] database [nssa-external] [link-state-id] [adv-router
[ip-address]]
show ip ospf [process-id area-id] database [nssa-external] [link-state-id] [self-originate]
[link-state-id]
show ip ospf [process-id area-id] database [router] [link-state-id]
show ip ospf [process-id area-id] database [router] [adv-router [ip-address]]
show ip ospf [process-id area-id] database [router] [self-originate] [link-state-id]
show ip ospf [process-id area-id] database [self-originate] [link-state-id]
show ip ospf [process-id area-id] database [summary] [link-state-id]
show ip ospf [process-id area-id] database [summary] [link-state-id] [adv-router [ip-address]]
show ip ospf [process-id area-id] database [summary] [link-state-id] [self-originate]
[link-state-id]

Syntax Description

process-id

(Optional) Internal identification. It is locally assigned and can be any positive integer. The number used here is the number assigned administratively when enabling the OSPF routing process.

area-id

(Optional) Area number associated with the OSPF address range defined in the network router configuration command used to define the particular area.

link-state-id

(Optional) Portion of the Internet environment that is being described by the advertisement. The value entered depends on the advertisement's LS type. It must be entered in the form of an IP address.

When the link state advertisement is describing a network, the link-state-id can take one of two forms:

  • The network's IP address (as in type 3 summary link advertisements and in autonomous system external link advertisements).

  • A derived address obtained from the link state ID. (Note that masking a network links advertisement's link state ID with the network's subnet mask yields the network's IP address.)

When the link state advertisement is describing a router, the link state ID is always the described router's OSPF router ID.

When an autonomous system external advertisement (LS  Type = 5) is describing a default route, its link state ID is set to Default Destination (0.0.0.0).

adv-router [ip-address]

(Optional) Displays all the LSAs of the specified router. If no IP address is included, the information is about the local router itself (in this case, the same as self-originate).

asbr-summary

(Optional) Displays information only about the autonomous system boundary router summary LSAs.

database-summary

(Optional) Displays how many of each type of LSA for each area there are in the database, and the total.

external

(Optional) Displays information only about the external LSAs.

network

(Optional) Displays information only about the network LSAs.

nssa-external

(Optional) Displays information only about the NSSA external LSAs.

router

(Optional) Displays information only about the router LSAs.

self-originate

(Optional) Displays only self-originated LSAs (from the local router).

summary

(Optional) Displays information only about the summary LSAs.

Command Mode

EXEC

Usage Guidelines

This command first appeared in Cisco IOS Release 10.0. The database-summary keyword first appeared in Release 11.0. The self-originate and adv-router keywords first appeared in Release  12.0.

Sample Display of Show IP OSPF Database

The following is sample output from the show ip ospf database command when no arguments or keywords are used:

Router# show ip ospf database
OSPF Router with id(190.20.239.66) (Process ID 300)
                                  Displaying Router Link States(Area 0.0.0.0)
  Link ID       ADV Router           Age        Seq#         Checksum  Link count
155.187.21.6   155.187.21.6    1731    0x80002CFB    0x69BC       8
155.187.21.5   155.187.21.5    1112    0x800009D2    0xA2B8       5
155.187.1.2    155.187.1.2     1662    0x80000A98    0x4CB6       9
155.187.1.1    155.187.1.1     1115    0x800009B6    0x5F2C       1
155.187.1.5    155.187.1.5     1691    0x80002BC     0x2A1A       5
155.187.65.6   155.187.65.6    1395    0x80001947    0xEEE1       4
155.187.241.5  155.187.241.5   1161    0x8000007C    0x7C70       1
155.187.27.6   155.187.27.6    1723    0x80000548    0x8641       4
155.187.70.6   155.187.70.6    1485    0x80000B97    0xEB84       6
                Displaying Net Link States(Area 0.0.0.0)
  Link ID       ADV Router      Age        Seq#        Checksum
155.187.1.3  192.20.239.66     1245    0x800000EC      0x82E
                Displaying Summary Net Link States(Area 0.0.0.0)
  Link ID       ADV Router       Age        Seq#        Checksum
155.187.240.0   155.187.241.5    1152      0x80000077      0x7A05
155.187.241.0   155.187.241.5    1152      0x80000070      0xAEB7
155.187.244.0   155.187.241.5    1152      0x80000071      0x95CB

Table 25 describes significant fields shown in the display.


Table 25: Show IP OSPF Database Field Descriptions
Field Description

Link ID

Router ID number.

ADV Router

Advertising router's ID.

Age

Link state age.

Seq#

Link state sequence number (detects old or duplicate link state advertisements).

Checksum

Fletcher checksum of the complete contents of the link state advertisement.

Link count

Number of interfaces detected for router.

Sample Display Using Show IP OSPF Database ASBR-Summary

The following is sample output from the show ip ospf database asbr-summary command when no optional arguments are specified:

Router# show ip ospf database asbr-summary
OSPF Router with id(190.20.239.66) (Process ID 300)
                Displaying Summary ASB Link States(Area 0.0.0.0)
	LS age: 1463
	Options: (No TOS-capability)
	LS Type: Summary Links(AS Boundary Router)
	Link State ID: 155.187.245.1 (AS Boundary Router address)
	Advertising Router: 155.187.241.5
	LS Seq Number: 80000072
	Checksum: 0x3548
	Length: 28
	Network Mask: 0.0.0.0 TOS: 0  Metric: 1

Table 26 describes significant fields shown in the display.


Table 26: Show IP OSPF Database ASBR-Summary Field Descriptions
Field Description

OSPF Router with id

Router ID number.

Process ID

OSPF process ID.

LS age

Link state age.

Options

Type of service options (Type 0 only).

LS Type

Link state type.

Link State ID

Link state ID (autonomous system boundary router).

Advertising Router

Advertising router's ID.

LS Seq Number

Link state sequence (detects old or duplicate link state advertisements).

Checksum

LS checksum (Fletcher checksum of the complete contents of the link state advertisement).

Length

Length in bytes of the link state advertisement.

Network Mask

Network mask implemented.

TOS

Type of service.

Metric

Link state metric.

Sample Display Using Show IP OSPF Database External

The following is sample output from the show ip ospf database external command when no optional arguments are specified:

Router# show ip ospf database external
OSPF Router with id(190.20.239.66) (Autonomous system 300)
                                      Displaying AS External Link States
LS age: 280
Options: (No TOS-capability)
LS Type: AS External Link
Link State ID: 143.105.0.0 (External Network Number)
Advertising Router: 155.187.70.6
LS Seq Number: 80000AFD
Checksum: 0xC3A
Length: 36
Network Mask: 255.255.0.0
          		Metric Type: 2 (Larger than any link state path)
          		TOS: 0
          		Metric: 1
          		Forward Address: 0.0.0.0
          		External Route Tag: 0

Table 27 describes significant fields shown in the display.


Table 27: Show IP OSPF Database External Field Descriptions
Field Description

OSPF Router with id

Router ID number.

Autonomous system

OSPF autonomous system number (OSPF process ID).

LS age

Link state age.

Options

Type of service options (Type 0 only).

LS Type

Link state type.

Link State ID

Link state ID (External Network Number).

Advertising Router

Advertising router's ID.

LS Seq Number

Link state sequence number (detects old or duplicate link state advertisements).

Checksum

LS checksum (Fletcher checksum of the complete contents of the link state advertisement).

Length

Length in bytes of the link state advertisement.

Network Mask

Network mask implemented.

   Metric Type

External Type.

   TOS

Type of service.

   Metric

Link state metric.

   Forward Address

Forwarding address. Data traffic for the advertised destination will be forwarded to this address. If the forwarding address is set to 0.0.0.0, data traffic will be forwarded instead to the advertisement's originator.

   External Route Tag

External route tag, a 32-bit field attached to each external route. This is not used by the OSPF protocol itself.

Sample Display Using Show IP OSPF Database Network

The following is sample output from the show ip ospf database network command when no optional arguments are specified:

Router# show ip ospf database network
 OSPF Router with id(190.20.239.66) (Process ID 300)
                Displaying Net Link States(Area 0.0.0.0)
LS age: 1367
Options: (No TOS-capability)
LS Type: Network Links
Link State ID: 155.187.1.3 (address of Designated Router)
Advertising Router: 190.20.239.66
LS Seq Number: 800000E7
Checksum: 0x1229
Length: 52
Network Mask: 255.255.255.0
        Attached Router: 190.20.239.66
        Attached Router: 155.187.241.5
        Attached Router: 155.187.1.1
        Attached Router: 155.187.54.5
        Attached Router: 155.187.1.5

Table 28 describes significant fields shown in the display.


Table 28: Show IP OSPF Database Network Field Descriptions
Field Description

OSPF Router with id

Router ID number.

Process ID 300

OSPF process ID.

LS age

Link state age.

Options

Type of service options (Type 0 only).

LS Type:

Link state type.

Link State ID

Link state ID of designated router.

Advertising Router

Advertising router's ID.

LS Seq Number

Link state sequence (detects old or duplicate link state advertisements).

Checksum

LS checksum (Fletcher checksum of the complete contents of the link state advertisement).

Length

Length in bytes of the link state advertisement.

Network Mask

Network mask implemented.

AS Boundary Router

Definition of router type.

Attached Router

List of routers attached to the network, by IP address.

Sample Display Using Show IP OSPF Database Router

The following is sample output from the show ip ospf database router command when no optional arguments are specified:

Router# show ip ospf database router
OSPF Router with id(190.20.239.66) (Process ID 300)
                Displaying Router Link States(Area 0.0.0.0)
LS age: 1176
Options: (No TOS-capability)
LS Type: Router Links
Link State ID: 155.187.21.6
Advertising Router: 155.187.21.6
LS Seq Number: 80002CF6
Checksum: 0x73B7
Length: 120
AS Boundary Router
155   Number of Links: 8
Link connected to: another Router (point-to-point)
(link ID) Neighboring Router ID: 155.187.21.5
(Link Data) Router Interface address: 155.187.21.6
Number of TOS metrics: 0
TOS 0 Metrics: 2

Table 29 describes significant fields shown in the display.


Table 29: Show IP OSPF Database Router Field Descriptions
Field Description

OSPF Router with id

Router ID number.

Process ID

OSPF process ID.

LS age

Link state age.

Options

Type of service options (Type 0 only).

LS Type

Link state type.

Link State ID

Link state ID.

Advertising Router

Advertising router's ID.

LS Seq Number

Link state sequence (detects old or duplicate link state advertisements).

Checksum

LS checksum (Fletcher checksum of the complete contents of the link state advertisement).

Length

Length in bytes of the link state advertisement.

AS Boundary Router

Definition of router type.

Number of Links

Number of active links.

link ID

Link type.

Link Data

Router interface address.

TOS

Type of service metric (Type 0 only).

Sample Display Using Show IP OSPF Database Summary

The following is sample output from show ip ospf database summary command when no optional arguments are specified:

Router# show ip ospf database summary
       OSPF Router with id(190.20.239.66) (Process ID 300)
                Displaying Summary Net Link States(Area 0.0.0.0)
LS age: 1401
Options: (No TOS-capability)
LS Type: Summary Links(Network)
Link State ID: 155.187.240.0 (summary Network Number)
Advertising Router: 155.187.241.5
LS Seq Number: 80000072
Checksum: 0x84FF
Length: 28
Network Mask: 255.255.255.0   TOS: 0  Metric: 1

Table 30 describes significant fields shown in the display.


Table 30: Show IP OSPF Database Summary Field Descriptions
Field Description

OSPF Router with id

Router ID number.

Process ID

OSPF process ID.

LS age

Link state age.

Options

Type of service options (Type 0 only).

LS Type

Link state type.

Link State ID

Link state ID (summary network number).

Advertising Router

Advertising router's ID.

LS Seq Number

Link state sequence (detects old or duplicate link state advertisements).

Checksum

LS checksum (Fletcher checksum of the complete contents of the link state advertisement).

Length

Length in bytes of the link state advertisement.

Network Mask

Network mask implemented.

TOS

Type of service.

Metric

Link state metric.

Sample Display Using Show IP OSPF Database Database-Summary

The following is sample output from show ip ospf database database-summary command when no optional arguments are specified:

Router# show ip ospf database database-summary
                    OSPF Router with ID (172.19.65.21) (Process ID 1)
Area ID          Router        Network        Sum-Net        Sum-ASBR        Subtotal        Delete        Maxage
202                  1                  0                    0                    0                      1                      0                  0
AS External                                                                                          0                      0                  0
Total              1                  0                    0                    0                      1

Table 31 describes significant fields shown in the display.


Table 31: Show IP OSPF Database Database-Summary Field Descriptions
Field Description

Area ID

Area number.

Router

Number of router link state advertisements in that area.

Network

Number of network link state advertisements in that area.

Sum-Net

Number of summary link state advertisements in that area.

Sum-ASBR

Number of summary autonomous system boundary router (ASBR) link state advertisements in that area.

Subtotal

Sum of Router, Network, Sum-Net, and Sum-ASBR for that area.

Delete

Number of link state advertisements that are marked "Deleted" in that area.

Maxage

Number of link state advertisements that are marked "Maxaged" in that area.

AS External

Number of external link state advertisements.

show ip ospf interface

To display OSPF-related interface information, use the show ip ospf interface EXEC command.

show ip ospf interface [type number]

Syntax Description

type

(Optional) Interface type.

number

(Optional) Interface number.

Command Mode

EXEC

Usage Guidelines

This command first appeared in Cisco IOS Release 10.0.

Sample Display

The following is sample output of the show ip ospf interface command when Ethernet 0 is specified:

Router# show ip ospf interface ethernet 0
Ethernet 0 is up, line protocol is up
Internet Address 131.119.254.202, Mask 255.255.255.0, Area 0.0.0.0
AS 201, Router ID 192.77.99.1, Network Type BROADCAST, Cost: 10
Transmit Delay is 1 sec, State OTHER, Priority 1
Designated Router id 131.119.254.10, Interface address 131.119.254.10
Backup Designated router id 131.119.254.28, Interface addr 131.119.254.28
Timer intervals configured, Hello 10, Dead 60, Wait 40, Retransmit 5
Hello due in 0:00:05
Neighbor Count is 8, Adjacent neighbor count is 2
    Adjacent with neighbor 131.119.254.28  (Backup Designated Router)
    Adjacent with neighbor 131.119.254.10  (Designated Router)

Table 32 describes significant fields shown in the display.


Table 32: Show IP OSPF Interface Ethernet 0 Field Descriptions
Field Description

Ethernet

Status of physical link and operational status of protocol.

Internet Address

Interface IP address, subnet mask, and area address.

AS

Autonomous system number (OSPF process ID), router ID, network type, link state cost.

Transmit Delay

Transmit delay, interface state, and router priority.

Designated Router

Designated router ID and respective interface IP address.

Backup Designated router

Backup designated router ID and respective interface IP address.

Timer intervals configured

Configuration of timer intervals.

Hello

Number of seconds until next hello packet is sent out this interface.

Neighbor Count

Count of network neighbors and list of adjacent neighbors.

show ip ospf neighbor

To display OSPF-neighbor information on a per-interface basis, use the show ip ospf neighbor EXEC command.

show ip ospf neighbor [type number] [neighbor-id] [detail]

Syntax Description

type

(Optional) Interface type.

number

(Optional) Interface number.

neighbor-id

(Optional) Neighbor ID.

detail

(Optional) Displays all neighbors given in detail (list all neighbors).

Command Mode

EXEC

Usage Guidelines

This command first appeared in Cisco IOS Release 10.0.

Sample Displays

The following is sample output from the show ip ospf neighbor command showing a single line of summary information for each neighbor:

Router# show ip ospf neighbor
   ID          Pri   State        Dead Time     Address         Interface
199.199.199.137 1    FULL/DR       0:00:31    160.89.80.37      Ethernet0
192.31.48.1     1    FULL/DROTHER  0:00:33    192.31.48.1       Fddi0
192.31.48.200   1    FULL/DROTHER  0:00:33    192.31.48.200     Fddi0
199.199.199.137 5    FULL/DR       0:00:33    192.31.48.189     Fddi0

The following is sample output showing summary information about the neighbor that matches the neighbor ID:

Router# show ip ospf neighbor 199.199.199.137
 
Neighbor 199.199.199.137, interface address 160.89.80.37
    In the area 0.0.0.0 via interface Ethernet0
    Neighbor priority is 1, State is FULL
    Options 2
    Dead timer due in 0:00:32
    Link State retransmission due in 0:00:04
 Neighbor 199.199.199.137, interface address 192.31.48.189
    In the area 0.0.0.0 via interface Fddi0
    Neighbor priority is 5, State is FULL
    Options 2
    Dead timer due in 0:00:32
    Link State retransmission due in 0:00:03

If you specify the interface along with the Neighbor ID, the Cisco IOS software displays the neighbors that match the neighbor ID on the interface, as in the following sample display:

Router# show ip ospf neighbor ethernet 0 199.199.199.137
 
Neighbor 199.199.199.137, interface address 160.89.80.37
    In the area 0.0.0.0 via interface Ethernet0
    Neighbor priority is 1, State is FULL
    Options 2
    Dead timer due in 0:00:37
    Link State retransmission due in 0:00:04

You can also specify the interface without the neighbor ID to show all neighbors on the specified interface, as in the following sample display:

Router# show ip ospf neighbor fddi 0
   ID          Pri   State        Dead Time     Address         Interface
192.31.48.1     1    FULL/DROTHER  0:00:33    192.31.48.1       Fddi0
192.31.48.200   1    FULL/DROTHER  0:00:32    192.31.48.200     Fddi0
199.199.199.137 5    FULL/DR       0:00:32    192.31.48.189     Fddi0

The following is sample output from the show ip ospf neighbor detail command:

Router# show ip ospf neighbor detail
 
Neighbor 160.89.96.54, interface address 160.89.96.54
    In the area 0.0.0.3 via interface Ethernet0
    Neighbor priority is 1, State is FULL
    Options 2
    Dead timer due in 0:00:38
 Neighbor 160.89.103.52, interface address 160.89.103.52
    In the area 0.0.0.0 via interface Serial0
    Neighbor priority is 1, State is FULL
    Options 2
    Dead timer due in 0:00:31

Table 33 describes the fields shown in the displays.


Table 33: Show IP OSPF Neighbor Field Descriptions
Field Description

Neighbor

Neighbor router ID.

interface address

IP address of the interface.

In the area

Area and interface through which OSPF neighbor is known.

Neighbor priority

Router priority of neighbor, neighbor state.

State

OSPF state.

Options

Hello packet options field contents (E-bit only; possible values are 0 and 2; 2 indicates area is not a stub; 0 indicates area is a stub.

Dead timer

Expected time before Cisco IOS software will declare neighbor dead.

show ip ospf virtual-links

To display parameters about and the current state of OSPF virtual links, use the show ip ospf virtual-links EXEC command.

show ip ospf virtual-links

Syntax Description

This command has no arguments or keywords.

Command Mode

EXEC

Usage Guidelines

This command first appeared in Cisco IOS Release 10.0.

The information displayed by the show ip ospf virtual-links command is useful in debugging OSPF routing operations.

Sample Display

The following is sample output from the show ip ospf virtual-links command:

Router# show ip ospf virtual-links
Virtual Link to router 160.89.101.2 is up
Transit area 0.0.0.1, via interface Ethernet0, Cost of using 10
Transmit Delay is 1 sec, State POINT_TO_POINT
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
Hello due in 0:00:08
Adjacency State FULL

Table 34 describes significant fields shown in the display.


Table 34: Show IP OSPF Virtual-Links Field Descriptions
Field Description

Virtual Link to router 160.89.101.2 is up

Specifies the OSPF neighbor, and if the link to that neighbor is up or down.

Transit area 0.0.0.1

The transit area through which the virtual link is formed.

via interface Ethernet0

The interface through which the virtual link is formed.

Cost of using 10

The cost of reaching the OSPF neighbor through the virtual link.

Transmit Delay is 1 sec

The transmit delay on the virtual link.

State POINT_TO_POINT

The state of the OSPF neighbor.

Timer intervals...

The various timer intervals configured for the link.

Hello due in 0:00:08

When the next hello is expected from the neighbor.

Adjacency State FULL

The adjacency state between the neighbors.

summary-address

Use the summary-address router configuration command to create aggregate addresses for OSPF. The no summary-address command restores the default.

summary-address address mask {level-1 | level-1-2 | level-2} prefix mask [not-advertise]
[tag
tag]
no summary-address address mask {level-1 | level-1-2 | level-2}

Syntax Description

address

Summary address designated for a range of addresses.

mask

IP subnet mask used for the summary route.

level-1

Only routes redistributed into Level 1 are summarized with the configured address/mask value. This keyword applies to IS-IS only.

level-1-2

The summary router is injected into both a Level 1 area and a Level 2 subdomain. This keyword applies to IS-IS only.

level-2

Routes learned by Level 1 routing will be summarized into the Level 2 backbone with the configured address/mask value. This keyword applies to IS-IS only.

prefix

IP route prefix for the destination.

mask

IP subnet mask used for the summary route.

not-advertise

(Optional) Used to suppress routes that match the prefix/mask pair. This keyword applies to OSPF only.

tag tag

(Optional) Tag value that can be used as a "match" value for controlling redistribution via route maps. This keyword applies to OSPF only.

Default

Disabled

Command Mode

Router configuration

Usage Guidelines

This command first appeared in Cisco IOS Release 10.0.

Multiple groups of addresses can be summarized for a given level. Routes learned from other routing protocols can also be summarized. The metric used to advertise the summary is the smallest metric of all the more specific routes. This command helps reduce the size of the routing table.

Using this command for OSPF causes an OSPF autonomous system boundary router (ASBR) to advertise one external route as an aggregate for all redistributed routes that are covered by the address. For OSPF, this command summarizes only routes from other routing protocols that are being redistributed into OSPF. Use the area range command for route summarization between OSPF areas.

Example

In the following example, summary address 10.1.0.0 includes address 10.1.1.0, 10.1.2.0, 10.1.3.0, and so forth. Only the address 10.1.0.0 is advertised in an external link state advertisement.

summary-address 10.1.0.0 255.255.0.0

Related Commands

You can use the master indexes or search online to find documentation of related commands.

area range
ip ospf authentication-key
ip ospf message-digest-key

timers lsa-group-pacing

To change the interval at which OSPF LSAs are collected into a group and refreshed, checksummed, or aged, use the timers lsa-group-pacing router configuration command. To restore the default value, use the no form of this command.

timers lsa-group-pacing seconds
no timers lsa-group-pacing

Syntax Description

seconds

Number of seconds in the interval at which LSAs are grouped and refreshed, checksummed, or aged. The range is 10 seconds to 1800  seconds. The default value is 240 seconds.

Default

240 seconds

Command Mode

Router configuration

Usage Guidelines

This command first appeared in Cisco IOS Release 11.3 AA.

OSPF LSA group pacing is enabled by default. For typical customers, the default group pacing interval for refreshing, checksumming, and aging is appropriate and you need not configure this feature.

The duration of the LSA group pacing is inversely proportional to the number of LSAs the router is handling. For example, if you have approximately 10,000 LSAs, decreasing the pacing interval would benefit you. If you have a very small database (40 to 100 LSAs), increasing the pacing interval to 10 to 20 minutes might benefit you slightly.

Example

The following example changes the OSPF pacing between LSA groups to 60 seconds:

router ospf
 timers lsa-group-pacing 60

timers spf

To configure the delay time between when OSPF receives a topology change and when it starts a shortest path first (SPF) calculation, and the hold time between two consecutive SPF calculations, use the timers spf router configuration command. To return to the default timer values, use the no form of this command.

timers spf spf-delay spf-holdtime
no timers spf
spf-delay spf-holdtime

Syntax Description

spf-delay

Delay time, in seconds, between when OSPF receives a topology change and when it starts a SPF. calculation. It can be an integer from 0 to 65535. The default time is 5 seconds. A value of 0 means that there is no delay; that is, the SPF calculation is started immediately.

spf-holdtime

Minimum time, in seconds, between two consecutive SPF calculations. It can be an integer from 0 to 65535. The default time is 10 seconds. A value of 0 means that there is no delay; that is, two consecutive SPF calculations can be done one immediately after the other.

Defaults

spf-delay: 5 seconds
spf-holdtime: 10 seconds

Command Mode

Router configuration

Usage Guidelines

This command first appeared in Cisco IOS Release 10.3.

Setting the delay and hold time low causes routing to switch to the alternate path more quickly in the event of a failure. However, it consumes more CPU processing time.

Example

The following example changes the delay to 10 seconds and the hold time to 20 seconds:

timers spf 10 20


hometocprevnextglossaryfeedbacksearchhelp
Copyright 1989-1998 © Cisco Systems Inc.