Полезная информация

cc/td/doc/product/software/ios120/12cgcr/dial_r
hometocprevnextglossaryfeedbacksearchhelp
PDF

Table of Contents

Easy IP Commands

Easy IP Commands

This chapter describes the commands used for configuring Easy IP (Phase 1). For configuration tasks and examples, refer to the chapter "Configuring Easy IP" in the Dial Solutions Configuration Guide.

ip address negotiated

To specify that the IP address for a particular interface is obtained via PPP/IPCP address negotiation, use the ip address negotiated interface configuration command. Use the no form of this command to disable this feature.

ip address negotiated
no ip address negotiated

Syntax Description

This command has no arguments or keywords.

Command Mode

Interface configuration

Usage Guidelines

This command first appeared in Cisco IOS Release 11.3.

Use the ip address negotiated interface command to enable a Cisco router to automatically negotiate its own registered WAN interface Internet Protocol (IP) address from a central server (via PPP/IPCP) and to enable all remote hosts to access the global Internet using this single registered IP address.

Example

The following example configures an asynchronous interface (interface async1) to obtain its IP address via PPP/IPCP address negotiation:

interface async1
  ip address negotiated
  encapsulation ppp

Related Commands

You can use the master indexes or search online to find documentation of related commands.

encapsulation ppp
ip address
ip unnumbered

ip nat inside source

To enable Network Address Translation (NAT) of the inside source address, use the ip nat inside source global configuration command. To remove the static translation or remove the dynamic association to a pool, use the no form of this command.

ip nat inside source {list {access-list-number | name} {pool name | interface dialer-name}
[overload] | static local-ip global-ip}
no ip nat inside source {list {access-list-number | name} {pool name | interface dialer-name}
[overload] | static local-ip global-ip}

Syntax Description

list access-list-number

Standard IP access list number. Packets with source addresses that pass the access list are dynamically translated using global addresses from the named pool.

list name

Name of a standard IP access list. Packets with source addresses that pass the access list are dynamically translated using global addresses from the named pool.

pool name

Name of the pool from which global IP addresses are allocated dynamically.

interface dialer-name

Name of the dialer interface on which the PPP/IPCP address negotiation takes place.

overload

(Optional) Enables the router to use one global address for many local addresses. When overloading is configured, each inside host's TCP or UDP port number distinguishes between the multiple conversations using the same local IP address.

static local-ip

Sets up a single static translation. This argument establishes the local IP address assigned to a host on the inside network. The address could be randomly chosen, allocated from RFC 1918, or obsolete.

global-ip

Sets up a single static translation. This argument establishes the globally unique IP address of an inside host as it appears to the outside world.


Note Simple translations, either static or dynamic, are not supported in non-Plus Cisco IOS software images. In order to enable dynamic or static simple translation along with Easy IP (Phase  1), you need to obtain the full NAT Plus Cisco IOS software image.

Default

No NAT translation of inside source addresses occurs.

Command Mode

Global configuration

Usage Guidelines

This command first appeared in Cisco IOS Release 11.2 F.

This command has two forms: dynamic and static address translation. The form with an access list establishes dynamic translation. Packets from addresses that match the standard access list are translated using global addresses allocated from the pool named with the ip nat pool command.

Alternatively, the syntax form with the keyword static establishes a single static translation.

Example

The following example translates between inside hosts addressed from either the 192.168.1.0 or 192.168.2.0 networks to the globally unique 171.69.233.208/28 network:

ip nat pool net-208 171.69.233.208 171.69.233.223 prefix-length 28
ip nat inside source list 1 pool net-208
!
interface ethernet 0
  ip address 171.69.232.182 255.255.255.240
  ip nat outside
!
interface ethernet 1
  ip address 192.168.1.94 255.255.255.0
  ip nat inside
!
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 1 permit 192.168.2.0 0.0.0.255

Related Commands

You can use the master indexes or search online to find documentation of related commands.

clear ip nat translation
ip nat
ip nat inside destination
ip nat outside source
ip nat pool
ip nat translation
show ip nat statistics
show ip nat translations


hometocprevnextglossaryfeedbacksearchhelp
Copyright 1989-1998 © Cisco Systems Inc.