Полезная информация

cc/td/doc/product/software/ios120/12cgcr
hometocprevnextglossaryfeedbacksearchhelp
PDF

Table of Contents

Configuring Synchronous Serial Ports

Configuring Synchronous Serial Ports

Synchronous serial ports can be used for leased-line or dial-up communications. In addition, high-speed lines (E1 or T1) can be configured to support multiple serial interfaces that can themselves be configured as if they were attached to dial-up lines. Finally, dialers can be configured on synchronous serial lines to support dial-on-demand routing.

This chapter presents configuration tasks required to make a serial interface operational. To configure routing and dial capabilities, additional configuration is required. For information about dial-up uses of the serial interfaces, refer to the "Configuring Channelized E1 and Channelized T1" chapter and to the chapters in the "Dial-on-Demand Routing" part of this manual. For protocol-specific routing configuration tasks, see the relevant routing protocol chapters in other volumes of the Cisco IOS software configuration guides.

Synchronous serial ports are available on many serial network interface processors and cards. Refer to the Cisco Product Catalog for information about available router and interface options.

For a complete description of the synchronous interface commands in this chapter, refer to the "Synchronous Serial Port Setup Commands" chapter of the Dial Solutions Command Reference. To locate documentation of other commands that appear in this chapter, use the command reference master index or search online.


Note In Cisco IOS Release 11.3, all commands supported on the Cisco 7500 series are also supported on the Cisco 7000 series.

Synchronous Serial Interface Task List

Perform the tasks in the following sections to configure a synchronous serial interface. The first task is required; the remaining tasks are optional.

For examples of synchronous serial interface configuration, see the "Synchronous Serial Interface Configuration Examples" section at the end of this chapter.

Specify a Synchronous Serial Interface

To specify a synchronous serial interface and enter interface configuration mode, use one of the following commands in global configuration mode:
Command Purpose

interface serial number

interface serial slot/port
(Cisco 7500 series or Cisco  7200 series)

interface serial slot/port-adapter/port (Cisco 7200 series)

interface serial slot/port:channel-group
(channelized T1 or E1 interface on the Cisco  7500 series)

interface serial number:channel-group
(channelized T1 or E1 interface on the Cisco  4000 series)

Specify an interface and enter interface configuration mode.

Specify Synchronous Serial Encapsulation

Encapsulation methods are set according to the type of protocol or application you configure in the Cisco IOS software.

By default, synchronous serial lines use the High-Level Data Link Control (HDLC) serial encapsulation method, which provides the synchronous framing and error detection functions of HDLC without windowing or retransmission. Synchronous serial interfaces support the following serial encapsulation methods for dial solutions:

In addition, synchronous serial interfaces support the following encapsulation methods that are discussed in other books in the Cisco IOS software documentation set:

These encapsulation methods are defined in their respective books and chapters describing the protocols or applications. Serial encapsulation methods are also discussed in the Configuration Fundamentals Command Reference in the chapter "Interface Commands" under the encapsulation command.

You can define the encapsulation method for dial solutions by using the following command in interface configuration mode:
Command Purpose

encapsulation {hdlc | ppp}

Configure synchronous serial encapsulation for dial solutions.

The default is HDLC encapsulation.

Configure PPP

To configure PPP (including PPP compression), see the "Configuring Media-Independent PPP" chapter of this manual.

Configure Compression of HDLC Data

You can configure point-to-point software compression on serial interfaces that use HDLC encapsulation. Compression reduces the size of a HDLC frame via lossless data compression. The compression algorithm used is a Stacker (LZS) algorithm.

Compression is performed in software and might significantly affect system performance. We recommend that you disable compression if CPU load exceeds 65 percent. To display the CPU load, use the show process cpu EXEC command.

If the majority of your traffic is already compressed files, you should not use compression.

To configure compression over HDLC, use the following command in interface configuration mode:
Step Command Purpose

1 . 

encapsulation hdlc

Enable encapsulation of a single protocol on the serial line.

2 . 

compress stac

Enable compression.

Configure the CRC

The cyclic redundancy check (CRC) on a serial interface defaults to a length of 16 bits. To change the length of the CRC to 32 bits on an FSIP or HIP of the Cisco 7000 series with RSP7000 only, use the following command in interface configuration mode:
Command Purpose

crc size

Set the length of the CRC.

Use the Line-Coding Format

All FSIP interface types on the Cisco 7000 series with RSP7000 support nonreturn-to-zero (NRZ) and nonreturn-to-zero inverted (NRZI) format. This is a line-coding format that is required for serial connections in some environments. NRZ encoding is most common. NRZI encoding is used primarily with EIA/TIA-232 connections in IBM environments.

The default configuration for all serial interfaces is NRZ format. The default is no nrzi-encoding. To enable NRZI format, use the following command in interface configuration mode:
Command Purpose

nrzi-encoding

Enable NRZI encoding format.

Enable the Internal Clock

When a DTE does not return a transmit clock, use the following interface configuration command on the Cisco 7000 series with RSP7000 to enable the internally generated clock on a serial interface:
Command Purpose

transmit-clock-internal

Enable the internally generated clock on a serial interface.

Invert the Transmit Clock Signal

Delays between the SCTE clock and data transmission indicate that the transmit clock signal might not be appropriate for the interface rate and length of cable being used. Different ends of the wire may have variances that differ slightly. Invert the clock signal to compensate for these factors by completing the following task in interface configuration mode on a Cisco 7000 series with RSP7000, Cisco  7200 series, and Cisco 7500 series router:
Command Purpose

invert-transmit-clock

Invert the clock signal on an interface.

Set Transmit Delay

It is possible to send back-to-back data packets over serial interfaces faster than some hosts can receive them. You can specify a minimum dead time after transmitting a packet to alleviate this condition. This setting is available for serial interfaces on the MCI and SCI interface cards and for the HSSI or MIP. Use one of the following interface configuration commands, as appropriate, for your system:
Command Purpose

transmitter-delay microseconds

Set the transmit delay on the MCI and SCI synchronous serial interfaces.

transmitter-delay hdlc-flags

Set the transmit delay on the HSSI or MIP.

Configure DTR Signal Pulsing

You can configure pulsing DTR signals on all serial interfaces. When the serial line protocol goes down (for example, because of loss of synchronization) the interface hardware is reset and the DTR signal is held inactive for at least the specified interval. This function is useful for handling encrypting or other similar devices that use the toggling of the DTR signal to resynchronize. To configure DTR signal pulsing, use the following command in interface configuration mode:
Command Purpose

pulse-time seconds

Configure DTR signal pulsing.

Ignore DCD and Monitor DSR as Line Up/Down Indicator

This task applies to Quad Serial NIM interfaces on the Cisco 4000 series and Hitachi-based serial interfaces on the Cisco  2500 series and Cisco 3000 series.

By default, when the serial interface is operating in DTE mode, it monitors the Data Carrier Detect (DCD) signal as the line up/down indicator. By default, the attached DCE device sends the DCD signal. When the DTE interface detects the DCD signal, it changes the state of the interface to up.

In some configurations, such as an SDLC multidrop environment, the DCE device sends the Data Set Ready (DSR) signal instead of the DCD signal, which prevents the interface from coming up. To tell the interface to monitor the DSR signal instead of the DCD signal as the line up/down indicator, use the following command in interface configuration mode:
Command Purpose

ignore-dcd

Configure the serial interface to monitor the DSR signal as the line up/down indicator.

Configure the Clock Rate for an DCE Mode Interface

You can configure the clock rate for the connector hardware of the serial interface to an acceptable bit rate. To do so, use the following command in interface configuration mode:
Command Purpose

clock rate bps

Configure the clock rate on serial interfaces.

Specify the Timing Signal Configuration

On Cisco 4000 series routers, you can specify the serial NPM timing signal configuration. When the board is operating as a DCE and the DTE provides terminal timing (SCTE or TT), you can configure the DCE to use SCTE from the DTE. When running the line at high speeds and long distances, this strategy prevents phase shifting of the data with respect to the clock.

To configure the DCE to use SCTE from the DTE, use the following command in interface configuration mode:
Command Purpose

dce-terminal-timing enable

Configure the DCE to use SCTE from the DTE.

When the board is operating as a DTE, you can invert the TXC clock signal it gets from the DCE that the DTE uses to transmit data. Invert the clock signal if the DCE cannot receive SCTE from the DTE, the data is running at high speeds, and the transmission line is long. Again, this prevents phase shifting of the data with respect to the clock.

To configure the interface so that the router inverts the TXC clock signal, use the following command in interface configuration mode:
Command Purpose

dte-invert-txc

Specify timing configuration to invert TXC clock signal.

Specify G.703 Interface Options

This section describes the optional tasks for configuring a G.703 serial interface:

Interfaces that meet the G.703 electrical and mechanical specifications operate at E1 data rates (2.048 Mbps).

Enable Framed Mode

G.703 interfaces have two modes of operation: framed and unframed. By default, serial interfaces on a G.703 port adapter are configured for unframed mode. To enable framed mode, use the following command in interface configuration mode:
Command Purpose

timeslot start-slot - stop-slot

Enable framed mode.

To restore the default, use the no form of this command or set the starting time slot to 0.

Enable CRC4 Generation

By default, the G.703 CRC4 is not generated. To enable generation of the G.703 CRC4, which is useful for checking data integrity while operating in framed mode, use the following command in interface configuration mode:
Command Purpose

crc4

Enable CRC4 generation.

Use Time Slot 16 for Data

By default, time slot 16 is used for signaling. It can also be used for data. To control the use of time slot 16 for data, use the following command in interface configuration mode:
Command Purpose

ts16

Specify that time slot 16 is used for data.

Specify a Clock

A G.703 interface can clock its transmitted data from either its internal clock or from a clock recovered from the line's receive data stream. By default, the clock source is the line's receive data stream. To control which clock is used, use the following command in interface configuration mode:
Command Purpose

clock source {line | internal}

Specify the clock used for transmitted data.

Synchronous Serial Interface Configuration Examples

This section contains the following examples:

For more information about synchronous serial interfaces configured on channelized E1/T1 and used for dialing, see the "Configuring Channelized E1 and Channelized T1" chapter of this manual.

Beginning the Interface Configuration Examples

The following example illustrates how to begin interface configuration on a serial interface. It assigns Point-to-Point (PPP) encapsulation to serial interface 0.

interface serial 0
  encapsulation ppp

The same example on a Cisco 7500 requires the following commands:

interface serial 1/0
  encapsulation ppp

Configuring a Serial Interface for DCE Mode Examples

The following example configures a serial interface for DCE mode on a Cisco 7500 series. Because the DTE does not return the Synchronous Clock Transmit Enable (SCTE) signal, the transmit-clock-internal is needed.

interface serial 0/0
 ip address 170.1.8.2 255.255.255.0
 clockrate 72000
 transmit-clock-internal
   

The following example configures a serial interface for DCE mode on a Cisco 4000 series router. Because the DTE does not return the Synchronous Clock Transmit Enable (SCTE) signal, the dce-terminal-timing-enable is needed. In this example, the default NRZ encoding and 16-bit CRC are accepted.

interface serial 1
 clockrate 72000
 dce-terminal-timing-enable
 nrz-encoding

G.703 Serial Interface Configuration Example

The following example shows a basic configuration for serial interface 9/1/3 on a E1-G.703/G.704 serial port adapter in a Cisco 7500 series router. In this example, the interface is configured for framed (G.704) operation, and timeslot 16 is used for data.

interface serial 9/1/3
 ip address 1.1.1.10 255.255.255.0
 no keepalive
 no fair-queue
 timeslot 1-31
 crc4
 ts16

JT2 6.3-MHz Serial Interface Configuration Example

The following example shows a configuration for serial interface 1/0/0 on a PA-2JT2 serial port adapter in a Cisco 7500 series router. In this example, the interface is configured to clock data using an internal clock source rather than the default line-derived clock source and to allow the frame alignment search criteria to use CRC5.

interface serial 1/0/0
 ip address 1.1.1.10 255.255.255.0
 clock source internal
 crc bits 5
 no shutdown

Signal Inversion Examples

The following example inverts data on serial interface 3/1/0:

interface serial 3/1/0
 invert data

The following example inverts the clock signal on serial interface 3/0:

interface serial 3/0
 invert txclock

The following example, specifies NRZI mark encoding for serial interface 4/0/2:

interface serial 4/0/2
 nrzi-encoding mark

Channelized E1 Controller Example

The following example configures a Cisco 7500 series router to acknowledge an E1 line. For an example of configuring circuits refer to the next section; circuits are configured in the same way, whether the line is E1 or T1.

controller e1 3/0
 channel-group 0 timeslots 1
 channel-group 8 timeslots 5-15, 20-30
 channel-group 12 timeslots 2
 channel-group 29 timeslots 31

Channelized T1 Controller and Interface Examples

The following example applies only to a Cisco 7500 series router. It configures the router to acknowledge a T1 line and its circuits. Four different circuits (and their corresponding serial interfaces) are defined for the second CxCT1 attached to the MIP in slot 4.

controller t1 4/1
 framing esf
 linecode b8zs
 channel-group 0 timeslots 1
 channel-group 8 timeslots 5,7,12-15, 20 speed 64
 channel-group 12 timeslots 2
 channel-group 23 timeslots 24

The following example configures circuit 0 for Point-to-Point (PPP) encapsulation:

interface serial 4/1:0
 ip address 131.108.13.1 255.255.255.0
 encapsulation ppp

The following example configures circuit 8 for IP routing and disables IP route cache:

interface serial 4/1:8
 ip address 131.108.1.1 255.255.255.0
 no ip route-cache

The following example configures circuit 12 for Frame Relay encapsulation and subinterface support:

interface serial 4/1:12
 encapsulation frame-relay
!
interface serial 4/1:12.1
 ip address 1.1.1.1 255.0.0.0
!
interface serial 4/1:12.2
 ip address 2.2.2.2 255.0.0.0

The following example configures circuit 23 for IP routing and enables autonomous switching:

interface serial 4/1:23
 ip address 3.3.3.3 255.0.0.0
 ip route-cache cbus

Interface Shutdown Examples

The following example shuts down a T1 circuit number 23 running on a Cisco 7500 series router:

interface serial 4/0:23
 shutdown

The following example shuts down the entire T1 line physically connected to a Cisco 7500 series router:

controller t1 4/0
 shutdown



hometocprevnextglossaryfeedbacksearchhelp
Copyright 1989-1998 © Cisco Systems Inc.