Полезная информация

cc/td/doc/product/software/ios120/12cgcr
hometocprevnextglossaryfeedbacksearchhelp
PDF

Table of Contents

Configuring Legacy DDR Spokes

Configuring Legacy DDR Spokes

This chapter describes how to configure legacy dial-on-demand routing on interfaces functioning as a spoke in a hub-and-spoke network topology. This chapter considers a spoke interface to be any interface that calls or receives calls from exactly one other router, and considers a hub interface to be an interface that calls or receives calls from more than one router: all the spokes in the network.

This chapter also describes the DDR-independent tasks required to bridge protocols or to route protocols over DDR. Most of these tasks are global in scope and can be completed before you begin to configure DDR.

For configuration tasks for the central hub interface in a hub-and-spoke network topology, see the "Configuring a Legacy DDR Hub" chapter in this manual. For a complete description of the legacy DDR spokes commands mentioned in this chapter, refer to the "Legacy DDR Spokes Commands" chapter in the Dial Solutions Command Reference. To locate documentation of other commands that appear in this chapter, use the command reference master index or search online.

For information about the Dialer Profiles implementation of DDR, see the "Configuring Peer-to-Peer DDR with Dialer Profiles" chapter in this manual.

Configuration Task Flow

Before you configure DDR, make sure you have completed the preparations for bridging or routing as described in the "Deciding and Preparing to Configure DDR" chapter of this manual. That chapter provides information about the minimal requirements. For detailed information about bridging, routing, and wide-area networking configurations, refer to the appropriate chapters in other volumes of this documentation set.

When you configure DDR on a spoke interface in a hub-and-spoke topology, you perform the following general steps:

Step 1 Specify the interface that will place calls to or receive calls from a single site. (See the "Configuring Legacy DDR Hubs" chapter for information about configuring an interface to place calls to or receive calls from multiple sites.)

Step 2 Enable DDR on the interface. This step is not required for some interfaces; for example, ISDN interfaces and passive interfaces that receive only from DTR-dialing interfaces.

Step 3 Configure the interface to receive calls only, if applicable. Receiving calls from multiple sites requires each inbound call to be authenticated.

Step 4 Configure the interface to place calls only, if applicable.

Step 5 Configure the interface to place and receive calls, if applicable.

Step 6 If the interface will place calls, specify access control for:

or

Step 7 Customize the interface settings (timers, interface priority, hold queues, bandwidth on demand, and disabling fast switching) as needed.

When you have configured the interface and it is operational, you can monitor its performance and its connections as described in the "Monitor DDR Connections" section.

You can also enhance DDR by configuring Multilink PPP and configuring PPP callback. The PPP configuration tasks are described in the "Configuring Media-Independent PPP and Multilink PPP" chapter of this manual.

See the "Legacy DDR Spoke Configuration Examples" section later in this chapter for examples of how to configure DDR on your network.

DDR Configuration Task List

To configure DDR on an interface, complete the tasks in the following sections. The first five bulleted items are required. The remaining tasks are not absolutely required, but might be necessary in your networking environment.

You can also monitor DDR connections. See the "Monitor DDR Connections" section for commands and other information.

For examples of Legacy DDR on a point-to-point connection, see the "Legacy DDR Spoke Configuration Examples" section.

Specify the Interface

The steps shown in this section assume that you have completed any preparatory steps required for the relevant interface. For example, if you intend to use an asynchronous interface, it assumes that you have completed the modem support and line configuration steps and the chat script creation steps. If you intend to use an ISDN interface, it assumes that you have the ISDN line properly provisioned and running.

You can configure any asynchronous, synchronous serial, ISDN, or dialer interface for Legacy DDR.


Note When you specify an interface, make sure to use the interface numbering scheme supported on the network interface module or other port hardware on the router. On the Cisco 7200 series, for example, you specify an interface by indicating its type, slot number, and port number.

To specify an interface to configure for DDR, use the following commands in global configuration mode:
Command Purpose

interface async number
interface serial number
interface bri number

or

interface serial slot/port:23
interface serial
slot/port:15

or

interface dialer number

Specify an interface to configure for DDR.

Specify an ISDN PRI D channel (T1).
Specify an ISDN PRI D channel (E1)

Specify a logical interface to function as a dialer rotary group leader.

Dialer interfaces are logical or virtual entities, but they use physical interfaces to place or receive calls.

Enable DDR on the Interface

This step is required for asynchronous or synchronous serial interfaces but not for ISDN interfaces. The software automatically configures ISDN interfaces to be dialer type ISDN.

This step is not required for ISDN interfaces (BRI interfaces and ISDN PRI D channels) and for purely passive interfaces that will receive calls only from interfaces that use DTR dialing.

Enabling DDR on an interface usually requires you to specify the type of dialer to be used. This step is not required for ISDN interfaces because the software automatically configures ISDN interfaces to be dialer type ISDN.

To enable DDR and specify the dialer type, use one of the following commands in global configuration mode:
Command Purpose

dialer dtr

or

dialer in-band [no-parity | odd-parity]

Enable DDR and configure the specified serial interface to use DTR dialing---for interfaces with non-V.25bis modems using EIA Data Terminal Ready (DTR) signaling.

Enable DDR and configure the specified serial interface to use in-band dialing---for asynchronous interfaces or interfaces using V.25bis modems.


Note An
interface configured with the dialer in-band command can both place and receive calls. A serial interface configured for DTR dialing can place calls only; it cannot accept them.

You can optionally specify parity if the modem on this interface uses the V.25bis command set. The 1984 version of the V.25bis specification states that characters must have odd parity. However, the default for the dialer in-band command is no parity.

For an example of configuring an interface to support DTR dialing, see the section "DTR Dialing Example" later in this chapter.

To receive calls from an interface that is using DTR dialing, an interface can be configured for in-band dialing or not configured for anything but encapsulation, depending on the desired behavior. If you expect the receiving interface to terminate a call when no traffic is received for some time, you must configure in-band dialing (along with access lists and a dummy dialer string). If the receiving interface is purely passive, no additional configuration is necessary.


Note You can configure an interface or dialer rotary group to both place and receive calls. If the interface is calling and being called by a single site, simply enable DDR and specify a dial string.

Configure the Interface to Place Calls

To configure an interface to place calls to one site only, complete the tasks in one of the following sections:

Specify the Dial String for Synchronous Serial Interfaces

If you want to call only one remote system per synchronous serial interface, use the dialer string command. Dialers pass the string you have defined to the external DCE. ISDN devices call the number specified in the string.

To specify the telephone number call on a serial interface (asynchronous or synchronous), use the following command in interface configuration mode:
Command Purpose

dialer string dial-string[:isdn-subaddress]

Specify the number to dial.

Dialers pass the string (telephone number) to the external DCE, which dials the number; ISDN devices themselves call the specified number.

Specify Chat Scripts and Dial Strings for Asynchronous Serial Interfaces

The modem chat script becomes the default chat script for an interface. This means that it becomes the default chat script for the dialer string and dialer map commands presented in this section.

To place a call to a single site on an asynchronous line for which either a modem dialing script has not been assigned or for which a system script login must be specified, use the following command in interface configuration mode:
Command Purpose

dialer map protocol next-hop-address [modem-script
modem-regexp] [system-script system-regexp] dial-string
[:isdn-subaddress]

Specify chat scripts and a dial string.

Configure the Interface to Receive Calls

If you enable DDR on an interface by using the dialer in-band command, the interface can receive calls. No additional configuration steps are required simply to receive calls. Parity is not required for receiving calls only. An interface configured with the dialer in-band command can terminate calls when the line is idle for some configurable time.

You cannot set up an ISDN interface only to receive calls from a single site, but you can set it up to receive and place calls to a single site.

To receive calls from an interface that is using DTR dialing, an interface can be configured for in-band dialing or not configured for anything but encapsulation, depending on the desired behavior. If you expect the receiving interface to terminate a call when no traffic is received for some time, you must configure in-band dialing (along with access lists and a dummy dialer string). If the receiving interface is purely passive, no additional configuration is necessary.

Authentication is not required when traffic comes from only one site. However, you can configure authentication for security. See the "Define the Traffic to Be Authenticated" section. If you want to receive calls only, do not provide a dial string in the dialer map command shown in that section.

Configure the Interface to Place and Receive Calls

If you enable DDR on an interface by using the dialer in-band command, the interface can receive calls. To enable it to place calls to one site, you must define the dialing destination.

To define the dialing destination, use the following command in interface configuration mode:
Command Purpose

dialer string dial-string[:isdn-subaddress]

Specify the number to dial one site.


Note Use the dialer map command instead of the dialer string command if you want to authenticate calls received. See the "Define the Traffic to Be Authenticated" section for more information.

When a dialer string is configured but PPP Challenge Handshake Authentication Protocol (CHAP) is not configured on the interface, the Cisco IOS software recognizes each incoming call as coming from the configured dialer string. That is, if your outgoing calls go to only one number and you don't authenticate incoming calls, it is assumed that all incoming calls come from that number. (If you received calls from multiple sites, you would need to authenticate the calls.)

Authentication is not required when traffic comes from only one site. However, you can configure authentication for an extra measure of security. See the "Define the Traffic to Be Authenticated" section for more information. If you want to receive and place calls, use the dialer map command.

Define the Traffic to Be Authenticated

Authentication can be done through CHAP or PAP. In addition, the interface must be configured to map a host's protocol address to the name to use for authenticating the remote host.

To enable CHAP or PAP on an interface and authenticate sites that are calling in, use the following command in interface configuration mode:
Step Command Purpose

1 . 

encapsulation ppp

Configure an interface for PPP encapsulation.

2 . 

ppp authentication chap [if-needed]
or
ppp authentication pap [if-needed]

Enable CHAP.

Enable PAP.

3 . 

dialer map protocol next-hop-address name hostname [modem-script modem-regexp] [system-script system-regexp] [dial-string[:isdn-subaddress]]

Map the protocol address to a host name.

If the dial string is not provided in , the interface will be able to receive calls from the host but will not be able to place calls to the host.

Configure Access Control for Outgoing Calls

Protocol access lists and dialer access lists are central to the operation of DDR. In general, access lists are used as the screening criteria for determining when to initiate DDR calls. All packets are tested against the dialer access list. Packets that match a permit entry are deemed interesting. Packets that do not match a permit entry or that do match a deny entry are deemed uninteresting. When a packet is found to be interesting, either the dialer idle timer is reset (if the line is active) or a connection is attempted (if the line is available but not active). If a tested packet is deemed uninteresting, it will be forwarded if it is intended for a destination known to be on a specific interface and the link is active. However, such a packet will not initiate a DDR call and will not reset the idle timer.

Configure Access Control for Bridging

You can control access by defining any transparent bridge packet as interesting, or you can use the finer granularity of controlling access by Ethernet type codes. To control access for DDR bridging, complete one of the following tasks in global configuration mode:


Note Spanning tree bridge protocol data units (BPDUs) are always treated as uninteresting.

Control Bridging Access by Ethernet Type Codes

To control access by Ethernet type codes, use the following command in global configuration mode:
Command Purpose

access-list access-list-number {permit | deny} type-code [mask]

Identify interesting packets by Ethernet type codes (access list numbers must be in the range 200-299).

To enable packets with a specified Ethernet type code to trigger outgoing calls, use the following command in interface configuration mode:
Command Purpose

dialer-list dialer-group protocol bridge list access-list-number

Define a dialer list for the specified access list.

For a table of some common Ethernet types codes, see the "Ethernet Types Codes" appendix in the Bridging and IBM Networking Command Reference.

Permit All Bridge Packets to Trigger Calls

To identify all transparent bridge packets as interesting, use the following command in interface configuration mode when you are configuring DDR:
Command Purpose

dialer-list dialer-group protocol bridge permit

Define a dialer list that treats all transparent bridge packets as interesting.

Assign the Interface to a Bridge Group

Packets are bridged only among interfaces that belong to the same bridge group. To assign an interface to a bridge group, use the following command in interface configuration mode:
Command Purpose

bridge-group bridge-group

Assign the specified interface to a bridge group.

Configure Access Control for Routing

Before you perform the tasks outlined in this section, configure access lists for the protocols you intend to route over DDR as described briefly in the "Deciding And Preparing to Configure DDR" chapter in this manual and as described in greater detail in the Network Protocols Configuration Guide, Part  1, Network Protocols Configuration Guide, Part  2, and Network Protocols Configuration Guide, Part  3.

An interface can be associated only with a single dialer access group; multiple dialer access group assignments are not allowed. To specify the dialer access group to which you want to assign an access list, use the following command in interface configuration mode:
Command Purpose

dialer-group group-number

Specify the number of the dialer access group to which the specific interface belongs.

Customize the Interface Settings

Perform the tasks in the following sections as needed to customize DDR in your network:

Configure Timers on the DDR Interface

Perform the tasks in the following sections as needed to set the timers:

Set Line-Idle Time

To specify the amount of time a line will stay idle before it is disconnected, use the following command in interface configuration mode:
Command Purpose

dialer idle-timeout seconds

Set line-idle time.

Set Idle Time for Busy Interfaces

The dialer fast idle timer is activated if there is contention for a line. Contention occurs when a line is in use, a packet for a different next hop address is received, and the busy line is required to send the competing packet.

If the line has been idle for the configured amount of time, the current call is disconnected immediately and the new call is placed. If the line has not yet been idle as long as the fast idle timeout period, the packet is dropped because there is no way to get through to the destination. (After the packet is dropped, the fast idle timer remains active and the current call is disconnected as soon as it has been idle for as long as the fast idle timeout). If, in the meantime, another packet is transmitted to the currently connected destination, and it is classified as interesting, the fast-idle timer is restarted.

To specify the amount of time a line for which there is contention will stay idle before the line is disconnected and the competing call is placed, use the following command in interface configuration mode:
Command Purpose

dialer fast-idle seconds

Set idle time for high traffic lines.

This command applies both to inbound and outbound calls.

Set Line-Down Time

To set the length of time the interface stays down before it is available to dial again after a line is disconnected or fails, use the following command in interface configuration mode:
Command Purpose

dialer enable-timeout seconds

Set the interface downtime.

This command applies both to inbound and outbound calls.

Set Carrier-Wait Time

To set the length of time an interface waits for the telephone service (carrier), use the following command in interface configuration mode:
Command Purpose

dialer wait-for-carrier-time seconds

Set the length of time the interface waits for the carrier to come up when a call is placed.

For asynchronous interfaces, this command sets the total time to wait for a call to connect. This time is set to allow for running the chat script.

Set Dialer Interface Priority

Interface priority indicates which interface in a dialer rotary group will get used first for outgoing calls. You might give one interface a higher priority if it is attached to faster, more reliable modem. In this way, the higher-priority interface will be used as often as possible.

To assign priority to an interface in a dialer rotary group, use the following command in interface configuration mode:
Command Purpose

dialer priority number

Set the interface priority in the dialer rotary group.

The range of values for number is 0 through 255. Zero is the default value and lowest priority; 255 is the highest priority. This command applies to outgoing calls only.

Configure a Dialer Hold Queue

Sometimes packets destined for a remote router are discarded because no connection exists. Establishing a connection using an analog modem can take time, during which packets are discarded. However, configuring a dialer hold queue will allow interesting outgoing packets to be queued and sent as soon as the modem connection is established.

A dialer hold queue can be configured on any type of dialer, including in-band synchronous, asynchronous, DTR, and ISDN dialers. Also, hunt group leaders can be configured with a dialer hold queue. If a hunt group leader (of a rotary dialing group) is configured with a hold queue, all members of the group will be configured with a dialer hold queue and no individual member's hold queue can be altered.

To establish a dialer hold queue, use the following command in interface configuration mode:
Command Purpose

dialer hold-queue packets

Create a dialer hold queue and specify the number of packets to be held in it.

As many as 100 packets can be held in an outgoing dialer hold queue.

Configure Bandwidth on Demand

You can configure a dialer rotary group to use additional bandwidth by placing additional calls to a single destination if the load for the interface exceeds a specified weighted value. Parallel communication links are established based on traffic load. The number of parallel links that can be established to one location is not limited.

To set the dialer load threshold for bandwidth on demand, use the following command in interface configuration mode:
Command Purpose

dialer load-threshold load

Configure the dialer rotary group to place additional calls to a single destination, as indicated by interface load.

Once multiple links are established, they are still governed by the load threshold. If the total load on all the links falls below the threshold, an idle link will be torn down.

Disable and Reenable DDR Fast Switching

Fast switching is enabled by default on all DDR interfaces. When fast switching is enabled or disabled on an ISDN D  channel, it is enabled or disabled on all B  channels. When fast switching is enabled or disabled on a dialer interface, it is enabled or disabled on all rotary group members but cannot be enabled or disabled on the serial interfaces individually.

Fast switching can be disabled and reenabled on a protocol-by-protocol basis. To disable fast switching and reenable it, use one of the following protocol-specific commands:
Command Purpose

no ip route-cache

ip route cache

no ip route-cache distributed



ip route-cache distributed

Disable IP fast switching over a DDR interface.

Reenable IP fast switching over a DDR interface.

Disable distributed IP fast switching over a DDR interface. This feature works in Cisco 7500 routers with a Versatile Interface Processor (VIP) card.

Enable distributed IP fast switching over a DDR interface. This feature works in Cisco 7500 routers with a Versatile Interface Processor (VIP) card.

no ipx route-cache

ipx route-cache

Disable IPX fast switching over a DDR interface.

Reenable IPX fast switching over a DDR interface.

Configure to Send Traffic over Frame Relay, X.25, or LAPB Networks

An interface configured for DDR can send traffic over networks that require LAPB, X.25, or Frame Relay encapsulation. To configure an interface for those networks, complete the tasks in the following sections:

Configure the Interface for Sending Traffic over a Frame Relay Network

Access to Frame Relay networks is now available through dial-up connections as well as leased lines. Dial-up connectivity allows Frame Relay networks to be extended to sites that do not generate enough traffic to justify leased lines and also allows a Frame Relay network to back up another network or point-to-point line.

DDR over Frame Relay is supported for synchronous serial and ISDN interfaces and for rotary groups, and is available for in-band, DTR, and ISDN dialers.

Frame Relay supports multiple PVC connections over the same serial interface or ISDN B  channel, but only one physical interface can be used (dialed, connected, and active) in a rotary group or with ISDN.

Configuration Restrictions

The following restrictions apply to DDR used over Frame Relay:

Frame Relay subinterfaces work the same on dial-up connections as they do on leased lines.

Configuration Overview

No new commands are required to support DDR over Frame Relay. In general, you configure Frame Relay and configure DDR. In general, complete the following steps to configure an interface for DDR over Frame Relay:

For example, enter the IP address and mask, the IPX network number, and the AppleTalk cable range and zone.
As a minimum, you must enable Frame Relay encapsulation and decide whether you need to do static or dynamic address mapping. If you decide to do dynamic mapping, you do not need to enter a command because Inverse ARP is enabled by default. If you decide to do static mapping, you must enter Frame Relay mapping commands.
You can then configure various options as needed for your Frame Relay network topology.
At a minimum, you must decide and configure the interface for outgoing calls only, incoming calls only, or both outgoing and incoming calls.
You can also configure DDR for your routed protocols (as specified in the "Preparations for Routing or Bridging over DDR" section of the "Deciding and Preparing to Configure DDR" chapter of this manual) and for snapshot routing (as specified in the "Configure Snapshot Routing" chapter of this manual). You can also customize DDR interfaces on your router or access server (as described in the "Customize the Interface Settings" section later in this chapter).

For examples of configuring various interfaces for DDR over Frame Relay, see the "Frame Relay Support Examples" section later in this chapter.

Configure the Interface for Sending Traffic over an X.25 Network

X.25 interfaces can now be configured to support DDR. Synchronous serial and ISDN interfaces on our routers and access servers can be configured for X.25 addresses, X.25 encapsulation, and mapping of protocol addresses to a remote host's X.25 address. In-band, DTR, and ISDN dialers can be configured to support X.25 encapsulation, but rotary groups cannot. On ISDN dialers configured for X.25 encapsulation, only one B channel can be used.

To configure an interface to support X.25 and DDR, use the following X.25-specific commands in interface configuration mode:
Step Command Purpose

1 . 

encapsulation x25 [dte | dce] [ietf]  

Configure the interface to use X.25 encapsulation.

2 . 

x25 address x.121-address

Assign an X.25 address to the interface.

3 . 

x25 map protocol address [protocol2 address2 [...[protocol9 address9]]] x.121-address [option]

Set up the LAN protocols-to-remote host address mapping.

The order of DDR and X.25 configuration tasks is not critical; you can configure DDR before or after X.25, and you can even mix the DDR and X.25 commands.

For an example of configuring an interface for X.25 encapsulation and then completing the DDR configuration, see the section "X.25 Support Example" later in this chapter.

Configure the Interface for Sending Traffic over a LAPB Network

Dial-on-demand routing over serial lines now supports Link Access Procedure, Balanced (LAPB) encapsulation, in addition to the previously supported PPP, HDLC, and X.25 encapsulations.

LAPB encapsulation is supported on synchronous serial, ISDN, and dialer rotary group interfaces, but not on asynchronous dialers.

Because the default encapsulation is HDLC, you must explicitly configure LAPB encapsulation. To configure an interface to support LAPB encapsulation and DDR, use the following command in interface configuration mode:
Command Purpose

encapsulation lapb [dte | dce] [multi | protocol]

Specify LAPB encapsulation.

For more information about the serial connections on which LAPB encapsulation is appropriate, see the encapsulation lapb command in the "X.25 and LAPB Commands" chapter of the Wide-Area Networking Command Reference.

For an example of configuring an interface for DDR over LAPB, see the "LAPB Support Example" section later in this chapter.

Monitor DDR Connections

To monitor DDR connections, use the following commands in privileged EXEC mode:
Command Purpose

show dialer [interface type number]

Display general diagnostics about the DDR interface.

show dialer map

Display current dialer maps, next-hop protocol addresses, user names, and the interfaces on which they are configured.

show interfaces bri 0

Display information about the ISDN interface.

show ipx interface [type number]

Display status about the IPX interface.

show ipx traffic

Display information about the IPX packets transmitted by the router or access server, including watchdog counters.

show appletalk traffic

Display information about the AppleTalk packets transmitted by the router or access server.

show vines traffic

Display information about the Banyan VINES packets transmitted by the router or access server.

show decnet traffic

Display information about the DECnet packets transmitted by the router or access server.

show xns traffic

Display information about the XNS packets transmitted by the router or access server.

clear dialer

Clear the values of the general diagnostic statistics.

Legacy DDR Spoke Configuration Examples

The examples provided in this section show various DDR configurations as follows:

Transparent Bridging over DDR Examples

The following two examples differ only in the packets that cause calls to be placed. The first example specifies by protocol (any bridge packet is permitted to cause a call to be made); the second example allows a finer granularity by specifying the Ethernet type codes of bridge packets.

The first example configures the serial 1 interface for DDR bridging. Any bridge packet is permitted to cause a call to be placed.

no ip routing
!
interface Serial1
 no ip address
 encapsulation ppp
 dialer in-band
 dialer enable-timeout 3
 dialer map bridge name urk broadcast 8985
 dialer hold-queue 10
 dialer-group 1
 ppp authentication chap
 bridge-group 1
 pulse-time 1
!
dialer-list 1 protocol bridge permit
bridge 1 protocol ieee
bridge 1 hello 10

The second example also configures the serial 1 interface for DDR bridging. However, this example includes an access-list command that specifies the Ethernet type codes that can cause calls to be placed and a dialer list protocol list command that refers to the specified access list.

no ip routing
!
interface Serial1
 no ip address
 encapsulation ppp
 dialer in-band
 dialer enable-timeout 3
 dialer map bridge name urk broadcast 8985
 dialer hold-queue 10
 dialer-group 1
 ppp authentication chap
 bridge-group 1
 pulse-time 1
!
access-list 200 permit 0x0800 0xFFF8
!
dialer-list 1 protocol bridge list 200 
bridge 1 protocol ieee
bridge 1 hello 10

Configuring DDR in an IP Environment Example

The following example illustrates how to use DDR on an synchronous interface in an IP environment. You could use the same configuration on an asynchronous serial interface by changing interface serial 1 to specify an asynchronous interface (for example, interface async 0).

interface serial 1
ip address 131.108.126.1 255.255.255.0
dialer in-band
! The next command sets the dialer idle time-out to 10 minutes
dialer idle-timeout 600
! The next command inserts the phone number
dialer string 5551234
! The next command gives the modem enough time to recognize that
! DTR has dropped so the modem disconnects the call
pulse-time 1
! The next command adds this interface to the dialer access group defined with
! the dialer-list command
dialer-group 1
!
! The first access list statement, below, specifies that IGRP updates are not
! interesting packets. The second access-list statement specifies that all
! other IP traffic such as Ping, Telnet, or any other IP packet are interesting
! packets. The dialer-list command then creates dialer access group 1 and
! states that access list 101 is to be used to classify packets as interesting
! or uninteresting. The ip route commands ! specify that there is a route to network 131.108.29.0 and to network ! 131.108.1.0 via 131.108.126.2. This means that several destination networks ! are available through a router that is dialed from interface async 1. ! access-list 101 deny igrp 0.0.0.0 255.255.255.255 255.255.255.255 0.0.0.0 access-list 101 permit ip 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255 dialer-list 1 list 101 ip route 131.108.29.0 131.108.126.2 ip route 131.108.1.0 131.108.126.2
ip local pool dialin 101.102.126.2 101.102.126.254

With many modems, the pulse-time command must be used so that DTR is dropped for sufficient time to allow the modem to disconnect.

The redistribute static command can be used to advertise static route information for DDR applications. See the redistribute static ip command, described in the "IP Routing Commands" chapter in the Network Protocols Command Reference, Part  1. Without this command, static routes to the hosts or network that the router can access with DDR will not be advertised to other routers with which the router is communicating. This behavior can block communication because some routes will not be known.

Set Up Two-Way DDR for Novell IPX Example

You can set dial-on-demand routing (DDR) for Novell IPX so that both the client and server have dial-in access to each other. This configuration is demonstrated in the following two subsections.

Remote Configuration

The following example configuration is performed on the remote side of the connection:

username local password secret
ipx routing
!
interface ethernet 0
 ipx network 40
!
interface async 
 ip unnumbered e0
 encapsulation ppp
 async mode dedicated
 async dynamic routing
 ipx network 45
 ipx watchdog-spoof
 dialer in-band
 dialer map ipx 45.0000.0cff.d016 broadcast name local 1212
 dialer-group 1
 ppp authentication chap
!
access-list 901 deny 0 FFFFFFFF 452
access-list 901 deny 0 FFFFFFFF 453
access-list 901 deny 0 FFFFFFFF 457
access-list 901 deny 0 FFFFFFFF 0 FFFFFFFF 452
access-list 901 deny 0 FFFFFFFF 0 FFFFFFFF 453
access-list 901 deny 0 FFFFFFFF 0 FFFFFFFF 457
access-list 901 permit 0
ipx route 41 45.0000.0cff.d016
ipx route 50 45.0000.0cff.d016
ipx sap 4 SERVER 50.0000.0000.0001 451 2
chat-script generic ABORT BUSY ABORT NO ## AT OK ATDT\T TIMEOUT 30 CONNECT
!
dialer-list 1 list 901
!
line 7
 modem InOut
 speed 38400
 flowcontrol hardware
 modem chat-script generic

Local Configuration

The following example configuration is performed on the local side of the connection:

username remote password secret
ipx routing
!
interface ethernet 0
 ipx network 41
!
interface async 
 ip unnumbered e0
 encapsulation ppp
 async mode dedicated
 async dynamic routing
 ipx network 45
 ipx watchdog-spoof
 dialer in-band
 dialer map ipx 45.0000.0cff.d016 broadcast name remote 8888
 dialer-group 1
 ppp authentication chap
!
access-list 901 deny 0 FFFFFFFF 452
access-list 901 deny 0 FFFFFFFF 453
access-list 901 deny 0 FFFFFFFF 457
access-list 901 deny 0 FFFFFFFF 0 FFFFFFFF 452
access-list 901 deny 0 FFFFFFFF 0 FFFFFFFF 453
access-list 901 deny 0 FFFFFFFF 0 FFFFFFFF 457
access-list 901 permit 0
ipx route 40 45.0000.0cff.d016
chat-script generic ABORT BUSY ABORT NO ## AT OK ATDT\T TIMEOUT 30 CONNECT
!
dialer-list 1 list 901
!
line 7
 modem InOut
 speed 38400
 flowcontrol hardware
 modem chat-script generic

AppleTalk Configuration Example

The following example configures DDR for AppleTalk access using an ISDN BRI. Two access lists are defined: one for IP and IGRP, and one for AppleTalk. AppleTalk packets from network 2141 only (except broadcast packets) can initiate calls.

interface BRI0
 ip address 130.1.20.107 255.255.255.0
 encapsulation ppp
 appletalk cable-range 2141-2141 2141.65
 appletalk zone SCruz-Eng
 no appletalk send-rtmps
 dialer map ip 130.1.20.106 broadcast 1879
 dialer map appletalk 2141.66 broadcast 1879
 dialer-group 1
!
access-list 101 deny   igrp 0.0.0.0 255.255.255.255 255.255.255.255 0.0.0.0
access-list 101 permit ip 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255
access-list 601 permit cable-range 2141-2141 broadcast-deny
access-list 601 deny other-access
!
dialer-list 1 list 101
dialer-list 1 list 601 

DECnet Configuration Example

The following example configures DDR for DECnet:

decnet routing 10.19
!
username RouterB password 7 030752180531
!
interface serial 0
 no ip address
 decnet cost 10
 encapsulation ppp
 dialer in-band
 dialer map decnet 10.151 name RouterB broadcast 4155551212
 dialer-group 1
 ppp authentication chap
 pulse-time 1
!
access-list 301 permit 10.0 0.1023 0.0 63.1023
!
dialer-list 1 protocol decnet list 301

ISO CLNS Configuration Example

The following example configures DDR for ISO CLNS:

username RouterB password 7 111C140B0E
clns net 47.0004.0001.0000.0c00.2222.00
clns routing
clns filter-set ddrline permit 47.0004.0001....
!
interface serial 0
 no ip address 
 encapsulation ppp
 dialer in-band
 dialer map clns 47.0004.0001.0000.0c00.1111.00 name RouterB broadcast 1212
 dialer-group 1
 ppp authentication chap
 clns enable
 pulse-time 1
!
clns route default serial 0
dialer-list 1 protocol clns list ddrline

XNS Configuration Example

The following example configures DDR for XNS. The access lists deny broadcast traffic to any host on any network, but allow all other traffic.

xns routing 0000.0c01.d8dd
username RouterB password 7 111B210A0F
interface serial 0
 no ip address 
 encapsulation ppp
 xns network 10
 dialer in-band
 dialer map xns 10.0000.0c01.d877 name RouterB broadcast 4155551212
 dialer-group 1
 ppp authentication chap
 pulse-time 1
!
access-list 400 deny -1 -1.ffff.ffff.ffff 0000.0000.0000
access-list 400 permit -1 10
!
dialer-list 1 protocol xns list 400

Dialing a Single Site Example

Assume that your configuration is as shown in Figure 100 and your router receives a packet with a next hop address of 1.1.1.1.


Figure 100: Sample Dialer String or Dialer Map Configuration


If the single site called by the DDR spoke interface on your router has the phone number 5555555, it will send the packet to that site, assuming that the next hop address 1.1.1.1 indicates the same remote device as phone number 5555555. The dialer string command is used to specify the string (telephone number) to be called.

interface serial 1
  dialer in-band
  dialer string 5555555

DTR Dialing Example

In the following example, Router A and Router B are connected to a public switched telephone network (PSTN). Router A is configured for DTR dialing. Remote Router B is configured for in-band dialing so it can disconnect an idle call. (See Figure 101.)


Figure 101: DTR Dialing through a PSTN


Router A
interface serial 0
 ip address 131.108.170.19 255.255.255.0
 dialer dtr
 dialer-group 1
!
access-list 101 deny igrp 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255
access-list 101 permit ip 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255
!
dialer-list 1 list 101
Router B
interface serial 0
 ip address 131.108.170.20 255.255.255.0
 dialer in-band
 dialer string 9876543
 pulse-time 1
!
access-list 101 deny igrp 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255
access-list 101 permit ip 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255
!
dialer-list 1 list 101

Set Up Hub-and-Spoke DDR for Asynchronous Interfaces and Authentication Example

You can set up dial-on-demand routing (DDR) to provide service to multiple remote sites. In a hub-and-spoke configuration, you can use a generic configuration script to set up each remote connection. Figure 102 illustrates a typical hub-and-spoke configuration.


Figure 102: Hub-and-Spoke DDR Configuration


This configuration is demonstrated in the following two subsections.

Spoke Configuration

The following example, configuration is performed on the spoke side of the connection. (A different "spoke" password must be specified for each remote client.) It provides authentication by identifying a password that must be provided on each end of the connection.

interface ethernet 0
 ip address 172.30.44.1 255.255.255.0
!
interface async 7
 async mode dedicated
 async default ip address 128.150.45.1
 ip address 1172.30.45.2 255.255.255.0
 encapsulation ppp
 ppp authentication chap
 dialer in-band
 dialer map ip 172.30.45.1 name hub system-script hub 1234
 dialer map ip 172.30.45.255 name hub system-script hub 1234
 dialer-group 1
!
ip route 172.30.43.0 255.255.255.0 172.30.45.1
ip default-network 172.30.0.0
chat-script generic ABORT BUSY ABORT NO ## AT OK ATDT\T TIMEOUT 30 CONNECT
chat-script hub "" "" name: spoke1 word: <spoke1-passwd> PPP
dialer-list 1 protocol ip permit
!
username hub password <spoke1-passwd>
!
router igrp 109
 network 172.30.0.0
 passive-interface async 7
!
line 7
 modem InOut
 speed 38400
 flowcontrol hardware
 modem chat-script generic

Hub Router Configuration

The following example, configuration is performed on the local side of the connection---the hub router. It configures the server for communication with three clients and provides authentication by identifying a unique password for each "spoke" in the hub-and-spoke configuration.

interface ethernet 0
 ip address 172.30.43.1 255.255.255.0
!
interface async 7
 async mode interactive
 async dynamic address
 dialer rotary-group 1
!
interface async 8
 async mode interactive
 async dynamic address
 dialer rotary-group 1
!
interface dialer 1
 ip address 172.30.45.2 255.255.255.0
 no ip split-horizon
 encapsulation ppp
 ppp authentication chap
 dialer in-band
 dialer map ip 172.30.45.2 name spoke1 3333
 dialer map ip 172.30.45.2 name spoke2 4444
 dialer map ip 172.30.45.2 name spoke3 5555
 dialer map ip 172.30.45.255 name spoke1 3333
 dialer map ip 172.30.45.255 name spoke2 4444
 dialer map ip 172.30.45.255 name spoke3 5555
 dialer-group 1
!
ip route 172.30.44.0 255.255.255.0 172.30.45.2
ip route 172.30.44.0 255.255.255.0 172.30.45.3
ip route 172.30.44.0 255.255.255.0 172.30.45.4
dialer-list 1 list 101
 access-list 101 deny igrp 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255
 access-list 101 permit ip 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255
 chat-script generic ABORT BUSY ABORT NO ## AT OK ATDT\T TIMEOUT 30 CONNECT
!
username spoke1 password <spoke1-passwd>
username spoke2 password <spoke2-passwd>
username spoke3 password <spoke3-passwd>
username spoke1 autocommand ppp 172.30.45.2
username spoke2 autocommand ppp 172.30.45.3
username spoke3 autocommand ppp 172.30.45.4
!
router igrp 109
 network 172.30.0.0
 redistribute static
!
line 7
 login tacacs
 modem InOut
 speed 38400
 flowcontrol hardware
 modem chat-script generic

Set Up Two-Way Reciprocal Client-Server DDR without Authentication Example

You can set up two-way reciprocal dial-on-demand routing (DDR) without authentication in which both the client and server have dial-in access to each other. This configuration is demonstrated in the following two subsections.

Remote Configuration

The following example configuration is performed on the remote side of the connection:

interface ethernet 0
 ip address 172.30.44.1 255.255.255.0
!
interface async 7
 ip address 172.30.45.2 255.255.255.0
 async mode dedicated
 async default ip address 172.30.45.1
 encap ppp
 dialer in-band
 dialer string 1234
 dialer-group 1
!
ip route 172.30.43.0 255.255.255.0 async 7
 ip default-network 172.30.0.0
 chat-script generic ABORT BUSY ABORT NO ## AT OK ATDT\T TIMEOUT 30 CONNECT
 dialer-list 1 protocol ip permit
!
line 7
 no exec
 modem InOut
 speed 38400
 flowcontrol hardware
 modem chat-script generic

Local Configuration

The following example configuration is performed on the local side of the connection:

interface ethernet 0
 ip address 172.30.43.1 255.255.255.0
!
interface async 7
 async mode dedicated
 async default ip address 172.30.45.2
 encapsulation ppp
 dialer in-band
 dialer string 1235
 dialer rotary-group 1
!
interface async 8
 async mode dedicated
 async default ip address 172.30.45.2
 dialer rotary-group 1
!
ip route 172.30.44.0 255.255.255.0 async 7
 ip address 172.30.45.2 255.255.255.0
 encapsulation ppp
 ppp authentication chap
 dialer in-band
 dialer map ip 172.30.45.2 name remote 4321
 dialer load-threshold 80
!
ip route 172.30.44.0 255.255.255.0 128.150.45.2
 chat-script generic ABORT BUSY ABORT NO ## AT OK ATDT\T TIMEOUT 30 CONNECT
 dialer-list 1 protocol ip permit
!
route igrp 109
network 172.30.0.0
redistribute static
passive-interface async 7
!
line 7
 modem InOut
 speed 38400
 flowcontrol hardware
 modem chat-script generic 

Frame Relay Support Examples

The examples in this section present various combinations of interfaces, Frame Relay features, and DDR features.

Frame Relay Access with In-Band Dialing (V.25bis) and Static Mapping Example

In the following example, a router is configured for IP over Frame Relay using in-band dialing. A Frame Relay static map is used to associate the next-hop protocol address to the DLCI. The dialer string allows dialing to only one destination.

interface Serial0
 ip address 1.1.1.1 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 1.1.1.2 100 broadcast
 dialer in-band
 dialer string 4155551212
 dialer-group 1
!
access-list 101 deny igrp any host 255.255.255.255
access-list 101 permit ip any any
!
dialer-list 1 protocol ip list 101

Frame Relay Access with ISDN Dialing and DDR Dynamic Maps Example

The following example shows a BRI interface configured for Frame Relay and for IP, IPX, and AppleTalk routing. No static maps are defined because this setup relies on Frame Relay local management interface (LMI) signaling and Inverse ARP to determine the network addresses-to-DLCI mappings dynamically. (Because Frame Relay Inverse ARP is enabled by default, no command is required.)

interface BRI0
 ip address 1.1.1.1 255.255.255.0
 ipx network 100
 appletalk cable-range 100-100 100.1
 appletalk zone ISDN
 no appletalk send-rtmps
 encapsulation frame-relay IETF
 dialer map ip 1.1.1.2 broadcast 4155551212
 dialer map apple 100.2 broadcast 4155551212
 dialer map ipx 100.0000.0c05.33ed broadcast 4085551234
 dialer-group 1
!
access-list 101 deny igrp any host 255.255.255.255
access-list 101 permit ip any any
access-list 901 deny -1 FFFFFFFF 452
access-list 901 deny -1 FFFFFFFF 453
access-list 901 deny -1 FFFFFFFF 457
access-list 901 deny -1 FFFFFFFF 0 FFFFFFFF 452
access-list 901 deny -1 FFFFFFFF 0 FFFFFFFF 453
access-list 901 deny -1 FFFFFFFF 0 FFFFFFFF 457
access-list 901 permit -1
access-list 601 permit cable-range 100-100 broadcast-deny
access-list 601 deny other-access
!
dialer-list 1 protocol ip list 101
dialer-list 1 protocol novell list 901
dialer-list 1 protocol apple list 601

X.25 Support Example

In the following example, a router is configured to support X.25 and DTR dialing:

interface serial 0
 ip address 131.108.170.19 255.255.255.0
 encapsulation x25
 x25 address 12345
 x25 map ip 131.108.171.20 67890 broadcast
 dialer dtr
 dialer-group 1
!
access-list 101 deny igrp 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255
access-list 101 permit ip 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255
!
dialer-list 1 list 101

LAPB Support Example

In the following example, the router is configured for LAPB encapsulation and in-band dialing:

interface serial 0
 ip address 131.108.170.19 255.255.255.0
 encapsulation lapb
 dialer in-band
 dialer string 4155551212
 dialer-group 1
!
access-list 101 deny igrp 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255
access-list 101 permit ip 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255
!
dialer-list 1 protocol ip list 101

hometocprevnextglossaryfeedbacksearchhelp
Copyright 1989-1998 © Cisco Systems Inc.