Полезная информация

cc/td/doc/product/software/ios120/12cgcr
hometocprevnextglossaryfeedbacksearchhelp
PDF

Table of Contents

Configuring ISDN Special Signaling

Configuring ISDN Special Signaling

This chapter describes features that either depend on special signaling services offered by an ISDN network service provider or overcome an inability to deliver certain signals.

For a complete description of the ISDN signaling commands in this chapter, refer to the "ISDN Special Signaling Commands" chapter of the Dial Solutions Command Reference. To locate documentation of other commands that appear in this chapter, use the command reference master index or search online.

This following sections of this chapter describe how to configure special signaling features of ISDN:

For examples of these signaling features, see the "ISDN Signaling Configuration Examples" section. For help in troubleshooting ISDN signaling features, see the "Troubleshoot ISDN" section.

Configure ISDN AOC

ISDN Advice of Charge (AOC) allows users to obtain charging information for all calls during the call (AOC-D) or at the end of the call (AOC-E) or both.

Users must have subscribed through their local ISDN network to receive the AOC information from the switch. No router configuration changes are required to retrieve this call charging information.

The ISDN AOC feature also supports, for the AOC-D service, an optional configurable short-hold mode which provides a dynamic idle timeout by measuring the call charging period, based on the frequency of the AOC-D or the AOC-E message from the network. The short-hold mode allows users to track call costs and to control and possibly reduce tariff charges. The short-hold mode idle time will do the following:

Incoming calls are disconnected using the static dialer idle timeout value.

The AOC-D and AOC-E messages are part of the Facility Information Element (IE) message. Its contents can be verified with the debug q931 command. Call accounting information from AOC-D and AOC-E messages is stored in SNMP MIB objects.

ISDN AOC is provided for ISDN PRI NET5 and ISDN BRI NET3 switch types only. AOC information at call setup is not supported.

ISDN AOC Terminology

AOC-D message---ISDN Advice of Charge information sent during a call. The message is sent periodically by the network to subscribers of AOC during-call services.

AOC-E message---ISDN Advice of Charge information sent at the end of a call. The message is sent periodically by the network to subscribers of AOC end-of-call services.

Short-hold mode---Configurable option for outgoing calls that causes the dialer idle timeout to be at the end of the current charging period, after a specified minimum idle time has elapsed. If the link has been idle less than the specified minimum time, the call stays connected into another charging period.

Configure Short-Hold Mode

No configuration is required to enable ISDN AOC.

However, you can configure the optional short-hold minimum idle timeout period for outgoing calls; the default minimum idle timeout is 120 seconds. If the short-hold option is not configured, the router default is to use the static dialer idle timeout. If the short-hold idle timeout has been configured but no charging information is available from the network, the static dialer idle timeout applies.

To configure an ISDN interface and provide the AOC short-hold mode option on an ISDN interface, use the following commands:

Step 1 Configure the ISDN BRI or PRI interface, as described in the "Setting Up Basic Rate Service" chapter or the "Configuring ISDN PRI" section of the "Configuring Channelized E1 or Channelized T1" chapter of the this manual, using the relevant keyword in the isdn switch-type command:

Step 2 Configure Dialer Profiles or legacy DDR for outgoing calls, as described in the "Dial-on-Demand Routing" part of this manual, making sure to do the following:

Step 3 Configure each specified dialer map class, providing a dialer idle timeout, or ISDN short-hold timeout, or both for outgoing calls, as described in this chapter.

To configure a dialer map class with timers, use the following commands beginning in global configuration mode:
Step Command Purpose

1 . 

map-class dialer class-name

Specify the dialer map class.

2 . 

dialer idle-timeout seconds

(Optional) Specify a static idle timeout for the map class to override the static line-idle timeout configured on the BRI interface.

3 . 

dialer isdn short-hold seconds

Specify a dialer ISDN short-hold timeout for the map class.

Monitor ISDN AOC Call Information

Use the following command to monitor ISDN AOC call information:
Command Purpose

show isdn {active | history | memory | service | status | timers}

Display information about active calls, call history, memory, Layer 2 or Layer 3 timers, or status of PRI channels. The history keyword displays AOC charging time units used during the call and indicates whether the AOC information is provided during calls or at the end of calls.

(The service keyword is available for PRI only.)

Configure NFAS on PRI Groups

ISDN Non-Facility Associated Signaling (NFAS) allows a single D channel to control multiple PRI interfaces. A backup D channel can also be configured for use when the primary NFAS D channel fails.

Use of a single D channel to control multiple PRI interfaces can free one B channel on each interface to carry other traffic.

Any hard failure causes a switchover to the backup D channel and currently connected calls remain connected.

Once the channelized T1controllers are configured for ISDN PRI, only the NFAS primary D channel must be configured; its configuration is distributed to all the members of the associated NFAS group.

ISDN NFAS Prerequisites

NFAS is only supported with a channelized T1 controller and, as a result, be ISDN PRI capable.

The router must connect to either a 4ess, dms250, dms100, or a National ISDN switch type. Table 16 shows the applicable ISDN switch types and supported NFAS types:

In addition, the router's channelized T1 controllers must be configured for ISDN, as described in the "Configuring ISDN PRI" section of the "Configuring Channelized E1 and Channelized T1" chapter of this manual.


Table 16:
Switch Type NFAS Type

Lucent 4ESS

Custom NFAS

Nortel DMS250

Custom NFAS

Nortel DMS100

Custom NFAS

Lucent 5ESS

Custom - Does not support NFAS

Lucent 5ESS

NI-2 NFAS

AGCS GTD5

NI-2 NFAS

Other Switch Types

NI-2 NFAS

ISDN Switch Types and Supported NFAS Types

Note On the Nortel dms100 switch, when a single D channel is shared, multiple PRI interfaces may be configured in a single trunk group. The additional use of alternate route indexing
, which is a feature of the dms100 switch, provides a rotary from one trunk group to another. This enables the capability of building large trunk groups in a public switched network.

ISDN NFAS Terminology

The following terms are used in this description of ISDN NFAS:

24 B channel interface---A PRI channel group configured to have no NFAS D channel; all its channels are B channels.

NFAS group---A PRI channel group (the group of interfaces) under control of a single D channel. The channel group can include all the ISDN channels on multiple T1 controllers. Cisco IOS supports ten PRI interfaces in an NFAS group with a primary D channel and a backup D channel. Five NFAS groups are supported in a single chassis.

NFAS member---A PRI interface in an NFAS group. For example, an NFAS group might include serial interfaces 1/0:23, 1/1:23, and 2/0:23 if T1 controllers 1/0, 1/1, and 2/0 are configured for NFAS.

non-facility associated signaling (NFAS)---An ISDN service that allows a single D channel to control multiple PRI interfaces. Use of a single D channel to control multiple PRI interfaces can free one B channel on each interface to carry other traffic.

ISDN NFAS Configuration Tasks

To configure NFAS on channelized T1 controllers configured for ISDN, use the commands in the following section:

You can also disable a channel or interface, if necessary, and monitor NFAS groups and ISDN service. To do so, use the commands in the following sections:

See the "NFAS Primary and Backup D Channels Example" in this chapter for a complete ISDN, NFAS, and DDR configuration.

Configure NFAS on PRI Groups

This section documents tasks used to configure NFAS with D channel backup. When configuring NFAS, you use an extended version of the ISDN pri-group command to specify the following values for the associated channelized T1 controllers configured for ISDN:

To configure ISDN NFAS, use the following commands in controller configuration mode:
Command Purpose

pri-group timeslots 1-24 nfas_d primary nfas_interface number nfas_group number

On one channelized T1 controller, configure the NFAS primary D channel.

pri-group timeslots 1-24 nfas_d backup nfas_interface number nfas_group number

On a different channelized T1 controller, configure the NFAS backup D channel to be used if the primary D channel fails.

pri-group timeslots 1-24 nfas_d none nfas_interface number nfas_group number

On other channelized T1 controllers, configure a 24 B channel interface, if desired. (Optional)

For an example of configuring three T1 controllers for the NFAS primary D channel, the backup D  channel, and 24 B channels, along with the DDR configuration for the PRI interface, see the "NFAS Primary and Backup D Channels Example" section.

When a backup NFAS D channel is configured and the primary NFAS D channel fails, rollover to the backup D channel is automatic and all connected calls stay connected.

If the primary NFAS D channel recovers, the backup NFAS D channel remains active and does not switch over again unless the backup NFAS D channel fails.

Disable a Channel or Interface

You can disable a specified channel or an entire PRI interface, thus taking it out of service or put it into one of the other states that is passed in to the switch. To disable a specific channel or PRI interface, use one of the following commands in interface configuration mode:
Command Purpose

isdn service dsl number b_channel number state state-value

Take an individual B channel out of service or set it to a different state.

isdn service dsl number b_channel 0 state state-value

Set the entire PRI interface to the specified state.

These are the supported state values:

Monitor NFAS Groups

To monitor NFAS groups, use the following command in EXEC mode:
Command Purpose

show isdn nfas group number

Display information about members of an NFAS group.

Monitor ISDN Service

To display information about ISDN channel service states, use the following command in EXEC mode:
Command Purpose

show isdn service

Display information about ISDN channels and the service states.

Configure ISDN Semipermanent Connections

German networks allow semipermanent connections between customer routers with BRIs and the 1TR6 basic rate switches in the exchange. Australian networks allow semipermanent connections between ISDN PRIs and the TS-014 primary rate switches in the exchange. Semipermanent connections are offered at better pricing than leased lines.

Configuring BRIs for semipermanent connection requires only that you use a keyword that indicates semipermanent connections when you are setting up network addressing as described in the previous section of this chapter.

To configure a BRI for semipermanent connections, use the following commands:

Step 1 Set up the ISDN lines and ports as described in the "Setting Up ISDN Basic Rate Service" chapter or in the "Configure ISDN PRI" section of the "Configuring Channelized E1 and Channelized T1" chapter.

Step 2 Configure dial-on-demand routing on a selected interface, as described in the "Dial-on-Demand Routing" part of this manual.

When you get to the DDR network addressing step, use the following commands in interface configuration mode:
Command Purpose

dialer map protocol next-hop-address name hostname spc [speed 56 | 64] [broadcast] dial-string[:isdn-subaddress]

Define the remote recipient's protocol address, host name, and dialing string; indicate semipermanent connections; optionally, provide the ISDN subaddress; set the dialer speed to 56 or 64 kbps, as needed.

Configure ISDN BRI for Leased Line Service

To configure ISDN BRI for leased line service, perform the tasks in one of the following sections as needed and available locally:


Note Once an ISDN BRI interface is configured for access over leased lines, it is no longer a dialer interface, and signaling over the D channel no longer applies. Although the interface is called interface bri  n, it is configured as a synchronous serial interface having the default HDLC encapsulation. However, the Cisco IOS commands that set the physical characteristics of a serial interface (such as the pulse time) do not apply to this interface.

Configure Leased Line Service at Normal Speeds

This service is offered in Japan and Germany and no call set up or tear down is involved. Data is placed on the ISDN interface similar to the way data is placed on a leased line connected to a serial port.

To configure the BRI to use the ISDN connection as a leased-line service, use the following commands in global configuration mode:
Command Purpose

isdn switch-type type

Configure the BRI switch type, as specified by the local service provider.

isdn leased-line bri number

Specify the BRI interface number.

To disable leased-line service if you no longer want to support it on a specified ISDN BRI, use the following command in global configuration mode:
Command Purpose

no isdn leased-line bri number

Remove leased line configuration from a specified ISDN BRI interface.

Configure Leased Line Service at 128 kbps

Beginning in Cisco IOS Release 11.2, leased-line service at 128 kbps via ISDN BRI is supported. This service combines two B channels into a single pipe.

This feature requires one or more ISDN BRI hardware interfaces that support channel aggregation and service provider support for ISDN channel aggregation at 128 kbps. At the time of Release 11.2, service providers offered support for ISDN channel aggregation at 128 kbps only in Japan.


Note This
feature is not supported on the Cisco  2500 series because its BRI hardware does not support channel aggregation.

To enable leased-line service at 128 kbps on a specified ISDN BRI, use the following commands in global configuration mode:
Command Purpose

isdn switch-type switch-type

Select the service provider switch type.

isdn leased-line bri number 128

Configure a specified BRI for access over leased lines.

To complete the configuration of the interface, see the "Configure a Synchronous Serial Ports" in this manual.

To remove the leased-line service configuration from a specified ISDN BRI, use the following command in global configuration mode:
Command Purpose

no isdn leased-line bri number

Remove leased line configuration from a specified ISDN BRI interface.

Configure Automatic Detection of Encapsulation Type

You can enable a serial or ISDN interface to accept calls and dynamically change the encapsulation in effect on the interface when the remote device does not signal the call type. For example, if an ISDN call does not identify the call type in the lower-layer compatibility fields and is using an encapsulation that is different from the one configured on the interface, the interface can change its encapsulation type dynamically.

This feature enables interoperation with ISDN terminal adapters that use V.120 encapsulation but do not signal V.120 in the call setup message. An ISDN interface that by default answers a call as synchronous serial with PPP encapsulation can change its encapsulation and answer such calls.

Automatic detection is attempted for the first 10 seconds after the link is established or the first five packets exchanged over the link, whichever is first.

To enable automatic detection of encapsulation type, use the following command in interface configuration mode:
Command Purpose

autodetect encapsulation encapsulation-type

Enable automatic detection of encapsulation type on the specified interface.

You can specify one or more encapsulations to detect. Cisco IOS software currently supports automatic detection of PPP and V.120 encapsulations.

Configure Encapsulation for Combinet Compatibility

Historically, Combinet devices supported only the Combinet Packet Protocol (CPP) for negotiating connections over ISDN B channels. To enable Cisco routers to communicate with those Combinet bridges, the Cisco IOS supports a new CPP encapsulation type.

To enable routers to communicate over ISDN interfaces with Combinet bridges that support only CPP, use the following commands in interface configuration mode:
Step Command Purpose

Step 1

encapsulation cpp

Specify CPP encapsulation.

Step 2

cpp callback accept

Enable CPP callback acceptance.

Step 3

cpp authentication

Enable CPP authentication.

Now most Combinet devices support PPP. Cisco routers can communicate over ISDN with these devices by using PPP encapsulation, which supports both routing and fast switching.

Combinet devices support only IP, IPX, and bridging. For AppleTalk, Cisco routers automatically perform half-bridging with Combinet devices. For more information about half-bridging, see the "Configure PPP Half-Bridging on Serial Interfaces" section in the "Media-Independent PPP and Multilink PPP" chapter of this manual.

Cisco routers can also half-bridge IP and IPX with Combinet devices that support only CPP. To configure this feature, you only need to set up the addressing with the ISDN interface as part of the remote subnet; no additional commands are required.

Troubleshoot ISDN

You can troubleshoot ISDN by using the following commands:
Command Purpose

debug dialer

Display the values of timers.

debug isdn q921 [interface bri number]


debug isdn q921 interface serial slot/controller-number:23

Display link layer information for all interfaces or, optionally, for a single BRI interface.
or
Display link layer information for a single PRI interface.

debug isdn q931 [interface bri number]




debug isdn q931 interface serial
slot/controller-number:23

Display the content of call control messages and information elements, in particular the Facility IE message for all interfaces or, optionally, for a single BRI interface.
or
Display the content of call control messages and information elements, in particular the Facility IE message for a single PRI interface.

ISDN Signaling Configuration Examples

This section provides the following configuration examples:

ISDN AOC Configuration Examples

This section provides the following ISDN Advice of Charge configuration examples:

Using Legacy DDR for ISDN PRI AOC Configuration Example

This example shows ISDN PRI configured on an E1 controller. Legacy DDR is configured on the ISDN D channel (serial interface 0:15) and propagates to all ISDN B channels. A static dialer idle-timeout is configured for all incoming calls on the B channels, but the map classes are configured independently of it. Map classes Kappa and Beta use AOC charging unit duration to calculate the timeout for the call. A short-hold idle timer is set so that if the line is idle for 10 or more seconds, the call is disconnected when the current charging period ends. Map class Iota uses a static idle timeout.

version 11.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname A
!
username c2503isdn password 7 1511021F0725
username B password 7 110A1016141D29
username C password 7 1511021F072508
isdn switch-type primary-net5
!
controller E1 0
 pri-group timeslots 1-31
!
interface Serial 0:15
 ip address 10.0.0.35 255.0.0.0
 encapsulation ppp
 dialer idle-timeout 150
 dialer map ip 10.0.0.33 name c2503isdn class Iota 06966600050
 dialer map ip 10.0.0.40 name B class Beta 778578 
 dialer map ip 10.0.0.45 name C class Kappa 778579 
 dialer-group 1
 ppp authentication chap
!
map-class dialer Kappa
 dialer idle-timeout 300
 dialer isdn short-hold 120
! 
map-class dialer Iota
 dialer idle-timeout 300
!
map-class dialer Beta
 dialer idle-timeout 300
 dialer isdn short-hold 90
!
dialer-list 1 protocol ip permit

Using Dialer Profiles for ISDN BRI AOC Configuration Example

This example shows ISDN BRI configured as a member of two dialer pools for Dialer Profiles.

version 11.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname delorean
!
username spanky password 7 0705344245
username delorean password 7 1511021F0725
isdn switch-type basic-net3
!
interface BRI0
 description Connected to NTT 81012345678901
 no ip address
 dialer pool-member 1 max-link 1
 dialer pool-member 2 max-link 
 encapsulation ppp
 no fair-queue
!
interface Dialer1
 ip address 7.1.1.8 255.255.255.0
 encapsulation ppp
 dialer remote-name spanky
 dialer string 81012345678902 class Omega
 dialer pool 1
 dialer-group 1
 ppp authentication chap
!
interface Dialer2
 ip address 8.1.1.8 255.255.255.0
 encapsulation ppp
 dialer remote-name dmsisdn
 dialer string 81012345678902 class Omega
 dialer string 14153909503 class Gamma
 dialer pool 2
 dialer-group 1
 ppp authentication chap
!
map-class dialer Omega
 dialer idle-timeout 60
 dialer isdn short-hold 150
!
map-class dialer Gamma
 dialer isdn short-hold 60
!
dialer-list 1 protocol ip permit

ISDN NFAS Configuration Examples

This section provides the following configuration examples:

NFAS Primary and Backup D Channels Example

The following example configures ISDN PRI and NFAS on three T1 controllers of a Cisco  7500 series router. The NFAS primary D channel is configured on the 1/0 controller, and the NFAS backup D channel is configured on the 1/1 controller. No NFAS D channel is configured on the 2/0 controller; it is configured for 24 B channels.

Once the NFAS primary D channel is configured, it is the only interface you see and have to configure; DDR configuration for the primary D channel---which is distributed to all B channels---is also included in this example.

isdn switch-type primary-4ess
!
! NFAS primary D channel on the channelized T1 controller in 1/0
controller t1 1/0
 framing esf
linecode b8zs
 pri-group timeslots 1-24 nfas_d primary nfas_interface 0 nfas_group 1 
!
! NFAS backup D channel on the channelized T1 controller in 1/1
controller t1 1/1
 framing esf
linecode b8zs
 pri-group timeslots 1-24 nfas_d backup nfas_interface 1 nfas_group 1 
!
! NFAS 24 B channels on the channelized T1 controller in 2/0
controller t1 2/0
 framing esf
linecode b8zs
 pri-group timeslots 1-24 nfas_d none nfas_interface 2 nfas_group 1 
!
! NFAS primary D channel interface configuration for PPP and DDR. 
This 
! configuration is distributed to all the B channels in NFAS group 1 on the 
! three channelized T1 controllers.
!
interface Serial 1/0:23 
 ip address 1.1.1.2 255.255.255.0
 no ip mroute-cache
 encapsulation ppp
 dialer map ip 1.1.1.1 name flyboy 567898
 dialer map ip 1.1.1.3 name flyboy 101112345678
 dialer map ip 1.1.1.4 name flyboy 01112345678
 dialer-group 1
 no fair-queue
 no cdp enable
 ppp authentication chap

PRI Interface Service State Example

The following example puts the entire PRI interface back in service after it previously had been taken out of service:

isdn service dsl 0 b-channel 0 state 0

ISDN BRI Leased Line Configuration Examples

The following example configures the BRI 0 interface for leased-line access at 128 kbps. Because of the leased-line---not dialed---environment, configuration of ISDN called and calling numbers are not needed and not used. The BRI 0 interface is henceforth treated as a synchronous serial interface, with the default HDLC encapsulation.

isdn leased-line bri 0 128

The following example configures the BRI 0 interface for PPP encapsulation:

interface bri 0
  ip address 1.1.1.2 255.255.255.0
  encapsulation ppp
  bandwidth 128


hometocprevnextglossaryfeedbacksearchhelp
Copyright 1989-1998 © Cisco Systems Inc.