Полезная информация

cc/td/doc/product/software/ios120/12cgcr
hometocprevnextglossaryfeedbacksearchhelp
PDF

Table of Contents

Configuring Channelized E1 and Channelized T1

Configuring Channelized E1 and Channelized T1

Channelized T1 and channelized E1 can be configured for ISDN PRI, synchronous serial, and asynchronous serial communications.

Channelized T1 and channelized E1 are supported by corresponding controllers. Each T1 or E1 controller has one physical network termination, but it can have many virtual interfaces, depending on the configuration.

This chapter describes how to configure channelized E1 and channelized T1 for ISDN PRI and for two types of signaling to support analog calls over digital lines. The following main configuration sections are provided:

In addition, this chapter describes how to run interface loopback diagnostics on channelized E1 and channelized T1. For more information, see the "Troubleshoot Channelized E1 and Channelized T1" section.

For hardware technical descriptions, and for information about installing the controllers and interfaces, refer to the hardware installation and maintenance publication for your particular product.

For a complete description of the channelized E1/T1 commands in this chapter, refer to the "Channelized E1 and Channelized T1 Setup Commands" chapter of the Dial Solutions Command Reference. To locate documentation of other commands that appear in this chapter, use the command reference master index or search online.

Background Information

This section presents background information about signaling and about the use of channelized E1/T1 on the Cisco  AS5200.

About In-Band and Out-of-Band Signaling

The terms in-band and out-of-band indicate whether various signals---used to set up, control, and terminate calls---travel in the same channel (or band) with users' voice calls or data, or whether those signals travel a separate channel (or band).

ISDN, which uses the D channel for signaling and the B channels for user data, fits into the out-of-band signaling category.

Robbed-bit signaling, which uses bits from specified frames in the user data channel for signaling, fits into the in-band signaling category.

Channel-associated signaling, which uses E1 timeslot 16 (the D channel) for signaling, fits into the out-of-band signaling category.

About Channelized E1 and T1 on the Cisco AS5200

On a Cisco AS5200, you can allocate the available channels for channelized E1 or T1 in the following ways:

See the "PRI Groups and Channel Groups on the Same Channelized T1 Controller Example," "Robbed-Bit Signaling Examples," and the "ISDN Channel-Associated Signaling Examples" sections at the end of this chapter.

Configure ISDN PRI

This section describes tasks that are required to get ISDN PRI up and running. This section does not address routing issues, dialer configuration, and dial backup. For information about those topics, see the "Dial-on-Demand Routing" part of this manual.

ISDN PRI is supported on the Cisco  7200 series and 7500 series routers using T1 or E1 versions of the Multichannel Interface Processor (MIP) card, on the Cisco 4000 series channelized E1/T1/PRI network processor module (NPM), and on the Cisco AS5200. Channelized T1 ISDN PRI offers 23  B  channels and 1 D  channel. Channelized E1 ISDN PRI offers 30 B  channels and 1 D  channel. Channel 24 is the D channel for T1, and channel 16 is the D channel for E1.

For a complete description of the commands mentioned in this chapter, refer to the "Channelized E1 and Channelized T1 Setup Commands" chapter in the Dial Solutions Command Reference.

Perform the tasks in the following sections to configure ISDN PRI:

See the end of this chapter for the "ISDN PRI Examples" section.


Note After the ISDN PRI interface and lines are operational, configure the D channel interface for DDR. The DDR configuration specifies the packets that can trigger outgoing calls, specifies whether to place or receive calls, and provides the protocol, address, and phone number to use.

For DDR configuration information, see the "Dial-on-Demand Routing" part of this manual. For command information, refer to the "Dial-on-Demand Routing" part of the Dial Solutions Command Reference.

Request PRI Line and Switch Configuration from a Telco Service Provider

Before configuring ISDN PRI on your Cisco router, you need to order a correctly provisioned ISDN PRI line from your telecommunications service provider.

This process varies dramatically from provider to provider on a national and international basis. However, some general guidelines follow:

When you order ISDN service, request the PRI switch configuration attributes displayed in Table 13.

Table 13: PRI Switch Configuration Attributes to Request from Service Vendor
Attribute Value

Line format

Extended Superframe Format (ESF)

Line coding

Binary 8-zero substitution (B8ZS)

Call type

23 incoming channels and 23 outgoing channels

Speed

64 kbps

Call-by-call capability

Enabled

Channels

23 B+D

Trunk selection sequence

Either ascending order (from 1 to 23) or descending order (from 23 to 1)

B + D glare

Yield

Directory numbers

Only 1 directory number assigned by service provider

ISDN call speed outside local exchange

Speed set to 56 kbps outside local exchange

SPIDs required?

None

Configure Channelized E1 ISDN PRI

To configure ISDN PRI on a channelized E1 controller, use the following commands, beginning in global configuration mode:
Step Command Purpose

1 . 

isdn switch-type switch-type

Select a service provider switch type that accommodates PRI. (See Table 14 for a list of supported switch type keywords.)

2 . 

controller e1 slot/port


controller e1 number

Define the controller location in the Cisco7200 or Cisco  7500 series by slot and port number.
or
Define the controller location in the Cisco 4000 series or the Cisco AS5200 universal access server by unit number.1

3 . 

framing crc4

Define the framing characteristics as cyclic redundancy check 4 (CRC4).

4 . 

linecode hdb3

Define the line code as high-density bipolar 3 (HDB3).

5 . 

pri-group [timeslots range]

Configure ISDN PRI.

1Controller numbers range 0 through 2 on the Cisco 4000 series and 1 to 2 on the Cisco AS5200.

If you do not specify the time slots, the specified controller is configured for 30 B  channels and one D  channel. The B channel numbers range 1 to 31; channel 16 is the D channel for E1. Corresponding serial interfaces numbers range 0 to 30. In commands, the D channel is interface serial controller-number:15. For example, interface serial 0:15.

   

Table 14: ISDN Service Provider PRI Switch Types
Keywords by Area Switch Type

none

No switch defined

Australia

primary-ts014

Australia PRI switches

Europe

primary-net5

European, New Zealand and Asia ISDN PRI switches (covers the Euro-ISDN E-DSS1 signaling system and is ETSI-compliant)

Japan

primary-ntt

Japanese ISDN PRI switches

North America

primary-4ess

AT&T 4ESS switch type for the U.S.

primary-5ess

AT&T 5ESS switch type for the U.S.

primary-dms100

NT DMS-100 switch type for the U.S.

primary-ni

AT&T National ISDN switch type


Note Cisco IOS Release 11.3T introduced ISDN switch type changes. The command parser will still accept the following switch types: basic-nwnet3, vn2, and basic-net3; however, when viewing the NVRAM configuration, the basic-net3 or vn3 switch types are displayed respectively. For specific details about ISDN switch type changes, refer to the "National ISDN Switch Types
for Basic Rate and Primary Rate Interfaces" document in Cisco IOS Release 11.3(3)T.

Configure Channelized T1 ISDN PRI

To configure ISDN PRI on a channelized T1 controller, use the following commands beginning in global configuration mode:
Step Command Purpose

Step 1

isdn switch-type switch-type

Select a service provider switch type that accommodates PRI. (See Table 14 for a list of supported PRI switch type keywords.)

Step 2

controller t1 slot/port
or
controller t1 number

Specify a T1 controller on a Cisco 7500
or
Specify a T1 controller on a Cisco 4000.1

Step 3

framing esf

Define the framing characteristics as Extended Superframe Format (ESF).

Step 4

linecode b8zs

Define the line code as binary 8 zero substitution (B8ZS).

Step 5

pri-group [timeslots range]2

Configure ISDN PRI.

If you do not specify the time slots, this controller is configured for 23 B  channels and 1  D  channel.

1Controller numbers range 0 through 2 on the Cisco 4000 series and 1 to 2 on the Cisco AS5200.
2On channelized T1, timeslots range 1 to 24. You can specify a range or timeslots (or example, pri-group timeslots 12-24) if other timeslots are used for non-PRI channel groups.

If you do not specify the time slots, the specified controller is configured for 24 B  channels and one D  channel. The B channel numbers range 1 to 24; channel 24 is the D channel for T1. Corresponding serial interfaces numbers range 0 to 23. In commands, the D channel is interface serial controller-number:23. For example, interface serial 0:23.

Configure the Serial Interface

When you configure ISDN PRI on the channelized E1 or channelized T1 controller, in effect you create a serial interface that corresponds to the PRI group timeslots This interface is a logical entity is associated with the specific controller. After you create the serial interface by configuring the controller, you must configure the D channel serial interface. The configuration applies to all the PRI B channels (timeslots).

To configure the D channel serial interface, complete the tasks in the following sections:

Specify an IP Address for the Interface

To configure the D channel serial interface created for ISDN PRI, use the following commands beginning in global configuration mode:
Step Command Purpose

1 . 

interface serial slot/port:23
interface serial
number:23

interface serial
slot/port:15
interface serial
number:15

Specify D channel on the serial interface for channelized T1.

Specify D channel on the serial interface for channelized E1.

2 . 

ip address ip-address

Specify an IP address for the interface.

When you configure the D channel, its configuration is applied to all the individual B channels.

Configure Encapsulation

PPP encapsulation is configured for most ISDN communication. However, the router might require a different encapsulation for traffic sent over a Frame Relay or X.25 network, or the router might need to communicate with devices that require a different encapsulation protocol.

Configure encapsulation as described in one of the following sections:

In addition, the router can be configured for automatic detection of encapsulation type on incoming calls. To configure this feature, complete the tasks in the following section:

Configure PPP Encapsulation

Each ISDN B  channel is treated as a serial line and supports HDLC and PPP encapsulation. The default serial encapsulation is HDLC. To configure PPP encapsulation, use the following command in interface configuration mode:
Command Purpose

encapsulation ppp

Configure PPP encapsulation.

Configure Encapsulation for Frame Relay or X.25 Networks

If traffic from this ISDN interface crosses a Frame Relay or X.25 network, the appropriate addressing and encapsulation tasks must be completed as required for Frame Relay or X.25 networks.

See the "Configuring Frame Relay" chapter or "Configuring X.25 and LAPB" chapter for more information about addressing, encapsulation, and other tasks necessary to configure Frame Relay or X.25 networks.

Configure Encapsulation for Combinet Compatibility

Historically, Combinet devices supported only the Combinet Proprietary Protocol (CPP) for negotiating connections over ISDN B channels. To enable Cisco routers to communicate with those Combinet bridges, the Cisco IOS software supports a new CPP encapsulation type.

To enable routers to communicate over ISDN interfaces with Combinet bridges that support only CPP, use the following commands in interface configuration mode:
Step Command Purpose

Step 1

encapsulation cpp

Specify CPP encapsulation.

Step 2

cpp callback accept

Enable CPP callback acceptance.

Step 3

cpp authentication

Enable CPP authentication.

Now most Combinet devices support PPP. Cisco routers can communicate over ISDN with these devices by using PPP encapsulation, which supports both routing and fast switching.

Combinet devices support only IP, IPX, and bridging. For AppleTalk, Cisco routers automatically perform half-bridging with Combinet devices. For more information about half-bridging, see the "Configure PPP Half-Bridging" section in the "Configuring Media-Independent PPP" chapter of this publication.

Cisco routers can also half-bridge IP and IPX with Combinet devices that support only CPP. To configure this feature, you only need to set up the addressing with the ISDN interface as part of the remote subnet; no additional commands are required.

Configure Automatic Detection of Encapsulation Type of Incoming Calls

You can enable a serial or ISDN interface to accept calls and dynamically change the encapsulation in effect on the interface when the remote device does not signal the call type. For example, if an ISDN call does not identify the call type in the Lower Layer Compatibility fields and is using an encapsulation that is different from the one configured on the interface, the interface can change its encapsulation type at that time.

This feature enables interoperation with ISDN terminal adapters that use V.120 encapsulation but do not signal V.120 in the call setup message. An ISDN interface that by default answers a call as synchronous serial with PPP encapsulation can change its encapsulation and answer such calls.

Automatic detection is attempted for the first 10 seconds after the link is established or the first five packets exchanged over the link, whichever is first.

To enable automatic detection of encapsulation type, use the following commands in interface configuration mode:
Command Purpose

autodetect encapsulation encapsulation-type

Enable automatic detection of encapsulation type on the specified interface.

You can specify one or more encapsulations to detect. Cisco IOS software currently supports automatic detection of PPP and V.120 encapsulations.

Configure Network Addressing

When you configure networking, you specify how to reach the remote recipient. To configure network addressing, use the following commands beginning in interface configuration mode:
Step Command Purpose

1 . 

dialer map protocol next-hop-address name hostname speed 56|64 dial-string[:isdn-subaddress]

dialer map protocol next-hop-address name hostname spc [speed 56 | 64] [broadcast] dial-string[:isdn-subaddress]

Define the remote recipient's protocol address, host name, and dialing string; optionally, provide the ISDN subaddress; set the dialer speed to 56 or 64 kbps, as needed.
or
(Australia) Use the spc keyword that enables ISDN semipermanent connections.

2 . 

dialer-group group-number

Assign the interface to a dialer group to control access to the interface.

3 . 

dialer-list dialer-group list access-list-number

Associate the dialer group number with an access list number.

4 . 

access-list access-list-number {deny | permit} protocol source address source-mask destination destination-mask

Define an access list permitting or denying access to specified protocols, sources, or destinations.

Australian networks allow semipermanent connections between customer routers with PRIs and the TS-014 ISDN PRI switches in the exchange. Semipermanent connections are offered at better pricing than leased lines.

Packets that are permitted by the access list specified in are considered interesting and cause the router to place a call to the destination protocol address that is identified in both and .


Note The access list reference in Step 4 of this task list is an example of the access list commands allowed by different protocols. Some protocols might require a different command form or might require multiple commands. Refer to the relevant protocol chapter in the Network Protocols Configuration Guide, Part  1, Part  2, or Part 3 for more information about setting up access lists for a protocol.

For more information about defining outgoing call numbers, see the "Configuring Legacy DDR" or "Configuring Dialer Profiles" chapter.

Configure ISDN Calling Number Identification

A router might need to supply the ISDN network with a billing number for outgoing calls. Some networks offer better pricing on calls in which the number is presented. When configured, the calling number information is included in the outgoing Setup message.

To configure the interface to identify the billing number, use the following commands in interface configuration mode:
Command Purpose

isdn calling-number calling-number

Specify the calling party number.

This command can be used with all ISDN PRI switch types.

Configure ISDN Voice Calls

All incoming ISDN analog modem calls that come in on an ISDN PRI receive signaling information from the ISDN D channel. The D channel is used for circuit switched data calls and analog modem calls. To enable all incoming ISDN voice calls to access the Cisco AS5200 and AS5300 call switch module and integrated modems, use the following command beginning in interface configuration mode:
Command Purpose

isdn incoming-voice modem

Route incoming ISDN modem calls to the modem module.

Configure Inclusion of the Sending Complete Information Element

In some geographic locations, such as Hong Kong and Taiwan, ISDN switches require that the Sending Complete information element be included in the outgoing Setup message to indicate that the entire number is included. This information element is not required in other locations.

To configure the interface to include the Sending Complete information element in the outgoing call Setup message, use the following command in interface configuration mode:
Command Purpose

isdn sending-complete

Include the Sending Complete information element in the outgoing call Setup message.

Configure NSF Call-by-Call Support

Network-Specific Facilities (NSF) are used to request a particular service from the network or to provide an indication of the service being provided. Call-by-call support means that a B channel can be used for any service; its use is not restricted to a certain preconfigured service, such as incoming 800 calls or an outgoing 800 calls. This specific NSF call-by-call service supports outgoing calls configured as voice calls.

This NSF call-by-call support feature is vendor-specific; only routers connected to AT&T Primary-4ESS switches need to configure this feature. This feature is supported on channelized T1.

To enable the router to for NSF call-by-call support and, optionally, to place outgoing voice calls, complete use the following steps:

Step 1 Configure the controller for ISDN PRI.

Step 2 Configure the D channel interface to place outgoing calls, using the dialer map command with a dialing-plan keyword. You can enter a dialer map command for each dialing plan to be supported.

Step 3 Define the dialer map class for that dialing plan.

To define the dialer map class for the dialing plan, use the following command beginning in global configuration mode:
Step Command Purpose

1 . 

map-class dialer classname

Specify the dialer map class, using the dialing-plan keyword as the classname.

2 . 

dialer voice-call

(Optional) Enable voice calls.

3 . 

dialer outgoing classname

Configure the specific dialer map class to make outgoing calls.


Note To set the called party type to international, the dialed number must be prefaced by 011.

Table 15 lists the NSF dialing plans and supported services offered on AT&T Primary-4ESS switches.


Table 15: NSF Supported Services on AT&T Primary-4ESS Switches
NSF Dialing Plan Data Voice International

Software Defined Network (SDN)1

Yes

Yes

GSDN (Global SDN)

MEGACOMM

No

Yes

Yes

ACCUNET

Yes

Yes

Yes

1The dialing plan terminology in this table is defined and used by AT&T.

Configure Multiple ISDN Switch Types

The Multiple ISDN Switch Types feature allows you to configure more than one ISDN switch type per router. You can apply an ISDN switch type on a per interface basis, thus extending the existing global isdn switch-type command to the interface level. This allows Primary Rate Interfaces (PRI) and Basic Rate Interfaces (BRI) and to run simultaneously on platforms that support both interface types.

A global ISDN switch type is required and must be configured on the router before you can configure a switch type on an interface. To configure multiple ISDN switch types for a PRI interface using a channelized E1 or channelized T1 controller, use the following command in global configuration mode:
Command Purpose

isdn switch-type switch-type

Apply a global ISDN switch type.

You must ensure the ISDN switch type is valid for the ISDN interfaces on the router. Table 14 lists valid ISDN switch types for BRI and PRI interfaces.


Note When you configure an ISDN switch type on the channelized E1 or T1 controller, this switch type is applied to all timeslots on that controller. For example, if you configure channelized T1  controller 1:23, which corresponds to serial interface 1, with the ISDN switch type of primary-net5, then all timeslots on serial interface 1 (and T1 controller 1) will use the primary-net5 switch type.

The following restrictions apply to Multiple ISDN Switch Types:

If, for example, you reconfigure the router to use global switch type basic-net3, the router will apply a primary-net5 switch type to PRI interfaces and basic-net3 to any BRI interfaces. You can override the default switch assignment by configuring a different ISDN switch type on the associated interface.

Configure B Channel Outgoing Call Order

You can configure the router to select the first available B channel in ascending order (channel B1) or descending order (channel B23 for a T1 and channel B30 for an E1). To configure the optional task of selecting B channel order for outgoing calls for PRI interface types, use the following command in interface configuration mode:
Command Purpose

isdn bchan-number-order {ascending | descending}

Enable B channel selection for outgoing calls on a PRI interface (optional).

Before configuring the ISDN PRI on your router, check with your service vendor to determine if the ISDN trunk call selection is configured for ascending or descending order. If there is a mismatch between the router and switch with regard to channel availability, the switch will send back an error message stating the channel is not available. By default, the router will select outgoing calls in descending order.

Perform Configuration Self-Tests

To test the router's ISDN configuration, we suggest that you use the following commands:
Command Purpose

show controllers t1 slot/port

Check Layer 1 (physical layer) of the PRI over T1.

show controllers e1 slot/port

Check Layer 1 (physical layer) of the PRI over E1.

debug q921

Check Layer 2 (data link layer).

debug isdn events

debug q931

debug dialer

show dialer

Check Layer 3 (network layer).

See the Debug Command Reference for information about the debug commands.

Monitor and Maintain ISDN PRI Interfaces

Use the following commands to monitor and maintain ISDN interfaces:
Command Purpose

show interfaces serial slot/port bchannel channel-number (Cisco  7500 series)

show interfaces serial
number bchannel channel-number (Cisco  4000 series)

Display information about the physical attributes of the ISDN PRI over T1 B and D  channels.

show interfaces serial slot/port bchannel channel-number (Cisco  7500 series)

show interfaces serial number bchannel channel-number (Cisco  4000 series)

Display information about the physical attributes of the ISDN PRI over E1 B and D  channels.

show controllers t1 [slot/port] (Cisco 7500 series)

show controller t1 number (Cisco 4000 series)

Display information about the T1 links supported on the ISDN PRI B and D  channels.

show controllers e1 [slot/port] (Cisco 7500 series)

show controllers e1 number (Cisco 4000 series)

Display information about the E1 links supported on the ISDN PRI B and D  channels.

show isdn {active | history | memory | services | status [dsl | serial number] | timers}

Display information about current calls, history, memory, services, status of PRI channels, or Layer 2 or Layer 3 timers. (The service keyword is available for PRI only.)

show dialer [interface type number]

Obtain general diagnostic information about the specified interface.

Configure Robbed-Bit Signaling for Analog Calls over T1 Lines

The Cisco AS5200 supports robbed-bit signaling for receiving and transmitting analog calls on T1 lines. Robbed-Bit signaling emulates older analog trunk and line in-band signaling methods that are transmitted in many networks.

In countries that support T1 framing (such as the United States and Canada), many networks send supervisory and signaling information to each other by removing the 8th bit of each timeslot of the 6th and 12th frame for superframe (SF) framing. For networks supporting extended superframe (ESF) framing, the 6th, 12th, 18th, and 24th frames are affected. This is done to support channel banks in the network that convert various battery and ground operations on analog lines into signaling bits the Robbed-bits are forwarded over digital lines.

Robbed-bit signaling configured on the Cisco AS5200 enables the integrated modems in the access server to answer and transmit analog calls. To support analog signaling over T1 lines on the Cisco  AS5200, robbed-bit signaling must be enabled.


Note The signal type configured on the access server must match the signal type offered by your telco provider. Ask your telco provider which signal type to configure on each T1 controller.

The Cisco  AS5200 has two controllers: controller T1 1 and controller T1 0, which must be configured individually.

To configure robbed-bit signaling support for calls made and received, use the following commands beginning in global configuration mode:
Step Command Purpose

1 . 

controller t1 0

Enable the T1 0 controller, and enter controller configuration mode.

2 . 

cablelength long dbgain-value dbloss-value

If the channelized T1 line connects to a smart jack instead of a CSU, set pulse equalization (use parameter values specified by your telco service provider).

3 . 

framing esf

Set the framing to match your telco service provider's offering, which in most cases is esf.

4 . 

linecode b8zs

Set the line code type to match your telco service provider's offering, which in most cases is b8zs.

5 . 

clock source line primary

Configure one T1 line to serve as the primary or most stable clock source line.

6 . 

cas-group channel-number timeslots range type  signal-type

Configure channels to accept voice calls.

This step creates interfaces that you can configure.

7 . 

fdl {att | ansi}

Set the facilities data link exchange standard for the CSU, as specified by your telco service provider.

If you want to configure robbed-bit signaling on the other T1 controller, repeat Steps 1 through 7, making sure in Step 5 to select T1 controller 1's line as the secondary clock source.

If you want to configure ISDN on the other controller, see the "Configure ISDN PRI" section of this chapter. If you want to configure channel groupings on the other controller, see the "Configuring Synchronous Serial Ports" chapter in this manual; specify the channel groupings when you specify the interface.

Configure Channel-Associated Signaling for Analog Calls over E1  Lines

The Cisco AS5200 and AS5300 Universal Access Servers supports channel-associated signaling for channelized E1 lines, which are commonly deployed in networks in Latin America, Asia, and Europe. Channel-associated signaling is configured to support channel banks in the network that convert various battery and ground operations on analog lines into signaling bits, which are forwarded over digital lines.

Channel-associated signaling is call signaling that is configured on an E1 controller and enables the access server to send or receive analog calls. The signaling uses the16th channel (timeslot); thus, channel-associated signaling fits in the out-of-band signaling category.

Once channel-associated signaling is configured on a single E1 controller, up to 30 remote users can simultaneously dial in to the Cisco  AS5200 and Cisco AS5300 through networks running the R2 protocol. The R2 protocol is an international signaling standard for analog connections. Because R2 signaling is not supported in the Cisco AS5200 and Cisco AS5300, an E1-to-E1 converter is required. See Figure 38.

Because the Cisco  AS5200 and Cisco AS5300 have more than one physical E1 port on the dual E1 PRI board, up to 60  simultaneous connections can be made through one dual E1 PRI board.


Figure 38:
Remote PC Accessing Network Resources through the Cisco AS5200



Note For information on how to configure an Anadigicom E1-to-E1 converter, refer to the documentation that came with the converter.

Note The dual E1 PRI card must be installed in the Cisco AS5200 before you can configure channel-associated signaling.

Configure Channel-Associated Signaling

To configure the Cisco AS5200's E1 controllers, use the following commands, beginning in global configuration mode:
Step Command Purpose

1 . 

controller e1 number

Define the controller location in the Cisco  AS5200/AS5300 by unit number, ranging from 1 to 2.

2 . 

cas-group channel-number timeslots range type signal-type

Configure channel-associated signaling and the R2 signaling protocol on a specified number of timeslots.

3 . 

framing crc4

Define the framing characteristics as cyclic redundancy check 4 (CRC4).

4 . 

linecode hdb3

Define the line code as high-density bipolar 3 (HDB3).

5 . 

clock source line primary1

Specify one E1 line to serve as the primary or most stable clock source line.

1Specify the other E1 line as the secondary clock source with the clock source line secondary command.

If you do not specify the time slots, channel-associated signaling is configured on all 30 B channels and one D channel on the specified controller.

Troubleshoot Channelized E1 and Channelized T1

When troubleshooting channelized T1 or E1, you must first determine if the problem is with a particular channel group or with the T1 or E1 line.

If the problem is with a single channel group, you have a potential interface problem.

If the problem is with the T1 or E1 line, or with all channel groups, you have a potential controller problem.

The following sections describe how to determine whether the problem affects an interface or a controller:

Troubleshoot Channelized E1 and T1 Controllers

When you troubleshoot E1 or T1 controllers, first check that the configuration is correct. The framing type and line code should match to what the service provider has specified. Then check channel group and PRI-group configurations, especially to verify that the timeslots and speeds are what the service provider has specified.

At this point, the show controller t1 or show controller e1 commands should be used to check for T1 or E1 errors. Use the command several times to determine if error counters are increasing, or if the line status is continually changing. If this is occurring, you need to work with the service provider.


Note Cisco routers do not have CSU capability and do not react to any remote loopback codes at the T1 or E1 level.

Run Controller Loopback Diagnostic Tests

Controller loopback tests are a means to isolate problems and are available for both channelized T1 controllers and channelized E1 controllers. The following loopback tests are documented for isolating T1 and E1 controller issues:

Local Loopback

The local loopback loops the controller both toward the router and toward the line. Since the loopback is done internally to the router, the controller should transition to the UP state within approximately 10 seconds, and no further T1 errors should be detected.

All channel groups will be looped back; if the encapsulation on that channel group supports loopbacks (for example, HDLC and PPP), you can test that channel group by pinging the interface address. For example, if you have assigned an IP address to the serial interface defined for a channel group, you can ping that IP address.

To place the controller into local loopback, use the following command in controller configuration mode.
Command Purpose

loopback local (controller)

Loop the T1 controller toward the router and toward the line.

To test a channel group, use the following command in EXEC mode:
Command Purpose

ping protocol protocol-address

Ping the interface address.

Check errors by using the following command in EXEC mode:
Command Purpose

show controller t1

Check errors.

If any errors occur, or the controller fails to change to the UP state, please contact the Cisco Technical Assistance Center (TAC).

Since the controller local loopback is bidirectional, the service provider can test the line integrity using a T1 BERT test set.

Remote Loopback

The second T1 controller loopback is a remote loopback. This loopback can be used only if the entire T1 goes to a remote CSU. This is not the case with 99.9% of channelized T1. When the loopback  remote controller command is executed, an inband CSU loop-up code will be sent over the entire T1, which will attempt to loop up the remote CSU. To place the controller in remote loopback, use the following command in controller configuration mode:
Command Purpose

loopback remote (controller)

Place the T1 controller in remote loopback.


Note If controller loopbacks are used, they will disrupt service for all channel groups on that interface.

Channelized E1 Controller Loopback

For the E1 controller, only the local loopback is available. Local loopback operates the same as the local loopback on the T1 controller, forming a bidirectional loopback, both toward the router and toward the line. To place the E1 controller in local loopback, use the following command in controller configuration mode:
Command Purpose

loopback (controller)

Place the E1 controller in local loopback toward the router and toward the line.

All channel groups will be looped back; if the encapsulation on that channel group supports loopbacks (for example, HDLC and PPP), you can test that channel group by pinging the interface address. For example, if you have assigned an IP address to the serial interface defined for a channel group, you can ping that IP address.

To place the controller into local loopback, use the following command in controller configuration mode.
Command Purpose

loopback local (controller)

Loop the T1 controller toward the router and toward the line.

To test a channel group, use the following command in EXEC mode:
Command Purpose

ping protocol protocol-address

Ping the interface address.

Check errors if any. by using the following command in EXEC mode:
Command Purpose

show controller t1

Check errors.

If any errors occur, it is most likely a hardware problem; please contact the Cisco TAC. In addition, you can ask the service provider to test the line by using a T1 BERT test set.

Troubleshoot Channelized E1 and T1 Channel Groups

Each channelized T1 or channelized E1 channel group is treated as a separate serial interface. To troubleshoot channel groups, first verify configurations and check everything that is normally checked for serial interfaces. You can verify that the timeslots and speed are correct for the channel group by checking for CRC errors and aborts on the incoming line.


Note None of the Cisco channelized interfaces will react to any loop codes. To loop a channelized interface requires that the configuration command be entered manually.

Two loopbacks are available for channel groups:

Interface Local Loopback

Interface local loopback is a bidirectional loopback, which will loopback toward the router and toward the line. The entire set of timeslots for the channel group are looped back. The service provider can use a BERT test set to test the link from the central office to your local router, or the remote router can test using pings to their local interface (which will go from the remote site, looped back at your local site, and return to the interface on the remote site).

To place the serial interface (channel group) into local loopback, use the following command in interface configuration mode:
Command Purpose

loopback local

Place the serial interface (channel group) in local loopback.

Interface Remote Loopback

Remote loopback is the ability to put the remote DDS CSU/DSU in loopback. It will work only with channel groups that have a single DS0 (1 timeslot), and with equipment that works with a latched CSU loopback as specified in AT&T specification TR-TSY-000476, "OTGR Network Maintenance Access and Testing." To place the serial interface (channel group) in remote loopback, use the following command in interface configuration mode:
Command Purpose

loopback remote (interface)

Place the serial interface (channel group) in remote loopback.

Using the loopback remote interface command sends a latched CSU loopback command to the remote CSU/DSU. The router must detect the response code, at which time the remote loopback is verified.

Configure Switched 56k Digital Dial-In over Channelized T1 and Robbed-Bit Signaling

Internet Service Providers can provide switched 56 kbps access to their customers using a Cisco  AS5300 or Cisco AS5200. Switched 56k digital dial-in enables many services for ISPs. When using traditional ISDN PRI, the access server uses the bearer capability to determine the type of service. However when providing switched 56k over a CT1 RBS connection, the DS0s in the access server can be configured to provide either modem or 56 kbps data service. The dial-in user can access a 56 kbps data connection using either an ISDN  BRI connection or a 2- or 4-wire switched 56 kbps connection. The telco to which the access server connects must configure its switches to route 56  kbps data calls and voice (modem) calls to the appropriate DS0.

Likewise, an enterprise can provide switched 56 kbps digital dial-in services to its full time telecommuters or small remote offices using ISDN PRI or a CT1 RBS connection.

Switched 56k digital dial-in offers the following benefits:

The following prerequisites apply to the Switched 56k Digital Dial-In feature:

The following apply to Switched 56k digital dial-in:

Functional Description

The following scenario descriptions are provided, which show multiple applications for supporting switched 56k over T1 CAS:

Switched 56k and Analog Modem Calls into T1 CAS

Figure 39 shows a sample network scenario using switched 56k. Two remote PCs are dialing in to the same Cisco AS5300 to get access to the Internet. The desktop PC is making switched 56k digital calls through an external CSU/DSU. The laptop PC is making analog modem calls through a 28.8  kbps modem. The Cisco  AS5300 dynamically assigns IP addresses to each node and forwards data packets off to the switched 56k channels and onboard modems respectively.


Figure 39:
PCs Making Switched 56k and Analog Modem Calls into a Cisco AS5300


For configuration examples, see the "Comprehensive Switched 56k Startup Configuration Example" at the end of this chapter.

Basic Call Processing Components

Figure 40 shows the basic components that process switched 56k calls and analog modem calls on board a Cisco AS5200 and AS5300. Switched 56k and modem calls are signaling using robbed-bit signaling. Digital switched 56k calls utilize logical serial interfaces just like in ISDN PRI. Modem calls utilize asynchronous interfaces, lines, and modems.


Note The BRI terminal must originate its calls with a bearer capability of 56 kbps
.

Figure 40:
Processing Components for Switched 56k Calls Versus Analog Modem Calls



Note The Cisco IOS software does enable you to configure one T1 controller to support both switched 56k digital calls and analog modem calls. In this scenario,
Figure 40 would show all calls coming into the access server through one T1 line and controller. However, you must negotiate with Telco, which DSOs will support switched 56k services and which DSOs will not. On the access server, analog modem calls are not supported over DS0s that are provisioned for switched 56k. For an example software configuration, see the "Mixture of Switched 56k and Modem Calls over CT1 CAS" section at the end of this chapter.

ISDN BRI Calls into T1 CAS

Figure 41 shows how switched 56k functionality can be used to forward ISDN BRI network traffic to a Cisco AS5300, which is configured for switched 56k robbed-bit signaling over CT1.


Note The BRI terminal must originate its calls with a bearer capability of 56 kbps.

Figure 41:
Remote PC Making BRI Digital Calls via Switched 56k to a Cisco AS5300


For a configuration example on the Cisco AS5300, see the "Comprehensive Switched 56k Startup Configuration Example" section in the end of this chapter.

Figure 42 shows a sample network scenario using switched 56k. Two remote PCs are dialing in to the same Cisco AS5300 to get access to the Internet. The desktop PC is making switched 56k digital calls through an external CSU/DSU. The laptop PC is making analog modem calls through a 28.8  kbps modem. The Cisco  AS5300 dynamically assigns IP addresses to each node and forwards data packets off to the switched 56k channels and onboard modems respectively.


Figure 42:
PCs Making Switched 56k and Analog Modem Calls into a Cisco AS5300

For the startup running configuration on the Cisco AS5300 shown in Figure 42, see the section in "Comprehensive Switched 56k Startup Configuration Example" in this chapter.

Configure Switched 56k Services

This section describes how to configure switched 56k services on an access server. After the cas-group command is enabled for switched 56k services, a logical serial interface is automatically created for each 56k channel, which must also be configured.

To configure an access server to support switched 56k digital calls, use the following commands beginning in Privileged EXEC mode:
Step Command Purpose

1 . 

configure terminal

Enter global configuration mode.

2 . 

controller t1 number

Specify a T1 controller.

3 . 

framing {sf | esf}

Set the framing.

4 . 

linecode {ami | b8zs}

Define the line code.

5 . 

clock source {line {primary | secondary} | internal}

Specify the clocking.

6 . 

cas-group channel timeslots range type signal service data

Configure robbed-bit signaling for a range of timeslots. A logical serial interface is automatically created for each switched 56k channel.

7 . 

exit

Exit controller configuration mode.

8 . 

interface serial number:number

Specify logical serial interface, which was dynamically created when the cas-group is issued and configure the core protocol characteristics for the serial interface.

For configuration examples, see the "Switched 56k Configuration Examples" section in this chapter.

Configure E1 R2 Signaling

R2 signaling is an international signaling standard that is common to channelized E1 networks. However, there is no single signaling standard for R2. The ITU-T Q.400-Q.490 recommendation defines R2, but a number of countries and geographic regions implement R2 in entirely different ways. Cisco Systems addresses this challenge by supporting many localized implementations of R2 signaling in its Cisco IOS software.

The following sections offer pertinent information about the E1 R2 signaling feature:

Functional Description

Cisco System's E1 R2 signaling default is ITU, which supports the following countries: Denmark, Finland, Germany, Russia (ITU variant), Hong Kong (ITU variant), and South Africa (ITU variant). The expression "ITU variant" means there are multiple R2 signaling types in the specified country, but Cisco supports the ITU variant.

Cisco Systems also supports specific local variants of E1 R2 signaling in the following regions, countries, and corporations:


Note Only MICA modems support R2 functionality. Microcom modems do not support R2.

The following are benefits of E1 R2 signaling:

Figure 43 shows a sample network topology for using E1 R2 signaling with a Cisco AS5300. All four controllers on the access server are configured with R2 digital signaling. Additionally, localized R2 country settings are enabled on the access server.

Configuration examples are supplied in the "Channelized E1 and Channelized T1 Configuration Examples" at the end of this chapter.


Figure 43: Service Provider Using E1 R2 Signaling and a Cisco AS5300


Configure E1 R2 Signaling

R2 signaling is channelized E1 signaling used in Europe, Asia, and South America. It is equivalent to channelized T1 signaling in North America. There are two types of R2 signaling: line signaling and interregister signaling. R2 line signaling includes R2 digital, R2 analog, and R2 pulse. R2 interregister signaling includes R2 compelled, R2 non compelled, and R2 semi compelled. These signaling types are configured using the cas-group (controller e1) command.

Many countries and regions have their own E1 R2 variant specifications, which supplement the ITU-T Q.400-Q.490 recommendation for R2 signaling. Unique E1 R2 signaling parameters for specific countries and regions are set by issuing the cas-custom channel command followed by the country name command.

Cisco's implementation of R2 signaling has DNIS support turned on by default. If you enable the ani option, the collection of DNIS information is still performed. Specifying the ani option does not disable DNIS collection. DNIS is the number being called. ANI is the caller's number. For example, if you are configuring router A to call router B, then the DNIS number is assigned to router B, the ANI number is assigned to router A. ANI is similar to Caller ID.

To configure support for E1 R2 signaling, use the commands in the following table beginning in global configuration mode:
Step Command Purpose

1 . 

controller e1 number

Specify the E1 controller that you want to configure with R2 signaling.

2 . 

cas-group channel timeslots range type signal

Replace the signal variable with any of the following choices under R2 analog, R2 digital, or R2 pulse.

  • r2-analog [dtmf | r2-compelled [ani] | r2-non-compelled [ani] | r2-semi-compelled [ani]]

or

  • r2-digital [dtmf | r2-compelled [ani] | r2-non-compelled [ani] | r2-semi-compelled [ani]]

or

  • r2-pulse [dtmf | r2-compelled [ani] | r2-non-compelled [ani] | r2-semi-compelled [ani]]

Configure R2 channel associated signaling on the E1 controller. For a complete description of the available R2 options, see the cas-group  (controller  e1) command.

The R2 part of this command is defined by the signal variable in the cas-group (controller e1) command.

3 . 

cas-custom channel

Enter cas-custom mode, which enables you to localize some of the E1  R2 signaling parameters, such as a specific R2 country settings for Hong Kong. For the customizing to take effect, the channel number used in the cas-custom command must match the channel number specified by the cas-group command.

4 . 

country name use-defaults

Specify the local country, region, or corporation specification to use with R2 signaling. Replace the name variable with one of the supported country names. Cisco strongly recommends that you include the use-defaults option, which enables the default settings for a specific country. The default country setting is ITU.

See the cas-custom command in the Dial Solutions Command Reference for the list of supported countries, regions, and corporation specifications.

5 . 

  • ani-digits

  • answer-signal

  • caller-digits

  • category

  • country

  • default

  • dnis-digits

  • invert-abcd

  • ka

  • kd

  • metering

  • nc-congestion

  • unused-abcd

  • request-category

(Optional) Further customize the R2 signaling parameters. Some switch types require you to fine tune your R2 settings. Do not tamper with these commands unless you fully understand your switch's requirements.

In nearly all cases, the country name use-defaults command fully configures your country's local settings. You should not need to use the commands in Step 5.

See the cas-custom command reference page for more information about each signaling command.

Monitor E1 R2 Signaling

Use the following commands to monitor E1 R2 signaling:
Command Purpose

show controller e1 or

show controller e1 number

View the status for all controllers or a specific controller. Ensure the status indicates the controller is up and there are no alarms or errors (lines 2, 4, 9, and 10 as shown in Figure 44).

show modem csm [slot/port | group number]

View status for a specific modem as shown in Figure 45.


Figure 44: Monitoring E1 R2 Using the Show controller E1 Command

5300# show controller e1 0
E1 0 is up.
  Applique type is Channelized E1 - balanced
  No alarms detected.
  Version info of Slot 0:  HW: 2, Firmware: 4, PLD Rev: 2
 
Manufacture Cookie is not programmed.
 
  Framing is CRC4, Line Code is HDB3, Clock Source is Line Primary.
  Data in current interval (785 seconds elapsed):
     0 Line Code Violations, 0 Path Code Violations
     0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
  Total Data (last 13 15 minute intervals):
     0 Line Code Violations, 0 Path Code Violations,
     0 Slip Secs, 12 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,
     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 12 Unavail Secs

Figure 45:
Monitoring E1 R2 Signaling Using the Show Modem CSM Command

5300# show modem csm 1/0
MODEM_INFO: slot 1, port 0, unit 0, tone r2-compelled, modem_mask=0x0000, 
modem_port_offset=0
tty_hwidb=0x60E63E4C, modem_tty=0x60C16F04, oobp_info=0x00000000, 
modem_pool=0x60BC60CC
modem_status(0x0002): VDEV_STATUS_ACTIVE_CALL.
csm_state(0x0205)=CSM_IC5_CONNECTED, csm_event_proc=0x600CFF70, current call thru 
CAS line
invalid_event_count=0, wdt_timeout_count=0
wdt_timestamp_started is not activated
wait_for_dialing:False, wait_for_bchan:False
pri_chnl=TDM_PRI_STREAM(s0, u3, c7), modem_chnl=TDM_MODEM_STREAM(s1, c0)
dchan_idb_start_index=0, dchan_idb_index=0, call_id=0x0239, bchan_num=6
csm_event=CSM_EVENT_DSX0_CONNECTED, cause=0x0000
ring_no_answer=0, ic_failure=0, ic_complete=3
dial_failure=0, oc_failure=0, oc_complete=0
oc_busy=0, oc_no_dial_tone=0, oc_dial_timeout=0
remote_link_disc=2, stat_busyout=2, stat_modem_reset=0
oobp_failure=0
call_duration_started=00:04:56, call_duration_ended=00:00:00, 
total_call_duration=00:01:43
The calling party phone number = 
The called party phone number  = 9993003
total_free_rbs_timeslot = 0, total_busy_rbs_timeslot = 0, 
total_dynamic_busy_rbs_timeslot = 0, total_static_busy_rbs_timeslot = 0, 
min_free_modem_threshold = 0

Troubleshoot E1 R2 Signaling

If the connection does not come up, check the following:

If problems persist, enable the modem management Call Switching Module (CSM) debug mode, using the debug modem csm command, as shown in Figure 46.


Figure 46: Debug E1 R1 Signaling Using the Debug Modem Command

5300# debug modem csm 1/0
*May 15 04:05:46.675: VDEV_ALLOCATE: slot 2 and port 39 is allocated.
 
*May 15 04:05:46.675: CSM_RX_CAS_EVENT_FROM_NEAT:(04BF):  EVENT_CALL_DIAL_IN at 
slot 2 and port 39
 
*May 15 04:05:46.675: CSM_PROC_IDLE: CSM_EVENT_DSX0_CALL at slot 2, port 39
 
*May 15 04:05:46.675: Mica Modem(2/39): Configure(0x0) 
*May 15 04:05:46.675: Mica Modem(2/39): Configure(0x3) 
*May 15 04:05:46.675: Mica Modem(2/39): Configure(0x6) 
*May 15 04:05:46.675: Mica Modem(2/39): Call Setup
*May 15 04:05:46.891: Mica Modem(2/39): State Transition to Call Setup
*May 15 04:05:46.891: Mica Modem(2/39): Went offhook
*May 15 04:05:46.891: CSM_PROC_IC1_RING: CSM_EVENT_MODEM_OFFHOOK at slot 2, port 39

When the E1 controller comes up, you will see the following messages:

%CONTROLLER-3-UPDOWN: Controller E1 0, changed state to up
It also shows these messages for individual timeslots:
%DSX0-5-RBSLINEUP: RBS of controller 1 timeslot 1 is up
%DSX0-5-RBSLINEUP: RBS of controller 1 timeslot 2 is up
%DSX0-5-RBSLINEUP: RBS of controller 1 timeslot 3 is up
%DSX0-5-RBSLINEUP: RBS of controller 1 timeslot 4 is up
%DSX0-5-RBSLINEUP: RBS of controller 1 timeslot 5 is up
%DSX0-5-RBSLINEUP: RBS of controller 1 timeslot 6 is up
%DSX0-5-RBSLINEUP: RBS of controller 1 timeslot 7 is up
%DSX0-5-RBSLINEUP: RBS of controller 1 timeslot 8 is up

Configure R1 Modified Signaling

Enabling R1 Modified Signaling allows a Cisco AS5200 or Cisco AS5300 universal access server to talk to central office trunks that also use R1 Modified Signaling. R1 Signaling is an international signaling standard that is common to channelized T1/E1 networks; however, Cisco only has made this feature available in Taiwan. You can configure a channelized T1/E1 interface to support different types of R1 Modified Signaling, which is used in older analog telephone networks.

Cisco now supports native R1 signaling on both E1 and T1 interfaces. This version of software supports R1 signaling customized for Taiwan only. This feature allows enterprises and service providers to fully interoperate with the installed Taiwanese telecommunications standards, providing interoperability in addition to the vast array of Cisco's IOS troubleshooting and diagnostic capability. This will provide customers with a seamless, single-box, solution for their Taiwan signaling requirements.

The following prerequisites restrictions apply to the R1 Modified Signaling feature:

Figure 47 illustrates a service provider using R1 Signaling with E1 and a Cisco AS5200 access server. The network topology would be the same for T1 and/or a Cisco AS5300 access server.


Figure 47: Service Provider Using E1 R1 Signaling with a Cisco AS5200


Configure R1 Modified Signaling

R1 modified signaling can be configured on a Cisco AS5200 or a Cisco AS5300, using either T1 or E1 interface types. Use the commands in the following sections to configure R1 modified signaling:

Configure R1 Modified Signaling on a T1 Interface

To configure R1 modified signaling on a T1 interface, use the following commands:.
Step Command Purpose
1

enable

password

Enter enable mode.

Enter the password.

You have entered enable mode when the prompt changes to 5300#.

2

configure terminal

Enter global configuration mode. You have entered global configuration mode when the prompt changes to 5300(config)#.

3

controller t1 [0  |  1  |  2  |  3]

Enter controller configuration mode to configure your T1 controller port. The T1 controller ports are labeled 0-3 on the quad T1/PRI cards.

4

framing {sf|esf}

Entering framing sf configures framing to T1 with sf.

Entering framing esf configures framing to T1 only.

5

linecode {ami | b8zs}

Entering linecode ami configures line code to AMI1 encoding.

Entering linecode b8zs configures line code to b8zs encoding.

6

clock source {internal | line [primary | secondary]}

Entering clock source internal configures the clock source to the internal clock.

Entering clock source line primary configures the clock source to the primary recovered clock.

Entering clock source secondary configures the clock source to the secondary recovered clock.

7

cas-group 1 timeslots 1-24 type r1-modified {ani-dnis | dnis}

Configure the timeslots that belong to each T1 circuit for R1 Modified Signaling. 2

  • The cas-group # ranges from 0 to 23 for CT1.

  • The timeslot # ranges from 1 to 24 for CT1.

  • For the type, each cas-group can be configured as one of the Robbed-Bit Signaling provisions.

  • ani-dnis indicates R1 will collect ani and dnis information; dnis indicates R1 will collect only dnis information.

8

^Z

Return to enable mode by simultaneously pressing the Ctrl key and the z key.

This message is normal and does not indicate an error.

1AMI = Alternate Mark Inversion.
2For additional details about the syntax and variables of this command see the Dial Solutions Command Reference in Cisco IOS Release 12.0.


Note The sample prompts and output are the same for both the Cisco AS5200 and the Cisco  AS5200.

Configure R1 Modified Signaling on an E1 Interface

To configure R1 modified signaling on an E1 interface, use the following commands:
Step Command Purpose
1

enable

password

Enter enable mode.

Enter the password.

You have entered enable mode when the prompt changes to 5300#.

2

configure terminal

Enter global configuration mode. You have entered global configuration mode when the prompt changes to 5300(config)#.

3

controller e1 [0  |  1  |  2  |  3]

Enter controller configuration mode to configure your E1 controller ports. The E1 controller ports are labeled 0-3 on the quad E1/PRI cards.

4

framing {crc4 | no-crc4}

Entering framing crc4 configures framing to E1 with cyclic redundancy check (CRC)

Entering framing no-crc4 configures framing to E1 only.

5

linecode {ami | hdb3}

Entering linecode ami configures line code to alternate mark inversion (AMI) encoding.

Entering linecode hdb3 configures line code to high-density bipolar (HDB) encoding.

6

clock source {internal | line [primary |secondary]}

Entering clock source internal configures the clock source to the internal clock.

Entering clock source line primary configures the clock source to the primary recovered clock.

Entering clock source secondary configures the clock source to the secondary recovered clock.

7

cas-group 1 timeslots 1-15, 17-31 type r1-modified {ani-dnis | dnis}

Configure the timeslots that belong to each E1 circuit for R1 Modified Signaling.

  • The cas-group # ranges from 0 to 30 for CE1.

  • The timeslot # ranges from 1 to 31 for CE1.

  • For the type, each cas-group can be configured as one of the Robbed-Bit Signaling provisions.

  • ani-dnis indicates R1 will collect ani and dnis information; dnis indicates R1 will collect only dnis information.

8

cas-custom 1

(Optional) Enter the channel number to customize.

9

^Z

Return to enable mode by simultaneously pressing the Ctrl key and the z key.

This message is normal and does not indicate an error.

Channelized E1 and Channelized T1 Configuration Examples

ISDN PRI Examples

This section contains the following ISDN PRI examples:

NSF Call-by-Call Support Example

The following example configures Network-Specific Facility (NSF), needed for an AT&T 4ESS switch when it is configured for Call-by-Call selection. The PRI 4ESS switch expects some AT&T-specific information when placing outgoing ISDN PRI voice calls; the options are accunet, sdn, and megacom.

This example shows both the controller and interface commands required to make the ISDN interface operational and the DDR commands, such as the dialer map, dialer-group, and map-class dialer commands, that are needed to configure the ISDN interface to make outgoing calls.

! The following lines configure the channelized T1 controller; all timeslots are
! configured for ISDN PRI. 
!
controller t1 1/1
 framing esf 
 linecode b8zs
 pri-group timeslots 1-23
 isdn switchtype primary-4ess 
!
! The following lines configure the D channel for DDR. This configuration applies
! to all B channels on the ISDN PRI interface.
!
interface serial 1/1:23
 description Will mark outgoing calls from AT&T type calls.
 ip address 7.1.1.1 255.255.255.0
 encapsulation ppp
 dialer map ip 7.1.1.2 name tommyjohn class sdnplan 14193460913
 dialer map ip 7.1.1.3 name angus class megaplan 14182616900
 dialer map ip 7.1.1.4 name angus class accuplan 14193453730
dialer-group 1
 ppp authentication chap
map-class dialer sdnplan
 dialer outgoing sdn
map-class dialer megaplan
 dialer voice-call
 dialer outgoing mega
map-class dialer accuplan
 dialer outgoing accu

PRI on a Cisco AS5200 Examples

The following example configures ISDN PRI on the appropriate interfaces for IP dial-in on channelized T1:

! T1 PRI controller configuration
controller T1 0
 framing esf
 linecode b8zs
 clock source line primary
 pri-group timeslots 1-24
!
controller T1 1
 framing esf
 linecode b8zs
 clock source line secondary
 pri-group timeslots 1-24
!
interface Serial0:23
 isdn incoming-voice modem
 dialer rotary-group 1
!
interface Serial1:23 
 isdn incoming-voice modem
 dialer rotary-group 1
!
interface Loopback0
 ip address 172.16.254.254 255.255.255.0
!
interface Ethernet0
 ip address 172.16.1.1 255.255.255.0
!
interface Group-Async1
 ip unnumbered Loopback0
 ip tcp header-compression passive
 encapsulation ppp
 async mode interactive
 peer default ip address pool default
 dialer-group 1
 ppp authentication chap pap default 
 group-range 1 48
!
interface Dialer1
 ip unnumbered Loopback0
 encapsulation ppp
 peer default ip address pool default
 ip local pool default 172.16.254.1 172.16.254.48
 dialer in-band
 dialer-group 1
 dialer idle-timeout 3600
 ppp multilink
 ppp authentication chap pap default 

The following example configures ISDN PRI on the appropriate interfaces for IP dial-in on channelized E1:

! E1 PRI controller configuration
controller E1 0
   framing crc4
 linecode hdb3
 clock source line primary
 pri-group timeslots 1-31
!
controller E1 1
 framing crc4
 linecode hdb3
 clock source line secondary
 pri-group timeslots 1-31
interface serial0:15
 isdn incoming-voice modem
 dialer rotary-group 1
!
interface serial1:15
 isdn incoming-voice modem
 dialer rotary-group 1
!
interface loopback0
 ip address 172.16.254.254 255.255.255.0
!
interface ethernet0
 ip address 172.16.1.1 255.255.255.0
!
!The following block of commands configures DDR for all the ISDN PRI interfaces 
!configured above. The dialer-group and dialer rotary-group commands tie the
!interface configuration blocks to the DDR configuration.
! 
interface dialer1
 ip unnumbered loopback0
 encapsulation ppp
 peer default ip address pool default
 ip local pool default 172.16.254.1 172.16.254.60 
 dialer in-band
 dialer-group 1
 dialer idle-timeout 3600
 ppp multilink
 ppp authentication chap pap default 

Multiple ISDN Switch Types Examples

The following example configures an ISDN switch type of primary-4ess on channelized T1 controller 0 and a switch type of primary-net5 for channelized T1 controller 1.

controller t1 0
  framing esf
  linecode b8zs
  isdn switchtype primary-4ess
! controller t1 1  framing esf  linecode b8zs  isdn switchtype primary-net5

The following example shows BRI interface 0 configured for a basic-net3 switch type that will override the basic-ni switch type configured globally. The PRI interface (channelized T1 controller), is configured for ISDN switch type primary-net5 and is applied only to the PRI interface.

isdn switch-type basic-ni
!
interface BRI0
 isdn switch-type basic-net3

interface serial0:23
! Apply the primary-net5 switch to this interface only
 isdn switch-type primary-net5

Outgoing B Channel Ascending Call Order Example

The following example configures the router to use global isdn switch-type primary-ni and configures the ISDN outgoing call channel selection to be made in ascending order:

isdn switch-type primary-ni
!
interface serial0:23
 isdn bchan-number-order ascending

PRI Groups and Channel Groups on the Same Channelized T1 Controller Example

The following example shows a channelized T1 controller configured for PRI groups and for channel groups. The pri-group command and the channel-group command cannot have overlapping timeslots; note the correct timeslot configuration in this example.

controller t1 0
channel-group 0 timeslot 1-6
channel-group 1 timeslot 7
channel-group 2 timeslot 8
channel-group 3 timeslot 9-11
pri-group timeslot 12-24

The same type of configuration also applies to channelized E1.

Robbed-Bit Signaling Examples

This section provides sample configurations for the Cisco AS5200's T1 controllers. You can configure the 24 channels of a channelized T1 to support ISDN PRI, robbed-bit signaling, channel grouping, or a combination of all three. It provides the following sections:

Allocating All Channels for Robbed-Bit Signaling Example

The following example configures all 24 channels to support robbed-bit signaling feature group B on a Cisco AS5200:

controller T1 0
 cas-group 1 timeslots 1-24 type e&m-fgb

Mixing and Matching Channels Example

The following example shows you how to configure all 24 channels to support a combination of ISDN PRI, robbed-bit signaling, and channel grouping. The range of timeslots that you allocate must match the timeslot allocations that your central office chooses to use. This is a rare configuration due to the complexity of aligning the correct range of timeslots on both ends of the connection.

The following configuration creates serial interfaces 0 to 9, which correspond to ISDN PRI timeslots 1 to 10 (shown as serial 1:0 through serial 1:9). The serial line 1:23 is the D channel, which carries the analog signal bits that dial a modem's phone number and determine if a modem is busy or available. The D channel is automatically created and assigned to timeslot 24.

controller T1 0
! ISDN PRI is configured on timeslots 1 through 10.
 pri-group timeslots 1-10
! Channelized T1 data is transmitted over timeslots 11 through 16.
 channel-group 11 timeslots 11-16
! The channel-associated signal ear and mouth feature group B is configured on
! virtual signal group 17 for timeslots 17 to 23, which are used for incoming 
! and outgoing analog calls. 
 cas-group 17 timeslots 17-23 type e&m-fgb

There is no specific interface, such as the serial interface shown in the earlier examples, that corresponds to the timeslot range.

Switched 56k Configuration Examples

The following switched 56k configuration examples are provided:

Switched 56k T1 Controller Example

The following shows how to configure one T1 controller on a Cisco AS5300 to support switched 56k digital calls. The Cisco AS5300 has four controllers, which are numbered 0 to 3. If you want all four T1s to support switched 56k calls, then repeat this procedure on each T1 controller.


Note Use this same procedure for configuring a Cisco AS5200.

Step 1 Enter global configuration mode using the configure terminal command:

Step 2 Specify a T1 controller with the controller t1 number command. Replace the number variable with a controller number between 0 and 3.

Step 3 Configure robbed-bit signaling on a range of timeslots then specify switched 56k digital services using the cas-group command. In this example, all calls coming into controller T1 1 are expected to be switched 56k data calls, not analog modem calls.

Step 4 Set the framing for your network environment. You can choose extended superframe (enter framing esf) or superframe (enter framing sf).

Step 5 Set the line code type for your network environment. You can choose AMI encoding (enter linecode ami) or B8ZS encoding (enter linecode b8zs).

Mixture of Switched 56k and Modem Calls over CT1 CAS

The following example configures one T1 controller to accept incoming switched 56k digital calls and analog modem calls over the same T1 CAS line. Timeslots 1 through 10 are provisioned by the telco to support switched 56k digital calls. Timeslots 11 through 24 are provisioned to support analog modem calls. Due to the DS0s provisioning, it is impossible for analog modems calls to transmit over the DS0s that map to timeslots 1 through 10.

router(config)# controller T1 0
router(config-controller)# cas-group 1 timeslots 1-10 type e&m-fgb service data
router(config-controller)# cas-group 1 timeslots 11-24 type e&m-fgb service voice
router(config-controller)# framing esf
router(config-controller)# clock source line primary
router(config-controller)# linecode b8zs
router(config-controller)# exit

Switched 56k and Analog Modem Calls over Separate T1 CAS Lines

The following example configures one Cisco AS5300 to accept 50 percent switched 56k digital calls and 50 percent analog modem calls. The controllers T1 0 and T1 1 are configured to support the switched 56k digital calls using the cas-group 1 timeslots 1-24 type e&m-fgb service digital command. The controllers T1 2 and T1 3 are configured to support analog modem calls.

router(config)# controller T1 0
router(config-controller)# cas-group 1 timeslots 1-24 type e&m-fgb service data
router(config-controller)# framing esf
router(config-controller)# clock source line primary
router(config-controller)# linecode b8zs
router(config-controller)# exit
router(config)# controller T1 1
router(config-controller)# cas-group 1 timeslots 1-24 type e&m-fgb service data
router(config-controller)# framing esf
router(config-controller)# clock source line secondary
router(config-controller)# linecode b8zs
router(config-controller)# exit
router(config)# controller T1 2
router(config-controller)# cas-group 1 timeslots 1-24 type e&m-fgb service voice
router(config-controller)# framing esf
router(config-controller)# clock source internal
router(config-controller)# linecode b8zs
router(config-controller)# exit
router(config)# controller T1 3
router(config-controller)# cas-group 1 timeslots 1-24 type e&m-fgb service voice
router(config-controller)# framing esf
router(config-controller)# clock source internal
router(config-controller)# linecode b8zs
router(config-controller)# exit
router(config)# copy running-config startup-config

Comprehensive Switched 56k Startup Configuration Example

The startup configuration in this section runs on the Cisco AS5300 in Figure 42. This configuration is for an IP dial-in scenario with a mix of switched 56k calls and modem calls. Switched 56k digital calls come into controllers T1 0 and T1 1. Analog modem calls come into controllers T1  2 and T1 3.

In this example, the switched 56k clients are single end points in a remote node configuration. If each switched 56k client were instead a router with a LAN behind it without port address translation (PAT) turned on, then a static address, subnet mask, and route must be configured for each remote end point. This is best done through RADIUS.

After a T1 timeslot is configured with robbed-bit signaling using the cas-group command with the service data option, a logical serial interface is instantly created for each switched 56k channel. For example, signaling configured on all 24 timeslots of controller T1 1 dynamically creates serial interfaces S0:0 through S0:23. You must then configure protocol support on each serial interface. No interface group command exists for serial interfaces, unlike asynchronous interfaces via the interface group-async command. Each serial interface must be individually configured. In most cases, the serial configurations will be identical. To streamline or shorten this configuration task, you might consider using a dialer interface as shown in the example.


Note In this example, only analog modem calls encounter the group asynchronous and line interfaces. Switched 56k calls encounter the logical serial interfaces and dialer interface.
!
version 11.3
service timestamps debug datetime msec 
service timestamps log datetime msec
service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname 5300
!
aaa new-model
aaa authentication login default local
aaa authentication login console enable
aaa authentication login vty local
aaa authentication login dialin radius
aaa authentication ppp default local
aaa authentication ppp dialin if-needed radius
aaa authorization exec local radius
aaa authorization network radius
aaa accounting network start-stop radius
aaa accounting exec start-stop radius
!
enable secret cisco
!
username admin password cisco
async-bootp dns-server 10.1.3.1 10.1.3.2
!
!
!Switched 56k calls come into controllers T1 0 and T1 1. Take note of the keywords 
!"service data" in the cas-group command.
!
controller T1 0
 framing esf
 clock source line primary
 linecode b8zs
 cas-group 0 timeslots 1-24 type e&m-fgb service data
!
controller T1 1
 framing esf
 clock source line secondary
 linecode b8zs
 cas-group 1 timeslots 1-24 type e&m-fgb service data
!
!Analog modem calls come into controllers T1 2 and T1 3.
!
controller T1 2
 framing esf
 clock source line internal
 linecode b8zs
 cas-group 2 timeslots 1-24 type e&m-fgb 
!
controller T1 3
 framing esf
 clock source line internal
 linecode b8zs
 cas-group 3 timeslots 1-24 type e&m-fgb 
!
interface loopback0
  ip address 10.1.2.62 255.255.255.192
!
interface Ethernet0
 no ip address 
  shutdown
!
interface FastEthernet0
 ip address 10.1.1.11 255.255.255.0
 ip summary address eigrp 10.10.1.2.0 255.255.255.192
!
! Interface serial0:0 maps to the first switched 56k channel. The dialer pool-member 
!  command connects ! this channel to dialer interface 1.
!
interface Serial0:0 
  dialer rotary-group 1
! 
interface Serial0:1 
  dialer rotary-group 1
!
interface Serial0:2
  dialer rotary-group 1
!
interface Serial0:3
  dialer rotary-group 1
!
interface Serial0:4
  dialer rotary-group 1
!
interface Serial0:5
  dialer rotary-group 1
!
interface Serial0:6
  dialer rotary-group 1
!
interface Serial0:7
  dialer rotary-group 1
!
interface Serial0:8
  dialer rotary-group 1
!
interface Serial0:9
  dialer rotary-group 1
!
interface Serial0:10
  dialer rotary-group 1
!
interface Serial0:11
  dialer rotary-group 1
!
interface Serial0:12
  dialer rotary-group 1
!
interface Serial0:13
  dialer rotary-group 1
!
interface Serial0:14
  dialer rotary-group 1
!
interface Serial0:15
  dialer rotary-group 1
!
interface Serial0:16
  dialer rotary-group 1
!
interface Serial0:17
  dialer rotary-group 1
!
interface Serial0:18
  dialer rotary-group 1
!
interface Serial0:19
  dialer rotary-group 1
!
interface Serial0:20
  dialer rotary-group 1
!
interface Serial0:21
  dialer rotary-group 1
!
interface Serial0:22
  dialer rotary-group 1
!
!Interface serial 0:23 is the last switched 56k channel for controller T1 0.
!
interface Serial0:23
  dialer rotary-group 1
!
!The switched 56k channels for controller T1 1 begin with interface serial 1:0 and end 
!with interface serial 1:23.
!
interface Serial1:0
  dialer rotary-group 1
!
interface Serial1:1
  dialer rotary-group 1
!
interface Serial1:2
  dialer rotary-group 1
!
interface Serial1:3
  dialer rotary-group 1
!
interface Serial1:4
  dialer rotary-group 1
!
interface Serial1:5
  dialer rotary-group 1
!
interface Serial1:6
  dialer rotary-group 1
!
interface Serial1:7
  dialer rotary-group 1
!
interface Serial1:8
  dialer rotary-group 1
!
interface Serial1:9
  dialer rotary-group 1
!
interface Serial1:10
  dialer rotary-group 1
!
interface Serial1:11
  dialer rotary-group 1
!
interface Serial1:12
  dialer rotary-group 1
!
interface Serial1:13
  dialer rotary-group 1
!
interface Serial1:14
  dialer rotary-group 1
!
interface Serial1:15
  dialer rotary-group 1
!
interface Serial1:16
  dialer rotary-group 1
!
interface Serial1:17
  dialer rotary-group 1
!
interface Serial1:18
  dialer rotary-group 1
!
interface Serial1:19
  dialer rotary-group 1
!
interface Serial1:20
  dialer rotary-group 1
!
interface Serial1:21
  dialer rotary-group 1
!
interface Serial1:22
  dialer rotary-group 1
!
interface Serial1:23
  dialer rotary-group 1
!
interface Group-Async1
 ip unnumbered Loopback0
 encapsulation ppp
  async mode interactive
  peer default ip address pool dialin_pool
 no cdp enable
 ppp authentication chap pap dialin
 group-range 1 96
!
interface Dialer1 
 ip unnumbered Loopback0
 no ip mroute-cache
 encapsulation ppp
  peer default ip address pool dialin_pool
 no fair-queue
 no cdp enable
 ppp authentication chap pap dialin
!
router eigrp 10
  network 10.0.0.0
  passive-interface Dialer0
  no auto-summary
!
ip local pool dialin_pool 10.1.2.1 10.1.2.96
ip default-gateway 10.1.1.1
ip classless
!
dialer-list 1 protocol ip permit
radius-server host 10.1.1.23 auth-port 1645 acct-port 1646
radius-server host 10.1.1.24 auth-port 1645 acct-port 1646
radius-server key cisco
!
line con 0
  login authentication console
line 1 96
 autoselect ppp
  autoselect during-login
  login authentication dialin
  modem DialIn
line aux 0
  login authentication console
line vty 0 4
  login authentication vty
  transport input telnet rlogin
!
end

ISDN Channel-Associated Signaling Examples

This section provides channelized E1 sample configurations for the Cisco AS5200. You can configure the 30 available channels with channel-associated signaling, channel grouping, or a combination of the two.

Allocate All Channels for Channel-Associated Signaling

The following interactive example configures channels (also known as timeslots) 1-30 with ear and mouth channel signaling and feature group B support on a Cisco  AS5200; it also shows that the router displays informative messages about each timeslot. Signaling messages are transmitted in the 16th timeslot; therefore, that timeslot is not brought up.

Router#
%SYS-5-CONFIG_I: Configured from console by console
Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# controller e1 0
Router(config-controller)# cas-group 1 timeslots 1-31 type e&m-fgb
Router(config-controller)#
%DSX0-5-RBSLINEUP: RBS of controller 0 timeslot 1 is up
%DSX0-5-RBSLINEUP: RBS of controller 0 timeslot 2 is up
%DSX0-5-RBSLINEUP: RBS of controller 0 timeslot 3 is up
%DSX0-5-RBSLINEUP: RBS of controller 0 timeslot 4 is up
%DSX0-5-RBSLINEUP: RBS of controller 0 timeslot 5 is up
%DSX0-5-RBSLINEUP: RBS of controller 0 timeslot 6 is up
%DSX0-5-RBSLINEUP: RBS of controller 0 timeslot 7 is up
%DSX0-5-RBSLINEUP: RBS of controller 0 timeslot 8 is up
%DSX0-5-RBSLINEUP: RBS of controller 0 timeslot 9 is up
%DSX0-5-RBSLINEUP: RBS of controller 0 timeslot 10 is up
%DSX0-5-RBSLINEUP: RBS of controller 0 timeslot 11 is up
%DSX0-5-RBSLINEUP: RBS of controller 0 timeslot 12 is up
%DSX0-5-RBSLINEUP: RBS of controller 0 timeslot 13 is up
%DSX0-5-RBSLINEUP: RBS of controller 0 timeslot 14 is up
%DSX0-5-RBSLINEUP: RBS of controller 0 timeslot 15 is up
%DSX0-5-RBSLINEUP: RBS of controller 0 timeslot 17 is up
%DSX0-5-RBSLINEUP: RBS of controller 0 timeslot 18 is up
%DSX0-5-RBSLINEUP: RBS of controller 0 timeslot 19 is up
%DSX0-5-RBSLINEUP: RBS of controller 0 timeslot 20 is up
%DSX0-5-RBSLINEUP: RBS of controller 0 timeslot 21 is up
%DSX0-5-RBSLINEUP: RBS of controller 0 timeslot 22 is up
%DSX0-5-RBSLINEUP: RBS of controller 0 timeslot 23 is up
%DSX0-5-RBSLINEUP: RBS of controller 0 timeslot 24 is up
%DSX0-5-RBSLINEUP: RBS of controller 0 timeslot 25 is up
%DSX0-5-RBSLINEUP: RBS of controller 0 timeslot 26 is up
%DSX0-5-RBSLINEUP: RBS of controller 0 timeslot 27 is up
%DSX0-5-RBSLINEUP: RBS of controller 0 timeslot 28 is up
%DSX0-5-RBSLINEUP: RBS of controller 0 timeslot 29 is up
%DSX0-5-RBSLINEUP: RBS of controller 0 timeslot 30 is up
%DSX0-5-RBSLINEUP: RBS of controller 0 timeslot 31 is up

Mix and Match Channels

The following interactive example shows you how to configure an E1 controller to support a combination of channel-associated signaling and channel grouping. The range of timeslots that you allocate must match the timeslot allocations that your central office chooses to use. This is a rare configuration because of the complexity of aligning the correct range of timeslots on both ends of the connection.

Timeslots 1 through 15 are assigned to channel group 1. In turn, these timeslots are assigned to serial interface 0 and virtual channel group 1 (shown as serial 0:1).

AS5200(config)# controller e1 0
Router(config-controller)# channel-group 1 timeslots 1-15
Router(config-controller)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0:1, changed state to down
%LINK-3-UPDOWN: Interface Serial0:1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0:1, changed state to up

Timeslots 17 to 31 are configured with channel associated signaling.

Router(config-controller)# cas-group 2 timeslots 17-31 type e&m-fgb
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0:1, changed state to down
Router(config-controller)#
%DSX0-5-RBSLINEUP: RBS of controller 0 timeslot 17 is up
%DSX0-5-RBSLINEUP: RBS of controller 0 timeslot 18 is up
%DSX0-5-RBSLINEUP: RBS of controller 0 timeslot 19 is up
%DSX0-5-RBSLINEUP: RBS of controller 0 timeslot 20 is up
%DSX0-5-RBSLINEUP: RBS of controller 0 timeslot 21 is up
%DSX0-5-RBSLINEUP: RBS of controller 0 timeslot 22 is up
%DSX0-5-RBSLINEUP: RBS of controller 0 timeslot 23 is up
%DSX0-5-RBSLINEUP: RBS of controller 0 timeslot 24 is up
%DSX0-5-RBSLINEUP: RBS of controller 0 timeslot 25 is up
%DSX0-5-RBSLINEUP: RBS of controller 0 timeslot 26 is up
%DSX0-5-RBSLINEUP: RBS of controller 0 timeslot 27 is up
%DSX0-5-RBSLINEUP: RBS of controller 0 timeslot 28 is up
%DSX0-5-RBSLINEUP: RBS of controller 0 timeslot 29 is up
%DSX0-5-RBSLINEUP: RBS of controller 0 timeslot 30 is up
%DSX0-5-RBSLINEUP: RBS of controller 0 timeslot 31 is up
Router(config-controller)#

E1 R2 Signaling Examples

The following example configures R2 signaling and customizes R2 parameters on controller E1 2 of a Cisco  AS5300. In most cases, the same R2 signaling type is configured on each E1 controller.

Step 1 Enter global configuration mode using the configure terminal command:

Step 2 Specify the E1 controller that you want to configure with R2 signaling using the controller e1 number global configuration command. A controller informs the access server how to distribute or provision individual timeslots for a connected channelized E1 line. You must configure one E1 controller for each E1 line.

Step 3 Configure channel associated signaling with the cas-group channel timeslots range type signal command. The signaling type forwarded by the connecting telco switch must match the signaling configured on the Cisco  AS5300. The Cisco IOS configuration options are r2-analog, r2-digital, or r2-pulse.

The following example specifies R2 ITU Q421 digital line signaling (r2-digital). This example also specifies R2 compelled register signaling and provisions the ANI ADDR option.

Step 4 Customize some of the E1 R2 signaling parameters with the cas-custom channel controller configuration command. This example specifies the default R2 settings for Argentina. For custom options, see the cas-custom command in the Dial Configurations Command Reference in Cisco IOS Release 12.0.




R1 Modified Signaling Configuration Example

The following example shows a configuration sample for R1 modified signaling, using an E1 interface:

version 11.3
service timestamps debug datetime msec
no service password-encryption
!
hostname router
!
enable secret 5 $1$YAaG$L0jTcQ.nMH.gpFYXaOU5c.
!
no modem fast-answer
ip host dirt 223.255.254.254
ip multicast rpf-check-interval 0
isdn switch-type primary-dms100
!
!
controller E1 0
 clock source line primary
 cas-group 1 timeslots 1-15,17-31 type r1-modified  ani-dnis
!
controller E1 1
 clock source line secondary
 cas-group 1 timeslots 1-15,17-31 type r1-modified  ani-dnis
!
controller E1 2
 clock source internal
!
controller E1 3
 clock source internal
!
interface Ethernet0
 ip address 1.19.36.7 255.255.0.0
 no ip mroute-cache
!
interface FastEthernet0
 no ip address
 no ip route-cache
 no ip mroute-cache
 shutdown
!
interface Group-Async1
 ip unnumbered Ethernet0
 encapsulation ppp
 dialer in-band
 dialer idle-timeout 480
 dialer-group 1
 async dynamic address
 async mode interactive
 peer default ip address pool DYNAMIC
 no fair-queue
 no cdp enable
 group-range 1 108
!
router igrp 200
 network 1.0.0.0
 network 223.255.254.0
!
no ip classless
ip route 0.0.0.0 0.0.0.0 Ethernet0
logging source-interface Ethernet0
!
line con 0
 exec-timeout 0 0
line 1 108
 exec-timeout 0 0
 modem InOut
 transport input all
line aux 0
line vty 0 4
!
end


hometocprevnextglossaryfeedbacksearchhelp
Copyright 1989-1998 © Cisco Systems Inc.