Полезная информация

cc/td/doc/product/software/ios120/120newft/120t
hometocprevnextglossaryfeedbacksearchhelp
PDF

Table of Contents

ISDN PRI QSIG Voice Signaling

Feature Summary

Platforms

Prerequisites

Supported MIBs and RFCs

Configuration Tasks

Command Reference

ISDN PRI QSIG Voice Signaling

Feature Summary

The QSIG protocol provides signaling for Private Integrated services Network Exchange (PINX) devices. It is based on the ISDN Q.931 standard. Using QSIG PRI signaling, the Cisco MC3810 can route incoming voice calls from a PINX across a WAN to a peer Cisco MC3810, which can then transport the signaling and voice packets to a second PINX.


Note In Cisco IOS Release 12.0(2)T, the Cisco MC3810 supports ISDN PRI only when a QSIG connection to the PINX is configured on the DVM T1/E1 controller.

Benefits

ISDN PRI QSIG Voice Signaling provides the following benefits:

List of Terms

DVM---Digital voice module

PINX---Private integrated services network exchange

Restrictions

The following restrictions and limitations apply to the Cisco MC3810 QSIG PRI implementation:

Platforms

This feature is supported on the Cisco MC3810 only.

Prerequisites

The following configuration tasks should be completed before configuring this feature:

Supported MIBs and RFCs

None.

Configuration Tasks

Figure 1 shows an example of a QSIG signaling configuration. In the example, the Cisco  MC3810 either acts as a master to a slave PBX, or as a slave to a master PBX.


Figure 1: QSIG Signaling Configuration


To configure QSIG PRI signaling support on the Cisco MC3810, complete the following steps beginning in global configuration mode:

Step Command Purpose

1

isdn switch-type [primary-qsig-slave | primary-qsig-master]

Configure the ISDN switch type to serve either as the primary QSIG slave or the primary QSIG master.

If the PINX is the primary QSIG master, configure the Cisco  MC3810 to serve as the primary QSIG slave. If the PINX is the primary QSIG slave, configure the Cisco  MC3810 to serve as the primary QSIG master.

Note You can configure the ISDN switch type using either this global command, or this same command in interface configuration mode, depending on your configuration. (See Step 3.) If you configure the global isdn-switch-type command for QSIG support, you do not need to also configure the interface isdn-switch-type command for QSIG.

For more information about the different options available with this command at the global and interface configuration level, see the "ISDN Switch Type Command Options" section.

2

interface serial 1:x

Enter interface configuration mode for the ISDN PRI interface. For T1, enter serial 1:23. For E1, enter serial 1:15.

3

isdn switch-type [primary-qsig-slave | primary-qsig-master]

If you did not configure the global ISDN switch type for QSIG support in Step 1, configure the interface ISDN switch type to serve either as the primary QSIG slave or the primary QSIG master.

The same conditions that apply to this command in global configuration mode also apply to this command in interface configuration mode.

Note This interface command overrides the global isdn switch-type command setting for this interface.

4

isdn overlap-receiving value

Activate overlap signaling to send to the destination PBX.

5

isdn network-failure-cause [value]

Specify the cause code to pass to the PBX when a call cannot be placed or completed because of internal network failures. Possible values are from 1 to 127.

6

isdn bchan-number-order {ascending | descending}

(Optional) Configure the ISDN Primary Rate Interface (PRI) interface to make the outgoing call selection in ascending or descending order.

The default is descending order, in which the first call from the Cisco MC3810 uses channel 23 (T1) or channel 31 (E1). The second call then uses channel 22 (T1) or channel 30 (E1), and so on in descending order.

If you select ascending order and the PRI group starts with 1, the first call uses channel 1, the second call uses channel 2, and so on in ascending order. If the PRI group starts with a different timeslot, the ascending order starts with the lowest timeslot.

7

controller {T1  |  E1} 1

Enter controller configuration mode. QSIG is only supported on controller 1.

8

pri-group timeslot [value-value]

Configure the PRI group for either T1 or E1 to carry voice traffic. For T1, available timeslots are from 1 to 23, and for E1 available timeslots are from 1 to 31.

You can configure the PRI group to include all the timeslots available, or you can configure a select group of timeslots for the PRI group. For example, if only timeslots 1 through 10 are in the PRI group, enter pri-group timeslot 1-10. If the PRI group includes all channels available for T1 (channels 1 through 24), enter pri-group timeslot 1-24. If the PRI group includes all channels available for E1 (channels 1 through 31), enter pri-group timeslot 1-31.

Note When a PRI group is configured, T1 timeslot 24 or E1 timeslot 16 is automatically assigned to handle D-channel signaling.

ISDN Switch Type Command Options

As shown in the table, you have a choice of configuring the isdn-switch-type command to support QSIG at either the global configuration level or at the interface configuration level. For example, if you have a QSIG connection on one line as well as on the BRI port, you can configure the ISDN switch type in one of the following combinations:


Note The voice-port codec command must be configured before any calls can be placed over the connection to the PINX. The default codec type is G729a.

When voice dial peers are configured for use with QSIG PRI, voice port 1/1 is used for all bearer channels.

You might need to configure voice dial peers to specify destination patterns for routing calls.

Configuration Example

The following configuration example configures interface serial 1:15 for QSIG PRI, and to act as the QSIG master. The example shows other commands necessary for the configuration.

! version 12.0
 no service pad
 service timestamps debug uptime
 service timestamps log uptime
 no service password-encryption
 !
 hostname c3810a
 !
 network-clock base-rate 56k
 ip subnet-zero
 no ip domain-lookup
 ip host rb 10.1.1.1
 !
 isdn switch-type primary-qsig-master
 !
 !
 stun peer-name 10.1.1.1
 stun protocol-group 1 basic
 !
 controller E1 1
  clock source internal
  pri-group timeslots 1-2,16
 !
 !
 !
 interface Ethernet0
  ip address 144.254.156.169 255.255.255.0
  no ip directed-broadcast
  no ip route-cache
  no ip mroute-cache
  no keepalive
 !
 interface Serial0
  ip address 10.1.1.2 255.255.255.0
  no ip directed-broadcast
  encapsulation frame-relay
  no ip route-cache
  no ip mroute-cache
  no arp frame-relay
  bandwidth 256
  no keepalive
  no fair-queue
  serial restart-delay 0
  frame-relay interface-dlci 30 voice-encap 80
  hold-queue 1024 out
 !
 interface Serial1
  no ip address
  no ip directed-broadcast
  encapsulation stun
  no ip route-cache
  no ip mroute-cache
  stun group 1
  stun route all interface Serial0 dlci 30
 !
 interface Serial1:15
  no ip address
  no ip directed-broadcast
  no logging event link-status
  isdn switch-type primary-qsig-master
  isdn bchan-number-order ascending
  no cdp enable
 !
 interface Switch0
  no ip address
  no ip directed-broadcast
  encapsulation frame-relay
  no fair-queue
 !
 interface FR-ATM0
  no ip address
  no ip directed-broadcast
 !
 interface FR-ATM20
  no ip address
  no ip directed-broadcast
  no ip route-cache
  shutdown
 !
 router rip
  network 10.0.0.0
  network 144.254.0.0
 !
 ip classless
 !
 map-list atm1
 !
 map-class frame-relay A-relay
  frame-relay traffic-rate 256000 1540000
  no frame-relay adaptive-shaping
 !
 line con 0
  transport input none
 line aux 0
 line 2 3
 line vty 0 4
  login
 !
 !
 voice-port 1/1
 !
 voice-port 1/2
 !
 dial-peer voice 1 pots
  destination-pattern 2...
  port 1/1
 !
 dial-peer voice 3 pots
  destination-pattern 3
  port 1/3
 !
 dial-peer voice 5 pots
  destination-pattern 5
  port 1/5
 !
 dial-peer voice 6 pots
  destination-pattern 6
  port 1/6
 !
 dial-peer voice 10 vofr
  destination-pattern 4...
  session target Serial0 30
 !
 end

Command Reference

The following revised command is used to configure the QSIG PRI signaling feature:

isdn switch type

To configure the Cisco MC3810 PRI interface to support QSIG signaling, use the isdn switch-type global or interface command. To disable QSIG signaling, use the no form of this command.

isdn switch-type switch-type
no isdn switch-type
switch-type

Syntax Description

switch-type

Service provider switch type.

The following two new switch types were added in Cisco IOS Release  12.0(2)T:

  • primary-qsig-slave---Specifies the Cisco MC3810 or the interface to act as the primary QSIG slave when the PINX is the primary QSIG master.

  • primary-qsig-master---Specifies the Cisco MC3810 or the interface to act as the primary QSIG master when the PINX is the primary QSIG slave.

Default

The switch type defaults to none, which disables the switch on the ISDN interface.

Command Mode

Global configuration mode or interface configuration mode.


Note This command can be entered in either global configuration mode or in interface configuration mode. When entered in global configuration mode, the setting applies to the entire Cisco  MC3810. When entered in interface configuration mode, the setting applies only to the T1/E1 interface specified. The interface configuration mode setting overrides the global configuration setting.

Usage Guidelines

This command first appeared as a global command in Cisco IOS Release 9.21.

This command first appeared as an interface command in Cisco IOS Release 11.3T.

The primary-qsig-slave and primary-qsig master switch type options to support PRI QSIG signaling were added in Cisco IOS Release 12.0(2)T.

You have a choice of configuring the isdn-switch-type command to support QSIG at either the global configuration level or at the interface configuration level. For example, if you have a QSIG connection on one line as well as on the BRI port, you can configure the ISDN switch type in one of the following combinations:


Note The voice-port codec command must be configured before any calls can be placed over the connection to the PINX. The default codec type is G729a.

Example

The following example configures the Cisco MC3810 to act as the QSIG master:

isdn switch-type primary-qsig-master

The following example configures T1 interface 23 on the Cisco MC3810 to act as the QSIG master:

interface serial 1:23
 isdn switch-type primary-qsig-master


hometocprevnextglossaryfeedbacksearchhelp
Posted: Fri Jan 22 18:05:32 PST 1999
Copyright 1989-1999©Cisco Systems Inc.