Полезная информация

cc/td/doc/product/software/ios120/120newft/120t
hometocprevnextglossaryfeedbacksearchhelp
PDF

Table of Contents

Common Channel Signaling (CCS)

Feature Summary

Platforms

Supported MIBs and RFCs

Configuration Tasks

Configuration Example

Command Reference

Common Channel Signaling (CCS)

Feature Summary

The Cisco MC3810 provides support for transparent Common Channel Signaling (CCS), which provides point-to-point PINX connection capability to Cisco MC3810 digital voice module (DVM) interfaces when the PINX does not support Q.SIG, or when the PINX has a proprietary solution.

You can configure transparent CCS in one of two ways: CCS cross-connect (or TDM cross-connect, which implies a fractional trunk), or CCS frame-forwarding. The configuration procedures are described in the "Configuration Tasks" section.

Benefits

This feature provides the following benefits:

Platforms

This feature is supported only on the Cisco MC3810.

Supported MIBs and RFCs

None.

Configuration Tasks

The configuration procedures are divided into the following sections:


Note Although not explicitly stated in the procedures, this feature also requires that voice ports and dial peers are also configured.

Configuring CCS Cross-Connect

This section is divided into the following procedures:

Figure 1 shows an example of CCS cross-connect. In this example, the CCS channel from the PBX is cross-connected on the Cisco MC3810 to a timeslot on the T1/E1 controller. The channel is then passed through the WAN as a leased line to the second Cisco MC3810, where it is cross-connected to the digital voice module (DVM) signaling timeslot (timeslot 24 for T1, or timeslot 16 for E1). The channel is then passed to the second PBX. The CCS signal byte stream is transparently passed transparently by the Cisco  MC3810.


Figure 1: CCS Cross-Connect Configuration


Configure CCS Cross-Connect for T1

When you configure CCS cross-connect for T1, you need to cross-connect from the first T1 controller to the second T1 controller. To configure CCS cross-connect for T1, complete the following steps beginning in global configuration mode:

Step Command Purpose

1

controller T1 0

Enter controller configuration mode for controller T1 0.

2

tdm-group tdm-group-no timeslot timeslot-list

Configure a TDM channel group for controller T1 0. Do not specify the type option in the command.

3

controller T1 1

Enter controller configuration mode for controller T1 1.

4

mode ccs cross-connect

Configure CCS cross-connect for controller T1 1.

5

tdm-group tdm-group-no timeslot timeslot-list

Configure a TDM channel group for controller T1 1. Do not specify the type option in the command.

6

cross-connect id controller-1 tdm-group-no-1 controller-2 tdm-group-no-2

Configure cross-connect pass-through between the two controllers.

Configure CCS Cross-Connect for E1

When you configure CCS cross-connect for E1, you need to configure cross-connect from the first E1 controller to the second E1 controller, and then configure the mode ccs cross-connect command to allow the cross-connect to timeslot  16. This enables all of the channels to perform similarly to normal CAS mode, but the signaling bit is no longer processed by the Cisco  MC3810.

To configure CCS cross-connect for E1, complete the following steps beginning in global configuration mode:

Step Command Purpose

1

controller E1 0

Enter controller configuration mode for controller E1 0.

2

tdm-group tdm-group-no timeslot timeslot-list

Configure a TDM channel group for E1. Do not specify the type option in the command.

3

controller E1 1

Enter controller configuration mode for controller E1 1.

4

mode ccs cross-connect

Configure controller E1 1 to support CCS cross-connect by enabling channel 16 to no longer carry the signaling bit.

5

voice-group channel-no timeslots timeslot-list type [ext-sig-master | ext-sig-slave]

Configure the specified channel to support CCS mode, and specify whether the T1/E1 trunk will be the external signaling master or slave.

A channel configured as ext-sig-master automatically generates the off-hook signal and stays in the off-hook state. A channel configured as ext-sig-slave automatically generates the answer signal when a call is terminated to that channel. These type options are available only when the mode ccs cross-connect command is enabled.

6

cross-connect id controller-1 tdm-group-no-1 controller-2 tdm-group-no-2

Configure cross-connect pass-through between the two controllers.

Configure T1/E1 Trunk Bearer Channels

If you will use CCS cross-connect for bearer channels of the T1/E1 trunk, you must perform the following additional configuration beginning in global configuration mode:

Step Command Purpose

1

controller {T1 | E1} number

Enter controller configuration mode for the controller.

2

mode ccs cross-connect

Specify the controller to support CCS cross-connect.

3

voice-group channel-no timeslots timeslot-list type [ext-sig-master | ext-sig-slave]

Configure the specified channel to support CCS mode, and specify whether the T1/E1 trunk will be the external signaling master or slave.

A channel configured as ext-sig-master automatically generates the off-hook signal and stays in the off-hook state. A channel configured as ext-sig-slave automatically generates the answer signal when a call is terminated to that channel. These type options are available only when the mode ccs cross-connect command is enabled.

4

voice-port slot/port

Enter voice-port configuration mode.

For digital voice ports, the slot number is 1 for this configuration. Valid numbers for port are from 1 to 24 for T1, and from 1 to 15 and from 17 to 31 for E1.

5

connection plar string

Configure the voice-port connection to support Private Line Auto Ringdown (PLAR) mode. For the string, enter the number of the voice channel that was configured as the ext-sig-slave for the voice-group command.

Note After a transparent CCS connection is configured by entering the connection plar command, any change to the configuration will not take place until the connection is shut down with a shutdown command and then restarted with a no shutdown command. For example, the phone number supplied in the connection plar command can be changed while the connection is in no shutdown state, but the change will not cause the current connection to be closed and a new connection to be opened to the new phone number. This will only take effect on the next no shutdown command following a shutdown command.

The voice channel type configured as the ext-sig-master is considered the master side of the permanent virtual circuit (PVC) connection and is responsible for establishing the PVC connection. After the master channel is configured, a fixed timer of 30 seconds starts. The voice-signaling driver then generates an off-hook signal on the master voice channel after the timer expires. The call is treated as a regular call, and the master voice channel will not hang up after the connection is made. If the call does not go through, or if the T1/E1 trunk is down, the 30-second timer on the master channel side restarts. A new off-hook signal is then generated at the master channel side after the timer expires.


Note CCS cross-connect is not supported on analog PVC connections.

Configuring CCS Frame-Forwarding

The Cisco MC3810 provides support for CCS frame-forwarding, which allows the Cisco MC3810 DVM to be connected to a Private Telco Network Exchange (PTNX) without having to interpret CCS signaling information for call processing. CCS frame-forwarding forwards High-Level Data Link Control (HDLC) frames over a preconfigured interface running HDLC, Frame Relay, or ATM encapsulation.

With CCS frame-forwarding, the connection between PTNXs over the network must be point-to-point and preconfigured. With the CCS frame-forwarding implementation, calls from the PTNXs are not routed, but follow a preconfigured route to the destination.

Figure 2 shows an example of CCS frame-forwarding. In the example, the Cisco MC3810 captures the signaling frame from the PBX. The Cisco MC3810 then transports the signaling frame as a data frame through the Frame Relay or ATM network to the second Cisco MC3810. The second Cisco  MC3810 then forwards the signaling frame to the PBX signaling channel.


Figure 2: CCS Frame-Forwarding



Note Although not explicitly stated in the procedures, this feature also requires that voice ports and dial peers must also be configured.

To configure CCS frame-forwarding, complete the following steps beginning in global configuration mode:

Step Command Purpose

1

controller {T1 | E1} 1

Enter controller configuration mode. CCS frame-forwarding is only available on controller T1/E1 1.

2

mode ccs frame-forwarding

Specify the controller to support CCS transparent signaling.

3

voice-group channel-no timeslots timeslot-list type [ext-sig-master | ext-sig-slave]

Configure the specified channel to support CCS mode, and specify whether the T1/E1 trunk will be the external signaling master or slave.

A channel configured as ext-sig-master automatically generates the off-hook signal and stays in the off-hook state. A channel configured as ext-sig-slave automatically generates the answer signal when a call is terminated to that channel. These type options are available only when the mode ccs frame-forwarding command is enabled.

4

voice-port slot/port

Enter voice-port configuration mode.

For digital voice ports, the slot number is always 1. Valid numbers for port are from 1 to 24 for T1, and from 1 to 15 and from 17 to 31 for E1.

5

connection plar string

If the voice port in the voice group is configured as the ext-sig-master, configure the voice-port connection to support PLAR mode for bearer channels. For the string, enter the number of the voice channel that was configured as the ext-sig-master for the voice-group command.

If the voice port in the voice group is configured as the ext-sig-slave, the dial peer should just terminate the PLAR calls.

Note After a transparent CCS connection is configured by entering the connection plar command, any change to the configuration will not take place until the connection is shut down with a shutdown command and then restarted with a no shutdown command.

For example, the phone number supplied in the connection plar command can be changed while the connection is in no shutdown state, but the change will not cause the current connection to be closed and a new connection to be opened to the new phone number. This will only take effect on the next no shutdown command following a shutdown command.

6

interface serial 1:x

Enter interface mode for serial 1:x where x represents the channel number. For E1, enter 15. For T1, enter 23.

This procedure maps the D channel from the DVM to the specified interface.

7

ccs connect {serial |atm} number [dlci  dlci| pvc vci | pvc vcd | pvc  vpi/vci | pvc string]

Configure the CCS connection. If the CCS connection is over Frame Relay, specify a serial interface and the DLCI. If the CCS connection is over ATM, specify ATM, interface 0, and the PVC.

8

no cdp enable

Disable Cisco Discovery Protocol (CDP) on the interface.

9

no keepalive

Disable keepalive packets on the interface.

Configuration Example

The following configuration example configures CCS frame-forwarding on controller E1. Other commands necessary for the configuration are included.

!

 version 12.0
 no service pad
 service timestamps debug uptime
 service timestamps log uptime
 no service password-encryption
 !
 hostname c3810a
 !
 logging buffered 4096 debugging
 !
 network-clock base-rate 56k
 ip subnet-zero
 no ip domain-lookup
 ip host rb 10.1.1.1
 !
 !
 !
 stun peer-name 10.1.1.1
 stun protocol-group 1 basic
 !
 controller E1 1
  framing NO-CRC4 Australia
  clock source internal
  mode ccs frame-forwarding
  voice-group 1 timeslots 1-2 type ext-sig-master
 !
 !
 !
 interface Ethernet0
  ip address 144.254.156.169 255.255.255.0
  no ip directed-broadcast
  no ip route-cache
  no ip mroute-cache
  no keepalive
 !
 interface Serial0
  ip address 10.1.1.2 255.255.255.0
  no ip directed-broadcast
  encapsulation frame-relay
  no ip route-cache
  no ip mroute-cache
  no arp frame-relay
  bandwidth 256
  no keepalive
  no fair-queue
  serial restart-delay 0
  frame-relay interface-dlci 30 voice-encap 80
  hold-queue 1024 out
 !
 interface Serial1
  no ip address
  no ip directed-broadcast
  encapsulation stun
  no ip route-cache
  no ip mroute-cache
  stun group 1
  stun route all interface Serial0 dlci 30
 !
 interface Serial1:15
  no ip address
  no ip directed-broadcast
  ccs connect Serial0 30
 !
 interface Switch0
  no ip address
  no ip directed-broadcast
  encapsulation frame-relay
  no fair-queue
 !
 interface FR-ATM0
  no ip address
  no ip directed-broadcast
 !
 interface FR-ATM20
  no ip address
  no ip directed-broadcast
  no ip route-cache
  shutdown
 !
 router rip
  network 10.0.0.0
  network 144.254.0.0
 !
 ip classless
 !
 !
 map-list atm1
 !
 map-class frame-relay A-relay
  frame-relay traffic-rate 256000 1540000
  no frame-relay adaptive-shaping
 !
 !
 line con 0
  transport input none
 line aux 0
 line 2 3
 line vty 0 4
  password cisco
  login
 !
 !
 voice-port 1/1
  vad
  connection plar 1
 !
 voice-port 1/2
  vad
  connection plar 2
 !
 dial-peer voice 1 vofr
  destination-pattern 1
  session target Serial0 30
 !
 dial-peer voice 2 vofr
  destination-pattern 2
  session target Serial0 30
 !
 end

Command Reference

The following new or modified commands are used to configure the transparent CCS and CCS frame forwarding features:

ccs connect

To configure a CCS connection on an interface configured to support CCS frame forwarding, use the ccs connect interface configuration command. To disable the CCS connection on the interface, use the no form of this command.

ccs connect {serial | atm} number [dlci dlci | pvc vci | pvc vcd | pvc vpi/vci | pvc string]
no ccs connect {serial | atm} number [dlci dlci | pvc vci | pvc vcd | pvc vpi/vci | pvc string]

Syntax Description

serial

Make a serial CCS connection.

atm

Make an ATM CCS connection.

number

Specifies the connection number. Choose one of the following options:

   dlci dlci

Specifies the DLCI number.

   pvc vci

Specifies the PVC virtual circuit identifier.

   pvc vcd

Specifies the PVC virtual circuit descriptor.

   pvc vpi/vci

Specifies the PVC virtual path identifier/virtual channel identifier.

   pvc string

Specifies the PVC string.

Default

No CCS connection is made.

Command Mode

Controller configuration mode

Usage Guidelines

This command first appeared in Cisco IOS Release 12.0(2)T.

Example

To configure a CCS frame-forwarding connection on DLCI 100, enter the following command:

ccs connect serial 1 dlci 100

To configure a CCS frame-forwarding connection over an ATM PVC, enter the following command:

ccs connect atm0 pvc 100

Related Commands

mode ccs

mode ccs

To configure the T1/E1 controller to support CCS cross-connect or CCS frame-forwarding, use the mode ccs controller configuration command. To disable support for CCS cross-connect or CCS frame-forwarding on the controller, use the no form of this command.

mode ccs {cross-connect | frame-forwarding}
no mode ccs {cross-connect | frame-forwarding}

Syntax Description

cross-connect

Enables CCS cross-connect on the controller.

frame-forwarding

Enables CCS frame forwarding on the controller.

Default

No CCS mode is configured.

Command Mode

Controller configuration mode

Usage Guidelines

This command first appeared in Cisco IOS Release 12.0(2)T.

Example

To enable CCS cross-connect on controller T1 1, enter the following commands:

controller T1 1
  mode ccs cross-connect

To enable CCS frame-forwarding on controller T1 1, enter the following commands:

controller T1 1
  mode ccs frame-forwarding

Related Commands

ccs connect

voice-group

To configure a list of timeslots for voice Channel Associated Signaling (CAS) or Common Channel Signaling (CCS) on the T1/E1 controller, use the voice-group controller configuration command. The no form of this command deletes the CAS group. This command is only available if the mode cas or mode ccs command is enabled.

voice-group channel-no timeslots timeslot-list type {e&m-immediate | e&m-delay | e&m-wink  | e&m-melcas | fxs-ground-start | fxs-loop-start | fxs-melcas | fxo-ground-start | fxo-loop-start | fxo-melcas} | {ext-sig-master | ext-sig-slave}
no voice-group channel-no timeslots timeslot-list type {e&m-immediate | e&m-delay | e&m-wink  | e&m-melcas | fxs-ground-start | fxs-loop-start | fxs-melcas | fxo-ground-start | fxo-loop-start | fxo-melcas} | {ext-sig-master | ext-sig-slave}

Syntax Description

channel-no

Channel number to identify the CAS group. The valid range is from 0 to 23.

timeslot list

A list of timeslots which comprise the CAS group. The valid range is from 1-24 for T1, and from 1-15 and 17-31 for E1.

type

The type of voice interface. Choose one of the following type options:

The following type options are available if the mode cas command is enabled:

e&m-immediate

E&M immediate.

e&m-delay

E&M delay.

e&m wink

E&M wink.

e&m melcas

E&M Mercury Exchange Limited (MEL) Channel Associated Signaling (CAS)

fxs-ground-start

Foreign Exchange Station ground-start.

fxs-loop-start

Foreign Exchange Station loop start.

fxs-melcas

Foreign Exchange Station Mercury Exchange Limited (MEL) Channel Associated Signaling.

fxo-ground-start

Foreign Exchange Office ground start.

fxo-loop-start

Foreign Exchange Office loop start.

fxo-melcas

Foreign Exchange Office Mercury Exchange Limited (MEL) Channel Associated Signaling.

The following type options are available only if the mode ccs command is enabled.

ext-sig-master

Specifies the channel to automatically generate the off-hook signal and stay in the off-hook state.

ext-sig-slave

Specifies the channel to automatically generate the answer signal when a call is terminated to that channel.

Default

None.

Command Mode

Controller configuration mode

Usage Guidelines

This command first appeared in Cisco IOS Release 11.3 MA.

The ext-sig-master and ext-sig-slave options were added in Cisco IOS Release 12.0(2)T.


Note Channel groups, CAS voice groups, and TDM groups all use group numbers. All group numbers configured for channel groups, CAS voice groups, and TDM groups must be unique on the local Cisco MC3810 concentrator. For example, you cannot use the same group number for a channel group and for a TDM group.

Related Commands

You can use the master indexes or search online to find documentation of related commands.

channel-group
mode
tdm-group


hometocprevnextglossaryfeedbacksearchhelp
Copyright 1989-1998 © Cisco Systems Inc.