Полезная информация

cc/td/doc/product/software/ios120/120newft/120t
hometocprevnextglossaryfeedbacksearchhelp
PDF

Table of Contents

Token Ring VLAN Support on the Route Switch Module

Feature Summary

Platforms

Prerequisites

Configuration Tasks

Configuration Examples

Command Reference

Debug Commands

Token Ring VLAN Support on the Route Switch Module

Feature Summary

The Token Ring VLAN support on the RSM adds the capability to do multi-protocol routing and bridging for Token Ring VLANs on the RSM. The RSM can be used standalone to do interVLAN routing, or it can be paired with a Catalyst VIP2 to provide external network connections with the same port adapters used on Cisco 7500 series routers. The RSM/VIP2 combination provides routing between VLANs and Catalyst VIP2 port adapters. A complete description of the RSM can be found in the Catalyst 5000 Series Route Switch Module Installation and Configuration Note and the Route Switch Module Catalyst VIP2-15 and VIP2-40 Installation and Configuration Note.

The Token Ring VLAN support on the RSM adds the following functionality to the Catalyst  5000  switch:

Both APPN and DLSw+ are supported for Token Ring VLANS on the RSM. However, RSRB is not supported on the RSM.

For information on how Token Ring VLANs are implemented on switches, refer to the Catalyst Token Ring Switching Implementation Guide, the Catalyst 5000 Series Token Ring Configuration Notes, the Catalyst 3900 Token Ring Switching User Guide, and the Catalyst 3920 Token Ring Switching User Guide.

Token Ring VLANs

A VLAN is essentially a broadcast domain. In transparent bridging, there is only one type of broadcast frame and, therefore, only one level of broadcast domain and one level of VLAN. In source routing, however, there are 2 types of broadcast frames:

Therefore, there are two levels of VLANs in a Token Ring switched network.

The first level is the Token Ring Concentrator Relay Function (TrCRF). At this level, the VLAN is a logical ring and, as such, is assigned a ring number. On a Token Ring switch, the logical ring (TrCRF) contains one or more physical ports. Source Route Switching (SRS) is used to forward frames within a TrCRF based on MAC address or Route Descriptor. On an RSM, a logical ring (TrCRF) can be defined that does not contain any physical ports, but rather is used only in processing source-routed traffic to terminate the RIF.

The second level of VLAN is the Token Ring Bridge Relay Function (TrBRF). This is the parent VLAN to which TrCRF VLANs are assigned. At this level, the VLAN is a logical bridge and, as such, is assigned a bridge number. The TrBRF is responsible for forwarding frames between groups of ports with the same ring number (TrCRFs) via either SRB or SRT.

Figure 1 depicts the relationship between TrCRF and TrBRF VLANS.


Figure 1: Token Ring VLAN Support on the RSM


Token Ring VLAN Support on the RSM

This section describes the basic operation of the RSM as it pertains to Token Ring VLANS. For a complete functional description of the RSM, refer to the Catalyst 5000 Series RSM Installation and Configuration Note.

The RSM is a router module running Cisco IOS router software that directly interfaces (plugs into) the Catalyst switch backplane. From the Token Ring VLAN perspective, the interface to the RSM is at the Token Ring bridged network (TrBRF) level. With the RSM, it is possible to route or bridge between separate Token Ring and Ethernet domains.

When routing or bridging between TrBRF VLANs that are defined as source-route bridging domains, it is necessary to create a logical ring on the RSM for proper RIF processing. This logical ring is defined as a TrCRF VLAN that does not contain any external Token Ring switch ports. Figure 2 illustrates the logical view of IP routing between two source-route bridged VLANs on the RSM. In this view, the RSM appears to have an interface to both ring 100 and ring 110.


Figure 2: Logical View of VLAN Support on the RSM


Platforms

Support for the Token Ring RSM feature was first introduced in the Cisco IOS 11.3(5)T. Table 1 shows the supported Cisco IOS Releases and software images.


Table 1:
Cisco IOS Release Supported Images

Cisco IOS 11.3(5)T

  • c5rsm-jsv-mz

  • c5rsm-jsv40--mz

  • c5rsm-js56i-mz

Cisco IOS 12.0(1)T

  • c5rsm-jsv-mz

  • c5rsm-jsv40--mz

  • c5rsm-js56i-mz

  • c5rsm-ajsv-mz

Supported Cisco IOS Releases and Images for Token Ring RSM

Prerequisites

Before you configure bridging or routing for Token Ring VLAN interfaces in the RSM, configure the VLANs on the Supervisor engine module.

To configure a VLAN on the Supervisor engine module, use the following command in privileged mode:
Command Purpose

set vlan vlan_num [name name] [state {active | suspend}] [mtu mtu] ring ring_number parent vlan_num [mode {srt | srb}] [backupcrf {off | on}] [aremaxhop hopcount] [stemaxhop hopcount]

Configure a TrCRF or TrBRF on the Supervisor engine module.

Configuration Tasks

To configure and monitor Token Ring VLAN support on the RSM, perform one or more of the following tasks:


Note For information on configuring APPN or DLSW+, refer to the chapters in the Bridging and IBM Networking Configuration Guide and Bridging and IBM Command Reference.

Configure IP Routing

The IP routing for Token Ring VLANs feature extends IP routing capabilities to include support for routing IP frame types in Token Ring VLAN configurations. IP can be routed between:

To configure IP routing on an RSM, use the following commands, beginning in global configuration mode:  
Step Command Purpose

1 . 

ip routing

Enable IP routing on the RSM.

2 . 

interface vlan vlanid type [trbrf | ethernet]

Configure a Token Ring or Ethernet interface on the RSM.

3 . 

ip address ip-address mask

Set a primary IP address for an interface.

You can configure an RSM to route source-routed traffic by creating a "pseudo-ring" to terminate the RIF path on a ring and by enabling the collection and use of RIF information.

To route source-routed traffic, use the following additional commands in interface configuration mode:  
Command Purpose

1 . 

multiring trcrf-vlan vlanid ring ring-number

Create a pseudo-ring to terminate the RIF and assign it to a VLAN.

2 . 

multiring {protocol-keyword [all-routes | spanning | all | other]}

Enable collection and use of RIF information with routed protocols.

Configure IPX Routing

The IPX Routing support for Token Ring VLANs extends Novell NetWare routing capabilities to include support for routing IPX on Token Ring VLAN interfaces, as well as Ethernet VLAN interfaces. IPX can be routed between:

Users with Novell NetWare environments can configure either SAP or SNAP encapsulations to be routed across VLAN boundaries.

To configure Cisco IOS software to route IPX on an RSM with connected Token Ring VLANs, use the following commands, beginning in global configuration mode:
Step Command Purpose

1 . 

ipx routing [node]

Enable IPX routing globally.

2 . 

interface vlan vlanid type [trbrf | ethernet]

Configure a Token Ring or Ethernet interface on the RSM.

3 . 

ipx encapsulation encapsulation type

Specify the IPX encapsulation.

4 . 

ipx network network number

Specify the IPX network.


Note The default IPX encapsulation format for Token Ring in Cisco IOS is SAP. Therefore, you only need to explicitly configure the IPX encapsulation type if your Token Ring network requires SNAP encapsulation instead of SAP.

When routing source-routed traffic for specific VLANs, use the following additional commands in interface configuration mode:  
Step Command Purpose

1 . 

multiring trcrf-vlan vlanid ring ring-number

Create a pseudo-ring to terminate the RIF and assign it to a VLAN.

2 . 

multiring {protocol-keyword [all-routes | spanning | all | other]}

Enable collection and use of RIF information with routed protocols.

Configure Source-Route Bridging

To configure source-route bridging on the RSM, use the following commands, starting in global configuration mode:
Step Command Purpose

1 . 

source-bridge ring-group vring-num

Configure a virtual ring for the RSM.

2 . 

interface vlan vlanid type [trbrf | ethernet]

Configure a Token Ring or Ethernet interface on the RSM.

3 . 

source-bridge trcrf-vlan vlanid ring-group ring-number

Attach a TrCRF VLAN identifier to the RSM's virtual ring.

Configure Source-Route Transparent Bridging

To configure transparent bridging on the RSM, use the following command, starting in global configuration mode:
Step Command Purpose

1 . 

interface vlan vlanid type [trbrf | ethernet]

Configure a Token Ring or Ethernet interface on the RSM.

2 . 

bridge-group bridge-group number

Specify the bridge group to which the interface belongs.

Configure Source-Route Translational Bridging

To configure source-route translational bridging on the RSM, use the following commands, starting in global configuration mode:
Step Command Purpose

1 . 

source-bridge ring-group vring-num

Configure a virtual ring for the RSM.

2 . 

source-bridge transparent ring-group pseudo-ring bridge-number tb-group [oui]

Enable bridging between transparent bridging and source-route bridging.

3 . 

interface vlan vlanid type [trbrf | ethernet]

Configure a Token Ring or Ethernet interface on the RSM.

4 . 

source-bridge trcrf-vlan vlanid ring-group ring-number

Assign a VLAN ID to the RSM's virtual ring.


Note For a complete description of SR/TLB, including configuring translation compatibility with IBM 8209 bridges and configuring Token Ring LLC2 to Ethernet Type II (0x80d5) and Token Ring LLC2 to Ethernet 802.3 LLC2 (standard) translations, please refer to the "Configuring Source-Route Bridging" and "Source-Route Bridging Commands" chapters in the Bridging and IBM Networking Configuration Guide and Bridging and IBM Command Reference.

Configure Automatic Spanning Tree

The automatic spanning-tree function supports automatic resolution of spanning trees in SRB networks, which provides a single path for spanning explorer frames to traverse from a given node in the network to another. Spanning explorer frames have a single-route broadcast indicator set in the routing information field. Port identifiers consist of ring numbers and bridge numbers associated with the ports. The spanning-tree algorithm for SRB does not support Topology Change Notification Bridge Protocol Data Unit (BPDU).

Although the automatic spanning-tree function can be configured with Source-Route Translational Bridging (SR/TLB), the SRB domain and transparent bridging domain have separate spanning trees. Each Token Ring interface can belong to only one spanning tree. Only one bridge group can run the automatic spanning-tree function at a time.

To create a bridge group that runs an automatic spanning-tree function compatible with the IBM SRB spanning-tree implementation, use the following command in global configuration mode:
Command Purpose

bridge bridge-group protocol ibm

Create a bridge group that runs the automatic spanning-tree function.

To enable the automatic spanning-tree function for a specified group of bridged interfaces in SRB or SR/TLB, use the following command in interface configuration mode:
Command Purpose

source-bridge spanning bridge-group

Enable the automatic spanning-tree function on a group of bridged interfaces.

Monitor Statistics

You can collect, clear, and display statistical information about the network.

The Duplicate Ring Protocol (DRiP) runs on Cisco routers and switches that support switched VLAN networking and is used to identify active Token Ring VLANs (TrCRFs).

DRiP maintains the status of TrCRFs and uses this information to determine whether there are multiple TrCRFs active in a TrBRF.

DRiP information is used for the following:

DRiP information is used in conjunction with the local configuration to determine which of the TrCRFs configured within a TrBRF have active ports. This information is used on the base switch to correctly filter all-routes explorers and on the RSM to discard AREs that have already been on an attached ring.
DRiP information is used in conjunction with the local configuration information to determine which TrCRFs are already active on the switches. If a TrCRF is enabled on more than one switch or router, the ports associated with the TrCRF are disabled on all switches. The RSM will not disable the internal ring used for processing source-routed traffic. Instead, the RSM generates the following error message to indicate that two identical TrCRFs exist:
DRIP conflict with CRF <vlan-id>

To show or clear DRiP or VLAN statistics, use one or all the following command in privileged EXEC mode:
Command Purpose

clear drip counters

Clear DRiP counters.

show drip

Display DRiP information.


Note When DRiP counters are cleared, the counter is reset to 0. Incrementing of DRiP counters indicates that the router is receiving packets across the TrBRF.

Configuration Examples

The following sections provide RSM and Catalyst 5000 switch configuration examples:

IP Routing Source-Routed Frames between a TrBRF VLAN and a VIP2 Token Ring Interface Example

Following is the configuration for the RSM as shown in Figure 3:

interface TokenRing 3/1
  ip address 4.4.4.1 255.255.255.0
!
interface vlan998 type trbrf
  ip address 5.5.5.1 255.255.255.0
  multiring trcrf-vlan 200 ring 100
  multiring ip

Figure 3: IP Routing Source-Routed Frames between a TrBRF VLAN and a VIP2 Token Ring Interface


The following is the configuration for the Catalyst 5000 switch with an Ethernet module in slot 2 and a Token Ring switch module in slot 5. In this configuration, the Token Ring port 5/1 is assigned with the TrCRF VLAN 201.

#vtp
set vtp domain trrsm
set vtp mode server
set vtp v2 enable
#drip
set tokenring reduction enable
set tokenring distrib-crf disable
#vlans
set vlan 998 type trbrf bridge 0xd stp ibm
set vlan 200 type trcrf parent 998 ring 0x64 mode srb
set vlan 201 type trcrf parent 998 ring 0x65 mode srb
#add token port to trcrf 201
set vlan 201 5/1

Because the VLANs are defined on a per port basis, endstations connected to ports that belong to the same VLAN should belong to the same IP subnetwork.

IP Routing Source-Routed Frames between a TrBRF VLAN and a VIP2 Ethernet Interface Example

Following is the configuration for the RSM as shown in Figure 4:

interface Ethernet 2/2
  ip address 4.4.4.1 255.255.255.0
!
interface vlan998 type trbrf
  ip address 5.5.5.1 255.255.255.0
  multiring trcrf-vlan 200 ring 100
  multiring all

Figure 4: IP Routing Source-Routed Frames between a TrBRF VLAN and a VIP2 Ethernet Interface


The following is the configuration for the Catalyst 5000 switch with an Ethernet module in slot 2 and a Token Ring switch module in slot 5. In this configuration, the Token Ring port 5/1 is assigned with TrCRF VLAN 201.

#vtp
set vtp domain trrsm
set vtp mode server
set vtp v2 enable
#drip
set tokenring reduction enable
set tokenring distrib-crf disable
#vlans
set vlan 998 type trbrf bridge 0xd stp ibm
set vlan 200 type trcrf parent 998 ring 0x64 mode srb
set vlan 201 type trcrf parent 998 ring 0x65 mode srb
#add token ring port to trcrf 201
set vlan 201 5/1

Because the VLANs are defined on a per port basis, endstations connected to ports that belong to the same VLAN should belong to the same IP subnetwork.

IP Routing Source-Routed Frames between TrBRF VLANs Example

Following is the configuration for the RSM as shown in Figure 5:

interface vlan998 type trbrf
  ip address 5.5.5.1 255.255.255.0
  multiring trcrf-vlan 200 ring 100
  multiring all
interface vlan999 type trbrf
  ip address 6.6.6.1 255.255.255.0
  multiring trcrf-vlan 201 ring 101
  multiring all

Figure 5: IP Routing Source-Routed Frames between TrBRF VLANs

The following is the configuration for the Catalyst 5000 switch with an Ethernet module in slot 2 and a Token Ring switch module in slot 5. In this configuration, the Token Ring port 5/1 is assigned with TrCRF VLAN 300 and the Token Ring port 5/2 is assigned with TrCRF VLAN 301.

#vtp
set vtp domain trrsm
set vtp mode server
set vtp v2 enable
#drip
set tokenring reduction enable
set tokenring distrib-crf disable
#vlans
set vlan 998 type trbrf bridge 0xd stp ibm
set vlan 200 type trcrf parent 998 ring 0x64 mode srb
set vlan 300 type trcrf parent 998 ring 0x66 mode srb
set vlan 999 type trbrf bridge 0xe stp ibm
set vlan 201 type trcrf parent 999 ring 0x65 mode srb
set vlan 301 type trcrf parent 999 ring 0x67 mode srb
#add token port to trcrfs
set vlan 300 5/1
set vlan 301 5/2

Because the VLANs are defined on a per port basis, endstations connected to ports that belong to the same VLAN should belong to the same IP subnetwork.

IP Routing Source-Routed Frames between a TrBRF VLAN and an Ethernet VLAN Example

Following is the configuration for the RSM as shown in Figure 6:

interface vlan998 type trbrf
  ip address 5.5.5.1 255.255.255.0
  multiring trcrf-vlan 200 ring 100
  multiring all
interface vlan500 type ethernet
  ip address 6.6.6.1 255.255.255.0

Figure 6: IP Routing Source-Routed Frames between a TrBRF VLAN and an Ethernet VLAN

The following is the configuration for the Catalyst 5000 switch with an Ethernet module in slot 2 and a Token Ring switch module in slot 5. In this configuration, the Token Ring port 5/1 is assigned with TrCRF VLAN 300 and the Ethernet port 2/1 is assigned with VLAN 500.

#vtp
set vtp domain trrsm
set vtp mode server
set vtp v2 enable
#drip
set tokenring reduction enable
set tokenring distrib-crf disable
#vlans
set vlan 998 type trbrf bridge 0xd stp ibm
set vlan 200 type trcrf parent 998 ring 0x64 mode srb
set vlan 300 type trcrf parent 998 ring 0x66 mode srb
#add token port to trcrf 300
set vlan 300 5/1
#add ether port to 500
set vlan 500 2/1

Because the VLANs are defined on a per port basis, endstations connected to ports that belong to the same VLAN should belong to the same IP subnetwork.

IP Routing Non-Source-Routed Frames between a TrBRF VLAN and a VIP2 Token Ring Interface Example

Following is the configuration for the RSM as shown in Figure 7:

interface TokenRing 3/1
  ip address 4.4.4.1 255.255.255.0
!
interface vlan998 type trbrf
  ip address 5.5.5.1 255.255.255.0

Note The multiring command is not needed in this configuration since these are non-source-routed frames.

Figure 7: IP Routing Non-Source-Routed Frames between a TrBRF VLAN and a VIP2 Token Ring Interface

The following is the configuration for the Catalyst 5000 switch with an Ethernet module in slot 2 and a Token Ring switch module in slot 5. In this configuration, the Token Ring port 5/1 is assigned with the TrCRF VLAN 201.

#vtp
set vtp domain trrsm
set vtp mode server
set vtp v2 enable
#drip
set tokenring reduction enable
set tokenring distrib-crf disable
#vlans
set vlan 998 type trbrf bridge 0xd stp ieee
set vlan 201 type trcrf parent 998 ring 0x65 mode srt
#add token port to trcrf 201
set vlan 201 5/1

Because the VLANs are defined on a per port basis, endstations connected to ports that belong to the same VLAN should belong to the same IP subnetwork.

IP Routing Non-Source-Routed Frames between a TrBRF VLAN and a VIP2 Ethernet Interface Example

Following is the configuration for the RSM as shown in Figure 8:

interface Ethernet 2/2
  ip address 4.4.4.1 255.255.255.0
!
interface vlan998 type trbrf
  ip address 5.5.5.1 255.255.255.0

Note  The multiring command is not needed in this configuration since these are non-source-routed frames.

Figure 8: IP Routing Non-Source-Routed Frames between a TrBRF VLAN and a VIP2 Ethernet Interface

The following is the configuration for the Catalyst 5000 switch with an Ethernet module in slot 2 and a Token Ring switch module in slot 5. In this configuration, the Token Ring port 5/1 is assigned with TrCRF VLAN 201.

#vtp
set vtp domain trrsm
set vtp mode server
set vtp v2 enable
#drip
set tokenring reduction enable
set tokenring distrib-crf disable
#vlans
set vlan 998 type trbrf bridge 0xd stp ieee
set vlan 201 type trcrf parent 998 ring 0x65 mode srt
#add token ring port to trcrf 201
set vlan 201 5/1

Because the VLANs are defined on a per port basis, endstations connected to ports that belong to the same VLAN should belong to the same IP subnetwork.

IP Routing Non-Source-Routed Frames between TrBRF VLANs

Following is the configuration for the RSM as shown in Figure 9:

interface vlan998 type trbrf
  ip address 5.5.5.1 255.255.255.0
interface vlan999 type trbrf
  ip address 6.6.6.1 255.255.255.0

Note The multiring command is not needed in this configuration since these are non-source-routed frames.

Figure 9: IP Routing Non-Source-Routed Frames between TrBRF VLANs

The following is the configuration for the Catalyst 5000 switch with an Ethernet module in slot 2 and a Token Ring switch module in slot 5. In this configuration, the Token Ring port 5/1 is assigned with VLAN 300 and the Token Ring port 5/2 is assigned with VLAN 301.

#vtp
set vtp domain trrsm
set vtp mode server
set vtp v2 enable
#drip
set tokenring reduction enable
set tokenring distrib-crf disable
#vlans
set vlan 998 type trbrf bridge 0xd stp ieee
set vlan 300 type trcrf parent 998 ring 0x66 mode srt
set vlan 999 type trbrf bridge 0xd stp ieee
set vlan 301 type trcrf parent 999 ring 0x67 mode srt
#add token port to trcrfs
set vlan 300 5/1
set vlan 301 5/2

Because the VLANs are defined on a per port basis, endstations connected to ports that belong to the same VLAN should belong to the same IP subnetwork.

IP Routing Non-Source-Routed Frames between a TrBRF VLAN and an Ethernet VLAN Example

Following is the configuration for the RSM as shown in Figure 10:

interface vlan998 type trbrf
  ip address 5.5.5.1 255.255.255.0
!
interface vlan500 type ethernet
  ip address 6.6.6.1 255.255.255.0

Note The multiring command is not needed in this configuration since these are non-source-routed frames.

Figure 10: IP Routing Non-Source-Routed Frames between a TrBRF VLAN and an Ethernet VLAN

The following is the configuration for the Catalyst 5000 switch with an Ethernet module in slot 2 and a Token Ring switch module in slot 5. In this configuration, the Token Ring port 5/1 is assigned with TrCRF VLAN 300 and the Ethernet port 2/1 is assigned with VLAN 500.

#vtp
set vtp domain trrsm
set vtp mode server
set vtp v2 enable
#drip
set tokenring reduction enable
set tokenring distrib-crf disable
#vlans
set vlan 998 type trbrf bridge 0xd stp ieee
set vlan 300 type trcrf parent 998 ring 0x66 mode srt
#add token port to trcrf 300
set vlan 300 5/1
#add ether port to 500
set vlan 500 2/1

Because the VLANs are defined on a per port basis, endstations connected to ports that belong to the same VLAN should belong to the same IP subnetwork.

SRB Between a TrBRF VLAN and VIP2 Token Ring Interface Example

The following configuration refers to the RSM as shown in Figure 11:

interface TokenRing3/1
 source-bridge 10 1 100
 source-bridge 
spanningIRE
FOBJ:12949_(_IREFOBJ:12953_
)_IREFOB
J:12958
!
source-bridge ring-group 100
interface vlan999 type trbrf
 source-bridge trcrf-vlan 40 ring-group 100
 source-bridge spanning

Figure 11:
SRB Between a TrBRF VLAN and VIP2 Token Ring Interface

Following is the configuration for the Catalyst 5000 switch which performs simple SRB. In this configuration, the Token Ring switch module exists in slot 5 and is using port 1. The Token Ring port on 5/1 is assigned to TrCRF VLAN 50.

#vtp
set vtp domain trrsm
set vtp mode server
set vtp v2 enable
#drip
set tokenring reduction enable
set tokenring distrib-crf disable
#vlans
set vlan 999 name trbrf type trbrf bridge 0xe stp ibm
set vlan 40 name trcrf40 type trcrf parent 999 ring 0x64 mode srb 
set vlan 50 name trcrf50 type trcrf parent 999 ring 0x1 mode srb 
#add token port to trcrf 50
set vlan 50 5/1

In this configuration, the keyword name is optional and srb is the default mode. The ring number on the switch must be specified in decimal by substituting the decring keyword for ring.

SRB Between TrBRF VLANs Example

The following configuration refers to the RSM as shown in Figure 12:


Figure 12: SRB Between TrBRF VLANs
source-bridge ring-group 100
!
interface vlan999 type trbrf
 source-bridge trcrf-vlan 40 ring-group 100
 source-bridge spanning
!
interface vlan998 type trbrf
 source-bridge trcrf-vlan 70 ring-group 100
 source-bridge spanning

The following is the configuration for the Catalyst 5000 switch with the Token Ring switch module in slot 5. The Token Ring port on 5/1 is assigned to TrCRF VLAN 50 and the Token Ring port on 5/2 is assigned to TrCRF VLAN 80.

#vtp
set vtp domain trrsm
set vtp mode server
set vtp v2 enable
#drip
set tokenring reduction enable
set tokenring distrib-crf disable
#vlans
set vlan 999 name trbrf type trbrf bridge 0xe stp ibm
set vlan 40 name trcrf40 type trcrf parent 999 ring 0x64 mode srb
set vlan 50 name trcrf50 type trcrf parent 999 ring 0x1 mode srb
set vlan 998 name trbrf type trbrf bridge 0xd stp ibm 
set vlan 70 name trcrf70 type trcrf parent 998 ring 0x64 mode srb
set vlan 80 name trcrf80 type trcrf parent 998 ring 0x2 mode srb
#add token port to trcrf 50
set vlan 50 5/1
#add token port to trcrf 80
set vlan 80 5/2

In this configuration, the keyword name is optional and srb is the default mode.

Transparent Bridging between a TrBRF VLAN and a VIP2 Token Ring Interface Example

The following is the configuration for the RSM as shown in Figure 13:

bridge 1 protocol ieee
! interface tokenring0  bridge-group 1 interface vlan 50 type trbrf  bridge-group 1

Figure 13: Transparent Bridging between a TrBRF VLAN and a VIP2 Token Ring Interface

The following is the configuration for the Catalyst 5000 switch with a Token Ring switch module in slot 5:

#vtp
set vtp domain trrsm
set vtp mode server
set vtp v2 enable
#drip
set tokenring reduction enable
set tokenring distrib-crf disable
#vlans
set vlan 50 name trbrf50 type trbrf bridge 0xb stp ieee
set vlan 100 name trcrf100 type trcrf ring 0x64 parent 50 mode srt
#add token port to trcrf 100
set vlan 100 5/14

SR/TLB between a TrBRF VLAN and a VIP2 Ethernet Interface Example

The following is the configuration for the RSM as shown in Figure 14:

source-bridge ring-group 100
bridge 1 protocol ieee
source-bridge transparent 100 200 10 1
!
interface vlan999 type trbrf
    source-bridge trcrf-vlan 20 ring-group 100
    source-bridge spanning
!
interface ethernet1/0
    bridge-group 1

Figure 14: SR/TLB between a TrBRF VLAN and a VIP2 Ethernet Interface


The following is the configuration for the Catalyst 5000 switch with an Ethernet module in slot 2 and a Token Ring switch module in slot 5. In this configuration, the Token Ring port on 2/1 is assigned to VLAN 21.

#vtp
set vtp domain trrsm
set vtp mode server
set vtp v2 enable
#drip
set tokenring reduction enable
set tokenring distrib-crf disable
#vlans
set vlan 999 type trbrf bridge 0xd stp ibm
set vlan 20 type trcrf parent 999 ring 0x64 mode srb
set vlan 21 type trcrf parent 999 ring 0x65 mode srb
#add token ring port to trcrf 21
set vlan 21 2/1

SR/TLB between a TrBRF VLAN and Ethernet VLAN Example

The following is the configuration for the RSM as shown in Figure 15:

source-bridge ring-group 100
bridge 1 protocol ieee
source-bridge transparent 100 200 10 1
!
interface vlan999 type trbrf
  source-bridge trcrf-vlan 20 ring-group 100
  source-bridge spanning
!
interface vlan100 type ethernet
  bridge-group 1

Figure 15: SR/TLB between a TrBRF VLAN and Ethernet VLAN


The following is the configuration for the Catalyst 5000 switch with an Ethernet module in slot 2 and a Token Ring switch module in slot 5. In this configuration, the Token Ring port on 5/1 is assigned to TrCRF 21, and the Ethernet port on 2/1 is assigned to VLAN 100.

#vtp
set vtp domain trrsm
set vtp mode server
set vtp v2 enable
#drip
set tokenring reduction enable
set tokenring distrib-crf disable
#vlans
set vlan 999 type trbrf bridge 0xd stp ibm
set vlan 20 type trcrf parent 999 ring 0x64 mode srb
set vlan 21 type trcrf parent 999 ring 0x65 mode srb
#add token port to trcrf 21
set vlan 21 5/1
#add ethernet
set vlan 100 type ethernet
set vlan 100 2/1

DLSw+ Example

The following is the configuration for the RSM with a VIP2 serial interface as shown in Figure 16:

source-bridge ring-group 100
dlsw local-peer peer-id 10.18.20.8
dlsw remote-peer 0 tcp 10.18.20.6
!
interface Serial1/0
  ip address 10.18.20.8 255.255.255.0
  no keepalive
  clockrate 64000
!
interface Vlan89 type trbrf
  no ip address
  source-bridge trcrf-vlan 9 ring-group 100
  source-bridge spanning

Figure 16: Configuration for DLSw+ Example


The following is the configuration for a Catalyst 5000 with a Token Ring module in slot 5. In this configuration, the Token Ring port 5/1 is assigned with the TrCRF VLAN 10:

#vtp
set vtp domain trrsm
set vtp mode server
set vtp v2 enable
#drip
set tokenring reduction enable
set tokenring distrib-crf disable
#vlans
set vlan 89 type trbrf bridge 0xd stp ibm
set vlan 10 type trcrf parent 89 ring 0xa mode srb
#add token ring port to TrCRF 10
set vlan 10 5/1

The following is the configuration for the remote router:

source-bridge ring group 100 
dlsw local-peer peer-id 10.18.20.6
dlsw remote-peer 0 tcp 10.18.20.8
!
interface loopback 0
  ip address 10.18.20.6
!
interface serial1/0
  no ip address
  no keepalive
  clockrate 64000
!
interface tokenring 2/0
  no ip address
  ring-speed 16
  source-bridge 20 1 100
  source-bridge spanning

APPN Example

The following is the configuration for the RSM running DLUR as shown in Figure 17:

source-bridge ring-group 102
interface Vlan100 type trbrf
  mac-address 4000.0001.0588
  ip address 10.10.205.81 255.255.255.0
  source-bridge trcrf-vlan 102 ring-group 102
!
appn control-point NETA.NEC2P
  dlus NETA.SJMVS1
  dlur
  complete
!
appn port TRVLAN Vlan100
  complete
!
appn link-station CORRI
!link to CM/2 end node.
  port TRVLAN 
  lan-dest-address 1000.5acc.724f
  complete
!
appn link-station HOST 
!link to DLUS.
  port TRVLAN
  lan-dest-address 4000.1060.1000
  retry-limit infinite 5
  complete
!
appn routing

Figure 17: Configuration for APPN Example


The following is the configuration for a Catalyst 5000 with a Token Ring module in slot 5. In this configuration, the Token Ring port 5/10 is assigned to TrCRF VLAN 20.

#vtp
set vtp domain trrsm
set vtp mode server
set vtp v2 enable
#drip
set tokenring reduction enable
set tokenring distrib-crf disable
#vlans
set vlan 100 type trbrf bridge 0xd stp ibm
set vlan 102 type trcrf parent 100 ring 0x66 mode srb
set vlan 20 type trcrf parent 100 ring 0x14 mode srb
#add token ring port to TrCRF 20
set vlan 20 5/10

Command Reference

This section documents new or modified commands. All other commands used with this feature are documented in the Cisco IOS Release 11.3 command references.

clear drip counters

Use the clear drip counters privileged EXEC command to clear DRiP counters from the RSM interfaces.

clear drip counters
Syntax Description

This command has no arguments or keywords.

Default

Disabled.

Command Mode

Privileged EXEC

Usage Guidelines

This command first appeared in Cisco IOS Release 11.3(4)T.

Use the clear drip counters command if you want to check whether the router is receiving any packets. The counters will start at 0. If the counters are incrementing, DRiP is active on the router.

Examples

The following example clears DRiP counters:

router# clear drip counters
router#
Related Commands

clear drip counters
interface vlan
show drip

interface vlan

Use the interface vlan interface configuration command to configure a Token Ring or Ethernet interface on the RSM.

interface vlan vlanid type [trbrf | ethernet]

Syntax Description

vlan-id

Unique VLAN ID number used to create a VLAN.

trbrf | ethernet

RSM Interface type.

Default

The RSM interfaces are not configured.

Command Mode

Interface configuration

Usage Guidelines

This command first appeared in Cisco IOS Release 11.3(5)T.

Valid Token Ring VLAN ID numbers are 2 through 1000.

Routing or bridging to a Token Ring VLAN (TrBRF) on the RSM is done by creating a logical interface to a TrBRF VLAN on the RSM with the interface vlan command. The TrBRF VLAN must be defined on the Supervisor module prior to creating the TrBRF interface on the RSM.

Examples

The interface vlan command is used to configure an RSM Token Ring interface with VLAN 998:

interface vlan998 type trbrf
  ip address 5.5.5.1 255.255.255.0
Related Commands

clear drip counters
multiring trcrf-vlan
source-bridge trcrf-vlan
show drip

multiring trcrf-vlan

Use the multiring trcrf-vlan interface configuration command to create a pseudo ring on the RSM and to terminate the RIF when routing IP or IPX source-routed traffic on Token Ring VLAN (TrBRF) interfaces. Use the no form of this command to disable the termination of RIFs on the RSM interface.

multiring trcrf-vlan vlanid ring-group ring-number
no multiring trcrf-vlan vlanid ring-group ring-number

Syntax Description

vlanid

VLAN ID number. Valid VLAN ID numbers are 2 through 1000.

ring ring-number

Keyword that specifies the pseudo ring number used to terminate the RIF.

Default

Termination of RIFs is disabled on the RSM interfaces.

Command Mode

Interface configuration

Usage Guidelines

This command first appeared in Cisco IOS Release 11.3(4)T.

Use the multiring command to collect and use RIFs for routed protocols. On an RSM, the multiring command appends RIFs for routed protocols on Token Ring VLAN interfaces. When this command is enabled for a protocol, the RSM will source packets that include information used by source-route bridges. The Token Ring VLAN interfaces on the RSM can connect to an SRB Token Ring network for the protocols specified in the command.

Each Token Ring VLAN interface that is configured with the multiring command on the RSM must also be accompanied by the multiring trcrf-vlan command.

Use the multiring trcrf-vlan command to:

When configuring SRB and IP or IPX routing SR frames on an RSM's TrBRF interface, define both a virtual ring and a pseudo-ring for the interface using the source-bridge and multiring trcrf-vlan commands. In this case, the VLAN ID used for the TrCRF that corresponds to the virtual ring can be the same as the one used for the pseudo ring number. If the VLAN IDs are different, the virtual ring and pseudo-ring numbers must be different.

Examples

In the following example, the multiring trcrf-vlan command is used to configure a pseudo-ring with ring number 100 on the RSM:

interface Ethernet 2/2
  ip address 4.4.4.1 255.255.255.0
!
interface vlan998 type trbrf
  ip address 5.5.5.1 255.255.255.0
  multiring trcrf-vlan 200 ring-group 100
  multiring all
Related Commands

interface vlan
clear drip counters
rif
multiring
show drip
show rif

show drip

Use the show drip privileged EXEC command to display the status of the DRiP database for a router or an RSM.

show drip

Syntax Description

This command has no arguments or keywords.

Command Mode

Privileged EXEC

Usage Guidelines

This command first appeared in Cisco IOS Release 11.3(4)T.

Examples

In the following example, the output for the show drip command is shown:

72-1#show drip
DRIP Database for Mgmt Domain FastEthernet4/0
--------------------------------------------------
Mac Address 0010-A6AE-B440
Vlan     100    Status    30 : l-active, l-config, 
Mac Address 0010-2F72-C800
Vlan      20    Status    0C : r-active, r-config, 
Vlan    1003    Status    0C : r-active, r-config,
Statistics:
Advertisements received            126
Advertisements processed           1
Advertisements transmitted         131
Last revision transmitted          0x84      
Last changed revision transmitted  0x2 
Related Commands

interface vlan
clear drip counters
show vlan

source-bridge trcrf-vlan

Use the source-bridge trcrf-vlan interface configuration command to attach a VLAN to the RSM's virtual ring when source-route bridging. Use the no form of the command to disable the attachment of a VLAN to the RSM's virtual ring.

source-bridge trcrf-vlan vlanid ring-group ringnum

Syntax Description

vlanid

VLAN ID number.

ring-group ringnum

Pseudo ring number that corresponds to the virtual ring number for the interface.

Command Mode

Interface configuration

Usage Guidelines

This command first appeared in Cisco IOS Release 11.3(4)T.

Use the source-bridge ring-group command to create a virtual ring for SRB between TrBRF VLANs. Use the source-bridge trcrf-vlan command to assign a TrCRF VLAN ID to the virtual ring.

In SRB and SR/TLB, define a unique TrCRF VLAN ID that corresponds to the virtual ring on the RSM for each TrBRF. Although the VLAN ID for the TrCRF is unique for each TrBRF, the ring number will be the same.

If IP or IPX routing SR frames is required on a TrBRF interface configured for SRB, you must also define a pseudo-ring for this interface with the multiring trcrf-vlan command. In this case, the VLAN ID used for the TrCRF that corresponds to the virtual ring can be the same as the one used for the pseudo-ring. If the VLAN IDs are different, the virtual ring and pseudo-ring numbers must be different.

Examples

An example with both SRB and IP routing for SR frames is shown below:

source-bridge ring-group 100
interface Token Ring3/1
  source-bridge 10 1 100
  source-bridge spanning
!
interface vlan999 type trbrf
 source-bridge trcrf-vlan 400 ring-group 100  source-bridge spanning  multiring all  multiring trcrf-vlan 400 ring-group 100

Note that the ring number must be the same for the source-bridge ring-group, source-bridge, and source-bridge trcrf-vlan commands. In this example, the ring number of the pseudo ring also matches the virtual ring number.

Related Commands

show source-bridge
source-bridge ring-group

Debug Commands

Following are the debug commands for Token Ring VLAN support on the RSM:

debug drip event

Use the debug drip event privileged EXEC command to display debug messages for DRIP events. Use the no form of this command to disable debugging output.

debug drip event
no debug drip event

Default

Debugging is disabled for DRiP events.

Command Mode

Privileged EXEC

Usage Guidelines

This command first appeared in Cisco IOS 11.3(4)T.

This command first appeared in Cisco IOS Release 11.3(4)T. When a TrBRF interface is configured on the RSM, the DRiP protocol is activated. The DRiP protocol adds the VLAN ID specified in the router command to its database and recognizes the VLAN as a locally configured, active VLAN.

Sample Display

Following is an example of debug output for the debug drip event command:

DRiP gets a packet from the network:

612B92C0: 01000C00 00000000 0C501900 0000AAAA  .........P....**
612B92D0: 0300000C 00020000 00000100 0CCCCCCC  .............LLL
612B92E0: 00000C50 19000020 AAAA0300 000C0102  ...P... **......
612B92F0: 01010114 00000002 00000002 00000C50  ...............P
612B9300: 19000001 04C00064 04                 .....@.d.       

DRiP gets a packet from the network:

Recvd. pak

DRiP recognizes that the VLAN ID it is getting is a new one from the network:

6116C840:                       0100 0CCCCCCC            ...LLL
6116C850: 00102F72 CBFB0024 AAAA0300 000C0102  ../rK{.$**......
6116C860: 01FF0214 0002E254 00015003 00102F72  ......bT..P.../r
6116C870: C8000010 04C00014 044003EB 14        H....@...@.k. 
DRIP : remote update - Never heard of this vlan

DRiP attempts to resolve any conflicts when it hears of a new VLAN. The value action = 1 means to notify the local platform of change in state:

DRIP : resolve remote for vlan 20 in VLAN0
DRIP : resolve remote - action = 1

The local platform is notified of change in state:

DRIP Change notification active vlan 20

Another new VLAN ID was received in the packet:

DRIP : resolve remote for vlan 1003 in Vlan0

No action is required:

DRIP : resolve remote - action = 0

Thirty seconds have expired, and DRiP sends its local database entries to all its trunk ports:

DRIP : local timer expired
DRIP : transmit on 0000.0c50.1900, length = 24
612B92C0: 01000C00 00000000 0C501900 0000AAAA  .........P....**
612B92D0: 0300000C 00020000 00000100 0CCCCCCC  .............LLL
612B92E0: 00000C50 19000020 AAAA0300 000C0102  ...P... **......
612B92F0: 01FF0114 00000003 00000002 00000C50  ...............P
612B9300: 19000001 04C00064 04                 .....@.d. 

debug drip packet

Use the debug drip packet privileged EXEC command to display debug messages for DRiP packets. Use the no form of this command to disable debugging output.

debug drip packet
no debug drip packet

Default

Debugging is not enabled for DRIP packets.

Command Mode

Privileged EXEC

Usage Guidelines

This command first appeared in Cisco IOS Release 11.3(4)T.

Before you use this command, you can optionally use the clear drip command first. As a result the DRiP counters are reset to 0. If the drip counters begin to increment, the router is receiving packets.

Sample Display

Following is sample output for the debug drip packet command.

The following type of output is displayed when a packet is entering the router and you use the show debug command:

039E5FC0:     0100 0CCCCCCC 00E0A39B 3FFB0028    ...LLL.\Q#.?{.(
039E5FD0: AAAA0300 000C0102 01FF0314 0000A5F6  **............%v
039E5FE0: 00008805 00E0A39B 3C000000 04C00028  .....\Q#.<....@.(
039E5FF0: 04C00032 044003EB 0F                 .@.2.@.k.       
039FBD20:                   01000C00 00000010          ........

The following type of output is displayed when a packet is transmitted by the router:

039FBD30: A6AEB450 0000AAAA 0300000C 00020000  &.4P..**........
039FBD40: 00000100 0CCCCCCC 0010A6AE B4500020  .....LLL..&.4P. 
039FBD50: AAAA0300 000C0102 01FF0114 00000003  **..............
039FBD60: 00000002 0010A6AE B4500001 04C00064  ......&.4P...@.d
039FBD70: 04                                   . 
Related Commands

debug drip event


hometocprevnextglossaryfeedbacksearchhelp
Copyright 1989-1998 © Cisco Systems Inc.