Полезная информация

cc/td/doc/product/software/ios120/120newft/120t
hometocprevnextglossaryfeedbacksearchhelp
PDF

Table of Contents

IPX Display and Debug Enhancements

Platforms

Prerequisites

Supported MIBs and RFCs

Configuration Tasks

Configuration Examples

Command Reference

IPX Display and Debug Enhancements

Feature Summary

Several IPX display and debug enhancements have been added to the Cisco IOS 12.0(1)T software to improve its flexibility and ease of maintenance:

Benefits

List of Terms

Platforms

This feature is supported on these platforms:

Prerequisites

Be sure IPX routing has been enabled.

Supported MIBs and RFCs

None

Configuration Tasks

After you have enabled IPX on the router, you must perform the following interface configuration tasks:

Configure IPX Watchdog Spoofing

IPX sends periodic watchdog keepalive packets from servers to clients after a client session has been idle for approximately 5 minutes. On a DDR link, this means that a call would be made every 5 minutes, regardless of whether there were data packets to send. You can prevent these calls from being made by configuring the Cisco IOS software to respond to the server's watchdog keepalive packets on a remote client's behalf---sometimes referred to as spoofing the server.

Use the ipx watchdog-spoof command to enable and set the duration of watchdog spoofing. You can specify the number of consecutive hours spoofing is to stay enabled and the number of minutes spoofing is to stay disabled. The server can clean up inactive connections when spoofing is disabled. Be sure that fast and autonomous switching is disabled on the serial interface before using this command.

Use the following interface configuration command to enable watchdog spoofing:
Command Purpose

ipx watchdog-spoof [enable-time-hours disable-time-minutes]

Enable and set the duration of watchdog spoofing.

Create GGS SAP Response Filters

To create filters for controlling which servers are included in the GGS responses sent by the Cisco IOS software, perform the following tasks:

Step 1 Create a SAP filtering access list, which includes a GGS response filter.

Step 2 Apply a GGS filter to an interface.


Note Because GGS SAP response filters are applied ahead of output SAP filters, a SAP entry permitted to pass through the GGS SAP response filter can still be filtered by the output SAP filter.

Use the following interface configuration command to filter the list of servers in GGS response messages:
Command Purpose

ipx output-ggs-filter

Filter the list of servers in Get General Service response messages.

Monitor and Maintain Traffic Statistics

New show and clear commands make it easier to monitor and maintain NLSP and IPX traffic statistics.

To monitor and maintain NLSP traffic, use one or more of the following EXEC commands:
Command Purpose

clear ipx nlsp traffic

Clear NLSP traffic counters.

show ipx nlsp traffic [since {bootup | show}]

Display cumulative traffic statistics for NLSP traffic counters.

To monitor and maintain IPX traffic, use one or more of the following EXEC commands:
Command Purpose

clear ipx traffic

Clear IPX traffic counters.

show ipx traffic [since {bootup | show}]

Display cumulative traffic statistics for IPX traffic counters.

Configuration Examples

This section provides the following configuration steps:

Configure IPX Watchdog Spoofing Example

In Figure 1 a DDR telephone line separates an IPX client from its server.


Figure 1: IPX over DDR Configuration

Routing and service information is sent every 60 seconds. The output RIP and SAP filters defined in this example filter these updates, preventing them from being sent between routers A and B. If you forwarded these packets, each of the two routers would have to telephone the other once every 60 seconds. On a serial link whose charges are based on the number of packets transmitted, this activity is generally not desirable. (This problem may not occur on a dedicated serial line.)

Once the server and client have established contact, the server will send watchdog keepalive packets regularly. When SPX is used, both the server and the client send keepalive packets whose purpose is to ensure that the connection between the server and the client is still functional; these packets contain no other information. Servers send watchdog packets approximately every 5  minutes.

If Router A were allowed to forward the server's keepalive packets to Router B, Router A would have to telephone Router B every 5  minutes just to send these packets. Again, on a serial link whose charges are based on the number of packets transmitted, this activity is generally not desirable. Instead of having Router A telephone Router B only to send keepalive packets, you can enable watchdog spoofing on Router A. The result will be that when the server connected to this router sends keepalive packets, Router A will respond on behalf of the remote client (the client connected to Router B). When SPX is used, enable spoofing of SPX keepalive packets on both routers A and B to inhibit the sending of them because both the server and the client send keepalive packets.

Use the ipx watchdog-spoof command to enable and set the duration of watchdog spoofing. You can specify the number of consecutive hours spoofing is to stay enabled and the number of minutes spoofing is to stay disabled. Use this command only on a serial interface whose fast and autonomous switching are disabled.

In the example watchdog spoofing will be enabled for 1 hour and disabled for 20 minutes, allowing the server to clean up inactive connections, before being enabled again.

ipx routing 0000.0c04.4878
!
interface Ethernet0
    ipx network 15200
!
interface Serial0
!ppp encap for DDR(recommended)
    encapsulation ppp
    ipx network DD1DD2
!kill all rip updates
    ipx output-network-filter 801
!kill all sap updates
    ipx output-sap-filter 1001
! fast-switching off for watchdog spoofing
    no ipx route-cache
!don't listen to rip
    ipx router-filter 866
!ipx watchdog spoofing 
    ipx watchdog-spoof 1 20
!SPX watchdog spoofing
    ipx spx-spoof
!turn on DDR
    dialer in-band
    dialer idle-timeout 200
    dialer map IP 198.92.96.132 name R13 7917
    dialer map IPX DD1DD2.0000.0c03.e3c3 7917
    dialer-group 1
    ppp authentication chap
!chap authentication required
    pulse-time 1
!
access-list 801 deny  FFFFFFFF
access-list 866 deny  FFFFFFFF
!serialization packets
access-list 900 deny  0 FFFFFFFF 0 FFFFFFFF 457
!RIP packets
access-list 900 deny  1 FFFFFFFF 453 FFFFFFFF 453
!SAP packets
access-list 900 deny  4 FFFFFFFF 452 FFFFFFFF 452
!permit everything else
access-list 900 permit -1 FFFFFFFF 0 FFFFFFFF 0
!
access-list 1001 deny  FFFFFFFF
!
!static ipx route for remote network
ipx route DD1 DD1DD2.0000.0c03.e3c3 
!
!
!IPX will trigger the line up (9.21 and later)
dialer-list 1 list 900

Configure GGS SAP Output Filters Example

GGS SAP output filters as shown in Figure 2 allow a router to determine whether to forward information it receives about a service.


Figure 2: GGS SAP Output Filter


The following example configures GGS SAP output filters for Router C. When the client issues a GGS request, the output GGS filter denies a response from Novell Server A and permits responses from Novell servers B and C.

access-list 1000 deny 3c01.0000.0000.0001
access-list 1000 permit -1
interface ethernet 0
    ipx network 3c
interface ethernet 1
    ipx output-ggs-filter 1000
    ipx network 10

Command Reference

This section documents the following new or modified commands in Cisco IOS Release 12.0(1)T. All other commands used with this feature are documented in the Cisco IOS Release 11.3 command reference.

clear ipx traffic

To clear IPX protocol and NLSP traffic counters, use the clear ipx traffic privileged EXEC command.

clear ipx [nlsp] traffic

Syntax Description

nlsp

(Optional) Clears only the NLSP traffic counters and leaves other IPX traffic counters intact.


Command Mode

Privileged EXEC

Usage Guidelines

This command first appeared in Cisco IOS Release 12.0(1)T.

Use show ipx traffic since bootup to recall traffic statistics that have been previously cleared.

Related Command

show ipx traffic

ipx output-ggs-filter

To control which servers are included in the Get General Service (GGS) responses sent by the Cisco IOS software, use the ipx output-ggs-filter interface configuration command. To remove the filter from the interface, use the no form of this command.

ipx output-ggs-filter {access-list-number | name}
no ipx output-ggs-filter {access-list-number | name}

Syntax Description

access-list-number

Number of the SAP access list. All outgoing GGS packets are filtered by the entries in this list. The access-list number is a number from 1000 to 1099.

name

Name of the access list. Names cannot contain a space or quotation mark, and they must begin with an alphabetic character to prevent their being confused with numbered access lists.

Default

No filters are predefined.

Command Mode

Interface configuration

Usage Guidelines

This command first appeared in Cisco IOS Release 12.0(1)T.

You can issue only one ipx output-ggs-filter command on each interface.


Note Because GGS SAP response filters are applied ahead of output SAP filters, a SAP entry permitted to pass through the GGS SAP response filter can still be filtered by the output SAP filter.

Example

The following example excludes the server at address 3c.0800.89a1.1527 from GGS responses sent on Ethernet interface 0, but allows all other servers:

access-list 1000 deny 3c.0800.89a1.1527
access-list 1000 permit -1
ipx routing
interface ethernet 0
    ipx network 2B
    ipx output-ggs-filter 1000

Related Commands

access-list (SAP filtering)
deny (SAP filtering)
ipx access-list
ipx output-gns-filter
ipx output-sap-filter
ipx router-sap-filter
permit (SAP filtering)

ipx watchdog-spoof

To enable watchdog spoofing use the ipx watchdog-spoof interface configuration command. To specify how long spoofing is to be enabled or disabled, use arguments. To disable spoofing, use the no form of this command.

ipx watchdog-spoof [enable-time-hours disable-time-minutes]
no ipx watchdog-spoof

Syntax Description

enable-time-hours

(Optional) Number of consecutive hours spoofing is to stay enabled. Values are 1 through 24.

disable-time-minutes

(Optional) Number of consecutive minutes spoofing is to stay disabled. Values are 18 through 1440.


Default

Do not enable watchdog spoofing.

Command Mode

Interface configuration

Usage Guidelines

This command was updated in Cisco IOS Release 12.0(1)T.

This command first appeared in Cisco IOS Release 10.0.

Use the ipx watchdog-spoof command only on a serial interface with DDR enabled. Be sure fast switching and autonomous switching are disabled on this interface.

If you do not choose any argument, IPX watchdog spoofing will remain active.

Example

The following example enables spoofing for 1 hour and disables it for 20 minutes on serial interface 0:

interface serial 0
  ipx watchdog-spoof 1 20
  no ipx route-cache

Related Commands

ipx route-cache
ipx spx-spoof

show ipx interface

To display the status of the IPX interfaces configured in the Cisco IOS software and the parameters configured on each interface, use the show ipx interface EXEC command.

show ipx interface [type number]

Syntax Description

type

(Optional) Interface type. It can be one of the following types: asynchronous, dialer, Ethernet (IEEE 802.3), FDDI, loopback, null, serial, Token Ring, or tunnel.

number

(Optional) Interface number.

Command Mode

EXEC

Usage Guidelines

This command was updated in Cisco IOS Release 12.0(1)T.

This command This command first appeared in Cisco IOS Release 10.0.

Sample Displays

The following is sample output from the show ipx interface command:

Router# show ipx interface serial 2/0
Serial2/0 is up, line protocol is up
    IPX address is 123.00e0.1efc.0b01 [up]
  Delay of this IPX network, in ticks is 6 throughput 0 link delay 0
  IPXWAN processing not enabled on this interface.
  IPX SAP update interval is 60 seconds
  IPX type 20 propagation packet forwarding is disabled
  Incoming access list is not set
  Outgoing access list is not set
  IPX helper access list is not set
    SAP GGS output filter list is 1000
    SAP GNS processing enabled, delay 0 ms, output filter list is not set
  SAP Input filter list is not set
  SAP Output filter list is not set
  SAP Router filter list is not set
  Input filter list is not set
  Output filter list is not set
  Router filter list is not set
  Netbios Input host access list is not set
  Netbios Input bytes access list is not set
  Netbios Output host access list is not set
  Netbios Output bytes access list is not set
  Updates each 60 seconds aging multiples RIP:3 SAP:3
  SAP interpacket delay is 55 ms, maximum size is 480 bytes
  RIP interpacket delay is 55 ms, maximum size is 432 bytes
      Watchdog spoofing is currently enabled
    On duration 1 hour(s), 00:24:50 remaining
    Off duration 18 minute(s), 00:00:00 remaining
      SPX spoofing is disabled, idle time 60
    IPX accounting is disabled
    IPX fast switching is not configured
    RIP packets received 0, RIP packets sent 26
    SAP packets received 0, SAP packets sent 25

Table 1 describes the fields shown in the display.


Table 1: Show IPX Interface Field Descriptions
Field Description

Serial is ..., line protocol is ...

Type of interface and whether it is currently active and inserted into the network (up) or inactive and not inserted (down).

IPX address is ...

Network and node address of the local router interface, followed by the type of encapsulation configured on the interface and the interface's status. Refer to the ipx network command for a list of possible values.

NOVELL-ETHER

Type of encapsulation being used on the interface, if any.

[up] line-up

Indicates whether IPX routing is enabled or disabled on the interface. The "line-up" indicates that IPX routing has been enabled with the ipx routing command. The "line-down" indicates that it is not enabled. The word in square brackets provides more detail about the status of IPX routing when it is in the process of being enabled or disabled.

RIPPQ

Number of packets in the RIP queue.

SAPPQ

Number of packets in the SAP queue.

Secondary address is ...

Address of a secondary network configured on this interface, if any, followed by the type of encapsulation configured on the interface and the interface's status. Refer to the ipx routing command for a list of possible values. This line is displayed only if you have configured a secondary address with the ipx routing command.

Delay of this IPX network, in ticks, ...

Value of the ticks field (configured with the ipx delay command).

throughput

Throughput of the interface (configured with the ipx spx-idle-time interface configuration command).

link delay

Link delay of the interface (configured with the ipx link-delay interface configuration command).

IPXWAN processing...

Indicates whether IPXWAN processing has been enabled on this interface with the ipx ipxwan command.

IPX SAP update interval

Indicates the frequency of outgoing SAP updates (configured with the ipx update interval command).

IPX type 20 propagation packet forwarding...

Indicates whether forwarding of IPX type 20 propagation packets (used by NetBIOS) is enabled or disabled on this interface, as configured with the ipx type-20-propagation command.

Outgoing access list

Indicates whether an access list has been enabled with the
ipx access-group command.

IPX Helper access list

Number of the broadcast helper list applied to the interface with the ipx helper-list command.

SAP GGS Output filter list

Number of the Get General Server (GGS) response filter applied to the interface with the ipx output-gns-filter command.

SAP GNS output filter list

Number of the Get Nearest Server (GNS) response filter applied to the interface with the ipx output-gns-filter command.

SAP Input filter list

Number of the input SAP filter applied to the interface with the
ipx input-sap-filter command.

SAP Output filter list

Number of the output SAP filter applied to the interface with the
ipx input-sap-filter command.

SAP Router filter list

Number of the router SAP filter applied to the interface with the
ipx router-sap-filter command.

Input filter list

Number of the input filter applied to the interface with the
ipx input-network-filter command.

Output filter list

Number of the output filter applied to the interface with the
ipx output-network-filter command.

Router filter list

Number of the router entry filter applied to the interface with the
ipx router-filter command.

Netbios Input host access list

Name of the IPX NetBIOS input host filter applied to the interface with the ipx netbios input-access-filter host command.

Netbios Input bytes access list

Name of the IPX NetBIOS input bytes filter applied to the ipx netbios input-access-filter interface with the ipx netbios input-access-filter bytes command.

Netbios Output host access list

Name of the IPX NetBIOS output host filter applied to the interface with the ipx netbios input-access-filter host command.

Netbios Output bytes access list

Name of the IPX NetBIOS output bytes filter applied to the interface with the input netbios input-access-filter bytes command.

Update time

How often the Cisco IOS software sends RIP updates, as configured with the ipx update sap-after-rip command.

SAP interpacket delay

Interpacket delay for SAP updates.

RIP interpacket delay

Interpacket delay for RIP updates.

Watchdog spoofing...

Indicates whether watchdog spoofing is enabled or disabled for this interface, as configured with the ipx watchdog spoof command. This information is displayed only on serial interfaces.

SPX spoofing...

Indicates whether SPX spoofing is enabled or disabled for this interface.

IPX accounting

Indicates whether IPX accounting has been enabled with the ipx accounting command.

IPX fast switching
IPX autonomous switching

Indicates whether IPX fast switching is enabled (default) or disabled for this interface, as configured with ipx route-cache command. (If IPX autonomous switching is enabled, it is configured with the ipx route-cache cbus command.)

IPX SSE switching

Indicates whether IPX SSE switching is enabled for this interface, as configured with the ipx route-cache sse command.

IPX NLSP is running on primary network E001

Indicates that NLSP is running and the number of the primary IPX network on which it is running.

RIP compatibility mode

State of RIP compatibility (configured by the ipx nlsp rip interface configuration command).

SAP compatibility mode

State of SAP compatibility (configured by the ipx nlsp sap interface configuration command).

Level 1 Hello interval

Interval between transmission of hello packets for nondesignated routers (configured by the ipx nlsp hello-interval interface configuration command).

Level 1 Designated Router Hello interval

Interval between transmission of hello packets for designated routers (configured by the ipx nlsp hello-interval interface configuration command).

Level 1 CSNP interval

CSNP interval (as configured by the ipx nlsp csnp-interval interface configuration command).

Level 1 LSP retransmit interval

LSP retransmission interval (as configured by the
ipx nlsp retransmit-interval interface configuration command).

LSP (pacing) interval

LSP transmission interval (as configured by the ipx nlsp lsp-interval interface configuration command).

Level 1 adjacency count

Number of Level 1 adjacencies in the adjacency database.

Level 1 circuit ID

System ID and pseudonode number of the designated router. In this example, 0000.0C02.8CF9 is the system ID, and 02 is the pseudonode number.

RIP packets received/sent

The number of RIP packets received or sent.

SAP packets received/sent

The number of SAP packets received or sent.

Related Commands

access-list (SAP filtering)
access-list (standard)
ipx accounting
ipx default-output-rip delay
ipx default-output-sap-delay
ipx delay
ipx helper-list
ipx input-network-filter
ipx input-sap-filter
ipx ipxwan
ipx netbios input-access-filter
ipx netbios output-access-filter
ipx network
ipx output-gns-filter
ipx output-network-filter
ipx output-rip-delay
ipx output-sap-filter
ipx route-cache
ipx router-filter
ipx router-sap-filter
ipx routing
ipx update sap-after-rip
ipx watchdog-spoof
netbios access-list

show ipx traffic

To display information about the number and type of IPX packets transmitted and received, use the show ipx traffic EXEC command.

show ipx [nlsp] traffic [since {bootup | show}]

Syntax Description

nlsp

(Optional) Display only NLSP traffic counters.

since bootup

(Optional) Display traffic statistics since bootup.

since show

(Optional) Display traffic statistics since last show command.

Default

Display traffic statistics since bootup or the last clear command.

Command Mode

EXEC

Usage Guidelines

The keywords nlsp, since bootup, and since show were added in Cisco IOS Release 12.0(1)T.

This command first appeared prior to Cisco IOS Release 10.0.

Sample Display

The following is sample output from the show ipx traffic command:

router>show ipx traffic
System Traffic for 0.0000.0000.0001 System-Name: router
Time since last clear: never
Rcvd:	     0 total, 0 format errors, 0 checksum errors, 0 bad hop count
                   0 packets pitched, 0 local destination, 0 multicast
Bcast:   0 received, 0 sent
Sent:	     0 generated, 0 forwarded
                   0 encapsulation failed, 0 no route
SAP:    0 Total SAP requests, 0 Total SAP replies, 0 servers
        0 SAP General Requests, 0 ignored, 0 replies
        0 SAP Get Nearest Server requests, 0 replies
       0 SAP Nearest Name requests, 0 replies
       0 SAP General Name requests, 0 replies
        0 SAP advertisements received, 0 sent
        0 SAP flash updates sent, 0 SAP format errors
RIP:    0 RIP requests, 0 ignored, 0 RIP replies, 0 routes
        0 RIP advertisements received, 0 sent
        0 RIP flash updates sent, 0 RIP format errors
Echo:   Rcvd 0 requests, 0 replies
        Sent 0 requests, 0 replies
        0 unknown: 0 no socket, 0 filtered, 0 no helper
              0 SAPs throttled, freed NDB len 0
Watchdog:
        0 packets received, 0 replies spoofed
Queue lengths:
        IPX input: 0, SAP 0, RIP 0, GNS 0
        SAP throttling length: 0/(no limit), 0 nets pending lost route reply
        Delayed process creation: 0
EIGRP:  Total received 0, sent 0
        Updates received 0, sent 0
        Queries received 0, sent 0
        Replies received 0, sent 0
        SAPs received 0, sent 0
NLSP:   Time since last clear: never
NLSP:   Level-1 Hellos (sent/rcvd): 0/0
        PTP Hellos     (sent/rcvd): 0/0
        Level-1 LSPs sourced (new/refresh): 1/0
        Level-1 LSPs flooded (sent/rcvd): 0/0
        LSP Retransmissions: 0
        Level-1 CSNPs (sent/rcvd): 0/0
        Level-1 PSNPs (sent/rcvd): 0/0
        Level-1 DR Elections: 0
        Level-1 SPF Calculations: 1
        Level-1 Partial Route Calculations: 0
                LSP checksum errors received: 0
NLSP:   Time since last clear: never
NLSP:   Level-1 Hellos (sent/rcvd): 0/0
        PTP Hellos     (sent/rcvd): 0/0
        Level-1 LSPs sourced (new/refresh): 1/0
        Level-1 LSPs flooded (sent/rcvd): 0/0
        LSP Retransmissions: 0
        Level-1 CSNPs (sent/rcvd): 0/0
        Level-1 PSNPs (sent/rcvd): 0/0
        Level-1 DR Elections: 0
        Level-1 SPF Calculations: 1
        Level-1 Partial Route Calculations: 0
        LSP checksum errors received: 0
Trace:  Rcvd 0 requests, 0 replies
                         Sent 0 requests, 0 replies

Table 2 describes the most important fields shown in the display.


Table 2: Show IPX Traffic Field Descriptions
Field Description

Time since last clear

Elapsed time since last clear command issued.

Rcvd:

Description of the packets received.

total

Total number of packets received.

       format errors

Number of bad packets discarded (for example, packets with a corrupted header). Includes IPX packets received in an encapsulation that this interface is not configured for.

       checksum errors

Number of packets containing a checksum error. This number should always be 0, because IPX rarely uses a checksum.

       bad hop count

Number of packets discarded because their hop count exceeded 16.

       packets pitched

Number of times the device received its own broadcast packet.

       local destination

Number of packets sent to the local broadcast address or specifically to the router.

       multicast

Number of packets received that were addressed to an IPX multicast address.

Bcast:

Description of broadcast packets the router received and sent.

       received

Number of broadcast packets received.

       sent

Number of broadcast packets sent, including those the router is either forwarding or has generated.

Sent:

Description of packets the software generated and sent and those the software received and routed to other destinations.

       generated

Number of packets transmitted that the router generated itself.

       forwarded

Number of packets transmitted that the router forwarded from other sources.

       encapsulation failed

Number of packets the software was unable to encapsulate.

       no route

Number of times the software could not locate a route to the destination in the routing table.

SAP:

Description of the SAP packets sent and received.

       Total SAP requests

Cumulative sum of SAP requests received:

  • SAP general requests

  • SAP Get Nearest Server requests

       Total SAP replies

Cumulative sum of all SAP reply types: General, Get Nearest Server, Nearest Name, and General Name.

       servers

Number of servers in the SAP table.

       SAP General Requests
               ignored
               replies

Number of general SAP requests, ignored requests, and replies. This field applies to Cisco  IOS Release 11.2 and above.

       SAP Get Nearest Server              requests
             replies

Number of Get Nearest Server requests and replies. This field applies to Cisco  IOS Release 11.2 and above.

       SAP Nearest Name requests
             replies

Number of SAP Nearest Name requests and replies. This field applies to Cisco  IOS Release 11.2 and above.

       SAP advertisements received
             sent

Number of SAP advertisements generated and sent as a result of a change in its routing or service tables.

       SAP flash updates sent

Number of SAP flash updates generated and sent because of changes to routing or service tables.

       SAP format errors

Number of incorrectly formatted SAP advertisements received.

RIP:

Description of the RIP packets sent and received.

       RIP requests

Number of RIP requests received.

       ignored

Number of RIP requests ignored.

       RIP replies

Number of RIP replies sent in response to RIP requests.

       routes

Number of RIP routes in the current routing table.

       RIP advertisements
   received
             sent


Number of RIP advertisements received from another router.
Number of RIP advertisements generated and then sent.

       RIP flash updates sent

Number of RIP flash updates generated and sent because of changes to its routing table.

       RIP format errors

Number of incorrectly formatted RIP packets received.

Echo:

Description of the ping replies and requests sent and received.

       Rcvd requests, replies

Number of ping requests and replies received.

       Sent 0 requests, replies

Number of ping requests and replies sent.

       unknown

Number of unsupported packets received on socket.

       no socket, filtered, no helper

Number of packets that could not be forwarded because helper addresses were improperly configured.

             SAPs throttled

Number of SAP packets discarded because they exceeded buffer capacity.

             freed NDB len

Number of Network Descriptor Blocks (NDBs) removed from the network but still needing to be removed from the router's routing table.

Watchdog:

Description of the watchdog packets the software handled.

       packets received

Number of watchdog packets received from IPX servers on the local network.

       replies spoofed

Number of times the software responded to a watchdog packet on behalf of the remote client.

Queue lengths

Description of outgoing packets currently in buffers waiting to be processed.

       IPX input

Number of incoming packets waiting to be processed.

       SAP

Number of outgoing SAP packets waiting to be processed.

       RIP

Number of outgoing RIP packets waiting to be processed.

       GNS

Number of outgoing GNS packets waiting to be processed.

       SAP throttling length

Maximum number of outgoing SAP packets allowed in the buffer. Additional packets received are discarded.

       nets pending lost reply route

Number of "downed" routes being processed by the Lost Route Algorithm.

EIGRP: Total received, sent

Description of the Enhanced IGRP packets the router received and sent.

       Updates received, sent

Number of Enhanced IGRP updates received and sent.

       Queries received, sent

Number of Enhanced IGRP queries received and sent.

       Replies received, sent

Number of Enhanced IGRP replies received and sent.

       SAPs received, sent

Number of SAP packets received from and sent to Enhanced IGRP neighbors.

NLSP:

Description of the NLSP packets the router sent and received.

NLSP: Time since last clear

Elapsed time since last clear command issued.

       Level-1 Hellos (sent/rcvd)

Number of LAN hello packets sent and received.

       PTP Hellos (sent/rcvd)

Number of point-to-point Hello packets sent and received.

       Level-1 LSPs sourced
       (new/refresh)

Number of local LSPs created/refreshed by this router.

       Level 1-LSPs flooded
       (sent/rcvd)

Number of LSPs sent and received by this router.

       LSP Retransmissions

Number of LSPs resent by this router.

       Level-1 CSNPs (sent/rcvd)

Number of complete sequence number PDU (CSNP) packets sent and received.

       Level-1 PSNPs (sent/rcvd)

Number of partial sequence number PDU (PSNP) packets sent and received.

       Level-1 DR Elections

Number of times the software calculated its designated router election priority.

       Level-1 SPF Calculations

Number of times the software performed the shortest path first (SPF) calculation.

       Level-1 Partial Route
Calculations

Number of times the software recalculated routes without running SPF.

       LSP Checksum errors received

Number of LSPs rejected because of checksum errors.

Trace:

       Requests/Replies received

Number of Novell IPX trace request packets received.

       Request/Replies sent

Number of Novell IPX trace request packets sent.

Related Command

clear ipx traffic


hometocprevnextglossaryfeedbacksearchhelp
Copyright 1989-1998 © Cisco Systems Inc.