Полезная информация

cc/td/doc/product/software/ios120/120newft/120limit/120xd
hometocprevnextglossaryfeedbacksearchhelp
PDF

Table of Contents

BERT/TDM Enhancements for
Cisco AS5300 8PRI/4T Cards

Feature Summary

BERT/TDM Enhancements for
Cisco AS5300 8PRI/4T Cards

Feature Summary


Note This product and document are in development. Some portions of this document are not complete. This document will be revised as soon as the content is available.

Cisco's bit-error-rate-testing (BERT) solution and time-division multiplexing (TDM) command enhancements have been implemented in this 12.0(2)XD IOS release for the Cisco AS5300. This enhancement has been applied for T1 and E1 facilities.

The BERT solution can be managed from remote CLI and SNMP management platforms for any AS5300 in the Network. A loopback LED on the AS5300 chassis blinks slowly to indicate that BERT is in progress and blinks rapidly if the test fails.

Benefits

Bit error rate testing and loopbacks are used by carriers and ISPs to aid in problem resolution as well as testing the quality of T1/E1 links. By early detection of poor quality links and fast problem isolation, AS5300 users can improve their quality of service and increase their revenues.

The TDM subsystem troubleshooting commands are not used during normal system operation. Instead, the IOS commands show the current status and settings of the TDM backplane, enable debug output for display to the user when TDM programming occurs, and provide a set of test commands to test the functionality of the TDM path.

List of Terms

BERT---Bit Error Rate Testing

E1---European equivalent of T1, 32 channels of 64Khz each, 1 for framing, 1 for signalling.

ISDN---Integrated Services Digital Network

PRI---Primary Rate Interface

TDM---Time Division Multiplexing

T1---North American Channelized TDM with 24 channels of 64Khz each plus 8Khz frame.

User profile---A user profile is a set of parameters related to the BERT test and is defined so that a user does not have to enter the same parameters for a test again. The user profiles are stored as part of the configuration in the NVRAM. A user can define a maximum of 15 profiles on the system.

Platforms

This feature is supported on this platform:

Prerequisites

Ensure that the AS5300 has 64MB DRAM before using the Octal PRI card. If you do not have at least this memory installed on the unit, you will receive an INSUFFICIENT MEMORY message and will experience boot failures.

Supported MIBs and RFCs

This feature supports the following Management Information Bases (MIBs):

For descriptions of supported MIBs and how to use MIBs, see Cisco's MIB website on CCO at http://www.cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml.

No RFCs are supported by this feature.

Configuration Tasks

This information will supplied as soon as the information is available.

Configuration Example

This information will supplied as soon as the information is available.

Command Reference

This section documents new or modified commands. All other commands used with this feature are documented in the Cisco IOS Release 12.0 command references.

The following commands are new:

bert

To display information about bit error testing use the bert EXEC command. The bit-error-rate test (BERT) feature enables you to test the quality of the connected PRI links by direct comparison of a pseudorandom or repetitive test pattern with an identical locally generated test pattern.

bert profile <number> pattern <pattern> threshold <threshold> error-injection

<err_inj> duration <duration>

Syntax Description

This information will supplied as soon as the information is available.

Default

This information will supplied as soon as the information is available.

Command Mode

Privileged EXEC

Usage Guidelines

This command first appeared in Cisco IOS Release 12.0(2)XD

Use the bert command to test the bit error rate on each port of the AS5300.

Sample Display

The following example shows sample display output for the bert EXEC command.

Router#bert ?
  abort       Abort a currently running BERT Test
  controller  controller
 
Router#bert abort ?
  <cr>
 
Router#bert abort
Router#
17:53:33: There is no BERT Test running ....
 
Router#bert controller ?
  t1  T1 controller
 
Router#bert controller T1 ?
  <0-7>  Controller Number
 
Router#bert controller T1 0 ?
  <0-7>    Last Controller Number
  profile  Profile(s) to execute
 
Router#bert controller T1 0 profile ?
  <0-0>    Profile Number
  default  Execute default profile
 
Router#bert controller T1 0 profile 0
Press <Return> to start the BERT [confirm]
 
17:55:34: %BERT-6-BERT_START: Starting BERT on Interface 0 with Profile default
 
Router#bert controller T1 0 profile 0
 
17:56:27: %BERT-3-BERT_ALREADY_TEST: A BERT is already running
 
Router#bert abort ?
  <cr>
 
Router#bert abort
Do you really want to abort the current BERT [confirm]
 
17:56:56: %BERT-6-BERT_RESULTS:  Controller T1 0 Profile default : The Test was
aborted by User
Router#debug bert ?
  <cr>
 
Router#debug bert
Bit Error Rate Testing debugging is on
 
Router#no debug bert
Bit Error Rate Testing debugging is off
 
Router#config
Configuring from terminal, memory, or network [terminal]?
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#bert ?
  profile  Profile Number for this BERT configuration
 
Router(config)#bert profile ?
  <1-15>  BERT Profile Number
 
Router(config)#bert profile 2 ?
  pattern  Pattern with which BERT generation must happen
 
Router(config)#bert profile 2 pattern ?
  0s             n repetitive pattern, all zeroes
  1_in_16        n repetitive pattern, 1 in 16
  1s             n repetitive pattern, all ones
  211-O.152      n pseudo-random pattern, 211 -1 O.152
  215-O.151      n pseudo-random pattern, 215 -1 O.151
  220-O.151QRSS  n pseudo-random pattern, 220 -1 O.151 QRSS
  220-O.153      n pseudo-random pattern, 220 -1 O.153
  3_in_24        n repetitive pattern, 3 in 24
 
Router(config)#bert profile 2 pattern 0s ?
  threshold  Error Threshold
 
Router(config)#bert profile 2 pattern 0s threshold ?
  10^-2  Bit Error Rate  of 10^(-2)
  10^-3  Bit Error Rate  of 10^(-3)
  10^-4  Bit Error Rate  of 10^(-4)
  10^-5  Bit Error Rate  of 10^(-5)
  10^-6  Bit Error Rate  of 10^(-6)
  10^-7  Bit Error Rate  of 10^(-7)
  10^-8  Bit Error Rate  of 10^(-8)
 
Router(config)#bert profile 2 pattern 0s threshold 10^-2 ?
  error-injection  The error injection rate in the BERT Pattern generated
 
Router(config)#$e 2 pattern 0s threshold 10^-2 error-injection ?
  10^-1  Error injection of 10^(-1)
  10^-2  Error injection of 10^(-2)
  10^-3  Error Injection of 10^(-3)
  10^-4  Error injection of 10^(-4)
  10^-5  Error Injection of 10^(-5)
  10^-6  Error Injection of 10^(-6)
  10^-7  Error Injection of 10^(-7)
  none   No Error Injection in the Data Pattern
 
Router(config)#$e 2 pattern 0s threshold 10^-2 error-injection 10^-1 ?
  duration  Duration for which BERT is to be executed
 
Router(config)#$n 0s threshold 10^-2 error-injection 10^-1 duration ?
  <1-1440>  Duration of BERT <1-1440> minutes
Router(config)#$n 0s threshold 10^-2 error-injection 10^-1 duration 1
Router(config)#
 
Router#show cont t1 ?
  <0-7>          Controller unit number
  bert           BERT Test Results
  call-counters  DS0 call counters
  cas-data       CAS DS0's data calls
  clock          Primary clock change history
  |              Output modifiers
  <cr>
 
Router#show cont t1 bert ?
  |  Output modifiers
  <cr>
 
Router#show controller t1 bert
 Controller T1 0 Profile default : The Test was aborted by User
 Controller T1 0 Profile 2 : Test Never Ran
 Controller T1 1 Profile default : Test Never Ran
 Controller T1 1 Profile 2 : Test Never Ran
 Controller T1 2 Profile default : Test Never Ran
 Controller T1 2 Profile 2 : Test Never Ran
 Controller T1 3 Profile default : Test Never Ran
 Controller T1 3 Profile 2 : Test Never Ran
 Controller T1 4 Profile default : Test Never Ran
 Controller T1 4 Profile 2 : Test Never Ran
 Controller T1 5 Profile default : Test Never Ran
 Controller T1 5 Profile 2 : Test Never Ran
 Controller T1 6 Profile default : Test Never Ran
 Controller T1 6 Profile 2 : Test Never Ran
 Controller T1 7 Profile default : Test Never Ran
 Controller T1 7 Profile 2 : Test Never Ran
 
Router#show controller t1 ?
  <0-7>          Controller unit number
  bert           BERT Test Results
  call-counters  DS0 call counters
  cas-data       CAS DS0's data calls
  clock          Primary clock change history
  |              Output modifiers
  <cr>
 
Router#show controller t1 0
T1 0 is up.
  No alarms detected.
  Version info of slot 2:  HW: 1, Firmware: 16, PLD Rev: 11
  Framer Version: 0x7
 
Framing is ESF, Line Code is B8ZS, Clock Source is Line Primary.
  Data in current interval (709 seconds elapsed):
     0 Line Code Violations, 0 Path Code Violations
     0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
  Data in Interval 1:
     0 Line Code Violations, 0 Path Code Violations
     0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
  Data in Interval 2:
     0 Line Code Violations, 0 Path Code Violations
     0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
  Data in Interval 3:
     0 Line Code Violations, 0 Path Code Violations
     0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
 
Router#show controller t1 0 ?
  bert           BERT Test Results
  call-counters  DS0 call counters
  cas-data       CAS DS0's data calls
  clock          Primary clock change history
  |              Output modifiers
  <cr>
 
Router#show controller t1 0 bert ?
  |  Output modifiers
  <cr>
 
Router#show controller t1 0 bert
 Controller T1 0 Profile default : The Test was aborted by User
 Controller T1 0 Profile 2 : Test Never Ran
 
Router#exit
 

Related Commands

show controller

tdm

To display information about time division multiplexing use the tdm EXEC command.

Syntax Description

This information will supplied as soon as the information is available.

Default

This information will supplied as soon as the information is available.

Command Mode

EXEC and Privileged EXEC

Usage Guidelines

This command first appeared in Cisco IOS Release 12.0(2)XD

Use the tdm command to test the time division multiplexing on each port of the AS 5300.

Sample Display

The following example shows sample display output for the tdm EXEC command.

tdm
    show tdm ?
    backplane TDM backplane connections matrix
    detail TDM detail information for selected stream/channel
    information TDM device information
    map TDM connection map
    pool TDM dynamic resource pool
 
    show tdm backplane ?
    information TDM device information
    stream show stream specific TDM backplane information
    |Output modifiers
    <cr>
 
    show tdm backplane info ?
    motherboard TDM device information for Motherboard
    slot TDM device information for slot
    |Output modifiers
    <cr>
 
    show tdm backplane info motherboard ?
    |Output modifers
    <cr>
 
    show tdm backplane info slot ?
    <0-2> Slot number
    
    show tdm backplane info slot 2 ?
    device TSI Chip number within the slot (0 or 1)
    |Output modifiers
    <cr>
 
    show tdm backplane info slot 2 device ?
    <0-1> TSI Chip number
 
    show tdm backplane info slot 2 device 0 ?
    |Output modifiers
    <cr>
 
    show tdm backplane stream ?
    <0-7> Backplane Stream number
 
    show tdm backplane stream 0 ?
    |Output modifiers
    <cr>
 
    show tdm detail ?
    <0-2> Slot/Device number (i.e. 0/1)
    
    show tdm detail 0/1 ?
    <0-15> Source Stream/Channel number (i.e. 4/1)
 
    show tdm detail 0/1 4/1 ?
    |Output modifiers
    <cr>
 
    show tdm information ?
    motherboard TDM device information for Motherboard
    slot TDM device information for slot
    |Output modifiers
    <cr>
 
    show tdm information motherboard ?
    |Output modifiers
    <cr>
 
    show tdm information slot ?
    <0-2>Slot number
 
    show tdm information slot 0 ?
    device TSI Chip number within the slot (0 or 1)
    |Output modifiers
    <cr>
 
    show tdm information slot 0 device ?
    <0-1>TSI Chip number
 
    show tdm information slot 0 device 0 ?
    |Output modifiers
    <cr>
 
    show tdm map ?
    <0-2>Slot/Device number (i.e. 0/1)
    
    show tdm map 0/1 ?
    |Output modifiers
    <cr>
 
    show tdm pool ?
    slot TDM dynamic maintenance backplane timeslot pool
    |Output modifiers
    <cr>
 
    show tdm pool slot ?
    <0-2> Slot number
    |Ouput modifiers
    <cr>
 
    show tdm pool slot 0 ?
    |Output modifiers
    <cr>
 
    debug tdm ?
    api TDM subsystem API
    detail TDM Detail debugging
    dynamic TDM Dynamic Backplane Timeslot Allocation
    pri TDM connect via PRI feature board
    test TDM unit test option
    tsi TSI Chip MT8980/MT90820 Driver
    vdev TDM per voice device debug
 
    debug tdm api ?
    <cr>
 
    debug tdm detail ?
    <cr>
 
    debug tdm dynamic ?
    <cr>
 
    debug tdm pri ?
    <cr>
 
    debug tdm test ?
    <cr>
 
    debug tdm tsi ?
    <cr>
 
    debug tdm vdev ?
    <0-2>Slot/port number (i.e. 0/1)
 
--------  CHANGED OR DELETED COMMANDS  ------------
 
    show tdm ?
    connections TDM connection information
    data TDM data information
 
    show tdm connections ?
    motherboard show motherboard TDM connection information
    slot show slot specific TDM connection information
    |Output modifiers
    <cr>
 
    show tdm connections motherboard ?
    stream Stream number within the TSI chip
    |Output modifiers
    <cr>
 
    show tdm connections motherboard stream ?
    <0-15> Stream Number
 
    show tdm connections motherboard stream 0 ?
    |Output modifiers
    <cr>
 
    show tdm connections slot ?
    <0-2>Slot number
 
    show tdm connections slot 0 ?
    device TSI Chip number within the slot (0 or 1)
    |Output modifiers
    <cr>
 
    show tdm connections slot 0 device ?
    <0-1>TSI Chip number
 
    show tdm connections slot 0 device 0 ?
    stream Stream number within the TSI chip
    |Output modifiers
    <cr>
 
    show tdm connections slot 0 device 0 stream ?
    <0-15>Stream Number
 
    show tdm connections slot 0 device 0 stream 0 ?
    |Output modifiers
    <cr>
 
    show tdm data ?
    motherboard show motherboard TDM connection information
    slot show slot specific TDM connection information
    |Output modifiers
    <cr>
 
    show tdm data motherboard ?
    stream Stream number within the TSI chip
    |Output modifiers
    <cr>
 
    show tdm data motherboard stream ?
    <0-15>Stream Number
 
    show tdm data motherboard stream 0?
    |Output modifiers
    <cr>
 
    show tdm data slot ?
    <0-2>Slot number
 
    show tdm data slot 0 ?
    device TSI Chip number within the slot (0 or 1)
    |Output modifiers
    <cr>
 
    show tdm data slot 0 device ?
    <0-1>TSI Chip number
 
    show tdm data slot 0 device 0 ?
    stream Stream number within the TSI chip
    |Output modifiers
    <cr>
 
    show tdm data slot 0 device 0 stream ?
    <0-15>Stream Number
 
    show tdm data slot 0 device 0 stream 0 ?
    |Output modifiers
    <cr>

e2-clockrate

The e2-clockrate EXEC command is an interface configuration command and is seen only with interface serial0. When this command is configured serial interface 0 will support speeds up to E2 (8 MHz full duplex) and the other three serial interfaces (1-3) will be put in "shutdown" state. Also, running this command will display a warning message "Serial interface 0 is configured to support E2 rates and serial ports "1-3" are moved to shutdown state."

e2-clockrate
no e2-clockrate

Syntax Description

This information will supplied as soon as the information is available.

Default

This information will supplied as soon as the information is available.

Command Mode

Privileged EXEC

Usage Guidelines

This command first appeared in Cisco IOS Release 12.0(2)XD

Use the e2-clockrate command to configure the serial0 interface for E2 (8 MHz full duplex) and to shutdown the other three serial interfaces (1-3).

Sample Display

The following example shows sample display output for the e2-clockrate EXEC command.

Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#int serial 0
Router(config-if)#e2
Router(config-if)#e2-clockrate ?
  <cr>
 
Router(config-if)#e2-clockrate 
Interface Serial 0 is configured to support clockrates upto E2 (8Mbps)
Interfaces serial 1-3 will not be operational
 
Router(config-if)#
Router(config-if)#end
Router#sh
*May 15 00:45:54 PDT8: %SYS-5-CONFIG_I: Configured from console by console runn
Router#sh runn
Building configuration...
 
Current configuration:
!
version 12.0
no service pad
service timestamps debug datetime msec localtime
service timestamps log datetime localtime show-timezone
no service password-encryption
service internal
service udp-small-servers
service tcp-small-servers
!
hostname Router
!
boot system flash flash:1:vdukki/c5300-i-mz
enable secret 5 $1$qfO1$OYKRD2cvIJx7hfQbhrJS61
enable password lab
!
bert profile default pattern 220-O.151QRSS threshold 10^-6 error-injection none duration 10
ip subnet-zero
no ip domain-lookup
ip domain-name cisco.com
!         
clock timezone PDT8 -8
clock summer-time PDT8 recurring
partition flash 2 8 8
!
controller T1 0
 clock source line primary
!
controller T1 1
 clock source line secondary 1
!
controller T1 2
 clock source line secondary 2
!
controller T1 3
 clock source line secondary 3
!
controller T1 4
 clock source line secondary 4
!
controller T1 5
 clock source line secondary 5
!
controller T1 6
 clock source line secondary 6
!
controller T1 7
 clock source line secondary 7
!
interface Ethernet0
 ip address 1.6.44.2 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
!
interface Serial0
 ip address 1.1.1.1 255.255.255.0
 no ip directed-broadcast
 no keepalive
 shutdown
 no fair-queue
 e2-clockrate
!
interface Serial1
 no ip address
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
 shutdown
 no fair-queue
 clockrate 2015232
!
interface Serial2
 no ip address
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
 shutdown
 no fair-queue
 clockrate 2015232
!
interface Serial3
 no ip address
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
 shutdown 
 no fair-queue
 clockrate 2015232
!
interface FastEthernet0
 mac-address 0000.0c00.0011
 ip address 15.0.0.1 255.0.0.0
 no ip directed-broadcast
 ip route-cache same-interface
 no ip route-cache
 no ip mroute-cache
 no keepalive
 duplex full
 hold-queue 75 in
!
ip classless
ip route 223.255.254.254 255.255.255.255 Ethernet0
!
access-list 101 permit ip any any
access-list 101 deny   igrp any any
dialer-list 1 protocol ip list 101
arp 25.0.0.1 1234.1234.1241 ARPA
arp 27.0.0.1 1234.1234.1243 ARPA
arp 26.0.0.1 1234.1234.1242 ARPA
arp 28.0.0.1 1234.1234.1244 ARPA
!
line con 0
 exec-timeout 0 0
 transport input none
line 1 54
line aux 0
 transport input all
line vty 0 4
 password lab
 login
!
scheduler interval 500
end
 

What to Do Next

For additional software configuration information, refer to the following publications:


hometocprevnextglossaryfeedbacksearchhelp

Copyright 1989-1998©Cisco Systems Inc.