Полезная информация

cc/td/doc/product/software/ios112/112cg_cr
hometocprevnextglossaryfeedbacksearchhelp
PDF

Table of Contents

Configuring ISDN

Configuring ISDN

This chapter describes tasks that are required to get an Integrated Services Digital Network (ISDN) line and interface up, and describes features involved in configuring ISDN in a circuit-switched internetworking environment. For a complete description of the commands mentioned in this chapter, refer to the "ISDN Commands" chapter in the Wide-Area Networking Command Reference.

This chapter does not address routing issues, dialer configuration, and dial backup. For information about those topics, see the "Configuring DDR" chapter.

For information about the Channel Interface Processor (CIP), see the chapter entitled "IBM Channel Attach Commands" in the Bridging and IBM Networking Command Reference. The CIP is described in a separate chapter because of the interrelation of host system configuration values and router configuration values.

For hardware technical descriptions, and for information about installing the router interfaces, refer to the hardware installation and maintenance publication for your particular product.

ISDN Task List

Perform the tasks in the following sections to configure ISDN lines and interfaces. You must configure the ISDN interface--Basic Rate Interface (BRI), MBRI, or Primary Rate Interface (PRI)--and network addressing. Perform the encapsulation for Frame Relay or X.25 task only if the traffic sent over the ISDN interface will cross a Frame Relay or X.25 network. The remaining tasks are optional.

You can also optionally configure snapshot routing for ISDN interfaces. Snapshot routing is a method of learning remote routes dynamically and keeping the routes available for a specified period of time, even though routing updates are not exchanged during that period. See the "Configuring DDR" chapter of this module for detailed information about snapshot routing.

To place calls on the ISDN interface, you must configure it with dial-on-demand routing (DDR). For configuration information about ISDN using DDR, see the "Configuring DDR" chapter. For command information, refer to the chapter entitled "DDR Commands" in the Wide-Area Networking Command Reference.

To configure bandwidth on demand and dial backup, see the "Configuring DDR" chapter.

See the end of this chapter for the "ISDN Configuration Examples" section.

Understand Line Configuration Requirements

Before configuring the ISDN interfaces on your Cisco router, it is necessary to order a correctly configured ISDN line (BRI or PRI) from your telecommunications service provider.

This process varies dramatically from provider to provider on a national and international basis. However, some general guidelines follow:

Configure an ISDN BRI

This section describes how to configure a BRI, whether it is the only BRI in a router or is one of many in an MBRI. Each of the BRIs in an MBRI can be configured separately and is configured in the same way as a BRI.

Perform the tasks in the following sections to configure an ISDN BRI. The switch type selection and BRI specification tasks are required; the remaining are optional.

Check the Buffers

When configuring a BRI, after the system comes up, make sure enough buffers are in the free list of the buffer pool that matches the maximum transmission unit (MTU) of your BRI interface. If not, you must reconfigure buffers in order for the BRI interfaces to function properly.

To check the MTU size and the buffers and, if necessary, to configure the buffers and the MTU size, complete the following tasks beginning in EXEC mode:

Task Command
Check the MTU size. show interfaces bri number
Check the free buffers. show buffers 1
Configure the buffers. configure terminal 2

buffers big permanent number
buffers big max-free number
buffers big min-free number
buffers big initial number

Specify the interface and enter interface configuration mode. interface bri number
Set the MTU size. mtu 15003

1 This command is documented in the "System Management Commands" chapter in the Configuration Fundamentals Command Reference.
2 This command is documented in the "System Image, Microcode Image, and Configuration File Load Commands" chapter in the Configuration Fundamentals Command Reference.
3 This command is documented in the "Interface Commands" chapter in the Configuration Fundamentals Command Reference.

Select the ISDN Switch Type

ISDN supports a variety of service provider switches. Table 3 lists, by geographic areas, the ISDN switch types supported by the ISDN interface. If you configure an interface with the interface bri command, you must also select a switch. Perform the following task in global configuration mode:

Task Command
Select the service provider switch type. isdn switch-type switch-type

Table  3: ISDN Service Provider Switch Types   
Keywords by Area Switch Type
none No switch defined
Australia
basic-ts013 Australian TS013 switches
Europe
basic-1tr6 German 1TR6 ISDN switches
basic-nwnet3 Norway NET3 switches (phase 1)
basic-net3 NET3 ISDN switches (UK, Denmark, and other nations); covers the Euro-ISDN E-DSS1 signalling system.
primary-net5 European ISDN PRI switches (UK and Europe)
vn2 French VN2 ISDN switches
vn3 French VN3 ISDN switches
Japan
ntt Japanese NTT ISDN switches
primary-ntt Japanese ISDN PRI switches
North America
basic-5ess AT&T basic rate switches
basic-dms100 NT DMS-100 basic rate switches
basic-ni1 National ISDN-1 switches
primary-4ess AT&T 4ESS switch type for the U.S. (ISDN PRI only)
primary-5ess AT&T 5ESS switch type for the U.S. (ISDN PRI only)
primary-dms100 NT DMS-100 switch type for the U.S. (ISDN PRI only)
New Zealand
basic-nznet3 New Zealand Net3 switches

Note Any router with an MBRI must be connected to the same switch type on all its ISDN interfaces.

Table  4: ISDN Switch Type Configuration Information
  
Switch Type Configuration
5ESS Custom BRI For Data Only

2 B channels for data.
Point to point.
Terminal type = E.
1 directory number (DN) assigned by service provider.
MTERM = 1.
Request delivery of calling line ID on Centrex lines.
Set speed for ISDN calls to 56 K outside local exchange.

For Voice and Data

(Use these values only if you have an ISDN telephone connected.)
2 B channels for voice or data.
Multipoint.
Terminal type = D.
2 directory numbers assigned by service provider.
2 service profile identifiers (SPIDs) required, assigned by service provider.
MTERM = 2.
Number of call appearances = 1.
Display = No.
Ringing/idle call appearances = idle.
Autohold= no.
Onetouch = no.
Request delivery of calling line ID on Centrex lines.
Set speed for ISDN calls to 56 kbps outside local exchange.
Directory number 1 can hunt to directory number 2.

5ESS National ISDN (NI-1) BRI Terminal type = A.
2 B channels for voice and data.
2 directory numbers assigned by service provider.
2 SPIDs required; assigned by service provider.
Set speed for ISDN calls to 56 K outside local exchange.
Directory number 1 can hunt to directory number 2.
DMS-100 BRI 2 B channels for voice and data.
2 directory numbers assigned by service provider.
2 SPIDs required; assigned by service provider.
Functional signaling.
Dynamic terminal endpoint identifier (TEI) assignment.
Maximum number of keys = 64.
Release key = no, or key number = no.
Ringing indicator = no.
EKTS = no.
PVC = 2.
Request delivery of calling line ID on Centrex lines.
Set speed for ISDN calls to 56 K outside local exchange.
Directory number 1 can hunt to directory number 2.
Primary Rate Lines Line format = Extended Superframe Format (ESF).
Line coding = binary 8-zero substitution (B8ZS).
Call type = 23 incoming channels and 23 outgoing channels.
Speed = 64 K.
Call-by-call capability.
23 B+D.
Trunk selection sequence = descending from 23 to 1.
Set B+D glare to yield.
Only 1 directory number assigned by service provider.
Set speed of ISDN calls to 56 K outside local exchange.
No SPIDs required.

Define ISDN TEI Negotiation

This section applies to ISDN BRI only. You can determine when Layer 2 ISDN terminal endpoint identifier (TEI) negotiation occurs. The default is for negotiation to occur when the router is powered on. TEI negotiation is useful in Europe and also useful for switches that might deactivate Layer 2 when no calls are active.

To define when TEI negotiation will occur, perform the following task in global configuration mode:

Task Command
Determine when ISDN TEI negotiation occurs. isdn tei [first-call | powerup]

Specify an ISDN Basic Rate Interface (BRI)

To specify an ISDN Basic Rate Interface (BRI) and enter interface configuration mode, perform the following task in global configuration mode:

Task Command
Begin BRI configuration. interface bri number

Specify ISDN Service Profile Identifiers (SPIDs)

This section applies to ISDN BRIs only. All ISDN devices subscribe to services provided by an ISDN service provider, usually a telephone company. However, only some service providers use service profile identifiers (SPIDs) to define the services subscribed to by the ISDN device that is accessing the ISDN service provider. The service provider assigns the ISDN device one or more SPIDs when you first subscribe to the service. If you are using a service provider that requires SPIDs, your ISDN device cannot place or receive calls until it sends a valid, assigned SPID to the service provider when accessing the switch to initialize the connection.

Currently, only the DMS-100 and NI-1 switch types require SPIDs. The AT&T 5ESS switch type may support a SPID, but we recommend that you set up that ISDN service without SPIDs. In addition, SPIDs have significance at the local access ISDN interface only. Remote routers are never sent the SPID.

A SPID is usually a seven-digit telephone number with some optional numbers. However, service providers may use different numbering schemes. For the DMS-100 switch type, two SPIDs are assigned, one for each B channel. Once your service provider has assigned you SPIDs, you must define these SPIDs on the router so that when access to the switch is attempted, the router has the valid information available.

To define the SPIDs and the local directory number (LDN) on the router, perform the following tasks in interface configuration mode (after specifying interface bri):

Task Command
Specify a SPID and local directory number for the B1-channel. isdn spid1 spid-number [ldn]
Specify a SPID and local directory number for the B2-channel. isdn spid2 spid-number [ldn]

The LDN is optional but might be necessary if the router is to answer calls made to the second directory number.

See the "Configuring DDR" chapter for information about configuring dial-on-demand routing (DDR). Refer to the "DDR Commands" chapter in the Wide-Area Networking Command Reference for specific DDR commands.

Configure Called Party Number Verification

When multiple devices are attached to an ISDN BRI, you can ensure that only a single device answers an incoming call by verifying the number or subaddress in the incoming call against the device's configured number or subaddress or both.

You can specify that the router verify a called-party number or subaddress number in the incoming setup message for ISDN BRI calls, if the number is delivered by the switch. You can do so by configuring the number that is allowed. To configure verification, perform the following task in interface configuration mode:

Task Command
Specify that the router verify a called-party number or subaddress number in the incoming setup message. isdn answer1 [called-party-number][:subaddress]

Verifying the called-party number ensures that only the desired router responds to an incoming call. If you want to allow an additional number for the router, you can configure it, too.

To configure a second number to be allowed, perform the following task in interface configuration mode:

Task Command
Specify that the router verify a second called-party number or subaddress number in the incoming setup message. isdn answer2 [called-party-number][:subaddress]

Configure ISDN Calling Number Identification

A router with an ISDN BRI interface might need to supply the ISDN network with a billing number for outgoing calls. Some networks offer better pricing on calls in which the number is presented. When configured, this information is included in the outgoing call Setup message.

To configure the interface to identify the billing number, perform the following task in interface configuration mode:

Task Command
Specify the calling party number. isdn calling-number calling-number

This command can be used with all switch types except German 1TR6 ISDN BRI switches.

Configure Automatic Detection of Encapsulation Type

You can enable a serial or ISDN interface to accept calls and dynamically change the encapsulation in effect on the interface when the remote device does not signal the call type. For example, if an ISDN call does not identify the call type in the Lower Layer Compatibility fields and is using an encapsulation that is different from the one configured on the interface, the interface can change its encapsulation type on the fly.

This feature enables interoperation with ISDN terminal adapters that use V.120 encapsulation but do not signal V.120 in the call setup message. An ISDN interface that by default answers a call as synchronous serial with PPP encapsulation can change its encapsulation and answer such calls.

Automatic detection is attempted for the first 10 seconds after the link is established or the first five packets exchanged over the link, whichever is first.

To enable automatic detection of encapsulation type, perform the following task in interface configuration mode:

Task Command
Enable automatic detection of encapsulation type on the specified interface. autodetect encapsulation encapsulation-type

You can specify one or more encapsulations to detect. Cisco IOS software currently supports automatic detection of PPP and V.120 encapsulations.

Configure Combinet Compatibility

Historically, Combinet devices supported only the Combinet Proprietary Protocol (CPP) for negotiating connections over ISDN B channels. To enable Cisco routers to communicate with those Combinet bridges, the Cisco IOS supports a new CPP encapsulation type.

To enable routers to communicate over ISDN interfaces with Combinet bridges that support only CPP, perform the following tasks in interface configuration mode:

Task Command
Specify CPP encapsulation. encapsulation cpp
Enable CPP callback acceptance. cpp callback accept
Enable CPP authentication. cpp authentication

Now most Combinet devices support PPP. Cisco routers can communicate over ISDN with these devices by using PPP encapsulation, which supports both routing and fast switching.

Combinet devices support only IP, IPX and bridging. For AppleTalk, Cisco routers automatically perform half-bridging with Combinet devices. For more information about half-bridging, see the "Configure PPP Half-Bridging on Serial Interfaces" section in the "Configuring PPP for Wide-Area Networking" chapter of this publication.

Cisco routers can also half-bridge IP and IPX with Combinet devices that support only CPP. To configure this feature, you only need to set up the addressing with the ISDN interface as part of the remote subnet; no additional commands are required.

Configure the Line Speed for Calls Not ISDN End-To-End

When calls are made at 56 kbps but delivered by the ISDN network at 64 kbps, the incoming data can be corrupted.

However, on ISDN calls, if the receiving side is informed that the call is not an ISDN call from end to end, it can set the line speed for the incoming call.

To set the speed for incoming calls recognized as not ISDN end-to-end, complete the following task in interface configuration mode:

Task Command
Set the speed to be used for incoming calls recognized as not ISDN end-to-end. isdn not-end-to-end {56 | 64}

Configure Inclusion of the Sending Complete Information Element

In some geographic locations, such as Hong Kong and Taiwan, ISDN switches require that the Sending Complete information element be included in the outgoing Setup message to indicate that the entire number is included. This information element is not required in other locations.

To configure the interface to include the Sending Complete information element in the outgoing call Setup message, complete the following task in interface configuration mode:

Task Command
Include the Sending Complete information element in the outgoing call Setup message. isdn sending-complete

Configure BRI for Leased Line Service

To configure a Basic Rate Interface (BRI) interface to use the ISDN physical connection as a leased-line service, use the isdn leased-line command.

This service is offered in Japan and Germany and there is no call set up or tear down involved. Data is placed on the ISDN interface similar to the way data is placed on a leased line connected to a serial port.

To configure the BRI to use the ISDN connection as a leased-line service, complete the following task in interface configuration mode:

Task Command
Specify the BRI interface number. isdn leased-line bri number

When you configure this feature on a router, make sure that an ISDN switch type is also configured.

The type of switch is not important. Pick the switch type you normally use in your country.

Configure Semipermanent Connections

German networks allow semipermanent connections between customer routers with BRIs and the 1TR6 basic rate switches in the exchange. Semipermanent connections are offered at better pricing than leased lines.

Configuring BRIs for semipermanent connection requires only that you use a keyword that indicates semipermanent connections when you are setting up network addressing as described in the previous section of this chapter.

To configure a BRI for semipermanent connections, use the following form of the dialer map command when you set up network addressing:

Task Command
Define the remote recipient's protocol address, host name, and dialing string; indicate semipermanent connections; optionally, provide the ISDN subaddress; set the dialer speed to 56 or 64 kbps, as needed. dialer map protocol next-hop-address name hostname spc [speed 56 | 64] [broadcast] dial-string[:isdn-subaddress]1

1 This command is documented in the "DDR Commands" chapter in the Wide-Area Networking Command Reference.

Configure an ISDN PRI

ISDN Primary Rate Interface (PRI) is supported on the Cisco 4000, the Cisco 4500, and the Cisco 7000 series routers using T1 or E1 versions of the Multichannel Interface Processor (MIP) card in conjunction with PRI signaling software. Channelized T1 ISDN PRI offers 23 B channels and 1 D channel. Channelized E1 ISDN PRI offers 30 B channels and 1 D channel.

Channelized T1 and channelized E1 are supported by corresponding controllers. A T1 or E1 controller has one physical network termination. However, it can have many virtual interfaces, depending on the configuration.

Perform the tasks in the following sections as appropriate for the T1 controller or the E1 controller:

Configure Channelized T1 ISDN PRI

To configure ISDN PRI on a channelized T1 controller, perform the following tasks beginning in global configuration mode:

Task Command
Select a service provider switch type that accommodates PRI. (See Table 3, earlier in this chapter, for a list of supported switch types.) isdn switch-type switch-type
Specify a T1 controller on a Cisco 7000
or
Specify a T1 controller on a Cisco 4000.
controller t1 slot/port1
or
controller t1 number1
Define the framing characteristics as Extended Superframe Format (ESF). framing esf 1
Define the line code as binary 8 zero substitution (B8ZS). linecode b8zs
Configure ISDN PRI. pri-group [timeslots range]
(Required for Hong Kong and Taiwan only) Include the Sending Complete information element in the outgoing call Setup message. isdn sending-complete

1 This command is documented in the "Interface Commands" chapter in the Configuration Fundamentals Command Reference.

Note You can define ISDN PRI groups and channel groups on the same controller. However, you cannot overlap time slots or use the ISDN D channel time slot in a channel group. See the
"PRI Groups and Channel Groups on the Same Channelized T1 Controller" section for an example of such a configuration.

If you do not specify the time slots, the specified controller is configured for 23 B channels and 1 D channel.


Note Any router configured for ISDN support must be connected to the same switch type on all its ISDN interfaces.

Configure Channelized E1 ISDN PRI

To configure ISDN PRI on a channelized E1 controller, perform the following tasks, beginning in global configuration mode:

Task Command
Select a service provider switch type that accommodates PRI. (See Table 3, earlier in this chapter, for a list of supported switch types.) isdn switch-type switch-type
Define the controller location in the Cisco 7000 series by slot and port number.
or
Define the controller location in the Cisco 4000 series by unit number, ranging from 0 through 2.
controller e1 slot/port1


controller e1 number1
Define the framing characteristics as cyclic redundancy check 4 (CRC4). framing crc41
Define the line code as high-density bipolar 3 (HDB3). linecode hdb3
Configure ISDN PRI. pri-group [timeslots range]
(Required for Hong Kong and Taiwan only) Include the Sending Complete information element in the outgoing call Setup message. isdn sending-complete

1 This command is documented in the "Interface Commands" chapter in the Configuration Fundamentals Command Reference.

Note You can define ISDN PRI groups and channel groups on the same controller. However, you cannot overlap time slots or use the ISDN D channel time slot in a channel group. See the
"PRI Groups and Channel Groups on the Same Channelized T1 Controller" section for an example of such a configuration.

If you do not specify the time slots, the specified controller is configured for 30 B channels and one D channel.


Note Any router configured for ISDN support must be connected to the same switch type on all its ISDN interfaces.

Configure the D Channel Serial Interface

When you configure ISDN PRI on the channelized E1 or channelized T1 controller, in effect you create a serial interface that corresponds to the PRI group timeslots. Then you must configure that serial interface.

To configure the interface, complete the tasks in the following sections:

Specify an IP Address for the Interface

To configure the serial interface created for ISDN PRI, complete the following tasks beginning in global configuration mode:

Task Command
Step 1 Specify D channel on the serial interface for channelized T1.

Specify D channel on the serial interface for channelized E1.
interface serial slot/port:23
interface serial
slot/port:23

interface serial
slot/port:15
interface serial number:15
Step 2 Specify an IP address for the interface. ip address ip-address

When you configure the D channel, its configuration is applied to all the individual B channels.

Configure Encapsulation

PPP encapsulation is configured for most ISDN communication. However, the router might require a different encapsulation for traffic sent over a Frame Relay or X.25 network, or the router might need to communicate with devices that require a different encapsulation protocol.

Configure encapsulation as described in one of the following sections:

In addition, the router can be configured for automatic detection of encapsulation type on incoming calls. To configure this feature, complete the tasks in the following section:

Configure PPP Encapsulation

Each ISDN B channel is treated as a serial line and supports HDLC and PPP encapsulation. The default serial encapsulation is HDLC. To configure PPP encapsulation, perform the following task in interface configuration mode:

Task Command
Configure PPP encapsulation. encapsulation ppp
Configure Encapsulation for Frame Relay or X.25 Networks

If traffic from this ISDN interface crosses a Frame Relay or X.25 network, the appropriate addressing and encapsulation tasks must be completed as required for Frame Relay or X.25 networks.

See the "Configuring Frame Relay" chapter or "Configuring X.25 and LAPB" chapter for more information about addressing, encapsulation, and other tasks necessary to configure Frame Relay or X.25 networks.

Configure Encapsulation for Combinet Compatibility

Historically, Combinet devices supported only the Combinet Proprietary Protocol (CPP) for negotiating connections over ISDN B channels. To enable Cisco routers to communicate with those Combinet bridges, the Cisco IOS software supports a new CPP encapsulation type.

To enable routers to communicate over ISDN interfaces with Combinet bridges that support only CPP, perform the following tasks in interface configuration mode:

Task Command
Specify CPP encapsulation. encapsulation cpp
Enable CPP callback acceptance. cpp callback accept
Enable CPP authentication. cpp authentication

Now most Combinet devices support PPP. Cisco routers can communicate over ISDN with these devices by using PPP encapsulation, which supports both routing and fast switching.

Combinet devices support only IP, IPX, and bridging. For AppleTalk, Cisco routers automatically perform half-bridging with Combinet devices. For more information about half-bridging, see the "Configure PPP Half-Bridging" section in the "Configuring Media-Independent PPP" chapter of this publication.

Cisco routers can also half-bridge IP and IPX with Combinet devices that support only CPP. To configure this feature, you only need to set up the addressing with the ISDN interface as part of the remote subnet; no additional commands are required.

Configure Automatic Detection of Encapsulation Type of Incoming Calls

You can enable a serial or ISDN interface to accept calls and dynamically change the encapsulation in effect on the interface when the remote device does not signal the call type. For example, if an ISDN call does not identify the call type in the Lower Layer Compatibility fields and is using an encapsulation that is different from the one configured on the interface, the interface can change its encapsulation type at that time.

This feature enables interoperation with ISDN terminal adapters that use V.120 encapsulation but do not signal V.120 in the call setup message. An ISDN interface that by default answers a call as synchronous serial with PPP encapsulation can change its encapsulation and answer such calls.

Automatic detection is attempted for the first 10 seconds after the link is established or the first five packets exchanged over the link, whichever is first.

To enable automatic detection of encapsulation type, perform the following task in interface configuration mode:

Task Command
Enable automatic detection of encapsulation type on the specified interface. autodetect encapsulation encapsulation-type

You can specify one or more encapsulations to detect. Cisco IOS software currently supports automatic detection of PPP and V.120 encapsulations.

Configure Network Addressing

When you configure networking, you specify how to reach the remote recipient. To configure network addressing, complete the following tasks beginning in interface configuration mode:

Task Command
Step 1 Define the remote recipient's protocol address, host name, and dialing string; optionally, provide the ISDN subaddress; set the dialer speed to 56 or 64 kbps, as needed.
or
(Australia) Use the command keyword that enables ISDN semipermanent connections.
dialer map protocol next-hop-address name hostname speed 56|64 dial-string[:isdn-subaddress]

dialer map protocol next-hop-address name hostname spc [speed 56 | 64] [broadcast] dial-string[:isdn-subaddress]

Step 2 Assign the interface to a dialer group to control access to the interface. dialer-group group-number
Step 3 Associate the dialer group number with an access list number. dialer-list dialer-group list access-list-number
Step 4 Define an access list permitting or denying access to specified protocols, sources, or destinations. access-list access-list-number {deny | permit} protocol source address source-mask destination destination-mask

Australian networks allow semipermanent connections between customer routers with PRIs and the TS-014 ISDN PRI switches in the exchange. Semipermanent connections are offered at better pricing than leased lines.

Packets that are permitted by the access list specified in Step 4 are considered interesting and cause the router to place a call to the destination protocol address that is identified in both Step 1 and Step 4.


Note The access list reference in Step 4 of this task list is an example of the access list commands allowed by different protocols. Some protocols might require a different command form or might require multiple commands. Refer to the relevant protocol chapter in the Network Protocols Configuration Guide, Part 1, Part 2, or Part 3 for more information about setting up access lists for a protocol.

For more information about defining outgoing call numbers, see the "Configuring Legacy DDR" or "Configuring Dialer Profiles" chapter.

Configure ISDN Calling Number Identification

A router might need to supply the ISDN network with a billing number for outgoing calls. Some networks offer better pricing on calls in which the number is presented.

To configure the interface to identify the billing number, perform the following task in interface configuration mode:

Task Command
Specify the calling party number. isdn calling-number calling-number

This command can be used with all ISDN PRI switches.

Configure Calling Line Identification (CLI) Screening

This task applies to any Cisco router that has one or more BRI or PRI interfaces. Calling line identification (CLI) (also called caller ID) screening adds a level of security by allowing you to screen incoming calls. You can verify that the calling line ID is from an expected origin. CLI screening requires a local switch that is capable of delivering the CLI to the router.

To configure caller ID screening, perform the following task in interface configuration mode:

Task Command
Configure caller ID screening. isdn caller number

Note If caller ID screening is configured and the local switch does not deliver caller IDs, the router rejects all calls.

Configure Automatic Detection of Encapsulation Type

You can enable a serial or ISDN interface to accept calls and dynamically change the encapsulation in effect on the interface when the remote device does not signal the call type. For example, if an ISDN call does not identify the call type in the Lower Layer Compatibility fields and is using an encapsulation that is different from the one configured on the interface, the interface can change its encapsulation type on the fly.

This feature enables interoperation with ISDN terminal adapters that use V.120 encapsulation but do not signal V.120 in the call setup message. An ISDN interface that by default answers a call as synchronous serial with PPP encapsulation can change its encapsulation and answer such calls.

Automatic detection is attempted for the first 10 seconds after the link is established or the first five packets exchanged over the link, whichever is first.

To enable automatic detection of encapsulation type, perform the following task in interface configuration mode:

Task Command
Enable automatic detection of encapsulation type on the specified interface. autodetect encapsulation encapsulation-type

You can specify one or more encapsulations to detect. Cisco IOS software currently supports automatic detection of PPP and V.120 encapsulations.

Configure Combinet Compatibility

Historically, Combinet devices supported only the Combinet Proprietary Protocol (CPP) for negotiating connections over ISDN B channels. To enable Cisco routers to communicate with those Combinet bridges, the Cisco IOS supports a new CPP encapsulation type.

To enable routers to communicate over ISDN interfaces with Combinet bridges that support only CPP, perform the following tasks in interface configuration mode:

Task Command
Specify CPP encapsulation. encapsulation cpp
Enable CPP callback acceptance. cpp callback accept
Enable CPP authentication. cpp authentication

Now most Combinet devices support PPP. Cisco routers can communicate over ISDN with these devices by using PPP encapsulation, which supports both routing and fast switching.

Combinet devices support only IP, IPX and bridging. For AppleTalk, Cisco routers automatically perform half-bridging with Combinet devices. For more information about half-bridging, see the "Configure PPP Half-Bridging on Serial Interfaces" section in the "Configuring PPP for Wide-Area Networking" chapter of this publication.

Cisco routers can also half-bridge IP and IPX with Combinet devices that support only CPP. To configure this feature, you only need to set up the addressing with the ISDN interface as part of the remote subnet; no additional commands are required.

Configuring NSF Call-by-Call Support

Network-Specific Facilities (NSF) are used to request a particular service from the network or to provide an indication of the service being provided. Call-by-call support means that a B channel can be used for any service; its use is not restricted to a certain preconfigured service, such as incoming 800 calls or an outgoing 800 calls. This specific NSF call-by-call service supports outgoing calls configured as voice calls.

This NSF call-by-call support feature is vendor-specific; only routers connected to AT&T Primary-4ESS switches need to configure this feature. This feature is supported on channelized T1.

To enable the router to for NSF call-by-call support and, optionally, to place outgoing voice calls, complete the following steps:

Step 1 Configure the controller for ISDN PRI.

Step 2 Configure the D channel interface to place outgoing calls, using the dialer map command with a dialing-plan keyword. You can enter a dialer map command for each dialing plan to be supported.

Step 3 Define the dialer map class for that dialing plan.

To define the dialer map class for the dialing plan, complete the following tasks beginning in global configuration mode:

Task Command
Step 1 Specify the dialer map class, using the dialing-plan keyword as the classname. map-class dialer classname
Step 2 (Optional) Enable voice calls. dialer voice-call
Step 3 Configure the specific dialer map class to make outgoing calls. dialer outgoing classname

Note To set the called party type to international, the dialed number must be prefaced by 011.

Table 5 lists the NSF dialing plans and supported services offered on AT&T Primary-4ESS switches.


Table  5: NSF Supported Services on AT&T Primary-4ESS Switches
NSF Dialing Plan Data Voice International
Software Defined Network (SDN)1 Yes Yes GSDN (Global SDN)
MEGACOMM No Yes Yes
ACCUNET Yes Yes Yes

1 The dialing plan terminology in this table is defined and used by AT&T.

Enable Asynchronous Access over ISDN

You can configure a router to support asynchronous access over ISDN by globally enabling PPP on VTY lines. PPP is typically enabled on synchronous or asynchronous serial interfaces; however, the Cisco IOS software permits you to configure PPP on virtual terminal (VTY) lines. This configures the VTY line to support asynchronous access over ISDN from the ISDN terminal to the VTY session on the router.

To enable asynchronous protocol features on VTY lines, perform the following task in global configuration mode:

Task Command
Configure all VTY lines to support asynchronous protocol features vty-async1

1 This command is documented in the "Terminal Lines and Modem Support" chapter in the Access Services Command Reference.

This task enables PPP on VTY lines on a global basis on the router. To configure PPP on a per-VTY basis, use the translate command in the "Protocol Translation Configuration Commands" chapter of the Access Services Command Reference.

Perform Configuration Self-Tests

To test the router's ISDN configuration, we suggest that you perform the following tasks:

Task Command
Check Layer 1 (physical layer) of the BRI. show controllers bri number1
Check Layer 1 (physical layer) of the PRI over T1. show controllers t1 slot/port 1
Check Layer 1 (physical layer) of the PRI over E1. show controllers e1 slot/port1
Check Layer 2 (data link layer). debug isdn q921
Check Layer 3 (network layer). debug isdn events

debug isdn q931

debug dialer

show dialer 2


1 This command is documented in the "Interface Commands" chapter in the Configuration Fundamentals Command Reference.
2 This command is documented in the "DDR Commands" chapter in the Wide-Area Networking Command Reference.

See the Debug Command Reference for information about the debug commands.

Monitor and Maintain ISDN Interfaces

Use the following commands to monitor and maintain ISDN interfaces:

Task Command
Display information about the physical attributes of the ISDN BRI B and D channels. show interfaces bri number
Display information about the physical attributes of the ISDN PRI over T1 B and D channels. (The number argument takes values between 1 and 23.) show interfaces serial slot/port bchannel number1
Display information about the physical attributes of the ISDN PRI over E1 B and D channels. (The number argument takes values between 1 and 31.) show interfaces serial slot/port bchannel number
Display protocol information about the ISDN B and D channels. show controllers bri number
Display information about memory, Layer 2 or Layer 3 timers, or status of PRI channels. (The service keyword is available for PRI only.) show isdn {memory | timers | service}
Obtain general diagnostic information about the specified interface. show dialer [interface type number] 2

1 This command is documented in the "Interface Commands" chapter in the Configuration Fundamentals Command Reference.
2 This command is documented in the "DDR Commands" chapter in the Wide-Area Networking Command Reference.

ISDN Configuration Examples

This section provides the following ISDN configuration examples:

Multilink PPP Example

The following example enables Multilink PPP on BRI 0.

interface BRI0
 description Enables PPP Multilink on BRI 0
 ip address 7.1.1.1 255.255.255.0
 encapsulation ppp
 dialer map ip 7.1.1.2 name starbuck 14195291357
 dialer map ip 7.1.1.3 name roaster speed 56 14098759854
 ppp authentication chap
 ppp multilink
 dialer-group 1

Compression Examples

The following example enables predictor compression on BRI 0.

interface BRI0
 description Enables predictor compression on BRI 0
 ip address 7.1.1.1 255.255.255.0 
 encapsulation ppp
 dialer map ip 7.1.1.2 name starbuck 14195291357
 compress predictor
 ppp authentication chap
 dialer-group 1

The following example enables Stacker compression on BRI 0.

interface BRI0
 description Enables stac compression on BRI 0
 ip address 7.1.1.1 255.255.255.0 
 encapsulation ppp
 dialer map ip 7.1.1.2 name starbuck 14195291357
 compress stac 
 ppp authentication chap
 dialer-group 1

Multilink PPP and Compression Example

The following example enables PPP Multilink and Stacker compression on BRI 0.

interface BRI0
 description Enables PPP Multilink and stac compression on BRI 0
 ip address 7.1.1.1 255.255.255.0 
 encapsulation ppp
 dialer map ip 7.1.1.2 name starbuck 14195291357
 ppp authentication chap
 compress stac
 ppp multilink
 dialer-group 1

Voice Over ISDN Examples

The following example allows incoming voice calls to be answered BRI 0.

interface BRI0
 description Allows incoming voice calls to be answered BRI 0
 ip address 7.1.1.1 255.255.255.0 
 encapsulation ppp
 isdn incoming-voice data
 dialer map ip 7.1.1.2 name starstruck 14038182344
 ppp authentication chap
 dialer-group 1

The following example places an outgoing call as a voice call on BRI 1.

interface BRI1
 description Places an outgoing call as a voice call on BRI 1
 ip address 9.1.1.1 255.255.255.0 
 encapsulation ppp
 dialer map ip 9.1.1.2 name angus class calltype 19091238877 
 ppp authentication chap
 dialer-group 1
map-class dialer calltype 
 dialer voice-call

NSF Call-by-Call Support Example

In the following example, the ISDN switch type is set to Primary-4ESS, ISDN PRI is configured on T1 controller 1/0, and the D channel is configured for dialer map classes that reference the NSF dialing plans. Finally, the map-class dialer command uses a dialing plan keyword and the dialer outgoing command refers to the same plan. This example supports a service offered only by AT&T on Primary-4ESS switches.

This example shows both the controller and interface commands required to make the ISDN interface operational and the DDR commands, such as the dialer map, dialer-group, and map-class dialer commands, that are needed to configure the ISDN interface to make outgoing calls.

isdn switchtype primary-4ess
interface Serial1/1:23
 description Will mark outgoing calls from AT&T type calls
 ip address 7.1.1.1 255.255.255.0
 encapsulation ppp
 dialer map ip 7.1.1.2 name tommyjohn class sdnplan 14193460913
 dialer map ip 7.1.1.3 name angus class megaplan 14182616900
 dialer map ip 7.1.1.4 name angus class accuplan 14193453730
dialer-group 1
 ppp authentication chap
map-class dialer sdnplan
 dialer outgoing sdn
map-class dialer megaplan
 dialer voice-call
 dialer outgoing mega
map-class dialer accuplan
 dialer outgoing accu

Dialer Rotary Groups Example

The following example configures BRI interfaces to connect into a rotary group (dialer-group) and then configures a dialer interface for that dialer-group. This configuration permits IP packets to trigger calls.

interface BRI 0
 description connected into a rotary group 
 encapsulation ppp
 dialer rotary-group 1
interface BRI 1
 no ip address
 encapsulation ppp
 dialer rotary-group 1
interface BRI 2
 encapsulation ppp
 dialer rotary-group 1
 
interface BRI 3
 no ip address
 encapsulation ppp
 dialer rotary-group 1
 
interface BRI 4
 encapsulation ppp
 dialer rotary-group 1
 
interface Dialer 0
 description Dialer group controlling the BRIs
 ip address 8.1.1.1 255.255.255.0
 encapsulation ppp
 dialer map ip 8.1.1.2 name angus 14802616900
 dialer-group 1
 ppp authentication chap
dialer-list 1 protocol ip permit 

PRI on a Cisco AS5200 Examples

The following example configures ISDN PRI on the appropriate interfaces for IP dial-in on channelized T1:

! T1 PRI controller configuration
controller T1 0
 framing esf
 linecode b8zs
 clock source line primary
 pri-group timeslots 1-24
!
controller T1 1
 framing esf
 linecode b8zs
 clock source line secondary
 pri-group timeslots 1-24
!
interface Serial0:23
 isdn incoming-voice modem
 dialer rotary-group 1
!
interface Serial1:23 
 isdn incoming-voice modem
 dialer rotary-group 1
!
interface Loopback0
 ip address 172.16.254.254 255.255.255.0
!
interface Ethernet0
 ip address 172.16.1.1 255.255.255.0
!
interface Group-Async1
 ip unnumbered Loopback0
 ip tcp header-compression passive
 encapsulation ppp
 async mode interactive
 peer default ip address pool default
 dialer-group 1
 ppp authentication chap pap default 
 group-range 1 48
!
interface Dialer1
 ip unnumbered Loopback0
 encapsulation ppp
 peer default ip address pool default
 ip local pool default 172.16.254.1 172.16.254.48
 dialer in-band
 dialer-group 1
 dialer idle-timeout 3600
 ppp multilink
 ppp authentication chap pap default 

The following example configures ISDN PRI on the appropriate interfaces for IP dial-in on channelized E1:

! E1 PRI controller configuration
controller E1 0
  framing crc4
 linecode hdb3
 clock source line primary
 pri-group timeslots 1-31
!
controller E1 1
 framing crc4
 linecode hdb3
 clock source line secondary
 pri-group timeslots 1-31
interface serial0:30
 isdn incoming-voice modem
 dialer rotary-group 1
!
interface serial1:30
 isdn incoming-voice modem
 dialer rotary-group 1
!
interface loopback0
 ip address 172.16.254.254 255.255.255.0
!
interface ethernet0
 ip address 172.16.1.1 255.255.255.0
!
interface group-async1
 ip unnumbered loopback0
 ip tcp header-compression passive
 encapsulation ppp
 async mode interactive
 peer default ip address pool default
 dialer-group 1
 ppp authentication chap pap default 
  group-range 1 60
!
!The following block of commands configures DDR for all the ISDN PRI interfaces 
!configured above. The dialer-group and dialer rotary-group commands tie the
!interface configuration blocks to the DDR configuration.
! 
interface dialer1
 ip unnumbered loopback0
 encapsulation ppp
 peer default ip address pool default
 ip local pool default 172.16.254.1 172.16.254.60 
 dialer in-band
 dialer-group 1
 dialer idle-timeout 3600
 ppp multilink
 ppp authentication chap pap default 

PRI Groups and Channel Groups on the Same Channelized T1 Controller

The following example shows a channelized T1 controller configured for PRI groups and for channel groups.The pri-group command and the channel-group command cannot have overlapping timeslots; note the correct timeslot configuration in this example.

controller t1 0
channel-group 0 timeslot 1-6
channel-group 1 timeslot 7
channel-group 2 timeslot 8
channel-group 3 timeslot 9-11
pri-group timeslot 12-24

The same type of configuration applies to channelized E1, also.


hometocprevnextglossaryfeedbacksearchhelp
Copyright 1989-1998 © Cisco Systems Inc.